Editar pontos, setas ou linhas de conexão

Editar pontos, setas ou linhas de conexão

Subscrição do Office 365, Office 2019, Office 2016, Office 2013, Office 2010

Tem bastante flexibilidade para editar e trabalhar com conexões. Pode editar a espessura, o estilo e a curvatura das linhas, controlar o aspeto dos ponto finais e setas, tornar as conexões curvas, em ângulo ou retas e gerir pontos de ligação de diversas formas.

Sugestão:    os comandos no grupo Ferramentas no separador Base colocam o Visio num estado ou modo diferente, o que por vezes pode ser confuso. Utilize o teclado para alterar, conforme necessário, entre a Ferramenta de Ponteiro Selecionar Objetos (prima Ctrl+1) e a ferramenta Conexão imagem de botão (prima Ctrl+3). Independentemente da ferramenta que estiver a utilizar, como o Bloco de Texto ou o Ponto de Ligação, prima Esc várias vezes para voltar à Ferramenta de Ponteiro (exceto no Visio 2010).

A maior parte deste artigo é relevante para a forma predefinida da Conexão Dinâmica que se pode redirecionar automaticamente em torno de outras formas. Existem alguns tipos de conexões, como a maioria das disponíveis no stencil Mais Formas \ Extras do Visio \ Conexões , que não se redirecionam automaticamente.

O que pretende fazer?   

Tornar conexões curvas, em ângulo ou retas

Adicionar setas ou outras extremidades de linha a uma conexão

Alterar a espessura, o estilo ou a curvatura de uma conexão

Inverter a direção de uma seta de conexão

Redirecionar ou intercetar conexões

Mais formas de trabalhar com pontos de ligação

Consulte Também

Tornar conexões curvas, em ângulo ou retas

Pode alterar uma única conexão ou alterar a predefinição para novas conexões.

Alterar uma conexão

  1. Selecione a conexão.

  2. No separador Estrutura, no grupo Esquema, selecione Conexões e, em seguida, selecione o estilo de direcionamento pretendido: Conexão de Ângulo Reto, Conexão de Linhas Retas ou Conexão de Linhas Curvas.

  3. Em alternativa, o menu Ação da forma de conexão, disponível ao clicar com o botão direito do rato, também tem opções para alterar o estilo de direcionamento da conexão.

Alterar a predefinição para novas conexões

  • Para tornar a conexão predefinida num ângulo reto, reta ou curva:

    • Visio Online (Plano 2), 2016, 2013    Desmarque todas as formas, selecionando a página. Selecione o separador Design e, em seguida, selecione o menu pendente Conexões no grupo Esquema . Em seguida, selecione Ângulo Reto, Linhas Retas ou Linhas Curvas.

    • Em alternativa, selecione o separador Ficheiro, selecione Imprimir, selecione Configurar Página, selecione o separador Esquema e Direcionamento e, em seguida, na lista Aspeto, selecione Reto ou Curvo.

    • , 2010   : selecione o separador Ficheiro, selecione Imprimir, selecione Pré-visualizar, selecione Configurar Página, selecione o separador Esquema e Direcionamento e, em seguida, na lista Aspeto, selecione Reto ou Curvo.

Início da Página

Adicionar setas ou outras extremidades de linha a uma conexão

Pode adicionar setas, pontos ou outras extremidades de linha a uma conexão.

  1. Selecione uma conexão.

  2. Siga um dos seguintes procedimentos:

    • Visio Online (Plano 2), 2016, 2013    Selecione a opção Formatar Forma a partir do menu Ação que pode ser acedido ao clicar com o botão direito do rato. Em alternativa, no separador Base, no grupo Estilos de Formas, selecione Linha e, em seguida, selecione Opções de Linha.

    • 2010   : no separador Base, no grupo Forma, selecione Linha e, em seguida, selecione Setas.

  3. Siga um dos seguintes procedimentos:

    • Visio Online (Plano 2), 2016, 2013   : no painel Formatar forma, em Linha, certifique-se de que a opção Linha contínua está selecionada e, em seguida, selecione o tipo, a largura ou o tipo de remate.

      Definições para fins de conexões
    • 2010   : selecione Mais Setas, na janela Linha, selecione o tipo, a largura ou o tipo de remate e, em seguida, clique em OK.

      Fins de setas

Início da Página

Alterar a espessura, o estilo ou a curvatura de uma conexão

  1. Selecione uma conexão.

  2. Siga um dos seguintes procedimentos:

    • Visio Online (Plano 2), 2016, 2013    Selecione a opção Formatar Forma a partir do menu Ação que pode ser acedido ao clicar com o botão direito do rato. Em alternativa, no separador Base, no grupo Estilos de Formas, selecione Linha e, em seguida, selecione Opções de Linha.

    • 2010   : no separador Base, no grupo Forma, selecione Linha e, em seguida, selecione Opções de Linha.

  3. Siga um dos seguintes procedimentos:

    • Visio Online (Plano 2), 2016, 2013   : no painel Formatar forma, em Linha, selecione a espessura, o estilo ou a curvatura.

      Definições para estilos de conexões
    • 2010   : na janela Linha, selecione a espessura, estilo ou curvatura e, em seguida, clique em OK.

      Espessura da linha e outras definições

Início da Página

Inverter a direção de uma seta de conexão

Nota: A direção de ligação em alguns tipos de diagramas é importante, como em vários diagramas de fluxo de processos. Por isso, o comando Inverter Extremidades deve ser utilizado para estas conexões, em vez de formatar novamente as extremidades. O botão do comando Inverter Extremidades pode ser adicionado facilmente ao friso, através da funcionalidade Ficheiro \ Opções \ Personalizar o Friso... Este comando oferece a possibilidade de inverter o fluxo de todas as conexões selecionadas.

Em alternativa, para alterar a direção de uma conexão, sem utilizar o comando Inverter Extremidades, adicione uma nova seta ao ponto final sem uma seta e remova a seta existente do outro ponto final.

  1. Selecione uma conexão.

  2. Siga um dos seguintes procedimentos:

    • Visio Online (Plano 2), 2016, 2013   : no separador Base, no grupo Estilos de Formas, selecione Linha e, em seguida, selecione Opções de Linha.

    • 2010   : no separador Base, no grupo Forma, selecione Linha e, em seguida, selecione Opções de Linha.

  3. Siga um dos seguintes procedimentos:

    • Visio Online (Plano 2), 2016, 2013    No painel Formatar forma, em Linha, selecione:

      • Tipo de Seta de Início e siga o passo 4.

      • Tipo de Seta de Fim e siga o passo 4.

      Definições para reverter setas
    • 2010    Na janela Linha, selecione:

      • Tipo de Seta de Início e siga o passo 4.

      • Tipo de Seta de Fim e siga o passo 4.

      Início e fim de setas
  4. Para adicionar, alterar ou remover uma seta no início e no fim da conexão selecionada, selecione uma seta ou a opção Nenhum no menu de setas.

    Selecione um estilo de seta ou Nenhum no menu de estilo de seta.

Início da Página

Redirecionar ou intercetar conexões

Na maioria dos casos, pode confiar no comportamento de conexão predefinido. Contudo, existem situações em que pretende ter mais controlo sobre o redirecionamento e a interseção de conexões no seu diagrama.

Sugestão:    utilize a funcionalidade Zoom para ver melhor pequenos detalhes e obter um controlo mais preciso sobre os pontos: Mais Zoom (prima Alt+F6), Menos Zoom (Alt+Shift+F6) e Ajustar à Janela (Ctrl+Shift+W).

  • Siga um ou mais dos seguintes procedimentos:

    • Para ligar uma conexão a outra conexão, adicione a conexão a uma forma e, em seguida, arraste a conexão até à outra conexão.

      Ligar a uma conexão
    • Para redirecionar uma conexão, selecione-a e, em seguida, arraste um ponto intermédio para uma nova localização.

      Redirecionar uma conexão
    • Para ajustar uma conexão píxel a píxel, selecione a conexão e, em seguida, prima Shift+Tecla de seta na direção que pretende.

      Mover uma conexão por píxel

Nota:    para criar um diagrama em árvore, consulte Criar um diagrama em árvore.

Início da Página

Mais formas de trabalhar com pontos de ligação

As seguintes secções abordam as várias formas através das quais poderá controlar pontos de ligação.

Sugestão:    utilize a funcionalidade Zoom para ver melhor pequenos detalhes e obter um controlo mais preciso sobre os pontos: Mais Zoom (prima Alt+F6), Menos Zoom (Alt+Shift+F6) e Ajustar à Janela (Ctrl+Shift+W).

Descrição geral dos pontos de ligação

Um ponto de ligação é um ponto especial numa forma no qual pode "colar" conexões e outras formas. Ao colar uma conexão ou forma a um ponto de ligação, estes ficam ligados, mesmo que uma das formas seja movida.

Os pontos de ligação tornam-se visíveis quando tenta ligar uma forma a outra. Pode ver os pontos de ligação de uma forma ao passar o rato junto à forma com a ferramenta Conexão ou ao arrastar o ponto final de uma conexão ou linha junto a uma forma que tenha pontos de ligação.

Ferramenta Conexão junto a um círculo com pontos de ligação

Nota:    os Pontos de Ligação não são os únicos locais onde pode colar conexões. Também pode colar conexões (e linhas) a vértices de formas, alças de formas e geometria de formas. Para obter mais informações, consulte Caixa de diálogo Ajustar e Colar.

Utilizar um ponto de ligação ou uma ligação dinâmica

Existem dois tipos de ligações que uma conexão pode ter a uma forma: um ponto de ligação (por vezes, referido como ligação estática) ou uma ligação dinâmica. Pode ter qualquer um dos tipos de ligação em qualquer um dos pontos finais de uma conexão. Se utilizar a Ligação Automática ou o comando Ligar Formas para ligar formas, ambos os pontos finais terão uma ligação dinâmica. Se selecionar manualmente onde uma conexão será anexada a uma forma, pode especificar o tipo de ligação.

No seguinte diagrama, a forma A tem um ponto de ligação à forma C e, para onde quer que a C seja movida, a conexão da A mantém-se no mesmo ponto na C. Por outro lado, a forma B tem uma ligação dinâmica à C e a conexão da B é movida para o ponto de ligação que estiver mais perto na C.

A tem uma ligação por pontos a C, mas B tem uma ligação dinâmica a C.

Criar um ponto de ligação   

Um ponto de ligação mantém uma ligação colada a um ponto específico na forma, mesmo se essa forma for movida ou rodada.

  1. Arraste a partir de um ponto de ligação na primeira forma até um ponto de ligação na segunda forma.

  2. Os pontos finais de uma conexão ficam a verde quando as formas estão ligadas.

Cole uma conexão a um ponto específico numa forma para fixar a conexão a esse ponto.

Criar uma ligação dinâmica    

Uma ligação dinâmica permite a uma conexão alterar a sua localização numa forma para que, à medida que a forma é movida ou rodada, a conexão se mova para o ponto de ligação na forma que estiver mais perto do ponto de origem da conexão.

  1. Coloque a ferramentaConexão sobre o centro da primeira forma até que uma caixa verde seja apresentada em torno da forma.

  2. Mantenha premido o botão do rato e arraste para o centro da segunda forma.

  3. Assim que uma caixa verde for apresentada em torno da segunda forma, liberte o botão do rato.

Cole uma conexão a uma forma para permitir movimento dinâmico da conexão a pontos na forma.

Adicionar um ponto de ligação a uma forma

Se a forma na qual pretende colar uma conexão não tiver um ponto de ligação no local que pretende, pode adicionar um.

  1. Selecione a forma.

  2. No separador Base, no grupo Ferramentas, clique na ferramenta Ponto de Ligação Imagem de botão .

  3. Se os pontos de ligação não estiverem visíveis, no separador Ver, no grupo Auxiliares Visuais selecione a caixa de verificação Pontos de Ligação.

  4. Prima Ctrl e clique no local onde quer adicionar o ponto de ligação. O novo ponto de ligação é selecionado automaticamente depois de o adicionar.

  5. No separador Base, no grupo Ferramentas, clique na Ferramenta de Ponteiro Selecionar Objetos para regressar à edição normal.

Adicionar um ponto de ligação a uma forma

Mover um ponto de ligação numa forma

Se não estiver satisfeito com a localização de um ponto de ligação, pode movê-lo.

  1. Selecione a forma.

  2. No separador Base, no grupo Ferramentas, selecione a ferramenta Ponto de Ligação Imagem de botão .

  3. Se os pontos de ligação não estiverem visíveis, no separador Ver, no grupo Auxiliares Visuais selecione a caixa de verificação Pontos de Ligação.

  4. Prima Ctrl e arraste o ponto de ligação que pretende mover.

  5. No separador Base, no grupo Ferramentas, clique na Ferramenta de Ponteiro Selecionar Objetos para regressar à edição normal.

Se estiver com dificuldades em mover o ponto de ligação para o local exato onde quer que esteja, experimente utilizar outras definições de ajuste. Para mais informações, consulte Regular a intensidade do ajuste ou desativar o ajuste.

Eliminar um ponto de ligação

Os pontos de ligação podem deixar de ser necessários. Nesse caso, pode eliminá-lo.

  1. Selecione a forma com um ponto de ligação que pretende eliminar.

  2. No separador Base, no grupo Ferramentas, clique na ferramenta Ponto de Ligação.

  3. Se não vir nenhum ponto de ligação, no separador Ver, no grupo Auxiliares Visuais, selecione a caixa de verificação Pontos de Ligação.

  4. Clique no ponto de ligação que pretende eliminar. O ponto de ligação fica com a cor magenta.

  5. Prima Delete.

  6. No separador Base, no grupo Ferramentas, clique na ferramenta Ponteiro Selecionar Objetos para regressar à edição normal.

Eliminação de um ponto de ligação

Ocultar pontos de ligação

Às vezes, pode querer ocultar pontos de ligação para ver melhor o seu diagrama.

  • No separador Ver, no grupo Auxiliares Visuais, desmarque a caixa de verificação Pontos de Ligação.

Adicionar texto junto a um ponto de ligação

Não é possível adicionar texto diretamente num ponto de ligação. Porém, pode adicionar texto à forma e, em seguida, mover o texto para junto do ponto de ligação.

  1. Selecione a forma onde quer adicionar o texto e comece a escrever. O texto que escrever aparece na forma.

  2. Selecione a ferramenta Ícone da ferramenta de Bloco de Texto Base \ Ferramentas \ Bloco de Texto (Ctrl + Shift + 4)

  3. O bloco de texto agora será agora selecionado

    Bloco de texto selecionado
  4. Arraste o bloco de texto para mover e redimensionar conforme necessário

    Mova e redimensione o bloco de texto

Selecione a Ferramenta de Ponteiro Selecionar Objetos (Ctrl + 1) quando quiser sair da ferramenta Bloco de Texto

Um método alternativo é criar múltiplas formas com denominações únicas, cada uma com um único ponto de ligação, e, em seguida, agrupá-las para criar uma forma maior. Os pontos de ligação continuarão acessíveis.

Criar múltiplos pontos de ligação com nome

Fazer com que um ponto de ligação aponte para dentro, para fora ou em ambas as direções

Utilize pontos de ligação para dentro e para fora para controlar a forma como "atrai" os pontos finais das conexões em formas.

  1. Selecione a forma.

  2. No separador Base, no grupo Ferramentas, clique na ferramenta Ponto de Ligação Imagem de botão .

  3. Se os pontos de ligação não estiverem visíveis, no separador Ver, no grupo Auxiliares Visuais selecione a caixa de verificação Pontos de Ligação.

  4. Se quiser adicionar um ponto de ligação para fora ou para dentro e para fora, clique com o botão direito do rato no ponto de ligação e clique em:

    • Para Dentro    : na maioria das vezes, o que pretende é um ponto de ligação para dentro. Os pontos de ligação para dentro "atraem" os pontos finais das conexões e os pontos de ligação para fora e para dentro e para fora em formas de duas dimensões (2D).

    • Para Fora    : se quiser colar uma forma 2D a outra forma, deverá utilizar um ponto de ligação para fora. Os pontos de ligação para fora são "atraídos por" pontos de ligação para dentro.

    • Para Dentro e Para Fora    : se não sabe de que forma quer colar uma forma a outras formas, provavelmente deverá utilizar um ponto de ligação para dentro e para fora.

Início da Página

Trabalhar com pontos de ligação

As seguintes secções abordam as várias formas através das quais poderá controlar pontos de ligação.

Descrição geral dos pontos de ligação

Uma forma com quatro pontos de ligação.

Uma forma com quatro pontos de ligação.

Adicionar pontos de ligação

Se a forma na qual pretende colar uma conexão ou forma não tiver um ponto de ligação no local onde quer, poderá facilmente adicionar um.

  1. Se os pontos de ligação não forem visíveis, no menu Ver, clique em Pontos de Ligação.

  2. Selecione a forma.

    Nota: Se não selecionar a forma primeiro, não será possível adicionar um ponto de ligação à mesma. A forma é selecionada se tiver um limite tracejado a verde em torno da mesma.

  3. Clique na ferramenta Ponto de Ligação Imagem de botão .

    Se não vir a ferramenta Ponto de Ligação, clique na seta para baixo junto à ferramenta Conexão imagem de botão e, em seguida, clique na ferramenta Ponto de Ligação Imagem de botão .

  4. Prima Ctrl e clique no local onde quer adicionar o ponto de ligação.

  5. Se quiser adicionar um ponto de ligação direcionado para fora ou para dentro e para fora, clique com o botão direito do rato no ponto de ligação e clique em Para Dentro, Para Fora ou Para Dentro e Para Fora.

    • Na maior parte das vezes, o ponto de ligação a escolher é para dentro. Os pontos de ligação para dentro "atraem" os pontos finais das conexões e os pontos de ligação para fora ou para dentro e para fora em formas de duas dimensões (2-D).

    • Se pretender colar uma forma 2-D noutra forma, deverá utilizar um ponto de ligação para fora. Os pontos de ligação para fora são "atraídos por" pontos de ligação para dentro.

    • Se não sabe de que forma pretende colar uma forma noutras formas, deverá utilizar um ponto de ligação para dentro e para fora.

  6. Clique na Ferramenta de Ponteiro Botão Ponteiro para regressar à edição normal.

Adicionar texto junto a um ponto de ligação

Infelizmente, não é possível adicionar texto diretamente a um ponto de ligação. Porém, pode adicionar texto à forma e, em seguida, mover o texto para junto do ponto de ligação.

  1. Selecione a forma.

  2. Comece a escrever. O texto que escrever aparece na forma.

  3. Clique na ferramenta Bloco de Texto Imagem de botão .

    Se não vir a ferramenta Bloco de Texto, clique na seta para baixo junto à ferramenta Texto Botão Ferramenta de Texto e, em seguida, clique na ferramenta Bloco de Texto Imagem de botão .

  4. Arraste o texto.

Sugestão: Se a forma tiver uma alça de controlo Imagem da alça de controlo – losango amarelo , poderá arrastá-la para mover rapidamente o texto da forma.

Mover pontos de ligação

Se não estiver satisfeito com a localização de um ponto de ligação, pode movê-lo.

  1. Selecione a forma.

    Nota: Se não selecionar a forma primeiro, não será possível mover o ponto de ligação. A forma é selecionada se tiver um limite tracejado a verde em torno da mesma.

  2. Clique na ferramenta Ponto de Ligação Imagem de botão .

    Se não vir a ferramenta Ponto de Ligação, clique na seta para baixo junto à ferramenta Conexão imagem de botão e, em seguida, clique na ferramenta Ponto de Ligação Imagem de botão .

  3. Arraste o ponto de ligação que pretende mover.

    Se não vir pontos de ligação, no menu Ver, clique em Pontos de Ligação.

  4. Clique na Ferramenta de Ponteiro Botão Ponteiro para regressar à edição normal.

Se estiver com dificuldades em mover o ponto de ligação para o local exato onde quer que esteja, experimente utilizar outras definições de ajuste:

  • No menu Ferramentas, clique em Ajustar e Colar e, em seguida, no separador Geral, em Ajustar, selecione as opções que pretende.

Eliminar ou ocultar pontos de ligação

Por vezes, os pontos de ligação podem representar um obstáculo. Quando assim for, tem duas opções: eliminá-los ou ocultá-los.

Para eliminar um ponto de ligação numa forma

  1. Selecione a forma.

    Nota: Se não selecionar a forma primeiro, não será possível eliminar o ponto de ligação. A forma é selecionada se tiver um limite tracejado a verde em torno da mesma.

  2. Clique na ferramenta Ponto de Ligação Imagem de botão .

    Se não vir a ferramenta Ponto de Ligação, clique na seta para baixo junto à ferramenta Conexão imagem de botão e, em seguida, clique na ferramenta Ponto de Ligação Imagem de botão .

  3. Clique no ponto de ligação que pretende eliminar. O ponto de ligação fica com a cor magenta.

    Se não vir pontos de ligação, no menu Ver, clique em Pontos de Ligação.

  4. Prima Delete.

  5. Clique na Ferramenta de Ponteiro Botão Ponteiro para regressar à edição normal.

Para ocultar um ponto de ligação

  • No menu Ver, clique em Pontos de Ligação.

Início da Página

Adicionar setas ou outras extremidades de linha a uma conexão

Pode adicionar elementos como setas, pontos ou outras extremidades de linha a uma conexão.

  1. Selecione uma conexão.

  2. No menu Formatar, clique em Linha.

  3. Em Extremidades de Linha, escolha o tipo e o tamanho da extremidade de linha pretendida.

  4. Clique em OK.

Sugestão: Também pode utilizar a ferramenta Extremidades de Linha na barra de ferramentas de Formatação.

Tornar conexões curvas, em ângulo ou retas

Alterar uma conexão no diagrama

  1. Clique com o botão direito do rato na conexão.

  2. Clique em Conexão de Ângulo Reto, Conexão Reta ou Conexão Curva.

Nota:    não é possível adicionar alças a conexões retas ou a conexões em ângulo reto, mas pode utilizar a ferramenta Lápis Imagem de botão para adicionar alças a conexões curvas.

Alterar a predefinição para novas conexões

  • Para tornar a conexão predefinida reta ou curva, no menu Ficheiro, clique em Configurar Página, clique no separador Esquema e Direcionamento e, em seguida, na lista de Aspeto, clique em Reto ou Curvo.

Inverter a direção de uma seta de conexão

Se quiser alterar a direção de uma conexão, pode fazê-lo ao adicionar uma nova seta à extremidade sem seta e ao remover a seta existente na outra extremidade.

  1. Selecione a conexão que pretende alterar.

  2. No separador Base no grupo Forma, clique em Linha e, em seguida, aponte para Setas para abrir o menu de Setas.

    Clique em Linha nos Estilos de Forma para abrir o menu e clique em Setas.
  3. Na parte inferior do menu Setas, clique em Mais Setas.

    Clique em Mais Setas na parte inferior do menu Setas.

    O Visio apresenta o painel de tarefas Formatar Forma com a opção Linha expandida.

  4. Para adicionar, alterar ou remover uma seta no início da conexão selecionada, selecione uma seta ou Nenhum no menu de setas em Tipo de Seta de Início.

    Numa linha de conexão selecionada, adicione, altere ou remova uma seta.

    Os menus de setas mostram o estilo de seta atualmente selecionado ou Nenhum relativamente à conexão selecionada.

    Selecione um estilo de seta ou Nenhum no menu de estilo de seta.
  5. Para adicionar, alterar ou remover uma seta no fim da conexão selecionada, selecione uma seta ou Nenhum no menu de setas em Tipo de Seta de Fim.

Consulte Também

Adicionar e editar texto de conexão

Adicionar conexões entre formas

Colar ou descolar conexões

Criar uma conexão personalizada

Adicionar ou remover saltos de linha de conexão

Formação do Visio

All you need to know about Visio desktop connectors (Tudo o que precisa de saber acerca das conexões no Visio para ambiente de trabalho) – blogue da equipa do Visio

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×