E (função E)

Utilize a função E, uma das funções lógicas, para determinar se todas as condições num teste são VERDADEIRO.

Exemplo

Exemplos da função E

A função E devolve VERDADEIRO se todos os argumentos devolverem VERDADEIRO; devolve FALSO se um ou mais argumentos devolverem FALSO.

Uma utilização comum para a função E consiste em expandir a utilidade das outras funções que executam testes lógicos. Por exemplo, a função SE executa um teste lógico e, em seguida, devolve um valor se o teste devolver VERDADEIRO e outro valor se o teste devolver FALSO. A utilização da função E como argumento teste_lógico da função SE permite testar várias condições diferentes em vez de apenas uma.

Sintaxe

E(lógico1;[lógico2];...)

A sintaxe da função E tem os seguintes argumentos:

Argumento

Descrição

Lógico1

Obrigatório. A primeira condição que pretende testar pode devolver VERDADEIRO ou FALSO.

Lógico2;...

Opcional. As condições adicionais que pretende testar podem devolver VERDADEIRO ou FALSO, até um máximo de 255 condições.

Observações

  • Os argumentos têm de devolver valores lógicos, tais como VERDADEIRO ou FALSO, ou os argumentos têm de ser matrizes ou referências que contenham valores lógicos.

  • Se uma matriz ou um argumento de referência contiver texto ou células vazias, esses valores são ignorados.

  • Se o intervalo especificado não contiver valores lógicos, a função E devolve o erro #VALOR!.

Exemplos

Eis alguns exemplos gerais da utilização da função E sozinha ou em conjunto com a função SE.

Exemplos de utilização das funções SE e E

Fórmula

Descrição

=E(A2>1;A2<100)

Apresenta VERDADEIRO se a célula A2 for maior do que 1 E menor do que 100, caso contrário, apresenta FALSO.

=SE(E(A2<A3;A2<100);A2;"O valor está fora do intervalo")

Apresenta o valor na célula A2 se for menor do que a célula A3 E menor do que 100, caso contrário, apresenta a mensagem "O valor está fora do intervalo".

=SE(E(A3>1;A3<100);A3;"O valor está fora do intervalo")

Apresenta o valor na célula A3 se for maior do que 1 E menor do que 100, caso contrário, apresenta uma mensagem. Pode substituir qualquer mensagem à sua escolha.

Cálculo do Bónus

Eis um cenário bastante comum em que é necessário calcular se os vendedores se qualificam para um bónus com as fórmulas SE e E.

Exemplos de cálculo de Bónus de Vendas com as funções SE e E.  A fórmula na célula E14 é =SE(E(B14>=$B$7;C14>=$B$5);B14*$B$8;0)
  • =SE(E(B14>=$B$7;C14>=$B$5);B14*$B$8;0)SE o Total de Vendas for maior ou igual (>=) ao Objetivo de Vendas E as Contas forem maiores ou iguais (>=) ao Objetivo de Conta, multiplicar o Total de Vendas pela % de Bónus; caso contrário, devolver 0.

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no User Voice do Excel.

Tópicos Relacionados

Vídeo: Funções SE avançadas
Saiba como utilizar funções aninhadas numa fórmula
Função SE
Função OU
Função NÃO
Descrição geral de fórmulas no Excel
Como evitar fórmulas quebradas
Utilizar a verificação de erros para detetar erros em fórmulas
Atalhos de teclado no Excel 2016 para Windows
Atalhos de teclado no Excel 2016 para Mac
Funções de lógica (referência)
Funções do Excel (por ordem alfabética)
Funções do Excel (por categoria)

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×