Detetar erros em fórmulas

Nota: Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Por vezes, as fórmulas podem resultar em valores de erro e devolver resultados não desejados. Seguem-se algumas ferramentas que pode utilizar para localizar e investigar as causas destes erros e determinar soluções.

Nota: Este tópico contém técnicas que podem ajudá-lo a corrigir erros de fórmulas. Não é uma lista exaustiva de métodos de correção de todos os erros de fórmulas. Para obter ajuda relativamente a erros específicos, pode procurar perguntas como as suas no Fórum da Comunidade do Excel ou publicar uma própria.

Ligação para o Fórum da Comunidade do Excel

Saiba como introduzir uma fórmula simples

As fórmulas são equações que executam cálculos com os valores na sua folha de cálculo. Uma fórmula começa com um sinal de igual (=). Por exemplo, a fórmula seguinte adiciona 3 a 1.

=3+1

Uma fórmula também pode conter um ou todos os elementos que se seguem: funções, referências, operadores e constantes.

elementos de uma fórmula

Elementos de uma fórmula

  1. Funções: com Excel, funções estão incluídas com engenharia fórmulas que executar cálculos específicos. Por exemplo, a função PI () devolve o valor de pi: 3,142...

  2. Referências: referem-se para células individuais ou intervalos de células. A2 devolve o valor na célula A2.

  3. Constantes: números ou valores de texto introduzidos diretamente numa fórmula, como, por exemplo, 2.

  4. Operadores: O operador ^ (acento circunflexo) eleva um número a uma potência e o operador * (asterisco) multiplica. Utilize + e – para somar e subtrair valores, e / para dividir.

    Nota: Algumas funções requerem o que é referido como argumentos. Os argumentos forem os valores que determinadas funções utilizam para efetuar os respetivos cálculos. Quando for necessário, argumentos são colocados entre parênteses () a função. Função PI não requer quaisquer argumentos, que é o motivo pelo qual está em branco. Algumas funções exigem um ou mais argumentos e podem deixar a sala para os argumentos adicionais. Tem de utilizar um ponto e vírgula para separe os argumentos ou um ponto e vírgula (;)) dependendo das suas definições de localização.

Por exemplo, a função SOMA requer apenas um argumento, mas pode acomodar 255 argumentos no total.

SOMA (função SOMA)

=SOMA(A1:A10) é um exemplo de um único argumento.

=SOMA(A1:A10, C1:C10) é um exemplo de vários argumentos.

A tabela seguinte resume alguns dos erros mais comuns que um utilizador pode cometer ao introduzir uma fórmula e explica como corrigi-los.

Certifique-se de que

Mais informações

Inicia cada uma das funções com o sinal de igual (=)

Se omitir o sinal de igual, o que escrever poderá ser apresentado como texto ou como uma data. Por exemplo, se escrever SOMA(A1:A10), o Excel apresentará a cadeia de texto SOMA(A1:A10) e não efetuará o cálculo. Se escrever 2/11, o Excel apresentará a data 2-nov (presumindo que o formato da célula é Geral) em vez de dividir 11 por 2.

Corresponde todos os parênteses de abertura e de fecho

Certifique-se de que todos os parênteses fazem parte de um par correspondente (de abertura ou de fecho). Quando utilizar uma função numa fórmula, é importante que cada parêntese esteja na posição correta para a função funcionar corretamente. Por exemplo, a fórmula =SE(B5<0);"Não é válido";B5*1,05) não funcionará, uma vez que existem dois parênteses de fecho e apenas um parêntese de abertura, quando apenas devia existir um de cada. A fórmula deve ter o seguinte aspeto: =SE(B5<0;"Não é válido";B5*1,05).

Utiliza dois pontos para indicar um intervalo

Ao referir-se a um intervalo de células, utilize dois pontos (:) para separar a referência à primeira célula no intervalo da referência à última célula no intervalo. Por exemplo, =SOMA(A1:A5) e não =SOMA(A1 A5), o que devolverá um erro #NULO!.

Introduz todos os argumentos necessários

Algumas funções têm argumentos necessários. Certifique-se ainda de que não introduziu demasiados argumentos.

Introduz o tipo de argumentos correto

Algumas funções, como a SOMA, precisam de argumentos numéricos. Outras funções, como SUBSTITUIR, precisam de um valor de texto de, pelo menos, um dos respetivos argumentos. Se utilizar o tipo de dados errado como um argumento, o Excel poderá devolver resultados inesperados ou apresentar um erro.

Não aninha mais de 64 funções

Pode introduzir ou aninhar até 64 níveis de funções numa função.

Coloca os nomes de outras folhas entre aspas simples

Se uma fórmula se referir a valores ou células noutras folhas de cálculo ou livros e os nomes dessas folhas de cálculo ou livros contiverem espaços ou carateres não alfabéticos, terá de colocar esses nomes entre aspas simples, como ='Dados Trimestrais'!D3 ou =‘123’!A1.

Coloca um ponto de exclamação (!) a seguir a um nome de folha de cálculo quando fizer referência ao mesmo numa fórmula

Por exemplo, para devolver o valor da célula D3 numa folha de cálculo chamada Dados Trimestrais no mesmo livro, utilize esta fórmula:='Dados Trimestrais'!D3.

Inclui o caminho para livros externos

Certifique-se de que cada referência externa contém um nome de livro e o caminho para o livro.

Uma referência a um livro inclui o nome do livro e tem de ser colocada entre parênteses ([Nomedolivro.xlsx]). A referência também tem de conter o nome da folha de cálculo no livro.

Mesmo que o livro a que pretende fazer referência não esteja aberto no Excel, pode incluir uma referência ao mesmo numa fórmula. Forneça o caminho completo para o ficheiro, tal como no seguinte exemplo: =LINS('C:\Os Meus Documentos\[Operações T2.xlsx]Vendas'!A1:A8). Esta fórmula devolve o número de linhas no intervalo que inclui as células A1 a A8 no outro livro (8).

Nota: Se o caminho completo contiver carateres de espaço, tal como no exemplo anterior, tem de colocar o caminho entre aspas simples (no início do caminho e depois do nome da folha de cálculo, antes do ponto de exclamação).

Introduz números sem formatação

Não formate números quando os introduzir numa fórmula. Por exemplo, se o valor que pretende inserir for 1 000 €, introduza 1000 na fórmula. Se introduzir um espaço ou um ponto como parte de um número, o Excel não conseguirá processá-lo e mostrará um erro. Se quiser que os números sejam apresentados de forma a apresentar o separador dos milhares ou milhões, ou os símbolos de moeda, formate as células depois de introduzir os números.

Por exemplo, se quiser somar 3100 ao valor da célula A3 e introduzir a fórmula =SOMA(3;100;A3), o Excel soma os números 3 e 100 e, em seguida, soma o total ao valor de A3, em vez de somar 3100 a A3, o que seria =SOMA(3100;A3). Em alternativa, se introduzir a fórmula =ABS(-2;134), o Excel apresenta um erro, porque a função ABS apenas aceita um argumento: =ABS(-2134).

Pode implementar determinadas regras para detetar erros nas fórmulas. Estas regras não garantem que a folha de cálculo fique isenta de erros, mas podem ser muito eficazes no que diz respeito à identificação dos erros mais comuns. Pode ativar ou desativar individualmente cada uma destas regras.

Os erros podem ser marcados e corrigidos de duas formas: um erro de cada vez (como um verificador ortográfico) ou imediatamente quando ocorrem na folha de cálculo à medida que introduz dados.

Pode resolver um erro ao utilizar as opções que o Excel apresenta ou pode ignorar o erro ao clicar em Ignorar Erro. Se ignorar um erro numa célula específica, o erro dessa célula não aparecerá em mais verificações de erros. No entanto, pode repor todos os erros ignorados anteriormente para que apareçam novamente.

  1. Para o Excel para Windows, clique em ficheiro > Opções > fórmulas, ou
    para o Excel para Mac, clique na menu do Excel > Preferências > erros.

    Em Excel 2007, clique no Botão do Microsoft Office Imagem de botão do Office > Opções do Excel > Fórmulas.

  2. Em Verificação de erros, selecione Ativar a verificação de erros de fundo. Qualquer erro que for encontrado, serão marcados com um triângulo no canto superior esquerdo da célula.

    Célula com um problema de fórmula
  3. Para alterar a cor do triângulo que assinala o local onde ocorreu um erro, na caixa Indicar erros utilizando esta cor selecione a cor pretendida.

  4. Em Regras da verificação do Excel, selecione ou desmarque as caixas de verificação de qualquer uma das regras seguintes:

    • Células que contêm fórmulas que resultam num erro: uma fórmula não utiliza a sintaxe, argumentos ou tipos de dados esperados. Entre os valores de erro incluem-se #DIV/0!, #N/D, #NOME?, #NULO!, #NÚM!, #REF! e #VALOR!. Cada um destes valores de erro tem causas diferentes e é resolvido de formas diferentes.

      Nota: Se introduzir um valor de erro diretamente numa célula, este é armazenado como esse valor de erro, mas não é marcado como um erro. No entanto, se uma fórmula de outra célula se referir a essa célula, a fórmula devolve o valor de erro dessa célula.

    • Fórmula de coluna calculada inconsistente em tabelas: uma coluna calculada pode incluir fórmulas individuais diferentes da fórmula da coluna principal, o que cria uma exceção. São criadas exceções na coluna calculada quando realiza uma das seguintes ações:

      • Escreve dados que não sejam uma fórmula numa célula da coluna calculada.

      • Escreva uma fórmula numa célula da coluna calculada e, em seguida, utilize Ctrl + Z ou clique em Anular Desfazer botão na Barra de ferramentas de acesso rápido.

      • Escreve uma nova fórmula numa coluna calculada que já contenha uma ou mais exceções.

      • Copia dados para a coluna calculada que não correspondem à fórmula da coluna calculada. Se os dados copiados contiverem uma fórmula, esta fórmula substitui os dados na coluna calculada.

      • Move ou elimina uma célula noutra área da folha de cálculo referida por uma das linhas numa coluna calculada.

    • Células que contêm anos representados por 2 dígitos: a célula contém uma data de texto que pode ser mal interpretada como sendo do século errado, quando utilizada em fórmulas. Por exemplo, a data na fórmula =ANO("1/1/31") pode ser referente a 1931 ou 2031. Utilize esta regra para verificar datas ambíguas de texto.

    • Números formatados como texto ou precedidos por um apóstrofo: a célula contém números armazenados como texto. Normalmente, isto ocorre quando são importados dados de outras origens. Os números que são armazenados como texto podem provocar resultados de ordenação inesperados, pelo que é conveniente convertê-los em números. ‘=SOMA(A1:A10) é visto como texto.

    • Fórmulas inconsistentes com outras fórmulas na região: a fórmula não corresponde ao padrão de outras fórmulas próximas. Em muitos casos, as fórmulas que estão adjacentes a outras fórmulas só diferem nas referências utilizadas. No exemplo seguinte de quatro fórmulas adjacentes, o Excel apresenta um erro junto à fórmula =SOMA(A10:C10) na célula D4, porque as fórmulas adjacentes sofrem um incremento de uma linha e essa sofre um incremento de 8 linhas, quando o Excel está à espera da fórmula =SOMA(A4:C4).

      O Excel apresenta um erro quando uma fórmula não corresponde ao padrão das fórmulas adjacentes

      Se as referências utilizadas numa fórmula não forem consistentes com as das fórmulas adjacentes, o Excel apresenta um erro.

    • Fórmulas que omitem células numa região: uma fórmula pode não incluir automaticamente referências aos dados inseridos entre o intervalo de dados original e a célula que contém a fórmula. Esta regra compara a referência numa fórmula com o intervalo de células efetivamente adjacente à célula que contém a fórmula. Se as células adjacentes contiverem valores adicionais e não estiverem em branco, o Excel apresentará um erro junto à fórmula.

      Por exemplo, o Excel insere um erro junto à fórmula =SOMA(D2:D4) quando esta regra é aplicada, porque as células D5, D6 e D7 são adjacentes às células referenciadas na fórmula, bem como à célula que contém a fórmula (D8), e essas células contêm dados que deveriam ter sido referenciados na fórmula.

      O Excel apresenta um erro quando uma fórmula ignora células num intervalo
    • Células desbloqueadas que contêm fórmulas: A fórmula não está bloqueada para protecção. Por predefinição, todas as células numa folha de cálculo estão bloqueadas para que não pode ser alterados quando a folha de cálculo está protegida. Isto pode ajudar a evitar erros inadvertidos como eliminar ou alterar fórmulas acidentalmente. Este erro indica que a célula tenha sido definida para ser desbloqueadas, mas a folha não estiver protegida. Selecione para se certificar de que não pretende que a célula bloqueada ou não.

    • Fórmulas que fazem referência a células vazias: a fórmula contém uma referência a uma célula vazia. Isto pode provocar resultados inesperados, conforme é mostrado no exemplo seguinte.

      Suponha que pretende calcular a média dos números na seguinte coluna de células. Se a terceira célula estiver em branco, não será incluída no cálculo e o resultado será 22,75. Se a terceira coluna contiver o valor 0, o resultado será 18,2.

      O Excel apresenta um erro quando uma fórmula refere células vazias
    • Os dados introduzidos numa tabela não são válidos: existe um erro de validação numa tabela. Verifique a definição de validação da célula clicando no separador Dados > grupo Ferramentas de Dados > Validação de Dados.

  1. Selecione a folha de cálculo em que pretende verificar os erros.

  2. Se a folha de cálculo for calculada manualmente, prima F9 para recalcular.

    Se a caixa de diálogo Verificação de Erros não for apresentada, clique no separador Fórmulas > Auditoria de Fórmulas > botão Verificação de Erros.

  3. Se anteriormente ignorou algum erro, pode procurar esse erro novamente ao efetuar o seguinte: clique em ficheiro > Opções > fórmulas. Para o Excel para Mac, clique na menu do Excel > Preferências > erros.

    Na secção Verificação de Erros, clique em Repor Erros Ignorados > OK.

    Verificação de Erros

    Nota: A reposição dos erros ignorados repõe todos os erros em todas as folhas do livro ativo.

    Sugestão: Pode ajudar mover a caixa de diálogo Verificação de Erros para imediatamente abaixo da barra de fórmulas.

    Mover a caixa Verificação de Erros abaixo da Barra de Fórmulas
  4. Clique num dos botões de ação do lado direito da caixa de diálogo. As ações disponíveis são diferentes para cada tipo de erro.

  5. Clique em Seguinte.

Nota: Se clicar em Ignorar erro, o erro é assinalado como ignorado em cada verificação consecutiva.

  1. Junto à célula, clique no botão Verificação de Erros Ícone Verificação de Erros apresentado e, em seguida, clique na opção pretendida. Os comandos disponíveis são diferentes para cada tipo de erro e a primeira entrada descreve o erro.

    Se clicar em Ignorar Erro, o erro é assinalado como ignorado em cada verificação consecutiva.

    Mover a caixa Verificação de Erros abaixo da Barra de Fórmulas

Se uma fórmula não conseguir avaliar corretamente um resultado, o Excel apresentará um erro, como #####, #DIV/0!, #N/D, #NOME?, #NULO!, #NÚM!, #REF! e #VALOR!. Cada tipo de erro tem causas e soluções diferentes.

A tabela seguinte contém ligações para artigos que descrevem esses erros detalhadamente e uma breve descrição que o ajuda a começar.

Tópico

Descrição

Corrigir um erro #####

O Excel apresenta este erro quando uma coluna não é suficientemente larga para apresentar todos os carateres numa célula ou quando uma célula contém valores de data ou hora negativos.

Por exemplo, se mudar a formatação de uma célula para Data e colocar uma fórmula que subtrai uma data no futuro a uma data no passado, como =6/15/2008-7/1/2008, o resultado será um valor de data negativo.

Sugestão: Tente ajustar automaticamente a célula fazendo duplo clique entre os cabeçalhos de coluna. Se # # # é apresentada uma vez que o Excel não consegue apresentar todos os carateres Isto irá corrigi-la.

N.º de erro

Corrigir um erro #DIV/0!

O Excel apresenta este erro quando um número é dividido por zero (0) ou por uma célula que não contém valores.

Sugestão: Adicione um processador de erros como no exemplo seguinte: =SE(C2;B2/C2;0)

Erro ao processar a função, como SE pode ser utilizado para abranger erros

Corrigir um erro #N/D

O Excel apresenta este erro quando um valor não está disponível para uma função ou fórmula.

Se estiver a utilizar uma função como a função PROCV, o que está a tentar pesquisa aos quais tem uma correspondência no intervalo de pesquisa? Não com mais frequência.

Experimente utilizar se. erro para suprimir a # n/d. Neste caso é utilizar:

=SE.ERRO(PROCV(D2;$D$6:$E$8;2;VERDADEIRO);0)

Erro #N/D

Corrigir um erro #NOME?

Este erro é apresentado quando o Excel não reconhece o texto numa fórmula. Por exemplo, o nome de um intervalo ou o nome de uma função pode estar escrito incorretamente.

Nota: Se estiver a utilizar uma função, certifique-se de que o nome da função está escrito corretamente. Neste caso soma é escrita incorretamente. Remover "e" e o Excel irá corrigi-la.

O Excel apresenta o erro #NAME? quando o nome de uma função tem um erro de digitação

Corrigir um erro #NULO!

O Excel apresenta este erro quando especifica uma interseção de duas áreas que não se intersetam (cruzam). O operador da interseção é um caráter de espaço que separa as referências numa fórmula.

Nota: Certifique-se do seu intervalos corretamente separados - as áreas C2: C3 e E4:E6 não se intersetam, para introduzir a fórmula = Soma (C2: C3 E4:E6) devolve o #NULL! Ocorreu um erro. Colocar uma vírgula entre os intervalos C e E irá corrigi-la =SUM(C2:C3,E4:E6)

Erro #NULO!

Corrigir um erro #NÚM!

O Excel apresenta este erro quando uma fórmula ou função contiver valores numéricos inválidos.

Está a utilizar uma função que se repete, como TIR ou taxa? Se Sim, o #NUM! erro é, provavelmente, porque a função não consegue obter um resultado. Consulte o tópico de ajuda para os passos de resolução.

Corrigir um erro #REF!

O Excel apresenta este erro quando uma referência de célula não for válida. Por exemplo, pode ter eliminado células que foram referenciadas por outras fórmulas ou pode ter colado células que moveu sobre outras células que foram referenciadas por outras fórmulas.

Eliminar acidentalmente uma linha ou coluna? Vamos foi eliminada a coluna B nesta fórmula = SUM(A2,B2,C2) e procure o que aconteceu.

Utilize Anular (Ctrl+Z) para anular a eliminação, recrie a fórmula ou utilize uma referência de intervalos contínua da seguinte forma: =SOMA(A2:C2), que teria sido atualizado automaticamente quando a coluna B foi eliminada.

O Excel apresenta o erro #REF! quando uma referência de célula não for válida

Corrigir um erro #VALOR!

O Excel pode apresentar este erro se a sua fórmula incluir células que contenham tipos de dados diferentes.

Está a utilizar os operadores matemáticos (+, -, *, /, ^) com diferentes tipos de dados? Se Sim, tente utilizar uma função. Neste caso =SUM(F2:F5) seria corrigir o problema.

Erro #VALOR!

Quando as células não estiverem visíveis numa folha de cálculo, pode ver estas células e as respetivas fórmulas na barra de ferramentas Janela de Monitorização. A Janela de Monitorização torna mais conveniente a inspeção, auditoria ou confirmação dos cálculos e resultados de fórmulas em folhas de cálculo grandes. Ao utilizar a Janela de Monitorização, não tem de percorrer ou aceder repetidamente a diferentes partes da sua folha de cálculo.

A Janela de Monitorização permite monitorizar facilmente as fórmulas utilizadas numa folha de cálculo

Esta barra de ferramentas pode ser movida ou ancorada como qualquer outra barra de ferramentas. Por exemplo, pode ancorá-la na parte inferior da janela. A barra de ferramentas mantém um registo das seguintes propriedades de célula: 1) Livro, 2) Folha, 3) Nome (se a célula tiver um Intervalo com Nome correspondente), 4) Endereço da célula, 5) Valor e 6) Fórmula.

Nota: Apenas pode ter uma monitorização por célula.

Adicionar células à Janela de Monitorização

  1. Selecione as células que pretende ver.

    Para selecionar todas as células numa folha de cálculo com fórmulas, no separador Base, no grupo Edição, clique em Localizar e Selecionar (ou pode utilizar Ctrl+G ou Controlo+G no Mac) > Ir Para Especial > Fórmulas.

    Ir para caixa de diálogo Especial
  2. No separador Fórmulas, no grupo Auditoria de Fórmulas, clique em Janela de Monitorização.

  3. Clique em Adicionar Monitorização.

    Clique em Adicionar Monitorização para adicionar uma monitorização à sua folha de cálculo
  4. Confirme se selecionou todas as células que pretende monitorizar e clique em Adicionar.

    Em Adicionar Monitorização, introduza o intervalo de células a monitorizar
  5. Para alterar a largura de uma coluna Janela de Monitorização, arraste o limite do lado direito do cabeçalho de coluna.

  6. Para apresentar uma célula a que uma entrada na barra de ferramentas Janela de Monitorização se refere, faça duplo clique na entrada.

    Nota: As células com referências externas a outros livros apenas são apresentadas na barra de ferramentas Janela de Monitorização quando os outros livros estiverem abertos.

Remover células da Janela de Monitorização

  1. Se a barra de ferramentas Janela de Monitorização não for apresentada, no separador Fórmulas, no grupo Auditoria de Fórmulas, clique em Janela de Monitorização.

  2. Selecione as células que pretende remover.

    Para selecionar múltiplas células, prima Ctrl e, em seguida, clique nas células.

  3. Clique em Eliminar Monitorização

    Eliminar Monitorização

Por vezes, é difícil compreender como uma fórmula aninhada calcula o resultado final porque existem vários cálculos intermédios e testes lógicos. No entanto, ao utilizar a caixa de diálogo Avaliar Fórmula, pode ver as diferentes partes de uma fórmula aninhada avaliadas de acordo com a ordem do cálculo da fórmula. Por exemplo, a fórmula =SE(MÉDIA(D2:D5)>50;SOMA(E2:E5);0) é mais fácil de compreender se conseguir ver os seguintes resultados intermédios:

Avaliar Fórmula ajuda-o a ver como as diferentes partes de uma fórmula aninhada são avaliadas

Caixa de diálogo Avaliar Fórmula

Descrição

=SE(MÉDIA(D2:D5)>50;SOMA(E2:E5);0)

A fórmula aninhada é apresentada inicialmente. A função MÉDIA e a função SOMA estão aninhadas na função SE.

O intervalo de células D2:D5 contém os valores 55, 35, 45 e 25, pelo que o resultado da função MÉDIA(D2:D5) é 40.

=SE(40>50;SOMA(E2:E5);0)

O intervalo de células D2:D5 contém os valores 55, 35, 45 e 25, pelo que o resultado da função MÉDIA(D2:D5) é 40.

=SE(Falso;SOMA(E2:E5);0)

Uma vez que 40 é inferior a 50, a expressão no primeiro argumento da função SE (o argumento teste_lógico) é Falso.

A função SE devolve o valor do terceiro argumento ( o argumento valor_se_falso). A função SOMA não é avaliada porque é o segundo argumento da função SE (o argumento valor_se_verdadeiro) e apenas é devolvida quando a expressão for Verdadeiro.

  1. Selecione a célula que pretende avaliar. Só é possível avaliar uma célula de cada vez.

  2. Selecione o separador Fórmulas > Auditoria de Fórmulas > Avaliar Fórmula.

  3. Clique em Avaliar para examinar o valor da referência sublinhada. O resultado da avaliação é apresentado em itálico.

    Se a parte sublinhada da fórmula for uma referência a outra fórmula, clique em Avançar para apresentar a outra fórmula na caixa Avaliação. Clique em Retroceder para voltar à célula e fórmula anteriores.

    O botão Avançar não está disponível para uma referência na segunda vez que a mesma é apresentada na fórmula ou se a fórmula se referir a uma célula noutro livro.

  4. Continue a clicar em Avaliar até que cada parte da fórmula tenha sido avaliada.

  5. Para ver a avaliação novamente, clique em Reiniciar.

  6. Para terminar a avaliação, clique em Fechar.

Notas: 

  • Algumas partes das fórmulas que utilizam as funções SE e SELECIONAR não são avaliadas (nestes casos, é apresentado o erro #N/D na caixa Avaliação).

  • Se a referência estiver em branco, o valor zero (0) é apresentado na caixa Avaliação.

  • As seguintes funções são recalculadas sempre que a folha de cálculo for alterada e podem fazer com que a caixa de diálogo Avaliar Fórmula apresente resultados diferentes do que os que são apresentados na célula: ALEATÓRIO, ÁREAS, ÍNDICE, DESLOCAMENTO, CÉL, INDIRETO, LINS, COLS, AGORA, HOJE, ALEATÓRIOENTRE.

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no UserVoice do Excel.

Consulte Também

Apresentar as relações entre fórmulas e células

Como evitar fórmulas quebradas

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×