Criar uma caixa de listagem em cascata

Nota:  Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Caixas de listagem em cascata ajudam os utilizadores a preencher formulários mais rápido e ajudar a garantir que os utilizadores introduzam dados corretamente. Este artigo descreve como criar e preencher as caixas de listagem em cascata com os dados. No Microsoft Office InfoPath, pode preencher uma lista com os dados que utiliza valores a partir do formulário, valores a partir de um documento Extensible Markup Language (XML) externo ou valores a partir de uma base de dados do Microsoft Office Access.

Neste artigo

O que é uma caixa de listagem em cascata?

Passo 1: Inserir uma caixa de listagem em cascata

Passo 2: Forneça os dados

O que é uma caixa de listagem em cascata?

Uma caixa de listagem em cascata é uma caixa de listagem com opções alterar baseado no valor que um utilizador seleciona na outra caixa de listagem. Por exemplo, se um utilizador clica condimentos na caixa categorias mostrado na ilustração seguinte, a caixa de produtos irá apresentar uma lista de condimentos.

Exemplo de caixa de listagem em cascata

As secções seguintes mostram como estruturar um modelo de formulário com duas caixas de listagem, onde a segunda caixa de listagem está filtrada baseado no valor que um utilizador seleciona na primeira caixa de listagem. Quando altera o valor na primeira caixa de listagem, o filtro é aplicado automaticamente a segunda caixa de listagem, que altera os valores.

Considerações sobre compatibilidade

Filtros podem ser utilizados apenas em modelos de formulário que foram concebidos para ser preenchido no InfoPath. Filtros não estão disponíveis em modelos de formulário compatível com o browser.

Início da página

Passo 1: Inserir uma caixa de listagem em cascata

Para criar uma caixa de listagem em cascata, terá de inserir duas caixas de listagem no seu modelo de formulário.

Nota: Quando insere uma caixa de listagem em cascata no seu modelo de formulário, certifique-se de que as duas caixas de listagem não estão numa secção de repetição ou tabela de repetição.

  1. Se o painel de tarefas Controlos não estiver visível, clique em Mais Controlos no menu Inserir ou prima ALT+I, C

  2. Em Inserir controlos no painel de tarefas controlos, clique em Caixa de lista pendente. Quando um utilizador preenche um formulário que é baseado no seu modelo de formulário, a seleção nesta caixa de lista pendente vai determinar as opções que estão disponíveis na segunda caixa de listagem.

  3. Clique em caixa de listagem. O modelo de formulário deve agora conter uma caixa de lista pendente e uma caixa de listagem padrão.

    Caixa de listagem pendente e caixa de listagem num formulário

  4. Faça duplo clique na caixa de lista pendente que é inserida no seu modelo de formulário no passo 2.

  5. Na caixa de diálogo Propriedades da caixa de lista pendente, clique no separador dados.

  6. Na caixa nome do campo, escreva Caixadelistagem1e, em seguida, clique em OK.

  7. Faça duplo clique em caixa de listagem que inseriu no seu modelo de formulário no passo 3.

  8. Na caixa de diálogo Propriedades da caixa de lista, clique no separador dados.

  9. Na caixa nome do campo, escreva Caixalista2cascatae, em seguida, clique em OK.

Início da página

Passo 2: Forneça os dados

Agora que inseriu as caixas de listagem no seu modelo de formulário, tem de fornecer os dados são apresentados. Em seguida, tem de aplicar uma filtro para que as opções na segunda caixa de listagem são baseadas na selecção do utilizador na primeira caixa de listagem.

Esta secção explica como ligar as caixas de listagem aos dados, utilizando três métodos comuns: adicionar os dados a partir de formulário propriamente dito; ligar o formulário a um documento XML existente que contém os dados; ou ligar o formulário a uma base de dados que contém os dados. Para concluir a criação da sua caixa de listagem em cascata, clique no método que pretende utilizar na lista que se segue.

Ligar a dados no formulário

Ligar a um documento XML externo

Ligar a uma base de dados

Ligar a dados no formulário

Nesta secção, vai aprender preencher as caixas de listagem com dados do formulário. Para fazer isto, tem primeiro de configurar campos no modelo de formulário para que pode introduzir os nomes das categorias e um conjunto de produtos para cada categoria.

Configurar campos no modelo de formulário

  1. Se o painel de tarefas Origem de dados não estiver visível, clique em Origem de dados no menu Ver.

  2. No painel de tarefas Origem de dados, com o botão direito do grupo meusCampos e, em seguida, clique em Adicionar.

  3. Na caixa nome, na caixa de diálogo Adicionar campo ou grupo, escreva CategoriasEProdutos.

  4. Na lista tipo, clique em grupo.

  5. Selecione a caixa de verificação de repetição e, em seguida, clique em OK.

  6. No painel de tarefas Origem de dados, botão direito do rato no grupo CategoriasEProdutos.

  7. Na caixa nome, na caixa de diálogo Adicionar campo ou grupo, escreva categoriae, em seguida, clique em OK. Este campo irá conter os nomes das categorias para a primeira caixa de lista.

  8. Botão direito do rato no grupo CategoriasEProdutos e, em seguida, clique em Adicionar.

  9. Na caixa nome, na caixa de diálogo Adicionar campo ou grupo, escreva do produto.

  10. Selecione a caixa de verificação de repetição e, em seguida, clique em OK. Este campo irá conter os nomes dos produtos para a segunda caixa de lista.

Uma vez que esta caixa de listagem é povoada com dados do formulário, os dados tem adicionados ao formulário. Para o fazer, terá de criar valores predefinidos para os campos categoria e produto.

Sugestão

Também pode criar caixas de listagens apresentam valores introduzidos pelos utilizadores no formulário de si. Para fazer isto, associe a caixa de listagem campos que estejam ligadas aos controlos no formulário. Quando um utilizador introduz valores para os controlos, altere as opções na caixa de listagem.

Criar valores predefinidos

  1. No menu Ferramentas, clique em Valores predefinidos.

  2. Na caixa de diálogo Editar valores predefinidos, no grupo CategoriasEProdutos, selecione o campo categoria (não desmarque a caixa de verificação), e, em seguida, na caixa valor predefinido, escreva alimentos de origem marinha.

  3. Selecione o campo de produto (não desmarque a caixa de verificação), e, em seguida, na caixa valor predefinido, escreva Santola.

  4. Botão direito do rato no campo produto e, em seguida, clique em Adicionar outro produto acima. Permite-lhe adicionar um segundo produto Marisco como um valor predefinido.

  5. Botão direito do rato a segunda instância do campo produto (não desmarque a caixa de verificação), e, em seguida, na caixa valor predefinido, escreva salmão.

  6. Botão direito do rato no grupo CategoriasEProdutos e, em seguida, clique em Adicionar outro CategoriasEProdutos abaixo. Permite-lhe adicionar uma segunda categoria como um valor predefinido.

  7. Utilize os passos anteriores para especificar os valores predefinidos para a segunda instância os campos categoria e produtoleite e derivados, Cheddar e leite com Chocolate, respetivamente.

  8. Clique em OK.

Agora que introduziu valores predefinidos para os campos e categoria de produto, pode ligar a primeira caixa de listagem para os dados que introduziu.

Ligar a primeira caixa de listagem aos dados

  1. No modelo de formulário, faça duplo clique em caixa de lista pendente que inseriu anteriormente.

  2. Clique no separador Dados.

  3. Na caixa de diálogo Propriedades da caixa de lista pendente, em entradas da caixa de listagem, clique em Procurar valores na origem de dados do formulário.

  4. Clique em Seleccionar XPath Imagem de botão junto à caixa de entradas.

  5. Na caixa de diálogo selecionar um campo ou grupo, no grupo CategoriasEProdutos, clique no campo categoria e, em seguida, clique em OK duas vezes.

Agora tem de ligar a segunda caixa de listagem aos dados. Ao fazer este ligação de dados, que irá que pretende aplicar um filtro a segunda caixa de listagem. Este filtro preencherá a segunda caixa de lista com os produtos adequados, com base na categoria seleccionada na primeira caixa de listagem. O filtro compara o valor seleccionado na primeira caixa de listagem (campo Caixadelistagem1) com a lista de categorias guardada no formulário de (campo de categoria).

Ligar a segunda caixa de listagem aos dados

  1. No modelo de formulário, faça duplo clique em caixa de listagem padrão que inseriu são anteriormente.

  2. Clique no separador Dados.

  3. Na caixa de diálogo Propriedades da caixa de lista, em entradas da caixa de listagem, clique em Procurar valores na origem de dados do formulário.

  4. Clique em Seleccionar XPath Imagem de botão junto à caixa de entradas.

  5. Na caixa de diálogo selecionar um campo ou grupo, no grupo CategoriasEProdutos, clique no campo de produto e, em seguida, clique em Filtrar dados.

  6. Na caixa de diálogo Filtrar dados, clique em Adicionar.

  7. Na caixa de diálogo Especificar condições de filtro, clique em selecionar um campo ou grupo na primeira caixa.

  8. Na caixa de diálogo selecionar um campo ou grupo, clique em Caixadelistagem1 e, em seguida, clique em OK.

  9. Na caixa de diálogo Especificar condições de filtro, clique em selecionar um campo ou grupo na terceira caixa.

  10. Na caixa de diálogo selecionar um campo ou grupo, clique no campo categoria e, em seguida, clique em OK para fechar todas as caixas de diálogo Abrir.

Agora que tiver ligado a segunda caixa de listagem aos dados e aplicou o filtro, está pronto para testar as caixas de listagem para se certificar de que estão a funcionar corretamente.

Testar as caixas de lista

  1. Para testar as suas alterações, clique em Pré-visualizar na barra de ferramentas Padrão ou prima CTRL+SHIFT+B.

  2. Na caixa de lista pendente, clique em alimentos de origem marinha. A caixa de listagem padrão deve mostrar uma linha em branco, Santola e salmão.

    Nota: Na linha em branco permite aos utilizadores limpar a sua escolha na caixa de listagem.

Se as caixas de listagem não funcionam corretamente, reveja o filtro para a segunda caixa de lista para se certificar de que se compara o campo Caixadelistagem1 com o campo categoria.

Início da secção

Ligar a um documento XML externo

Nesta secção, vai aprender a criar uma ligação de dados para um documento XML que contém valores de produtos e categoria. O documento XML estará a sua origem de dados secundária. Para criar esta ligação de dados, terá de criar o documento XML, associar as caixas de lista no modelo de formulário com o documento XML e, em seguida, aplicar um filtro a segunda caixa de listagem para que a lista de produtos é alterada corretamente.

Pode associar o formulário a uma origem de dados secundária, tem de criar o documento XML.

Criar o documento XML

  1. Inicie o bloco de notas ou outro editor de texto.

  2. Copie e cole os seguintes dados XML no editor de texto:

    <?xml version="1.0" encoding="UTF-8"?>
    <ListBoxData>
    <CategoriesAndProducts>
    <Categories>Seafood</Categories>
    <Products>
    <Product>Crab meat</Product>
    </Products>
    <Products>
    <Product>Salmon</Product>
    </Products>
    </CategoriesAndProducts>
    <CategoriesAndProducts>
    <Categories>Dairy</Categories>
    <Products>
    <Product>Chocolate milk</Product>
    </Products>
    <Products>
    <Product>Cheddar</Product>
    </Products>
    </CategoriesAndProducts>
    </ListBoxData>
  3. Guarde o ficheiro no seu computador como dadosCaixaListagem. XML.

Agora que criou um documento XML, pode ligá-lo para o modelo de formulário. Isto vai criar uma origem de dados secundária.

Ligar o documento XML ao modelo de formulário

  1. No menu Ferramentas, clique em Ligações de dados.

  2. Na caixa de diálogo Ligações de dados, clique em Adicionar.

  3. No Assistente de ligação de dados, clique em dados de receção e, em seguida, clique em seguinte.

  4. Na página seguinte do assistente, clique em documento XML e, em seguida, clique em seguinte.

  5. Na página seguinte do assistente, clique em Procurar, selecione o ficheiro de dadosCaixaListagem. XML que guardadas no seu computador e, em seguida, clique em Abrir.

  6. Na página seguinte do assistente, clique em incluir os dados como um ficheiro de recursos no modelo de formulário ou peça para modelo e, em seguida, clique em seguinte.

  7. Na página seguinte do assistente, na caixa introduzir um nome para esta ligação de dados, escreva listBoxDataXMLFile.

  8. Selecione a caixa de verificação obter dados automaticamente quando formulário está aberto. Isto garante que os dados da caixa lista irão estar disponíveis sempre que abrir o formulário, em vez de requerer que um utilizador a consulta para o mesmo.

  9. Clique em Concluir.

  10. Na caixa de diálogo Ligações de dados, clique em Fechar.

Agora, está pronto para ligar a primeira caixa de lista no modelo de formulário para os dados no documento XML.

Ligar a primeira caixa de listagem aos dados

  1. No modelo de formulário, faça duplo clique em caixa de lista pendente que inseriu anteriormente.

  2. Clique no separador Dados.

  3. Na caixa de diálogo Propriedades da caixa de lista pendente, em entradas da caixa de listagem, clique em Procurar valores a partir de uma origem de dados externos.

  4. Na caixa origem de dados, clique em listBoxDataXMLFile.

  5. Clique em Seleccionar XPath Imagem de botão junto à caixa de entradas.

  6. Na caixa de diálogo selecionar um campo ou grupo, no grupo CategoriasEProdutos, clique no campo de categorias.

    Nota: O fundo amarelo na caixa de diálogo selecionar um campo ou grupo indica que está a trabalhar com a origem de dados secundária.

  7. Clique duas vezes em OK.

Agora terá de ligar a segunda caixa de lista para o documento XML. Ao tornar esta ligação de dados, que irá que pretende aplicar um filtro a segunda caixa de listagem. Este filtro preencherá a segunda caixa de lista com os produtos adequados, com base na categoria seleccionada na primeira caixa de listagem. O filtro compara o valor seleccionado na primeira caixa de listagem (campo Caixadelistagem1) com a lista de categorias guardada no formulário de (campo de categoria).

Ligar a segunda caixa de listagem aos dados

  1. No modelo de formulário, faça duplo clique em caixa de listagem padrão que inseriu são anteriormente.

  2. Clique no separador Dados.

  3. Na caixa de diálogo Propriedades da caixa de lista, em entradas da caixa de listagem, clique em Procurar valores a partir de uma origem de dados externos.

  4. Na caixa origem de dados, clique em listBoxDataXMLFile.

  5. Clique em Seleccionar XPath Imagem de botão junto à caixa de entradas.

  6. Na caixa de diálogo selecionar um campo ou grupo, no grupo CategoriasEProdutos, expandir o grupo de produtos e, em seguida, clique no campo de produto.

  7. Clique em filtrar dados.

  8. Na caixa de diálogo Filtrar dados, clique em Adicionar.

  9. Na caixa de diálogo Especificar condições de filtro, clique em selecionar um campo ou grupo na primeira caixa.

  10. Na caixa origem de dados, na caixa de diálogo selecionar um campo ou grupo, clique em principal.

  11. Clique em Caixadelistagem1 e, em seguida, clique em OK.

  12. Na caixa de diálogo Especificar condições de filtro, clique em selecionar um campo ou grupo na terceira caixa.

  13. Na caixa origem de dados, na caixa de diálogo selecionar um campo ou grupo, clique em listBoxDataXMLFile (secundário) e, em seguida, clique em categorias.

  14. Clique em OK para fechar todas as caixas de diálogo abertas.

Agora que tiver ligado a segunda caixa de listagem para o documento XML e aplicou o filtro, está pronto para testar as caixas de listagem para se certificar de que estão a funcionar corretamente.

Testar as caixas de lista

  1. Para testar as suas alterações, clique em Pré-visualizar na barra de ferramentas Padrão ou prima CTRL+SHIFT+B.

  2. Na caixa de lista pendente, clique em alimentos de origem marinha. A caixa de listagem padrão deve ser apenas uma linha em branco, Santola e salmão.

    Nota: Na linha em branco permite aos utilizadores limpar a sua escolha na caixa de listagem.

Se as caixas de listagem não funcionam corretamente, reveja o filtro para a segunda caixa de lista para se certificar de que se compara o campo Caixadelistagem1 com o campo categoria.

Início da secção

Ligar a uma base de dados

Nesta secção, vai aprender a criar uma ligação de dados para duas tabelas numa base de dados do Access. Para fazer isto, associar as caixas de lista no modelo de formulário com a base de dados e, em seguida, aplicar um filtro a segunda caixa de listagem para que a lista seja apresentada corretamente na segunda alterações da caixa de lista com base no valor selecionado na primeira caixa de listagem. Neste exemplo, vamos assumir que a base de dados do Access contém duas tabelas denominadas categorias e produtos e que as duas tabelas estão relacionadas umas às outras ao campo CódigoDaCategoria, que é utilizado em cada tabela.

Tabela de categorias   

CódigoDaCategoria

NomeDaCategoria

1

Alimentos de origem marinha

2

Laticínios

Tabela de produtos   

Iddoproduto

CódigoDaCategoria

NomeDoProduto

1

1

Santola

2

1

Salmão

3

2

Leite com chocolate

4

2

Cheddar

Ligar o modelo de formulário para a origem de dados

Em primeiro lugar, tem de criar uma ligação de dados entre o modelo de formulário e as tabelas na base de dados. Dado que estiver a apresentar apenas os dados da base de dados, em vez de modificá-la diretamente, a base de dados do Access será uma origem de dados secundária para o modelo de formulário.

  1. No menu Ferramentas, clique em Ligações de dados.

  2. Na caixa de diálogo Ligações de dados, clique em Adicionar.

  3. No Assistente de ligação de dados, clique em dados de receção e, em seguida, clique em seguinte.

  4. Na página seguinte do assistente, clique em base de dados (Microsoft SQL Server ou apenas para o Microsoft Office Access) e, em seguida, clique em seguinte.

  5. Na página seguinte do assistente, clique em Selecionar base de dados e, em seguida, procure e faça duplo clique sobre a base de dados do Access no seu disco rígido.

  6. Na caixa de diálogo Selecionar tabela, clique na tabela que contém os dados que pretende mostrar na primeira lista (neste exemplo, a tabela de categorias) e, em seguida, clique em OK. A tabela seguinte especifica como sendo a tabela principal para a ligação de dados.

  7. No assistente, clique em Adicionar tabela.

  8. Na caixa de diálogo Adicionar tabela ou consulta, clique na tabela que contém os dados que pretende mostrar na segunda lista (neste exemplo, a tabela de produtos) e, em seguida, clique em seguinte.

  9. Na caixa de diálogo Editar relações, certifique-se de que os campos de ligação estão corretos. Neste exemplo, as tabelas estão relacionadas umas às outras ao campo CódigoDaCategoria.

    Sugestão: Se os campos de ligação forem incorretos, selecione os campos e, em seguida, clique em Remover relação. Em seguida, clique em Adicionar relação, selecione os campos corretos e, em seguida, clique em OK.

  10. Clique em Concluir.

    Nota: Neste exemplo, a tabela de categorias tem uma relação um-para-muitos à tabela de produtos, o que significa que para cada categoria podem existir vários produtos. Numa base de dados, este tipo de relação, normalmente, é estabelecido utilizando campos de chave. Neste caso, o campo CódigoDaCategoria ativa o acesso associar o conjunto de produtos correto na categoria adequada.

  11. No assistente, reveja a estrutura de origem de dados. Deverá visualizar duas tabelas ligadas umas às outras: tabela principal e a tabela secundária. Para ver os campos individuais na tabela, selecione a caixa de verificação Mostrar colunas da tabela. Assim que tiver terminado de rever a estrutura de dados, clique em seguinte.

  12. Desmarque a caixa de verificação do arquivo de uma cópia dos dados no modelo de formulário e, em seguida, clique em seguinte.

  13. Na caixa introduzir um nome para esta ligação de dados, na página seguinte do assistente, escreva um nome para a ligação de dados.

  14. Selecione a caixa de verificação obter dados automaticamente quando formulário está aberto.

  15. Clique em Concluir e, em seguida, clique em Fechar na caixa de diálogo Ligações de dados.

Ligar a primeira caixa de listagem a dados

Agora que criou uma ligação de dados à origem de dados secundária, pode ligar a primeira caixa de listagem no modelo de formulário com as tabelas na base de dados.

  1. No modelo de formulário, faça duplo clique em caixa de lista pendente que inseriu anterior.

  2. Clique no separador Dados.

  3. Na caixa de diálogo Propriedades da caixa de lista pendente, em entradas da caixa de listagem, clique em Procurar valores a partir de uma origem de dados externos.

  4. Na caixa origem de dados, certifique-se de que a ligação de dados que criou está selecionada.

  5. Clique em Seleccionar XPath Imagem de botão junto à caixa de entradas.

  6. Na caixa de diálogo selecionar um campo ou grupo, clique no nome da tabela que contém os dados que pretende mostrar na lista pendente (neste exemplo, d:categorias ) e, em seguida, clique em OK.

    Nota: O fundo amarelo na caixa de diálogo selecionar um campo ou grupo indica que está a trabalhar com a origem de dados secundária.

  7. Clique em Seleccionar XPath Imagem de botão junto à caixa valor.

  8. Na caixa de diálogo selecionar um campo ou grupo, certifique-se de que o campo conexão (neste exemplo, : CódigoDaCategoria ) está selecionada e, em seguida, clique em OK. Este é o valor que vai ser guardado quando o utilizador faz uma seleção na caixa de listagem.

  9. Clique em Seleccionar XPath Imagem de botão junto à caixa de nome a apresentar.

  10. Na caixa de diálogo selecionar um campo ou grupo, clique no nome do campo que pretende apresentar na lista pendente (neste exemplo, : NomeDaCategoria ).

  11. Clique duas vezes em OK.

Ligar a segunda caixa de listagem a dados

Irão agora ter que ligar a segunda caixa de listagem à base de dados. Ao tornar esta ligação de dados, que irá que pretende aplicar um filtro a segunda caixa de listagem. Este filtro preencherá segunda caixa de listagem com os valores adequados, baseado no valor selecionados na primeira caixa de listagem.

  1. No modelo de formulário, faça duplo clique em caixa de listagem padrão.

  2. Clique no separador Dados.

  3. Na caixa de diálogo Propriedades da caixa de lista, em entradas da caixa de listagem, clique em Procurar valores a partir de uma origem de dados externos.

  4. Na caixa origem de dados, certifique-se de que a ligação de dados que criou está selecionada.

  5. Clique em Seleccionar XPath Imagem de botão junto à caixa de entradas.

  6. Na caixa de diálogo selecionar um campo ou grupo, expanda o grupo principal (neste exemplo, d:categorias ) e, em seguida, clique no grupo secundário que corresponde à tabela que contém os dados que pretende apresentar na caixa de listagem em cascata (neste exemplo, produtos ).

  7. Clique em filtrar dados.

  8. Na caixa de diálogo Filtrar dados, clique em Adicionar.

  9. Na caixa de diálogo Especificar condições de filtro, na primeira caixa, certifique-se de que o campo da tabela secundária (neste exemplo, produtos ), conexão está selecionada.

    Importante: Se os campos de ligação têm o mesmo nome em ambas as tabelas, certifique-se de que seleciona o correto. Os campos de cada tabela são ordenados em conjunto na lista. Por conseguinte, pode utilizar os nomes de campo adjacente para determinar qual é o correto. Neste exemplo, podemos selecione o campo CódigoDaCategoria que aparece com os outros campos da tabela produtos.

  10. Na terceira caixa, clique em selecionar um campo ou grupo.

  11. Na caixa origem de dados, na caixa de diálogo selecionar um campo ou grupo, clique em principal, clique no campo Caixadelistagem1 e, em seguida, clique em OK.

    Agora ter configurado um filtro que compara o valor seleccionado na caixa de lista pendente (campo Caixadelistagem1) com a lista de valores na caixa de listagem padrão.

  12. Clique em OK três vezes para voltar à caixa de diálogo Propriedades da caixa de lista.

  13. Clique em Seleccionar XPath Imagem de botão junto à caixa valor.

  14. Na caixa de diálogo selecionar um campo ou grupo, selecione o valor que pretende guardar quando o utilizador faz uma seleção na caixa de listagem. Neste exemplo, vamos pretende guardar o campo CódigoDoProduto para utilizar posteriormente. Por conseguinte, selecione estamos a : Iddoproduto agrupar e, em seguida, clique em OK.

  15. Clique em Seleccionar XPath Imagem de botão junto à caixa de nome a apresentar.

  16. Na caixa de diálogo selecionar um campo ou grupo, clique no nome do campo que pretende mostrar na caixa de listagem (neste exemplo, : ProductName ).

  17. Clique duas vezes em OK.

Testar as caixas de lista

Agora que tiver ligado a segunda caixa de listagem à base de dados e aplicou o filtro, está pronto para testar as caixas de listagem para se certificar de que estão a funcionar corretamente.

  1. Para testar as suas alterações, clique em Pré-visualizar na barra de ferramentas Padrão ou prima CTRL+SHIFT+B.

  2. Selecione um valor na caixa de lista pendente. A caixa de listagem padrão deve mostrar os valores adequados da tabela secundária, consoante o campo de conexão que tenha escolhido.

Sugestão: Se as caixas de listagem não funcionam corretamente, reveja o filtro para a segunda caixa de lista para se certificar de que se compara o campo Caixadelistagem1 com o campo CódigoDaCategoria.

Início da secção

Início da página

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×