Criar um Modelo de Base de Dados (também conhecido como diagrama de Entidade-Relação)

Criar um Modelo de Base de Dados (também conhecido como diagrama de Entidade-Relação)

Com o modelo Diagrama de Modelo Base de Dados, pode criar um novo modelo ou proceder à engenharia inversa de uma base de dados existente para criar um modelo através dos conceitos de modelação relacional ou de modelação relacional de objetos. Utilize o stencil Entidade-Relação para modelar bases de dados baseadas no SQL92 e em padrões anteriores. Utilize o stencil Relacional-Objeto, que contém formas adicionais para trabalhar com tipos, para modelar bases de dados baseadas no SQL99 e em padrões posteriores.

Exemplo de modelo de base de dados

Com o modelo Diagrama de Modelo Base de Dados, pode criar um novo modelo ou proceder à engenharia inversa de uma base de dados existente para criar um modelo através dos conceitos de modelação relacional ou de modelação relacional de objetos. Utilize o stencil Entidade-Relação para modelar bases de dados baseadas no SQL92 e em padrões anteriores. Utilize o stencil Relacional-Objeto, que contém formas adicionais para trabalhar com tipos, para modelar bases de dados baseadas no SQL99 e em padrões posteriores.

Este artigo descreve como pode criar um modelo de base de dados e o que pode fazer com o mesmo depois de o criar.

Não consegue encontrar as funcionalidades de modelo de base de dados?

Nem todas as edições do Microsoft Visio têm a funcionalidade de modelo de base de dados. Se não conseguir encontrar as funcionalidades descritas nos procedimentos descritos neste artigo, é provável que a sua edição do Visio não as inclua.

  • O Microsoft Visio Standard não inclui o modelo Diagrama de Modelo de Base de Dados.

  • As edições Microsoft Visio Professional e Microsoft Visio Premium suportam as funcionalidades de engenharia inversa para o modelo Diagrama de Modelo de Base de Dados (isto é, utilizar uma base de dados existente para criar um modelo no Visio), mas não suportam engenharia direta (isto é, utilizar um modelo de base de dados do Visio para gerar um código SQL).

  1. Para começar a criar o seu diagrama de modelo de base de dados, siga um dos seguintes passos:

    Criar um novo diagrama de modelo de raiz

    Se não tiver uma base de dados existente que queira utilizar como ponto de partida, pode começar com um Modelo de Base de Dados e adicionar as suas próprias tabelas e relações.

    1. Clique no separador Ficheiro.

    2. Clique em Novo, clique em Software e Base de Dados e, em seguida, faça duplo clique em Diagrama de Modelo de Base de Dados.

    3. No separador Base de Dados, no grupo Gerir, clique em Opções de Visualização.

    4. Na caixa de diálogo Opções de Documento da Base de Dados, selecione o conjunto de símbolos que pretende utilizar e outra tabela ou opções de relação e, em seguida, clique em OK.

    Utilizar uma base de dados existente como ponto de partida

    Se tiver uma base de dados que pretende modelar para que a possa compreender melhor ou utilizá-la como ponto de partida para um novo modelo, pode utilizar o Assistente de Engenharia Inversa para extrair o esquema ou estrutura da base de dados e criar um novo modelo.

    Antes de iniciar o assistente:

    1. Se estiver a proceder à engenharia inversa de um livro do Microsoft Excel, antes de iniciar o assistente, tem de abrir o livro e atribuir um nome ao grupo (ou intervalo) de células que contém os cabeçalhos de coluna. Se quiser utilizar mais do que uma folha de cálculo, atribua um nome ao grupo de células da coluna em cada folha de cálculo. Estes intervalos são tratados como tabelas no assistente. Para obter mais informações sobre como atribuir um nome a um intervalo de células, consulte o tópico na ajuda do Excel intitulado Definir referências ou intervalos de células com nome.

    2. Para obter melhores resultados, defina o seu controlador predefinido para a base de dados de destino na qual pretende proceder à engenharia inversa antes de executar o Assistente de Engenharia Inversa. Este passo garante que o assistente mapeia corretamente os tipos de dados nativos e que todos os códigos extraídos pelo assistente são apresentados corretamente na janela Código.

    3. Clique no separador Ficheiro.

    4. Clique em Novo, clique em Software e Base de Dados e, em seguida, faça duplo clique em Diagrama de Modelo de Base de Dados.

    5. No separador Base de Dados, no grupo Modelo, clique em Engenharia Inversa.

    6. No primeiro ecrã do Assistente de Engenharia Inversa, faça o seguinte:

      1. Selecione o controlador de bases de dados para o seu sistema de gestão de bases de dados (DBMS). Se ainda não associou o controlador de bases de dados do Visio a uma origem de dados ODBC específica, clique em Configuração.

        Nota: Se estiver a proceder à engenharia inversa de uma folha de cálculo do Excel, selecione o Controlador Genérico de ODBC.

      2. Selecione a origem de dados da base de dados que está a atualizar. Se ainda não criou uma origem de dados para a base de dados existente, clique em Novo para o fazer agora.

        Ao criar uma nova origem, o respetivo nome é adicionado à lista Origens de Dados.

      3. Quando estiver satisfeito com as definições, clique em Seguinte.

    7. Siga as instruções nas caixas de diálogo específicas do controlador.

      Por exemplo, na caixa de diálogo Ligar Origem de Dados, escreva o nome de utilizador e palavra-passe e, em seguida, clique em OK.

      Nota: Se utilizar o Controlador Genérico de ODBC, poderá receber uma mensagem de erro a indicar que as informações submetidas a engenharia inversa poderão estar incompletas. Na maioria dos casos, isto não é um problema: clique em OK e prossiga com o assistente.

    8. Selecione as caixas de verificação dos tipos de informações que pretende extrair e, em seguida, clique em Seguinte.

      Nota: Alguns itens poderão estar indisponíveis (quando aparecem a cinzento) porque nem todos os sistemas de gestão de bases de dados suportam todos os tipos de elementos que o assistente pode extrair.

    9. Selecione as caixas de verificação das tabelas (e vistas, se existirem) que pretende extrair ou clique em Seleccionar Tudo para extraí-las todas e, em seguida, clique em Seguinte.

      Nota: Se estiver a proceder à engenharia inversa de uma folha de cálculo do Excel e não vir nada nesta lista, é provável que tenha de atribuir um nome ao intervalo de células que contém os cabeçalhos de coluna na sua folha de cálculo.

    10. Se selecionou a caixa de verificação Procedimentos Armazenados, selecione os procedimentos que pretende extrair ou clique em Seleccionar Tudo para extraí-los todos e, em seguida, clique em Seguinte.

    11. Selecione se pretende que os itens submetidos a engenharia inversa sejam adicionados automaticamente à página atual.

      Nota: Pode deixar que o assistente crie automaticamente o desenho, para além de indicar os itens submetidos a engenharia inversa na janela Tabelas e Vistas. Se decidir não deixar que o desenho seja criado automaticamente, pode arrastar os itens da janela Tabelas e Vistas para a sua página de desenho para criar manualmente o modelo de base de dados.

    12. Reveja as suas seleções para verificar se está a extrair as informações que pretende e, em seguida, clique em Concluir.

      O assistente extrai as informações selecionadas e apresenta notas sobre o processo de extração na janela Saída.

    Importar e refinar um modelo existente

    Se tiver um modelo existente do VisioModeler ou PLATINUM ERwin, poderá conseguir importá-lo para criar um diagrama de modelo de base de dados do Visio. Esta funcionalidade está limitada ao VisioModeler 2.0 ou a ficheiros de modelo de dicionário (.imd) e a ficheiros .erx do PLATINUM ERwin 2.6, 3.0 e 3.52.

    1. Clique no separador Ficheiro.

    2. Clique em Novo, clique em Software e Base de Dados e, em seguida, faça duplo clique em Diagrama de Modelo de Base de Dados.

    3. No separador Base de Dados, no grupo Modelo, clique em Importar e, em seguida, clique no tipo de modelo.

    4. Escreva o caminho e o nome de ficheiro do modelo que pretende importar ou clique no botão Procurar para localizar o ficheiro do modelo e, em seguida, clique em Abrir.

    5. Na caixa de diálogo Importar, clique em OK.

      O Visio importa o ficheiro e apresenta o respetivo progresso na janela Saída. As tabelas importadas são apresentadas na janela Tabelas e Vistas.

    6. Na janela Tabelas e Vistas, selecione as tabelas que pretende modelar e, em seguida, arraste-as para a página de desenho.

  2. Após criar um diagrama de modelo de base de dados, segue-se o passo de aperfeiçoar o diagrama. Pode adicionar e personalizar tabelas e vistas, criar relações e personalizar colunas e tipos de dados.

    Tabelas

    Utilize a forma Entidade para criar uma tabela no seu diagrama.

    1. A partir do stencil Entidade-Relação ou Relacional-Objecto, arraste uma forma Entidade para o desenho.

    2. Faça duplo clique na forma para abrir a janela Propriedades da Base de Dados.

    3. Em Categorias, clique em Definição e escreva um nome para a tabela.

    4. Em Categorias, clique em Colunas, escreva um nome e selecione um tipo de dados.

    5. Selecione a caixa de verificação Necessário para as colunas que não podem ter valores nulos.

    6. Selecione a caixa de verificação PK (chave primária) para as colunas que identificam exclusivamente cada linha na tabela da base de dados.

    7. Em Categorias, clique em Índices, Accionadores, Verificar ou Expandidos para criar estes elementos opcionais.

    Colunas

    Utilize a janela Propriedades da Base de Dados para adicionar ou alterar as propriedades das colunas, incluindo tipos de dados e chaves primárias.

    1. Faça duplo clique na tabela no seu diagrama.

    2. Na janela Propriedades da Base de Dados, em Categorias, clique em Colunas.

    3. Clique na primeira célula Nome Físico vazia e escreva um nome.

    4. Para alterar o tipo de dados de uma coluna, clique no campo Tipo de Dados da coluna e, em seguida, selecione um tipo de dados da lista ou escreva-o na lista. Por exemplo, pode escrever decimal(8,2) ou char(30).

    5. Para evitar valores nulos, selecione a caixa de verificação Necessário.

    6. Para especificar a coluna como uma chave primária, selecione a caixa de verificação PK.

    7. Para ver mais propriedades de coluna para além das apresentadas ao clicar na categoria Colunas, selecione a coluna e, em seguida, clique em Editar.

    Relações

    As relações utilizam chaves primárias e externas para permitir que as bases de dados correspondam determinada linha numa tabela com uma linha numa tabela relacionada. Pode mostrar essas relações no seu diagrama. Além disso, pode definir a respetiva cardinalidade (por exemplo, um-para-muitos) e utilizar uma notação de Pés de galinha, Relacional ou IDEF1X para mostrar a cardinalidade. Não pode mostrar relações muitos-para-muitos com nenhuma destas notações no modelo Diagrama de Modelo de Base de Dados.

    1. Crie uma relação entre tabelas:

      1. Certifique-se de que ambas as tabelas estão visíveis no diagrama. Se procedeu à engenharia inversa do modelo de uma base de dados existente, poderá ter de arrastar uma ou ambas as tabelas da janela Tabelas e Vistas para a página de desenho.

      2. Faça duplo clique na tabela que pretende para o lado da chave primária da relação.

      3. Na janela Propriedades da Base de Dados, em Categorias, clique em Colunas.

      4. Na grelha, clique na coluna que pretende utilizar para identificar exclusivamente cada linha na tabela e selecione a caixa de verificação PK para defini-la como a chave primária.

      5. A partir do stencil Relacional-Objecto ou Entidade-Relação, arraste uma forma Relação e largue-a num espaço em branco na página.

      6. Ligue o lado superior da tabela à tabela principal.

      7. Ligue o outro lado à tabela subordinada.

        Se a segunda tabela ainda não contiver uma coluna com o mesmo nome da chave primária, o modelador irá adicioná-la à segunda tabela como uma chave externa.

        Nota: Caso as linhas de relação desapareçam, no separador Base de Dados, no grupo Gerir, clique em Opções de Visualização. No separador Relações, em Mostrar, selecione a caixa de verificação Relações.

    2. Defina a cardinalidade da relação:

      1. Faça duplo clique na relação.

      2. Na janela Propriedades da Base de Dados, em Categorias, clique em Diversos.

      3. Em Cardinalidade, selecione o tipo de cardinalidade que melhor se adequa à relação. Em relações um-para-muitos, a melhor escolha é Zero ou mais ou Um ou mais. Em relações um-para-um, a melhor escolha é Zero ou um ou Exatamente um.

  3. Para fazer ajustes ao seu diagrama (como criar índices, cláusulas de verificação e acionadores), pode fazer o seguinte:

    Criar índices

    Os índices melhoram o desempenho (ou velocidade) da sua base de dados ao executar uma consulta.

    1. Abra o diagrama de modelo de base de dados.

    2. Faça duplo clique na tabela à qual pretende adicionar um índice e, na janela Propriedades da Base de Dados, na lista Categorias, clique em Índices.

    3. Clique em Novo.

    4. Na caixa de diálogo Criar Índice, escreva um nome para o índice e, em seguida, clique em OK.

    5. Na lista Tipo de Índice, selecione uma opção para criar ou índice exclusivo ou não exclusivo.

    6. Na lista Colunas Disponíveis, selecione o nome de cada coluna que pretende incluir neste índice e, em seguida, clique em Adicionar >.

    7. Na lista Colunas com Índice, selecione a caixa de verificação Asc para criar um índice com uma sequência de ordenação ascendente ou desselecione a caixa de verificação para criar um índice com uma ordem descendente.

      O diagrama de modelo de base é atualizado.

    Criar vistas

    Pode considerar uma vista como uma consulta guardada. As vistas são particularmente úteis se precisar de aceder repetidamente às mesmas informações de múltiplas tabelas ou quiser expor os dados aos utilizadores sem permitir que estes alterem as tabelas.

    A partir do stencil Entidade-Relação ou Relacional-Objecto, arraste uma forma Vista para a página de desenho.

    Definir propriedades expandidas de tabelas e vistas

    Consoante o seu sistema de gestão de bases de dados (DBMS), poderá definir propriedades expandidas de tabelas ou vistas para determinar onde estas são armazenadas.

    Faça duplo clique na tabela ou vista cujas propriedades expandidas pretende definir e, na janela Propriedades da Base de Dados, na lista Categorias, clique em Expandidos.

    Criar cláusulas de verificação

    Utilize cláusulas de verificação para garantir que os dados introduzidos numa coluna estão dentro de um intervalo de valores específico. Por exemplo, pode criar uma cláusula de verificação que exija que os dados numa coluna com o nome "Idade" sejam superiores a 65.

    1. Faça duplo clique na tabela para abrir a janela Propriedades da Base de Dados.

    2. Em Categorias, clique em Colunas e, em seguida, clique na coluna à qual pretende adicionar uma cláusula de verificação.

    3. Clique em Editar.

    4. No separador Verificar da caixa de diálogo Propriedades da Coluna, introduza as restrições que pretende aplicar.

      A cláusula de verificação é adicionada à janela Código em Código local.

    Criar procedimentos armazenados e funções definidas pelo utilizador

    Utilize procedimentos armazenados e funções definidas pelo utilizador para criar pacotes de código que pode reutilizar para repetir as mesmas ações. A principal diferença entre os dois é que uma função definida pelo utilizador devolve um valor, enquanto o procedimento armazenado executa códigos sem devolver um valor.

    1. No separador Base de Dados, no grupo Mostrar/Ocultar, selecione a caixa de verificação Código para abrir a janela Código.

    2. Clique em Código Global e, em seguida, clique em Novo.

    3. No separador Propriedades do Editor de Códigos, clique no tipo de código que pretende criar e escreva um nome para o código.

    4. No separador Corpo, escreva o código e, em seguida, clique em OK.

    Criar acionadores

    Os acionadores fazem com que o código SQL que especificar no acionador seja executado ao ocorrer um evento específico na base de dados.

    1. Faça duplo clique na tabela para abrir a janela Propriedades da Base de Dados.

    2. Em Categorias, clique em Accionadores e, em seguida, clique em Adicionar.

    3. No separador Propriedades, escreva um nome para o acionador.

    4. No separador Corpo, escreva o código e, em seguida, clique em OK.

      O acionador é adicionado à janela Código em Código local.

Este artigo descreve como pode criar um modelo de base de dados e o que pode fazer com o mesmo depois de o criar. Para começar rapidamente, no menu Ficheiro, aponte para Novo, Software e Base de Dados e, em seguida, clique em Diagrama de Modelo de Base de Dados.

Não consegue encontrar as funcionalidades de modelo de base de dados?

Muito provavelmente, a sua edição do Microsoft Office Visio não inclui as funcionalidades de que está à procura. Para saber qual é a edição do Visio que possui, clique em Acerca do Microsoft Office Visio no menu Ajuda. O nome da edição encontra-se na linha de texto superior na caixa de diálogo.

  • O Microsoft Office Visio Standard não inclui o modelo Diagrama de Modelo de Base de Dados.

  • O Microsoft Office Visio Professional suporta as funcionalidades de engenharia inversa para o modelo Diagrama de Modelo de Base de Dados (isto é, utilizar uma base de dados existente para criar um modelo no Visio), mas não suporta engenharia direta (isto é, utilizar um modelo de base de dados do Visio para gerar um código SQL).

  • No Visio for Enterprise Architects, encontrará o conjunto de funcionalidades de modelação de bases de dados completo, incluindo engenharia inversa e direta. O Visio for Enterprise Architects está incluído na Subscrição do MSDN Premium, que está disponível nas edições com base em funções do Visual Studio Professional e do Visual Studio Team System.

  1. Para começar a criar o seu diagrama de modelo de base de dados, siga um dos seguintes passos:

    Criar um novo diagrama de modelo de raiz

    Se não tiver uma base de dados existente que queira utilizar como ponto de partida, pode começar com um Modelo de Base de Dados e adicionar as suas próprias tabelas e relações.

    1. No menu Ficheiro, aponte para Novo, Software e Base de Dados e, em seguida, clique em Diagrama de Modelo de Base de Dados.

    2. No menu Base de Dados, aponte para Opções e, em seguida, clique em Documento.

    3. Na caixa de diálogo Opções de Documento da Base de Dados, selecione o conjunto de símbolos que pretende utilizar e outra tabela ou opções de relação e, em seguida, clique em OK.

    Utilizar uma base de dados existente como ponto de partida

    Se tiver uma base de dados que pretende modelar para que a possa compreender melhor ou utilizá-la como ponto de partida para um novo modelo, pode utilizar o Assistente de Engenharia Inversa para extrair o esquema ou estrutura da base de dados e criar um novo modelo.

    Nota: Antes de iniciar o assistente:

    1. Se estiver a proceder à engenharia inversa de um livro do Microsoft Office Excel, antes de iniciar o assistente, tem de abrir o livro e atribuir um nome ao grupo (ou intervalo) de células que contém os cabeçalhos de coluna. Se quiser utilizar mais do que uma folha de cálculo, atribua um nome ao grupo de células da coluna em cada folha de cálculo. Estes intervalos são tratados como tabelas no assistente. Para obter mais informações sobre como atribuir um nome a um intervalo de células, consulte o tópico na ajuda do Microsoft Office Excel intitulado Definir referências ou intervalos de células com nome.

    2. Para obter melhores resultados, defina o seu controlador predefinido para a base de dados de destino na qual pretende proceder à engenharia inversa antes de executar o Assistente de Engenharia Inversa. Este passo garante que o assistente mapeia corretamente os tipos de dados nativos e que todos os códigos extraídos pelo assistente são apresentados corretamente na janela Código.

    3. No menu Ficheiro, aponte para Novo, Software e Base de Dados e, em seguida, clique em Diagrama de Modelo de Base de Dados.

    4. No menu Base de Dados, clique em Engenharia Inversa.

    5. No primeiro ecrã do Assistente de Engenharia Inversa, faça o seguinte:

      1. Selecione o controlador de bases de dados do Microsoft Office Visio para o seu sistema de gestão de bases de dados (DBMS). Se ainda não associou o controlador de bases de dados do Visio a uma origem de dados ODBC específica, clique em Configuração.

        Nota: Se estiver a proceder à engenharia inversa de uma folha de cálculo do Excel, selecione o Controlador Genérico de ODBC.

      2. Selecione a origem de dados da base de dados que está a atualizar. Se ainda não criou uma origem de dados para a base de dados existente, clique em Novo para o fazer agora.

        Ao criar uma nova origem, o respetivo nome é adicionado à lista Origens de Dados.

      3. Quando estiver satisfeito com as definições, clique em Seguinte.

    6. Siga as instruções nas caixas de diálogo específicas do controlador.

      Por exemplo, na caixa de diálogo Ligar Origem de Dados, escreva um nome de utilizador e palavra-passe e, em seguida, clique em OK. Se a sua origem de dados não estiver protegida por palavra-passe, clique em OK.

      Nota: Se utilizar o Controlador Genérico de ODBC, poderá receber uma mensagem de erro a indicar que as informações submetidas a engenharia inversa poderão estar incompletas. Na maioria dos casos, isto não é um problema: clique em OK e prossiga com o assistente.

    7. Selecione as caixas de verificação dos tipos de informações que pretende extrair e, em seguida, clique em Seguinte.

      Nota: Alguns itens poderão estar indisponíveis (quando aparecem a cinzento) porque nem todos os sistemas de gestão de bases de dados suportam todos os tipos de elementos que o assistente pode extrair.

    8. Selecione as caixas de verificação das tabelas (e vistas, se existirem) que pretende extrair ou clique em Seleccionar Tudo para extraí-las todas e, em seguida, clique em Seguinte.

      Nota: Se estiver a proceder à engenharia inversa de uma folha de cálculo do Excel e não vir nada nesta lista, é provável que tenha de atribuir um nome ao intervalo de células que contém os cabeçalhos de coluna na sua folha de cálculo.

    9. Se selecionou a caixa de verificação Procedimentos Armazenados no passo 5, selecione os procedimentos que pretende extrair ou clique em Seleccionar Tudo para extraí-los todos e, em seguida, clique em Seguinte.

    10. Selecione se pretende que os itens submetidos a engenharia inversa sejam adicionados automaticamente à página atual.

      Nota: Pode deixar que o assistente crie automaticamente o desenho, para além de indicar os itens submetidos a engenharia inversa na janela Tabelas e Vistas. Se decidir não deixar que o desenho seja criado automaticamente, pode arrastar os itens da janela Tabelas e Vistas para a sua página de desenho para criar manualmente o modelo de base de dados.

    11. Reveja as suas seleções para verificar se está a extrair as informações que pretende e, em seguida, clique em Concluir.

      O assistente extrai as informações selecionadas e apresenta notas sobre o processo de extração na janela Saída.

    Importar e refinar um modelo existente

    Se tiver um modelo existente do VisioModeler ou PLATINUM ERwin, poderá conseguir importá-lo para criar um diagrama de modelo de base de dados do Visio. Esta funcionalidade está limitada ao VisioModeler 2.0 ou a ficheiros de modelo de dicionário (.imd) e a ficheiros .erx do PLATINUM ERwin 2.6, 3.0 e 3.52.

    1. No menu Ficheiro, aponte para Novo, Software e Base de Dados e, em seguida, clique em Diagrama de Modelo de Base de Dados.

    2. No menu Base de Dados, aponte para Importar e, em seguida, clique em Importar <tipo de modelo>.

    3. Escreva o caminho e o nome de ficheiro do modelo que pretende importar ou clique no botão Procurar para localizar o ficheiro do modelo e, em seguida, clique em Abrir.

    4. Na caixa de diálogo Importar, clique em OK.

      O Visio importa o ficheiro e apresenta o respetivo progresso na janela Saída. As tabelas importadas são apresentadas na janela Tabelas e Vistas.

    5. Na janela Tabelas e Vistas, selecione as tabelas que pretende modelar e, em seguida, arraste-as para a página de desenho.

  2. Após criar um diagrama de modelo de base de dados, segue-se o passo de aperfeiçoar o diagrama. Pode adicionar e personalizar tabelas e vistas, criar relações e personalizar colunas e tipos de dados.

    Tabelas

    Utilize a forma Entidade para criar uma tabela no seu diagrama.

    1. A partir do stencil Entidade-Relação ou Relacional-Objecto, arraste uma forma Entidade para o desenho.

    2. Faça duplo clique na forma para abrir a janela Propriedades da Base de Dados.

    3. Em Categorias, clique em Definição e escreva um nome para a tabela.

    4. Em Categorias, clique em Colunas, escreva um nome e selecione um tipo de dados.

    5. Selecione a caixa de verificação Necessário para as colunas que não podem ter valores nulos.

    6. Selecione a caixa de verificação PK (chave primária) para as colunas que identificam exclusivamente cada linha na tabela da base de dados.

    7. Em Categorias, clique em Índices, Accionadores, Verificar ou Expandidos para criar estes elementos opcionais.

    Colunas

    Utilize a janela Propriedades da Base de Dados para adicionar ou alterar as propriedades das colunas, incluindo tipos de dados e chaves primárias.

    1. Faça duplo clique na tabela no seu diagrama.

    2. Na janela Propriedades da Base de Dados, em Categorias, clique em Colunas.

    3. Clique na primeira célula Nome físico vazia e escreva um nome.

    4. Para alterar o tipo de dados de uma coluna, clique no campo Tipo de Dados da coluna e, em seguida, selecione um tipo de dados da lista ou escreva-o na lista. Por exemplo, pode escrever decimal(8,2) ou char(30).

    5. Para evitar valores nulos, selecione a caixa de verificação Necessário.

    6. Para especificar a coluna como uma chave primária, selecione a caixa de verificação PK.

    7. Para ver mais propriedades de coluna para além das apresentadas ao clicar na categoria Colunas, selecione a coluna e, em seguida, clique em Editar.

    Relações

    As relações utilizam chaves primárias e externas para permitir que as bases de dados correspondam determinada linha numa tabela com uma linha numa tabela relacionada. Pode mostrar essas relações no seu diagrama. Além disso, pode definir a respetiva cardinalidade (por exemplo, um-para-muitos) e utilizar uma notação de Pés de galinha, Relacional ou IDEF1X para mostrar a cardinalidade. Não pode mostrar relações muitos-para-muitos com nenhuma destas notações no modelo Diagrama de Modelo de Base de Dados.

    1. Crie uma relação entre tabelas:

      1. Certifique-se de que ambas as tabelas estão visíveis no diagrama. Se procedeu à engenharia inversa do modelo de uma base de dados existente, poderá ter de arrastar uma ou ambas as tabelas da janela Tabelas e Vistas para a página de desenho.

      2. Faça duplo clique na tabela que pretende para o lado da chave primária da relação.

      3. Na janela Propriedades da Base de Dados, em Categorias, clique em Colunas.

      4. Na grelha, clique na coluna que pretende utilizar para identificar exclusivamente cada linha na tabela e selecione a caixa de verificação PK para defini-la como a chave primária.

      5. A partir do stencil Relacional-Objecto ou Entidade-Relação, arraste uma forma Relação e largue-a num espaço em branco na página.

      6. Ligue o lado superior da tabela à tabela principal.

      7. Ligue o outro lado à tabela subordinada.

        Se a segunda tabela ainda não contiver uma coluna com o mesmo nome da chave primária, o modelador irá adicioná-la à segunda tabela como uma chave externa.

        Nota: Caso as linhas de relação desapareçam, no menu Base de Dados, aponte para Opções e, em seguida, clique em Documento. No separador Relações, em Mostrar, selecione a caixa de verificação Relações.

    2. Defina a cardinalidade da relação:

      1. Faça duplo clique na relação.

      2. Na janela Propriedades da Base de Dados, em Categorias, clique em Diversos.

      3. Em Cardinalidade, selecione o tipo de cardinalidade que melhor se adequa à relação. Em relações um-para-muitos, a melhor escolha é Zero ou mais ou Um ou mais. Em relações um-para-um, a melhor escolha é Zero ou um ou Exatamente um.

  3. Para fazer ajustes ao seu diagrama (como criar índices, cláusulas de verificação e acionadores), pode fazer o seguinte:

    Criar índices

    Os índices melhoram o desempenho (ou velocidade) da sua base de dados ao executar uma consulta.

    1. Abra o diagrama de modelo de base de dados.

    2. Faça duplo clique na tabela à qual pretende adicionar um índice e, na janela Propriedades da Base de Dados, na lista Categorias, clique em Índices.

    3. Clique em Novo.

    4. Na caixa de diálogo Criar Índice, escreva um nome para o índice e, em seguida, clique em OK.

    5. Na lista Tipo de Índice, selecione uma opção para criar ou índice exclusivo ou não exclusivo.

    6. Na lista Colunas Disponíveis, selecione o nome de cada coluna que pretende incluir neste índice e, em seguida, clique em Adicionar >.

    7. Na lista Colunas com Índice, selecione a caixa de verificação Asc para criar um índice com uma sequência de ordenação ascendente ou desselecione a caixa de verificação para criar um índice com uma ordem descendente.

      O diagrama de modelo de base é atualizado.

    Criar vistas

    Pode considerar uma vista como uma consulta guardada. As vistas são particularmente úteis se precisar de aceder repetidamente às mesmas informações de múltiplas tabelas ou quiser expor os dados aos utilizadores sem permitir que estes alterem as tabelas.

    A partir do stencil Entidade-Relação ou Relacional-Objecto, arraste uma forma Vista para a página de desenho.

    Definir propriedades expandidas de tabelas e vistas

    Consoante o seu sistema de gestão de bases de dados (DBMS), poderá definir propriedades expandidas de tabelas ou vistas para determinar onde estas são armazenadas.

    Faça duplo clique na tabela ou vista cujas propriedades expandidas pretende definir e, na janela Propriedades da Base de Dados, na lista Categorias, clique em Expandidos.

    Criar cláusulas de verificação

    Utilize cláusulas de verificação para garantir que os dados introduzidos numa coluna estão dentro de um intervalo de valores específico. Por exemplo, pode criar uma cláusula de verificação que exija que os dados numa coluna com o nome "Idade" sejam superiores a 65.

    1. Faça duplo clique na tabela para abrir a janela Propriedades da Base de Dados.

    2. Em Categorias, clique em Colunas e, em seguida, clique na coluna à qual pretende adicionar uma cláusula de verificação.

    3. Clique em Editar.

    4. No separador Verificar da caixa de diálogo Propriedades da Coluna, introduza as restrições que pretende aplicar. Para obter mais informações sobre as suas opções, consulte Caixas de diálogo Propriedades da Coluna e Propriedades do Campo (separador Verificar).

      A cláusula de verificação é adicionada à janela Código, em Código local.

    Criar procedimentos armazenados e funções definidas pelo utilizador

    Utilize procedimentos armazenados e funções definidas pelo utilizador para criar pacotes de código que pode reutilizar para repetir as mesmas ações. A principal diferença entre os dois é que uma função definida pelo utilizador devolve um valor, enquanto o procedimento armazenado executa códigos sem devolver um valor.

    1. No menu Base de Dados, aponte para Ver e, em seguida, clique em Código para abrir a janela Código.

    2. Clique em Código Global e, em seguida, clique em Novo.

    3. No separador Propriedades do Editor de Códigos, clique no tipo de código que pretende criar e escreva um nome para o código.

    4. No separador Corpo, escreva o código e, em seguida, clique em OK.

    Criar acionadores

    Os acionadores fazem com que o código SQL que especificar no acionador seja executado ao ocorrer um evento específico na base de dados.

    1. Faça duplo clique na tabela para abrir a janela Propriedades da Base de Dados.

    2. Em Categorias, clique em Accionadores e, em seguida, clique em Adicionar.

    3. No separador Propriedades, escreva um nome para o acionador.

    4. No separador Corpo, escreva o código e, em seguida, clique em OK.

      O acionador é adicionado à janela Código em Código local.

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×