Criar um diagrama de Visualização de Dados

Nota:  Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Quer criar automaticamente um fluxograma do Visio detalhado e de aspeto profissional a partir de um livro do Excel? Pode fazê-lo através dos modelos da Visualização de Dados. Cada modelo tem um livro do Excel associado, utilizado para converter os dados do processo num fluxograma no Visio. Também pode adicionar um modelo personalizado do Excel, mapear dados do Excel em formas no assistente Criar Diagrama a partir de Dados e criar automaticamente o diagrama. Também pode adicionar colunas adicionais de dados no Excel que são convertidas em dados da forma do Visio.

O Visio também suporta a sincronização bidirecional entre o diagrama do Visio e o livro do Excel. Não só pode criar o fluxograma ao editar os dados no Excel e atualizar o diagrama no Visio, como também pode fazer alterações ao Diagrama do Visio e, em seguida, atualizar os dados no Excel a partir do diagrama. 

Descrição geral da Visualização de Dados

A capacidade de utilizar os modelos da Visualização de Dados só se encontra disponível no Visio Online (Plano 2) na Via com Atualizações Recentes. Se não tiver a certeza de qual é a versão do Visio que está a utilizar, selecione Ficheiro > Conta > Acerca do Visio. Consulte a página Visio Online (Plano 2) para saber mais sobre a versão de subscrição do Visio.

Se não conseguir ver os modelos da Visualização de Dados ou se tiver outras dúvidas sobre como começar, visite a página Perguntas mais frequentes da Visualização de Dados.

Nota: Para poder utilizar esta funcionalidade, precisa de ter uma subscrição do Office 365. Se for um subscritor do Office 365, certifique-se de que tem a versão mais recente do Office. Se for um profissional de TI que gere o processo de atualização do Office 365, consulte a página de lançamentos de vias para saber quais as atualizações fornecidas em cada via.

Neste artigo

Criar um diagrama de Visualização de Dados

Antes de começar

Reúna as suas ideias e desenvolva-as num rascunho em papel ou através de tinta digital. Esse rascunho pode ajudá-lo a começar rapidamente o seu trabalho e a tornar os passos seguintes mais fáceis de concluir.

Para criar um diagrama de Visualização de Dados pode trabalhar simultaneamente no Excel e no Visio. Para facilitar o seu trabalho, pode trabalhar em duas janelas no seu dispositivo Windows ou num ambiente com múltiplos monitores. A comparação visual entre o seu trabalho no Excel e no Visio ajuda-o a confirmar que está a fazer o que pretende.

Recomendado:    veja este vídeo do Microsoft Office para vê-lo em ação – Visualização de Dados: demonstração.

Fase 1: selecionar um modelo de Visualização de Dados

  1. Abra o Visio ou selecione Ficheiro > Novo se estiver a editar um diagrama.

  2. Selecione MODELOS.

    O comando MODELOS
  3. Selecione Fluxograma.

    O comando Fluxograma
  4. Selecione Fluxograma básico - Visualizer de dados, fluxograma multifuncional - Visualizer de dados ou de diagrama de auditoria - Visualizer de dados.

    Os modelos da Visualização de Dados

    Um modelo de Visualização de Dados tem um ícone do Excel no canto superior esquerdo.

Para obter mais informações sobre fluxogramas e as suas formas, consulte os artigos Criar um fluxograma base e Criar um fluxograma multifuncional.

Fase 2: criar um livro do Excel

  1. Na pré-visualização do modelo, selecione Modelo de dados do Excel.

    Seleção da ligação do Modelo de Dados do Excel

    Nota:    tenha em atenção que, se quiser utilizar os mesmos modelos de exemplo do Excel utilizados neste artigo para referência, pode transferi-los a partir das seguintes ligações:

  2. Selecione Ficheiro > Guardar, especifique um computador, servidor de rede ou biblioteca de documentos do SharePoint, introduza um nome de ficheiro e, em seguida, selecione Guardar.

  3. Para adicionar uma nova folha de cálculo, na parte inferior do livro, selecione Nova folha Botão Nova Folha .

  4. Crie uma tabela do Excel. Para obter mais informações sobre como utilizar tabelas do Excel, consulte os artigos Descrição geral das tabelas do Excel, Criar ou eliminar uma tabela do Excel e Redimensionar uma tabela ao adicionar ou remover linhas e colunas.

  5. Adicione colunas e linhas para a tabela que são utilizadas para criar um diagrama do Visio. Existem requisitos específicos para os cabeçalhos de coluna de tabela do Excel e valores. Utilize a secção, de colunas do Excel como interagem com componentes de fluxograma do Visio como um guia visual.

Fase 3: incluir dados adicionais da forma à tabela do Excel (opcional)

  1. Verifique o separador Mapa de Processos no modelo do Excel. As colunas na tabela do Excel são coloridas a azul e verde. As cores diferenciam as colunas.

    As colunas a azul são utilizadas para criar o fluxograma no diagrama do Visio. Todas as colunas são adicionadas como dados da forma.

  2. Para incluir dados da forma adicionais, adicione uma ou mais colunas à sua tabela do Excel.

    As colunas a verde indicam os dados da forma adicionais que pode incluir em cada forma. Pode adicionar o número de colunas adicionais que quiser. Por predefinição, estes dados não são visíveis no diagrama, a menos que adicione gráficos de dados. Para ver os dados da forma no diagrama do Visio, selecione Dados > Janela de Dados da Forma. Para obter mais informações sobre dados da forma e gráficos de dados, consulte os artigos Adicionar dados a formas e Descrição geral dos gráficos de dados.

Fase 4: criar um diagrama do Visio com o assistente

  1. Regresse ao Visio, selecione uma unidade de medida na pré-visualização do modelo e, em seguida, selecione Criar.

  2. Na primeira página do assistente Criar Diagrama a Partir de Dados, faça o seguinte:

    1. Em Que diagrama pretende criar a partir dos dados, selecione um modelo: Fluxograma Base, Fluxograma Multifuncional (horizontal) ou Fluxograma Multifuncional (vertical).

    2. Em Selecione o livro do Excel, selecione um livro da lista de livros utilizados mais recentemente ou selecione Procurar para localizar o livro que criou na Fase 2.

    3. Em Selecione uma tabela ou intervalo personalizado no livro, selecione a tabela que contém os seus dados de processo do Excel.

    4. SelecioneConcluir. Esta ação aceita todos os valores predefinidos preenchidos nas outras páginas do assistente pelo Visio.

Como resultado, o diagrama é criado automaticamente num contentor. Serão incluídas páginas adicionais do Visio conforme o tamanho do fluxograma.

Fase 5: guardar o diagrama do Visio

  • Selecione Ficheiro > Guardar, encontre uma localização, introduza um nome de ficheiro e, em seguida, selecione Guardar.

Recomendamos que mantenha os ficheiros do Excel e do Visio na mesma localização, uma vez que funcionam em conjunto.

Fase 6: sincronizar os dados e o diagrama

Depois de criar um diagrama com a Visualização de Dados, poderá fazer alterações ao mesmo. O Visio suporta sincronização bidirecional entre os dados de origem e o diagrama.

Sugestão:    mantenha ambos os ficheiros sincronizados e atualizados após terminar de trabalhar com os mesmos. Quando alterar os dados do Excel, atualize o diagrama. Quando alterar os conteúdos do diagrama, atualize os dados do Excel.

Para modificar os dados no Excel e atualizar o diagrama

  1. Faça alterações aos dados de origem na tabela do Excel. Pode adicionar, atualizar ou eliminar linhas.

  2. Guarde o livro do Excel.

  3. No Visio, clique no contentor do diagrama para ativar as Ferramentas de Dados no separador Estrutura no friso e, em seguida, selecione Atualizar o Diagrama.

Como resultado, as alterações que efetuou no livro do Excel serão apresentadas no diagrama do Visio. Tenha em atenção o seguinte:

  • Se efetuou alterações ao diagrama que possam ser perdidas após a atualização, o Visio apresenta uma caixa de diálogo Conflito de Atualização do Diagrama.

  • A atualização só efetua alterações às formas e conexões existentes no contentor.

  • Todas as alterações de formatação que efetuar às formas ou conexões dentro do contentor serão mantidas.

  • Mantenha todas as formas e linhas de conexão do diagrama dentro do contentor. Todos os restantes objetos na página que estiverem fora do contentor não serão afetados. Para obter mais informações sobre contentores, consulte Clarificar a estrutura dos diagramas com contentores e listas.

Para modificar os conteúdos do diagrama e atualizar os dados no Excel

  1. Faça alterações ao diagrama do Visio. Pode adicionar, atualizar ou eliminar formas e conexões.

  2. Se o livro do Excel estiver num computador ou num servidor de ficheiros de rede, certifique-se de que está guardado e fechado.

  3. No Visio, clique no contentor do diagrama para ativar as Ferramentas de Dados no separador Estrutura no friso e, em seguida, selecione Atualizar Origem de Dados.

Como resultado, as alterações que fez no diagrama do Visio serão atualizadas no livro do Excel. Se existir a possibilidade de perda de dados no Excel, o Visio apresentará a caixa de diálogo Conflito de Atualização de Dados de Origem. Para evitar problemas, siga as seguintes práticas recomendadas:

  • Guarde uma cópia de segurança dos dados do Excel antes de substituir as alterações.

  • No livro do Excel, utilize uma Tabela do Excel como origem de dados e não um intervalo personalizado. Depois de selecionar Substituir na caixa de diálogo Atualizar Dados de Origem, o Visio converte o intervalo personalizado numa tabela do Excel.

  • Não utilize fórmulas nos dados de origem do Excel. Depois de selecionar Substituir na caixa de diálogo Atualizar Dados de Origem, o Visio converte a fórmula para o resultado da fórmula.

  • Criou o diagrama através da seguinte opção no assistente Criar Diagrama a Partir de Dados, no qual as colunas de dados estão mapeadas para funções e fases: Mapeamento > Mais Opções > Mantenha a ordem dos valores das colunas dos seus dados para criar > Selecionar Função ou Pista ou Fase ou Linha Cronológica. Neste caso, o Visio precisa de uma coluna adicional nos seus dados para representar a conexão entre as formas. Depois de selecionar Substituir na caixa de diálogo Atualizar Dados de Origem, será adicionada uma nova coluna.

  • Criou um fluxograma multifuncional com as pistas e fases baseadas na ordem dos valores de dados no Excel. Criou o diagrama através da seguinte opção no assistente Criar Diagrama a Partir de Dados, no qual as colunas de dados estão ligadas a atividades e passos do processo: Mapeamento > Especifique como ligar as atividades/passos do processo > Ligar sequencialmente. Neste caso, o Visio precisa de uma coluna adicional nos seus dados para representar a conexão entre as formas. Se alterar a ordem das pistas ou fases no diagrama, a ordem será alterada nos dados de origem. Depois de selecionar Substituir na caixa de diálogo Atualizar Dados de Origem, as linhas e fases no diagrama deixarão de seguir a ordem dos dados no livro do Excel.

Fase 7: personalizar a interação entre a tabela do Excel e o diagrama do Visio (opcional)

Existem casos onde poderá optar por personalizar a criação dos seus diagramas de Visualização de Dados. Por exemplo, poderá utilizar formas diferentes de modo a cumprir as normas da sua organização ou mapear nomes de coluna diferentes na tabela do Excel.

  1. Ao selecionar a opção Criar para entrar no assistente Criar Diagrama a Partir de Dados e após introduzir os valores na primeira página (consulte a Fase 4), selecione Seguinte ou Anterior para apresentar todas as páginas no assistente.

  2. Selecione Ajuda (?) para obter mais informações sobre como personalizar cada opção na página. Para obter mais informações, consulte Utilizar o assistente Criar Diagrama a Partir de Dados.

Início da Página

Como as colunas do Excel interagem com os componentes de fluxogramas do Visio

Utilize o seguinte guia de imagens para compreender como cada coluna do Excel é utilizada para criar o fluxograma do Visio.

ID de Passo do Processo    Um número que identifica cada uma das formas no fluxograma. Esta coluna é obrigatória, cada valor na tabela do Excel tem de ser exclusivo e a respetiva célula não pode estar em branco. Este valor não é apresentado no fluxograma.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: ID do Passo do Processo

Descrição dos Passos do Processo    O texto adicionado a cada uma das formas no fluxograma.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: Descrição do Passo do Processo

ID do Passo Seguinte    O ID de Passo do Processo da forma seguinte na sequência. Uma forma com ramificações contém dois passos seguintes e é representada por números separados por vírgulas, por exemplo 4,5. Pode ter mais do que dois passos seguintes.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: ID do Passo Seguinte

Etiqueta da Conexão    Para as formas com ramificações, as etiquetas de conexão são representadas como texto separado por uma vírgula, por exemplo Sim,Não. Neste exemplo, o valor Sim corresponde ao ID 4 e o valor Não corresponde ao ID 5.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: Etiqueta da Conexão

Tipo da Forma    O tipo de forma que pretende representar no diagrama do Visio, por exemplo Processo ou Decisão. A Microsoft recomenda a utilização de listas pendentes para o ajudar a validar as suas escolhas.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: Tipo de Forma

Função e Fase    A função (ou pista de diagrama) e fase (ou linha cronológica) a que cada forma pertence. Esta coluna aplica-se somente a Fluxogramas Multifuncionais e não é contemplada nos Fluxogramas Base.

Interação do Mapa de Processos do Excel com o fluxograma do Visio: Função e Fase

Início da Página

Utilizar outros stencils para criar um diagrama de Visualização de Dados

Para além de utilizar os modelos de dados Visualizer, também pode utilizar stencils de outros modelos quando cria um diagrama de Visualizer de dados. Por exemplo, crie diagramas de processos para operações financeiras ou gestão de inventário. Existem outros stencils orientados para processos, incluindo modelos BPMN básicas e objetos de fluxo de trabalho. Ainda pode adicionar formas personalizadas ao utilizar o stencil As minhas formas. Para mais informações, consulte criar, guardar e partilhar stencils personalizados.

  1. Abra um diagrama de Visualização de Dados (Fluxograma Base ou Fluxograma Multifuncional) que já tenha criado.

  2. Selecione Criar para entrar no assistente Criar Diagrama a Partir de Dados e, após introduzir os valores na primeira página, selecione Seguinte até ser apresentada a página Mapeamento de Formas do assistente.

  3. Adicione um ou mais stencils com a opção Mais Formas.

  4. Selecione qualquer forma e arraste para mapeá-la aos valores de dados da sua coluna Tipo de Forma.

Início da Página

Aplicar Gráficos de Dados ao seu diagrama

Pode melhorar o seu diagrama ao adicionar gráficos de dados, que o ajudam a visualizar dados de formas no diagrama. Na prática, pode transformar o seu diagrama num dashboard de processos onde os gráficos de dados apresentam informações do Indicador Chave de Desempenho (KPI) através de um ícone de gráficos de dados com base nos dados da forma.

  1. Abra o diagrama de Visualização de Dados.

    Selecione o contentor onde quer aplicar Gráficos de Dados.

  2. Selecione Dados > Campos de Gráficos de Dados.

  3. Selecione os campos de gráficos de dados que pretende adicionar ao seu diagrama.

    Aplicar Gráficos de Dados no Diagrama de Visualização de Dados do Visio

    Os gráficos de dados são aplicados ao diagrama inteiro. Para ocultar gráficos de dados de certas formas, mantenha os valores da coluna de dados em branco no livro do Excel para essas linhas.

  4. Se quiser, pode definir opções adicionais no separador Dados. Para obter mais informações, consulte Descrição geral dos gráficos de dados.

Início da Página

Próximos passos

Eis algumas tarefas que poderá efetuar após criar um diagrama de Visualização de Dados.

  • Temas    Um tema no Visio é um conjunto de cores e efeitos que pode aplicar a um desenho com apenas um clique. Os temas são uma forma rápida de dar um aspeto profissional aos seus desenhos. Para obter mais informações, consulte Dar um aspeto profissional aos seus desenhos através de temas.

  • Esquema    O Visio tem guias manuais e ferramentas automáticas para ajudá-lo a garantir que as formas contidas no seu diagrama estão alinhadas e com um espaçamento apropriado. Isso ajuda a tornar o seu desenho o mais claro possível e a dar-lhe um aspeto organizado. Para obter mais informações, consulte Alinhar e posicionar formas num diagrama.

  • Exportar    Exporte um diagrama de Visualização de Dados e um livro do Excel associado para um pacote de modelos do Visio (.vtpx). Um pacote de modelos do Visio guarda os dados, stencils e definições do diagrama para as outras pessoas utilizarem como um ponto de partida rápido para criarem os seus próprios diagramas de Visualização de Dados. Os outros utilizadores podem instalar o pacote de modelos nos respetivos computadores. Para obter mais informações, consulte Exportar e instalar um pacote de modelos de Visualização de Dados.

Início da Página

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×