Criar ou executar macros

Word para Office 365, Word 2019, Word 2016, Word 2013, Word 2010

Nota: Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

No Word, pode automatizar tarefas frequentemente utilizadas através da criação e execução de macros. Uma macro é uma série de comandos e instruções que agrupa como um único comando para desempenhar automaticamente uma tarefa.

Para poupar tempo nas tarefas que faz mais vezes, agrupe os passos numa macro. Primeiro, tem de gravar a macro. Depois, para executá-la, basta clicar num botão na Barra de Ferramentas de Acesso Rápido ou premir uma combinação de teclas. Depende da forma com a configurar.

  1. Clique em Ver > Macros > Gravar Macro.

    Comando Gravar Macro

  2. Escreva um nome para a macro

    Caixa Nome da macro

  3. Para utilizar esta macro nos documentos que vier a criar, certifique-se de que a caixa Guardar macro em diz Todos os Documentos (Normal.dotm).

    Caixa para escolher onde pretende guardar a macro

  4. Para executar a macro quando clicar num botão, clique em Botão.

    Clique para atribuir a macro a um botão

  5. Clique na macro nova (o nome deverá ser semelhante a Normal.MacrosNovas.<nome da sua macro>) e clique em Adicionar.

    A macro e o botão Adicionar

  6. Clique em Modificar.

    Botão modificar na caixa Personalizar a Barra de Ferramentas de Acesso Rápido

  7. Escolha uma imagem para o botão, escreva o nome que pretende e faça duplo clique em OK.

    Opções do botão na caixa Modificar Botão

  8. Agora é altura de gravar os passos. Clique nos comandos ou prima as teclas relativas a cada passo da tarefa. O Word grava os cliques e batimentos de teclas.

    Nota: Utilize o teclado para selecionar o texto enquanto está a gravar a macro, porque as macros não gravam seleções feitas com o rato.

  9. Para parar de gravar, clique em Ver > Macros > Parar de Gravar.

    Comando Parar de Gravar

O botão da macro aparece na Barra de Ferramentas de Acesso Rápido.

Botão Macro na Barra de Ferramentas de Acesso Rápido

Para executar a macro, clique no botão.

  1. Clique em Ver > Macros > Gravar Macro.

    Comando Gravar Macro

  2. Escreva um nome para a macro

    Caixa Nome da macro

  3. Para utilizar esta macro nos documentos que vier a criar, certifique-se de que a caixa Guardar macro em diz Todos os Documentos (Normal.dotm).

    Caixa para escolher onde pretende guardar a macro

  4. Para executar a macro quando prime um atalho de teclado, clique em Teclado.

    Clique para atribuir um atalho de teclado à macro

  5. Escreva uma combinação de teclas na caixa Premir tecla de atalho nova.

  6. Verifique se a combinação já foi atribuída a outro item. Se sim, experimente outra combinação.

  7. Para utilizar este atalho de teclado nos documentos que vier a criar, certifique-se de que a caixa Guardar alterações em diz Normal.dotm.

  8. Clique em Atribuir.

  9. Agora é altura de gravar os passos. Clique nos comandos ou prima as teclas relativas a cada passo da tarefa. O Word grava os cliques e batimentos de teclas.

    Nota: Utilize o teclado para selecionar o texto enquanto está a gravar a macro, porque as macros não gravam seleções feitas com o rato.

  10. Para parar de gravar, clique em Ver > Macros > Parar de Gravar.

    Comando Parar de Gravar

Para executar a macro, prima as teclas do atalho de teclado.

Para executar uma macro, clique no botão na Barra de Ferramentas de Acesso Rápido, prima o atalho de teclado ou pode executar a macro a partir da lista de Macros.

  1. Clique em Ver > Macros > Ver Macros.

    Comando Ver Macros

  2. Na lista em Nome da macro, clique na que pretende executar.

  3. Clique em Executar.

Para disponibilizar uma macro de um documento em todos os documentos novos, adicione-a ao modelo Normal.dotm.

  1. Abra o documento que contém a macro.

  2. Clique em Ver > Macros > Ver Macros.

    Comando Ver Macros

  3. Clique em Organizador.

    Botão Organizador na caixa Ver Macros

  4. Clique na macro que pretende adicionar ao modelo Normal.dotm e clique em Copiar.

  1. Clique em Ficheiro > Opções > Personalizar Friso.

  2. Em Escolher comandos de, clique em Macros.

  3. Clique na macro que pretende.

  4. Em Personalizar o friso, clique no separador e no grupo personalizado no qual pretende adicionar a macro.

Se não tiver um grupo personalizado, clique em Novo Grupo. Em seguida, clique em Mudar o nome e escreva um nome para o grupo.

  1. Clique em Adicionar.

  2. Clique em Mudar o Nome para escolher uma imagem para a macro e escreva o nome que pretende.

  3. Faça duplo clique em OK.

  1. No separador Programador, no grupo Código, clique em Macros.

  2. Na caixa Nome da macro, escreva um nome para a macro.

    Nota: Se lhe atribuir uma nova macro o mesmo nome de uma macro incorporada no Word, as novas acções de macro irão substituir a macro incorporada. Para ver uma lista das macros incorporadas, clique em Comandos do Word na lista de Macros no.

  3. Na lista de Macros em, clique no modelo ou o documento no qual pretende armazenar a macro.

    Para tornar a macro disponível em todos os documentos, certifique-se de que clique em normal. dotm.

  4. Clique em Criar para abrir o Visual Basic Editor.

Depois de abrir o Visual Basic Editor, poderá querer obter mais informações sobre como trabalhar com Visual Basic for Applications. Para mais informações, clique em Ajuda do Microsoft Visual Basic, no menu Ajuda ou prima F1.

Pode gravar uma sequência de ações ou pode escrever uma macro de raiz introduzindo do Visual Basic para o código de aplicações na Visual Basic Editor.

Nota: Para trabalhar com macros em Office Word 2007, precisar de mostrar o separador Programador.

  1. Clique no Botão do Microsoft Office Imagem de botão do Office e, em seguida, clique em Opções do Word.

  2. Clique em Popular.

  3. Em Opções principais para trabalhar com o Word, selecione a caixa de verificação Mostrar separador Programador no Friso.

    Nota: O Friso é um componente da interface de utilizador Microsoft Office Fluent.

  1. No separador Programador, no grupo Código, clique em Gravar Macro.

    Grupo Código no separador Programador
  2. Na caixa Nome da macro, escreva um nome para a macro.

    Nota: Se atribuir a uma nova macro o mesmo nome de uma macro incorporada no Office Word 2007, as novas acções de macro irão substituir a macro incorporada. Para ver uma lista de macros incorporadas, no separador Programador, no grupo código, clique em Macros. Na lista de Macros em, clique em Comandos do Word.

  3. Na caixa Guardar macro em, clique no modelo ou o documento no qual pretende armazenar a macro.

    Importante: Para tornar a macro disponível em todos os documentos, certifique-se de que clique em normal. dotm.

  4. Na caixa Descrição, escreva a descrição da macro.

  5. Siga um dos seguintes procedimentos:

    • Iniciar gravação    Para começar a gravar a macro sem o atribuir a um botão na barra de ferramentas de acesso rápido ou para uma tecla de atalho, clique em OK.

    • Criar um botão    Para atribuir a macro a um botão na barra de ferramentas de acesso rápido, efetue o seguinte procedimento:

      1. Clique em botão.

      2. Em Personalizar ferramentas de acesso rápido, selecione o documento (ou todos os documentos) para o qual pretende adicionar a macro à barra de ferramentas de acesso rápido.

        Importante: Para tornar a macro disponível em todos os documentos, certifique-se de que clique em normal. dotm.

      3. Em caixa de diálogo Escolher comandos de, clique na macro que está a registar e, em seguida, clique em Adicionar.

      4. Para personalizar o botão, clique em Modificar.

      5. Em Símbolo, clique no símbolo que pretende utilizar para o seu botão.

      6. Na caixa nome a apresentar, escreva o nome da macro que pretende apresentar.

      7. Clique em OK duas vezes para começar a gravar a macro.

        O símbolo que escolher é apresentado na barra de ferramentas de acesso rápido. O nome que escrever é apresentado quando aponta para o símbolo.

    • Atribuir um atalho de teclado    Para atribuir a macro a um atalho de teclado, faça o seguinte:

      1. Clique em Teclado.

      2. Na caixa comandos, clique na macro que está a registar.

      3. Na caixa Nova tecla de atalho, escreva a sequência de teclas que pretende e, em seguida, clique em atribuir.

      4. Clique em Fechar para começar a gravar a macro.

  6. Efetue as ações que pretende incluir na macro.

    Nota: Quando grava uma macro, pode utilizar o rato para clicar nos comandos e opções, mas não para selecionar texto. Tem de utilizar o teclado para selecionar texto. Para mais informações acerca da seleção de texto, utilizando o teclado, consulte o artigo Selecione texto.

  7. Para parar a gravação suas ações, clique em Parar Gravação no grupo código.

Alterar o atalho de teclado para uma macro

  1. Clique no Botão do Microsoft Office Imagem de botão do Office e, em seguida, clique em Opções do Word.

  2. Clique em Personalizar.

  3. Ao lado de atalhos de teclado, clique em Personalizar.

  4. Na lista categorias, clique em Macros.

  5. Na lista de Macros, clique na macro que pretende alterar.

  6. Na caixa Nova tecla de atalho, escreva a combinação de teclas que pretende escolher.

  7. Selecione a caixa teclas atuais para se certificar de que não estão a atribuir uma combinação de teclas que já estiver a utilizar para efetuar uma tarefa diferente.

  8. Na lista Guardar alterações em, clique na opção que corresponde em que pretende executar a macro.

    Importante: Para tornar a macro disponível em todos os documentos, certifique-se de que clique em normal. dotm.

  9. Clique em Fechar.

  1. No separador Programador, no grupo Código, clique em Macros.

    Grupo Código no separador Programador

  2. Na lista em nome da Macro, clique na macro que pretende executar.

  3. Clique em Executar.

  1. No separador Programador, no grupo Código, clique em Macros.

    Grupo Código no separador Programador

  2. Na caixa Nome da macro, escreva um nome para a macro.

    Nota: Se atribuir a uma nova macro o mesmo nome de uma macro incorporada no Office Word 2007, as novas acções de macro irão substituir a macro incorporada. Para ver uma lista das macros incorporadas, clique em Comandos do Word na lista de Macros no.

  3. Na lista de Macros em, clique no modelo ou o documento no qual pretende armazenar a macro.

    Para tornar a macro disponível em todos os documentos, certifique-se de que clique em normal. dotm.

  4. Clique em Criar para abrir o Visual Basic Editor.

Depois de abrir o Visual Basic Editor, poderá querer obter mais informações sobre como trabalhar com Visual Basic for Applications. Para mais informações, clique em Ajuda do Microsoft Visual Basic, no menu Ajuda ou prima F1.

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×