Criar ou editar ficheiros .csv para importar para o Outlook

Criar ou editar ficheiros .csv para importar para o Outlook

Um ficheiro de valores separados por vírgulas (CSV) é um tipo especial de ficheiro que pode criar ou editar no Excel. Em vez de armazenarem informações em colunas, os ficheiros CSV armazenam informações separadas por vírgulas. Quando o texto e os números são guardados num ficheiro CSV, é fácil movê-los de um programa para outro. Por exemplo, pode exportar os seus contactos do Google para um ficheiro CSV e, em seguida, importá-los para o Outlook.

Para obter assistência ao importar uma lista de entradas de calendário para o Outlook, consulte Importar e exportar email, contatos e calendário do Outlook.

Criar um ficheiro .csv a partir de outro programa ou fornecedor de e-mail

Quando exporta os seus contactos de outro programa, por exemplo, do Gmail, normalmente pode selecionar um de vários formatos. O Gmail dá-lhe a escolher entre um ficheiro CSV do Google, um ficheiro CSV do Outlook ou vCards. Ao exportar de um perfil do Outlook para importar noutro perfil, pode optar por exportar para um ficheiro de valores separados por vírgulas ou um Ficheiro de Dados do Outlook (.pst).

Transferir e abrir um ficheiro .csv de exemplo para importar contactos para o Outlook

Se quiser criar um ficheiro CSV para os seus contactos manualmente, pode fazê-lo de uma das seguintes formas.

Criar um ficheiro do Excel e guardá-lo como um ficheiro CSV

Se tiver informações de contactos num programa que não lhe permite exportá-las, pode escrevê-las manualmente.

  1. Crie um novo documento no Excel.

  2. Adicione um cabeçalho de coluna para cada informação que pretende gravar (por exemplo, nome próprio, apelido, endereço de e-mail, número de telefone e data de nascimento) e, em seguida, escreva as informações nas colunas apropriadas.

  3. Quando terminar, o seu ficheiro do Excel deverá ter um aspeto semelhante a este.

    Eis o aspeto do ficheiro .csv de exemplo no Excel.

  4. Selecione Ficheiro > Guardar Como.

  5. Utilize a caixa pendente para selecionar CSV (Delimitado por vírgulas, com a extensão *.csv), dê um nome ao seu ficheiro e, em seguida, selecione Guardar.

    Guarde o seu ficheiro do Excel como um ficheiro CSV.

  6. Agora pode utilizar este novo ficheiro CSV para importar os seus contactos para o Outlook.

Transferir um modelo de um ficheiro CSV

Se quiser começar com um ficheiro CSV em branco, pode transferir um ficheiro de exemplo abaixo.

  1. Transfira este ficheiro .csv de exemplo para o seu computador. Quando lhe for pedido, selecione a opção para Guardar o ficheiro no seu computador como um ficheiro CSV. Se o guardar como um ficheiro do Excel (.xls ou .xlsm), todos os dados ficarão contidos numa só coluna!

    Quando transferir um ficheiro .csv de exemplo, guarde-o no seu computador com o tipo de ficheiro .csv.

  2. No seu computador, abra o Excel.

  3. No Excel, aceda a Ficheiro > Abrir > e, em seguida, navegue até ao ficheiro .csv que transferiu para o seu computador. Para localizar o ficheiro .csv, certifique-se de que seleciona Todos os Ficheiros. Clique no ficheiro .csv para o abrir.

    Para encontrar o ficheiro .csv, certifique-se de que procura por Todos os Ficheiros.

Existem alguns aspetos que deve ter em atenção ao trabalhar com este ficheiro CSV de exemplo:

  • O Outlook necessita de cabeçalhos de coluna na primeira linha, por isso não os substitua por algo diferente.

    Eis o aspeto do ficheiro .csv de exemplo no Excel.

  • Pode eliminar os dados nas linhas 2 a 6 (os endereços de e-mail, números de telefone e nomes de exemplo ou outros dados).

  • Não precisa de introduzir valores para todas as colunas. Introduza apenas as informações que pretende.

  • Guarde o ficheiro com um novo nome no formato CSV (.csv). Se utilizar o Excel para trabalhar no ficheiro, quando o guardar, o Excel irá perguntar-lhe algumas vezes "Tem a certeza de que pretende guardar este ficheiro no formato CSV?" Selecione sempre Sim. Se selecionar Não, o ficheiro será guardado no formato nativo do Excel (.xlsx) e o Outlook não conseguirá utilizá-lo para importar os dados.

  • Experimente importar o seu ficheiro CSV com alguns contactos para garantir que fica satisfeito com os resultados. Posteriormente, pode eliminar os contactos importados, adicionar mais contactos ao ficheiro CSV e importá-lo novamente.

    Se quisesse importar os dados no ficheiro CSV de exemplo, eis o aspeto que o mesmo teria no Outlook na Web do Office 365:

    Após importar contactos, eis o aspeto dos mesmos no Outlook na Web.

Editar um ficheiro .csv de contactos que pretende importar para o Outlook

Imagine que pretende editar um ficheiro .csv que exportou do Outlook e, em seguida, importá-lo para o Outlook ou para outro fornecedor de e-mail. Utilizar o Excel facilita a edição do ficheiro .csv.

Eis alguns aspetos a ter em atenção quando edita um ficheiro .csv:

  • Mantenha os cabeçalhos de coluna na primeira linha.

  • Ao guardar o ficheiro CSV, o Excel irá perguntar-lhe algumas vezes "Tem a certeza de que pretende guardar este ficheiro no formato CSV?" Selecione sempre Sim. Se selecionar Não, o ficheiro será guardado no formato nativo do Excel (.xlsx) e a sua importação para o Outlook não funcionará.

Problema: todos os meus dados são apresentados na primeira coluna

Um exemplo de um ficheiro .csv guardado no formato .xls.

Eis algumas razões para esta situação e algumas soluções que pode experimentar para tentar corrigir este problema:

  • Se guardar o ficheiro CSV noutro formato, como .xls, .xlsx  ou .xlm, todos os dados serão apresentados na primeira coluna. Regresse ao ficheiro CSV original e certifique-se de que o guarda como .csv.

  • É possível que o programa que cria o ficheiro CSV esteja a colocar aspas adicionais nos dados. Consequentemente, o Excel processa os dados com uma só unidade. Por exemplo, imagine que os seus dados têm o seguinte aspeto:

    a, b, c, d – o Excel coloca cada letra na sua respetiva coluna.

    "a, b, c, d", e – o Excel coloca as letras "a, b, c, d" numa coluna e a letra "e" noutra.

    Para confirmar se este é o problema do seu ficheiro, abra o mesmo no Bloco de Notas: Clique com o botão direito do rato no ficheiro CSV no Windows, selecione Abrir Com > Bloco de Notas. Procure aspas em excesso.

    Se encontrar aspas em excesso, eis como corrigir o seu problema:

    1. Utilize o Excel para abrir o ficheiro CSV. Todos os dados estarão na coluna A e já não existirão aspas.

    2. Agora utilize o assistente Texto em Colunas para separar os dados na coluna A em colunas individuais: na barra de menus, selecione Dados > Texto em Colunas.

      Selecione Dados > Texto para Colunas

    3. Selecione Delimitado > Seguinte. Em seguida, selecione Vírgulas > Concluir.

    4. Guarde o ficheiro como .csv para conseguir importá-lo para o Outlook.

Consulte Também

Importar contactos para o Outlook

Exportar contactos do Outlook

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×