Criar, executar, editar ou eliminar uma macro no Office para Mac

Nota: Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Para poupar tempo em tarefas que realiza frequentemente, pode gravar os passos dessas tarefas como uma macro. Em seguida, quando pretender efetuar uma destas tarefas gravadas, pode ativar a macro para efetuar os passos para si.

Word

No Word 2016 para Mac, pode criar uma macro com um atalho de teclado, executar uma macro e eliminar uma macro que já não precisa.

  1. Clique em Ver > Macros > Gravar Macro.

    No separador Ver, clique em Macro e, em seguida, clique em Gravar Macro para começar a criar uma macro.
  2. Escreva um nome para a macro ou aceite o predefinido que o Word fornece.

    Introduza um nome para a sua macro em Nome da macro ou aceite o nome genérico fornecido pelo Word.
  3. Para utilizar esta macro em quaisquer novos documentos que criar, verifique se todos os documentos (normal) estão selecionados na lista guardar macro em .

  4. Clique em teclado para atribuir uma combinação de teclas à sua macro.

    o Word apresenta a caixa de diálogo Personalizar teclado .

  5. Escreva uma combinação de teclas na caixa premir novo atalho de teclado .

    Quando prime uma combinação de teclas, o Word apresenta o comando ou macro atribuídos à combinação, se esta já existir.

    Quando prime uma combinação de teclas, o Word apresenta o comando ou a ação atualmente atribuída a essa combinação de teclas, se existir.

  6. Se a combinação de teclas que escolheu já estiver atribuída, elimine-a da caixa prima novo atalho de teclado e, em seguida, selecione uma nova combinação de teclas.

    Avance para o passo seguinte depois de ter encontrado uma combinação de teclas não atribuída.

    O Word identifica quando prime uma combinação de teclas que ainda não foi atribuída a um comando ou macro.
  7. Para utilizar este atalho de teclado em documentos novos, certifique-se de que normal. dotm, o modelo global, está selecionado na lista guardar alterações em .

    Selecione Normal.dotm para disponibilizar uma macro para utilizar em documentos novos que crie.
  8. Clique em Atribuir.

  9. Quando estiver pronto para gravar a macro, clique em OK.

  10. Clique nos comandos ou prima as teclas relativas a cada passo da tarefa.

    o Word grava os seus cliques e toques de teclas, mas não grava texto que selecione com o rato. Para selecionar texto durante a gravação de uma macro, utilize o teclado.

  11. Para parar de gravar, clique em Ver > Macros > Parar de Gravar.

    Clique em Parar Gravação no menu Macros para parar de gravar uma macro.

Para executar uma macro, prima o atalho de teclado atribuído à mesma ou execute a macro a partir da lista de macros.

  1. Clique em Ver > Macros > Ver Macros.

    Clique em Ver Macros para ver e ditar macros associadas ao documento atual.
  2. Na lista em nome da macro, selecione a macro que pretende executar.

  3. Clique em Executar.

    Após selecionar uma macro em Nome da macro, clique em Executar para a executar.

  1. Clique em Ver > Macros > Ver Macros.

    Clique em Ver Macros para ver e ditar macros associadas ao documento atual.
  2. Verifique se a localização especificada por macros no inclui a localização da macro que pretende eliminar.

    Selecione a localização das macros que pretende ver a partir das Macros na lista.

    A lista irá incluir o documento que está aberto na janela atual, bem como o modelo global e os comandos do Word.

  3. Em nome da macro, selecione a macro que pretende eliminar e, em seguida, clique no sinal de subtração abaixo da lista.

    Selecione a macro que pretende eliminar e, em seguida, clique no sinal de subtração por baixo da lista.
  4. Quando o Word pede para confirmar que pretende eliminar a macro, clique em Sim.

Excel

No Excel 2016 para Mac, pode criar uma macro com um atalho de teclado, executar uma macro e eliminar uma macro que já não precisa.

Quando gravar uma macro, o gravador de macros grava todos os passos necessários para concluir as ações que pretende que a macro efetue. Estes passos podem incluir escrever texto ou números, clicar em células ou comandos no friso ou nos menus, formatar, selecionar células, linhas ou colunas e arrastar o rato para selecionar células na folha de cálculo.

Nota: Os comandos para gravar, criar e eliminar macros, bem como outras funcionalidades avançadas, também estão disponíveis no separador programador no Ribbon. Para obter mais informações sobre como utilizar o separador programador, consulte o artigo utilizar o separaDor programador para criar ou eliminar uma macro no Excel 2016 para Mac.

  1. Selecione ferramentas > macro > gravar nova.

    Selecione Ferramentas e, em seguida, macro e, em seguida, gravar nova macro

  2. Na caixa Nome da macro, introduza um nome para a macro.

    Introduzir um nome de macro, localização e tecla de atalho

  3. Para criar um atalho de teclado para a macro, escreva uma letra na caixa opção + cmd .

  4. Selecione uma localização para a macro a partir da lista pendente.

    Para guardar a macro

    Clique em

    No documento em que está a criar uma macro

    Neste Livro

    Em todos os documentos abertos

    Novo Livro

    Para estar disponível sempre que utilizar o Excel

    Livro Pessoal de Macros

  5. Adicional Adicione uma descrição da sua macro.

  6. Quando estiver pronto para gravar, clique em OK.

  7. Clique nos comandos ou prima as teclas relativas a cada passo da tarefa.

  8. Para parar a gravação, selecione ferramentas > macro > parar gravação. (Este passo não será registado na sua macro.)

    Selecione Parar gravação

Para executar uma macro, prima o atalho de teclado atribuído à mesma ou execute a macro a partir da caixa de diálogo macros.

  1. No separador Ver, clique em Ver Macros.

  2. Clique em macros no menu de pop-up e selecione este livro.

  3. Selecione a sua macro da lista e clique em Executar.

    Caixa de diálogo Macros no Excel para Mac

  1. Selecione ferramentas > macro > macros.

    Selecione macro e, em seguida, selecione macros

  2. Selecione a macro que pretende eliminar e, em seguida, prima o sinal de subtração.

    Selecione nome da macro e, em seguida, selecione sinal de subtração

  3. Será apresentada uma mensagem de confirmação. Clique em Sim para confirmar a eliminação.

    Confirmar eliminação

Também pode eliminar uma macro a partir do separador programador .

  1. No separador Programador, clique em Macros.

  2. Na lista, clique na macro que quer eliminar e, em seguida, clique no botão Eliminar.

    Selecione uma macro e clique no sinal de subtração para a eliminar

Word

Para automatizar uma tarefa repetitiva, pode criar rapidamente uma macro no Word. Também pode utilizar o Visual Basic Editor no Microsoft Visual Basic for Applications para escrever o seu próprio script de macro ou copiar toda ou parte de uma macro para uma nova macro.

Quando gravar uma macro, todos os passos necessários para concluir as ações que pretende que a macro execute sejam gravadas. No entanto, a navegação para o separador para interromper a gravação não está incluída nos passos gravados.

  1. No separador Programador, em Visual Basic, clique em Gravar.

    Separador Programador do Word, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Na caixa Nome da macro, introduza um nome para a macro.

  3. No menu de pop-up Guardar macro em, efetue um dos seguintes procedimentos:

    Para guardar a macro

    Clique em

    No documento no qual está a criar a macro

    [nome do documento] (documento)

    Em todos os documentos abertos

    Todos os Documentos (Normal)

  4. Clique em OK e, em seguida, efetue as ações que pretende gravar.

  5. No separador Programador, em Visual Basic, clique em Parar.

Pode utilizar o Visual Basic Editor incorporado para criar uma macro.

  1. No separador Programador, em Visual Basic, clique em Editor.

    Separador Programador do Word, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Se tiver de inserir um módulo, no Visual Basic Editor, no menu Inserir, clique em Módulo.

  3. Na janela de código do módulo, escreva ou cole o código da macro que pretende utilizar.

  4. Quando terminar, no menu do Word, clique em Fechar e Regressar ao Microsoft Word.

  1. No separador Programador, em Visual Basic, clique em Macros.

    Separador Programador do Word, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Na lista, clique na macro que pretende executar e, em seguida, clique em Executar.

Para editar uma macro, utilize o Visual Basic Editor.

  1. No separador Programador, em Visual Basic, clique em Macros.

    Separador Programador do Word, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Na lista, clique na macro que pretende editar e, em seguida, clique em Editar.

    O Visual Basic Editor é aberto.

  3. Efetue as alterações pretendidas.

  4. Quando terminar, no menu do Word, clique em Fechar e Regressar ao Microsoft Word.

  1. No separador Programador, em Visual Basic, clique em Macros.

    Separador Programador do Word, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Na lista, clique na macro que pretende copiar e, em seguida, clique em Editar.

    O Visual Basic Editor é aberto.

  3. Na janela de código do Visual Basic Editor, selecione as linhas da macro que pretende copiar.

    Sugestão: Para copiar toda a macro, inclua as linhas Sub e End Sub na seleção.

  4. No menu Editar, clique em Copiar.

  5. Na caixa Projeto da janela de código, clique no módulo em que pretende colocar o código.

  6. No menu Editar, clique em Colar.

  1. No separador Programador, em Visual Basic, clique em Macros.

    Separador Programador do Word, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Na lista, clique na macro que pretende eliminar e, em seguida, clique em Eliminar.

PowerPoint

Para automatizar uma tarefa repetitiva, pode utilizar o Visual Basic for Applications para criar uma macro no PowerPoint.

Pode utilizar o Visual Basic Editor incorporado para criar uma macro.

  1. No separador Programador, em Visual Basic, clique em Editor.

    Separador Programador do PowerPoint, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Se tiver de inserir um módulo, no Visual Basic Editor, no menu Inserir, clique em Módulo.

  3. Na janela de código do módulo, escreva ou cole o código da macro que pretende utilizar.

  4. Quando terminar, no menu do PowerPoint, clique em Fechar e Regressar ao Microsoft PowerPoint.

  1. No separador Programador, em Visual Basic, clique em Macros.

    Separador Programador do PowerPoint, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Na lista, clique na macro que pretende executar e, em seguida, clique em Executar.

Para editar uma macro, utilize o Visual Basic Editor.

  1. No separador Programador, em Visual Basic, clique em Macros.

    Separador Programador do PowerPoint, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Na lista, clique na macro que pretende editar e, em seguida, clique em Editar.

    O Visual Basic Editor é aberto.

  3. Efetue as alterações pretendidas.

  4. Quando terminar, no menu do PowerPoint, clique em Fechar e Regressar ao Microsoft PowerPoint.

  1. No separador Programador, em Visual Basic, clique em Macros.

    Separador Programador do PowerPoint, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Na lista, clique na macro que pretende copiar e, em seguida, clique em Editar.

    O Visual Basic Editor é aberto.

  3. Na janela de código do Visual Basic Editor, selecione as linhas da macro que pretende copiar.

    Sugestão: Para copiar toda a macro, inclua as linhas Sub e End Sub na seleção.

  4. No menu Editar, clique em Copiar.

  5. Na caixa Projeto da janela de código, clique no módulo em que pretende colocar o código.

  6. No menu Editar, clique em Colar.

  1. No separador Programador, em Visual Basic, clique em Macros.

    Separador Programador do PowerPoint, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Na lista, clique na macro que pretende eliminar e, em seguida, clique em Eliminar.

Excel

Para automatizar uma tarefa repetitiva, pode criar rapidamente uma macro no Excel. Também pode utilizar o Visual Basic Editor no Microsoft Visual Basic for Applications para escrever o seu próprio script de macro ou copiar toda ou parte de uma macro para uma nova macro.

Todos os passos necessários para concluir as ações que pretende que a macro efetue são gravados. No entanto, a navegação para o separador para interromper a gravação não está incluída nos passos gravados.

  1. No separador Programador, em Visual Basic, clique em Gravar.

    Separador Programador do Excel, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Na caixa Nome da macro, introduza um nome para a macro.

    Sugestão: Para criar um atalho de teclado para a macro, escreva uma letra na caixa Opção+Cmd+.

  3. No menu de pop-up Guardar macro em, efetue um dos seguintes procedimentos:

    Para guardar a macro

    Clique em

    No documento no qual está a criar a macro

    Neste Livro

    Em todos os documentos abertos

    Novo Livro

    Para estar disponível sempre que utilizar o Excel

    Livro Pessoal de Macros

    O livro pessoal de macros está localizado em utilizadores/ nome_do_usuário/library/Application Support/Microsoft/Office/Excel.

  4. Clique em OK e, em seguida, efetue as ações que pretende gravar.

  5. No separador Programador, em Visual Basic, clique novamente em Gravar.

Pode utilizar o Visual Basic Editor incorporado para criar uma macro.

  1. No separador Programador, em Visual Basic, clique em Editor.

    Separador Programador do Excel, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Se tiver de inserir um módulo, no Visual Basic Editor, no menu Inserir, clique em Módulo.

  3. Na janela de código do módulo, escreva ou cole o código da macro que pretende utilizar.

  4. Quando terminar, no menu do Excel, clique em Fechar e Regressar ao Microsoft Excel.

  1. No separador Programador, em Visual Basic, clique em Macros.

    Separador Programador do Excel, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Na lista, clique na macro que pretende executar e, em seguida, clique em Executar.

    Sugestão: Para executar uma macro utilizando um atalho de teclado, prima OPÇÃO + COMANDO + a letra que escreveu quando criou o atalho de teclado.

Para editar uma macro, utilize o Visual Basic Editor.

  1. No separador Programador, em Visual Basic, clique em Macros.

    Separador Programador do Excel, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Na lista, clique na macro que pretende editar e, em seguida, clique em Editar.

    O Visual Basic Editor é aberto.

  3. Efetue as alterações pretendidas.

  4. Quando terminar, no menu do Excel, clique em Fechar e Regressar ao Microsoft Excel.

Quando concluir este procedimento, a macro será executada sempre que abrir o livro que contém a macro.

  1. No separador Programador, em Visual Basic, clique em Gravar.

    Separador Programador do Excel, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Na caixa Nome da macro, escreva Abrir_Automaticamente.

  3. No menu de pop-up Guardar macro em, efetue um dos seguintes procedimentos:

    Para guardar a macro

    Clique em

    No documento no qual está a criar a macro

    Neste Livro

    Em todos os documentos abertos

    Novo Livro

    Para estar disponível sempre que utilizar o Excel

    Livro Pessoal de Macros

  4. Clique em OK e, em seguida, efetue as ações que pretende gravar.

  5. No separador Programador, em Visual Basic, clique novamente em Gravar.

  6. No menu Ficheiro, clique em Guardar Como.

  7. No menu de pop-up Formatar, clique em Livro com Permissão para Macros do Excel (.xlsm) e, em seguida, clique em Guardar.

  1. No separador Programador, em Visual Basic, clique em Macros.

    Separador Programador do Excel, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Na lista, clique na macro que pretende copiar e, em seguida, clique em Editar.

    O Visual Basic Editor é aberto.

  3. Na janela de código do Visual Basic Editor, selecione as linhas da macro que pretende copiar.

    Sugestão: Para copiar toda a macro, inclua as linhas Sub e End Sub na seleção.

  4. No menu Editar, clique em Copiar.

  5. Na caixa Projeto da janela de código, clique no módulo em que pretende colocar o código.

  6. No menu Editar, clique em Colar.

  1. No separador Programador, em Visual Basic, clique em Macros.

    Separador Programador do Excel, grupo Visual Basic

    Se o separador Programador não estiver disponível

    1. No lado direito do friso, clique em Menu pop-up Ação e, em seguida, clique em Preferências do Friso.

    2. Em Personalizar, selecione a caixa de verificação Programador.

  2. Na lista, clique na macro que pretende eliminar e, em seguida, clique em Eliminar.

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×