Copiar uma fórmula ao arrastar a alça de preenchimento no Excel para Mac

Nota: Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Pode copiar rapidamente fórmulas em células adjacentes utilizando a alça de preenchimento.

a seleção de gráficos no Friso

Ao arrastar a alça para outras células, o Excel mostrará diferentes resultados para cada célula.

Copiar uma fórmula ao arrastar a alça de preenchimento

Siga estes passos:

  1. Selecione a célula que tem a fórmula que quer preencher nas células adjacentes.

  2. Pouse o cursor no canto inferior direito para que se torne num sinal de adição (+), da seguinte forma:

    Cursor sobre a alça de preenchimento

  3. Arraste a alça de preenchimento para baixo, para cima ou pelas células que pretende preencher. Neste exemplo, aqui na figura mostra arrastar a alça de preenchimento para baixo:

    Cursor a arrastar a alça de preenchimento para baixo

  4. Ao largar, a fórmula é preenchida automaticamente para as outras células:

    Valores apresentados em células que foram preenchidas

  5. Para alterar a forma como quer preencher as células, clique no botão Opções de Preenchimento Automático Botão Opções de Preenchimento Automático que aparece após terminar de arrastar e escolha a opção que quer.

Para obter mais informações sobre como copiar fórmulas, consulte o artigo Copiar e colar uma fórmula para outra célula ou folha de cálculo.

Sugestões: 

  • Também pode premir Ctrl + D para preencher a fórmula para baixo numa coluna. Em primeiro lugar selecione a célula que contém a fórmula que pretende preencher, em seguida, selecione as células abaixo do mesmo e, em seguida, prima Ctrl + D.

  • Também pode premir Ctrl + R para preencher a fórmula para a direita numa linha. Em primeiro lugar selecione a célula que contém a fórmula que pretende preencher, em seguida, selecione as células à direita da mesma e, em seguida, prima Ctrl + R.

Quando o preenchimento não funciona

Por vezes preencher funciona fino e outras horas não funciona como esperado. Razão pela qual é importante verificar se as referências de células da primeira célula.

As referências de células são apenas ponteiros para outras células. Por exemplo, digamos que a primeira célula tem a seguinte fórmula:


=SOMA(A1,B1)


A1 e B1 são referências relativas. Basta Isto significa que quando preencher a fórmula para baixo, as referências irão alterar incrementada de A1, B1 para A2, B2 e assim sucessivamente, da seguinte forma:

=SUM(A1,B1)

=SOMA(A2,B2)

=SUM(A3,B3)

Noutros casos, poderá não pretende que as referências para outras células para alterar. Por exemplo, vamos supor que pretendia que a primeira referência, A1, mantenha-se fixa e B1 para alterar à medida que arrasta a alça de preenchimento. Se for o caso, terá de introduzir um cifrão ($) na primeira referência: =SUM($A$1,B1). Um cifrão força o Excel para manter a apontar para A1 à medida que preenche noutras células. Este é o mesmo aspeto:

=SOMA($A$1,B1)

=SOMA($A$1,B2)

=SOMA($A$3,B3)

As referências com cifrões ($) chamam-se referência absolutas. Quando preenche para baixo, a referência A1 permanece fixa mas o Excel altera a referência de B1 para B2 e B3.

Está com dificuldades em ver a alça de preenchimento?

Se não vir o alça de preenchimento, poderá ser ocultada. Para o apresentar:

  1. No menu do Excel, clique em Preferências.

  2. Clique em Editar.

  3. Em Opções de Edição, marque a caixa Permitir a alça de preenchimento e arrastar e largar célula.

Se o cálculo do livro automática não está a funcionar, fórmulas não são recalculadas quando preencher células.

Eis como a ativá-la:

  1. No menu do Excel, clique em Preferências.

  2. Clique em Cálculo.

  3. Nas Opções de cálculo, certifique-se de que está selecionada automática.

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×