Converter uma base de dados para o formato de ficheiro .accdb

Nota: Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Access 2016, o Access 2013, o Access 2010 e o Access 2007 crie bases de dados no formato de ficheiro. accdb. Este formato suporta funcionalidades tais como campos de valores múltiplos, macros de dados e publicar no Access Services.

É possível converter bases de dados que tenham sido criadas no Microsoft Office Access 2003, no Access 2002, no Access 2000 ou no Access 97 para o formato de ficheiro .accdb. No entanto, tenha em atenção que uma base de dados no formato de ficheiro .accdb não pode ser aberta nem ligada utilizando versões do Access anteriores ao Access 2007.

Além disso, o formato .accdb não suporta a replicação ou a segurança de nível de utilizador. Se necessitar de partilhar a sua base de dados com pessoas que utilizam o Access 2003 ou anterior ou se necessitar de utilizar a replicação ou a segurança de nível de utilizador, tem de utilizar o formato de ficheiro .mdb.

Nota: Apesar dos que partilham o mesmo formato de ficheiro, algumas funcionalidades do Access 2016, o Access 2013 e o Access 2010 não podem ser utilizadas no Access 2007. Para mais informações, consulte a secção utilizar o Access 2007 para abrir uma base de dados que foi criada ou modificada no Access 2010, o Access 2013 ou o Access 2016.

Neste artigo

Converter uma base de dados do Access 2000 ou do Access 2002 - 2003 para o formato .accdb

Converter uma base de dados do Access 97 para o formato .accdb

Utilizar o Access 2007 para abrir uma base de dados criada ou modificada no Access 2010, o Access 2013 ou o Access 2016

Converter uma base de dados do Access 2000 ou do Access 2002 - 2003 para o formato .accdb

Para converter uma Access 2000 ou do Access 2002-2003 base de dados (. mdb) para o formato de ficheiro. accdb, tem primeiro abra a base de dados utilizando o Access 2007, o Access 2010, o Access 2013 ou o Access 2016 e, em seguida, guarde-o no formato de ficheiro. accdb.

  1. Clique em Ficheiro e, em seguida, clique em Abrir.

  2. Clique na base de dados do Access 2000 ou do Access 2002 - 2003 (.mdb) que pretende converter.

    Nota: Se for apresentada a caixa de diálogo Melhoramento da Base de Dados, a base de dados está a utilizar um formato de ficheiro que é anterior ao do Access 2000. Para continuar, consulte a secção Converter uma base de dados do Access 97 para o formato .accdb.

  3. Clique em Ficheiro, depois em Guardar Como e, em seguida, em Guardar Base de Dados Como.

  4. Escolha o tipo de ficheiro do Access e, em seguida, clique em Guardar Como.

    Se estiverem abertos objetos da base de dados quando clicar em Guardar Como, o Access pede-lhe para os fechar antes de criar a cópia. Clique em Sim para fazer com que o Access feche os objetos ou clique em Não para cancelar todo o processo. Se for necessário, o Access também lhe pedirá para guardar as alterações.

  5. Na caixa de diálogo Guardar Como, escreva um nome para o ficheiro na caixa Nome do ficheiro e clique em Guardar.

    O Access cria a cópia da base de dados e, em seguida, abre a cópia. O Access fecha automaticamente a base de dados original.

Início da Página

Converter uma base de dados do Access 97 para o formato .accdb

Com início após o lançamento do Access 2013, deixa de ser possível converter diretamente bases de dados do Access 97 (.mdb) no formato de ficheiro .accdb. No entanto, pode abrir bases de dados do Access 97 numa versão anterior do Access e, em seguida, guardá-la num formato que possa ser aberto no Access 2013. Por exemplo, pode utilizar o Access 2003 para abrir uma base de dados do Access 97 e, depois, convertê-la num formato que possa ser aberto no Access 2013 da seguinte forma:

  1. Abra a base de dados do Access 97 no Access 2003.

  2. Clique em Ferramentas > Utilitários de Base de Dados > Converter a Base de Dados > no formato de ficheiro do Access 2002-2003.

  3. Introduza um nome para a base de dados e clique em Guardar.

  4. Feche o Access 2003 e abra o Access 2013.

  5. Abra a base de dados e clique em Ficheiro > Guardar Como > Base de Dados do Access(.accdb) > Guardar Como > Guardar.

Também pode utilizar o Access 2007 ou o Access 2010 para converter uma base de dados do Access 97 no formato .accdb. Sempre que abre uma base de dados do Access 97 num destes dois produtos, aparece o Assistente de Melhoramento da Base de Dados para ajudar a converter a base de dados no formato .accdb.

Início da Página

Utilizar o Access 2007 para abrir uma base de dados criada ou modificada no Access 2010, o Access 2013 ou o Access 2016

Uma vez que o Access 2016, Access 2013, Access 2010 e do Access 2007 todos os utilizarem o mesmo formato de ficheiro, pode utilizar o Access 2007 para abrir uma base de dados que foi criado no Access 2010, Access 2013 ou Access 2016 sem utilizar primeiro o comando Guardar como . No entanto, o Access 2016, Access 2013 e o Access 2010 incluem algumas funcionalidades que requerem acesso 2016, Access 2013 e Access 2010 para executar. Consoante a funcionalidade, um dos seguintes poderão ocorrer quando tenta utilizar a base de dados no Access 2007:

  • Não é possível modificar o objeto que utiliza a funcionalidade.

  • Não é possível abrir o objeto que utiliza a funcionalidade.

  • Não é sequer possível abrir a base de dados no Access 2007.

Início da Página

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×