Fórmulas e funções

Função CONTAR.SE

CONTAR.SE (função CONTAR.SE)

Nota: Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Utilize a função CONTAR.SE, uma das funções estatísticas, para contar o número de células que correspondem a um critério. Por exemplo, para contar o número de vezes que uma determinada cidade é apresentada numa lista de clientes.

De uma forma resumida, a função CONTAR.SE diz:

  • =CONTAR.SE(Onde pretende procurar?; O que pretende procurar?)

Por exemplo:

  • =CONTAR.SE(A2:A5;"Londres")

  • =CONTAR.SE(A2:A5,A4)

O seu browser não suporta vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

CONTAR.SE(intervalo; critérios)

Nome do argumento

Descrição

intervalo    (obrigatório)

O grupo de células que pretende contar. O intervalo pode conter números, matrizes, um intervalo com nome ou referências que contêm números. Os valores em branco e de texto são ignorados.

Saiba como selecionar intervalos numa folha de cálculo.

critérios    (obrigatório)

Um número, expressão, referência de célula ou cadeia de texto que determina que células vão ser contadas.

Por exemplo, pode utilizar um número (32), uma comparação (">32"), uma célula (B4) ou uma palavra ("maçãs").

A função CONTAR.SE utiliza um único critério. Utilize a função CONTAR.SE.S caso pretenda utilizar vários critérios.

Exemplos

Para utilizar estes exemplos no Excel, copie os dados na tabela abaixo e cole-os na célula A1 de uma nova folha de cálculo.

Dados

Dados

maçãs

32

laranjas

54

pêssegos

75

maçãs

86

Fórmula

Descrição

=CONTAR.SE(A2:A5;"maçãs")

Conta o número de células com maçãs nas células A2 a A5. O resultado é 2.

=CONTAR.SE(A2:A5;A4)

Conta o número de células com pêssegos (o valor em A4) nas células A2 a A5. O resultado é 1.

=CONTAR.SE(A2:A5;A2)+CONTAR.SE(A2:A5;A3)

Conta o número de maçãs (o valor em A2) e laranjas (o valor em A3) nas células A2 a A5. O resultado é 3. Esta fórmula utiliza a função CONTAR.SE duas vezes para especificar múltiplos critérios, um critério por expressão. Também pode utilizar a função CONTAR.SE.S.

=CONTAR.SE(B2:B5;">55")

Conta o número de células com um valor superior a 55 nas células B2 a B5. O resultado é 2.

=CONTAR.SE(B2:B5;"<>"&B4)

Conta o número de células com um valor diferente de 75 nas células B2 a B5. O E comercial (&) intercala o operador de comparação "<>" (diferente de) e o valor em B4 para ler =CONTAR.SE(B2:B5;"<>75"). O resultado é 3.

=CONTAR.SE(B2:B5;">=32")-CONTAR.SE(B2:B5;">85")

Conta o número de células com um valor maior ou igual a 32 e menor ou igual a 85 nas células B2 a B5. O resultado é 3.

=CONTAR.SE(A2:A5;"*")

Conta o número de células que contêm qualquer texto nas células A2 a A5. O asterisco * é o caráter universal utilizado para corresponder a qualquer caráter. O resultado é 4.

=CONTAR.SE(A2:A5;"?????es")

Conta o número de células que têm exatamente 7 caracteres e que terminam com as letras "es" nas células a2 a a5. O ponto de interrogação (?) é utilizado como carateres universais para corresponder a carateres individuais. O resultado é 2.

Problemas Comuns

Problema

O que correu mal

Foi devolvido um valor errado para as cadeias longas.

A função CONTAR.SE devolve resultados incorretos quando a utiliza para corresponder a cadeias com mais de 255 carateres.

Para corresponder cadeias com mais de 255 carateres, utilize a função CONCATENAR ou o operador concatenar &. Por exemplo, =CONTAR.SE(A2:A5;"cadeia longa"&"outra cadeia longa").

Não foi devolvido nenhum valor.

Certifique-se de que introduz o argumento critérios entre aspas.

A fórmula CONTAR.SE recebe um erro #VALOR! ao referir outra folha de cálculo.

Este erro ocorre quando a fórmula que contém a função refere células ou um intervalo num livro fechado e as células são calculadas. Para esta funcionalidade funcionar, o outro livro tem de estar aberto.

Práticas recomendadas

Faça o seguinte

Por que motivo

Tenha em atenção que a função CONTAR.SE ignora as letras maiúsculas e minúsculas nas cadeias de texto.

Os critérios não são sensíveis a maiúsculas/minúsculas. Por outras palavras, a cadeia "maçãs" e a cadeia "MAÇÃS" vão corresponder às mesmas células.

Utilize carateres universais.

Carateres uniVersais – o ponto de interrogação (?) e o asterisco (*), podem ser utilizados em critérios. Um ponto de interrogação corresponde a qualquer caráter individual. Um asterisco corresponde a qualquer sequência de carateres. Se pretender localizar um ponto de interrogação ou asterisco verdadeiro, escreva um til (~) à frente do caráter.

Por exemplo, =CONTAR.SE(A2:A5;"maçã?") contará todas as instâncias de "maçã" em que a última letra pode variar.

Certifique-se de que os seus dados não contêm carateres inválidos.

Ao contar os valores de texto, certifique-se de que os dados não contêm espaços à esquerda, espaços à direita, carateres não imprimíveis ou que não utilizam de forma inconsistente as aspas retas (' ou ") e curvas (‘ ou “). Nestes casos, a função CONTAR.SE pode devolver um valor inesperado.

Experimente utilizar a função LIMPARB ou a função COMPACTAR.

Para sua comodidade, utilize intervalos com nome

CONTAR.SE suporta intervalos com nome numa fórmula (como =CONTAR.SE(fruta;">=32")-CONTAR.SE(fruta;">85"). O intervalo com nome pode estar na folha de cálculo atual, noutra folha de cálculo no mesmo livro ou num livro diferente. Para referenciar a partir de outro livro, o segundo livro também tem de estar aberto.

Nota: A função CONTAR.SE não conta células com base na cor do fundo ou do tipo de letra da célula. No entanto, o Excel suporta Funções Definidas pelo Utilizador (UDFs) através de operações do Microsoft Visual Basic for Applications (VBA) em células com base na cor do fundo ou do tipo de letra. Eis um exemplo de como pode Contar o número de células com uma cor de célula específica através do VBA.

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no UserVoice do Excel.

Consulte também

Para contar células que não estão em branco, utilize a função contar. Val

Para contar células com múltiplos critérios, utilize a função contar.se/contar.se.S

Veja um vídeo sobre como utilizar a função contar.se/contar.se.S

A função SOMA.SE soma apenas os valores que correspondem a um único critério

A função SOMA.SE.S soma apenas os valores que correspondem a múltiplos critérios

Função SE.S (Office 365, Excel 2016 e posterior)

Utilizar a função arrumar para remover espaços à esquerda e à direita das células

Utilizar a função limpar para remover carateres não imprimíveis de células

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Detetar erros em fórmulas

Funções estatísticas

Funções do Excel (por ordem alfabética)

Funções do Excel (por Categoria)

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×