Contar carateres nas células

Nota:  Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Quando precisar de contar os carateres nas células, utilize a função NÚM. CARAT— que conta letras, números, carateres e todos os espaços. Por exemplo, o comprimento de "É graus 98 hoje em dia, para que irá aceda natação" (excluindo as aspas) é 42 caracteres — 31 letras, 2 números, 8 espaços, um ponto e vírgula e 2 apóstrofos.

Para utilizar a função, introduza = Núm. CARAT (célula) na barra de fórmulas, em seguida, prima Enter no teclado.

Múltiplas células: Para aplicar a mesma fórmula múltiplas células, introduza a fórmula na primeira célula e, em seguida, arraste a alça de preenchimento para baixo (ou ao longo) o intervalo de células.

Introduzir várias funções NÚM.CARAT numa folha de dados

Para obter a uma contagem total de todos os carateres em várias células é utilizar as funções soma , juntamente com NÚM. CARAT. Neste exemplo, a função LEN conta os carateres em cada célula e a função SOMA soma as contagens:

= Soma ((NÚM. CARAT ( cell1 ), NÚM. CARAT ( cell2 ), (NÚM. CARAT ( cell3 )) )).

Quer tentar?

Aqui estão alguns exemplos que demonstram como utilizar a função NÚM. CARAT.

Copie a tabela abaixo e cole-a na célula A1 numa folha de cálculo do Excel. Arraste a fórmula de B2 para B4 para ver o comprimento de texto em todas as células na coluna A.

Cadeias de texto

Fórmulas

O mnopqr castanho rápida.

=NÚM.CARAT(A2)

O rápida castanho hijkl mnopqr stuvw xyz.

Amostra: abcdefg hijkl mnopqr stuvw xyz áàãâ ç éê íóõôú

Contar carateres numa célula

  1. Clique na célula B2.

  2. Introduza carat (a2).

A fórmula conta os carateres na célula A2, totais 27 — que inclui todos os espaços e o período no fim da frase.

Nota: espaços após o último carácter a função LEN conta.

Contar carateres múltiplas células

  1. Clique na célula B2.

  2. Prima Ctrl + C para copiar célula B2, em seguida, selecione as células B3 e B4 e, em seguida, prima Ctrl + V para colar a fórmula nas células B3: B4.

Isto copia a fórmula para as células B3 e B4, e a função conta os carateres em cada célula (20, 27 e 45).

Contar um número total de carateres

  1. No livro de exemplo, clique na célula B6.

  2. Na célula, introduza =SOMA(NÚM.CARAT(A2);NÚM.CARAT(A3);NÚM.CARAT(A4)) e prima a tecla Enter.

Isto conta os carateres em cada uma das três células e dá o total (92).

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×