Como corrigir um erro #VALOR! nas funções MÉDIA ou SOMA

Se as funções MÉDIA ou SOMA se referirem a células com erros #VALOR!, as fórmulas resultarão num erro #VALOR!.

Erro #VALOR! na função MÉDIA

Para ignorar os valores de erro, iremos construir uma fórmula que ignore os erros no intervalo de referência ao calcular a média com os valores "normais" restantes.

Para contornar este cenário, utilizamos uma combinação da função MÉDIA com as funções SE e É.ERRO para determinar se existe um erro num intervalo específico. Este cenário particular requer uma fórmula de matriz:

=MÉDIA(SE(É.ERRO(B2:D2);"";B2:D2))

Nota: Esta é uma fórmula de Matriz e tem de ser introduzida com Ctrl+Shift+Enter. O Excel irá colocar automaticamente a fórmula entre chavetas {}. Se tentar introduzir as chavetas, o Excel irá apresentar a fórmula como texto.

A função de matriz na função MÉDIA para resolver o erro #VALOR!

Nota: A função acima não funcionará apenas para o erro #VALOR!, mas também para #N/D, #NULO, #DIV/0!, entre outros.

Também pode utilizar a função SOMA da mesma forma:

=SOMA(SE(É.ERRO(B2:D2);"";B2:D2))

Tem uma pergunta específica sobre funções?

Publique uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Tem sugestões sobre como podemos melhorar a próxima versão do Excel? Se tiver, consulte os tópicos em Excel User Voice.

Consulte Também

Corrigir um erro #VALOR!

Função MÉDIA

Função SOMA

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Utilizar a verificação de erros para detetar erros nas fórmulas

Todas as funções do Excel (por ordem alfabética)

Todas as funções do Excel (por categoria)

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×