Como corrigir um erro #VALOR! nas funções ÍNDICE/CORRESP

Este tópico explica os cenários comuns onde encontra o erro #VALOR! quando utiliza as funções ÍNDICE e CORRESP em conjunto numa fórmula. Uma das razões mais comuns para utilizar a combinação ÍNDICE e CORRESP é quando pretende procurar um valor num cenário onde a função PROCV não funciona para si, como no caso em que o valor de pesquisa tem mais de 255 carateres.

Problema: a fórmula não foi introduzida como uma matriz

Se estiver a utilizar a função ÍNDICE como uma fórmula de matriz com a função CORRESP para conseguir obter um valor, terá de converter a sua fórmula numa fórmula de matriz, caso contrário verá um erro #VALOR!.

Solução: as funções ÍNDICE e CORRESP devem ser utilizadas com uma fórmula de matriz, o que significa que tem de premir Ctrl+Shift+Enter. Esta ação irá colocar automaticamente a fórmula entre chavetas {}. Se tentar introduzir as chavetas, o Excel irá apresentar a fórmula como texto.

Se estiver a utilizar a função ÍNDICE/CORRESP quando tem um valor de pesquisa com mais de 255 carateres, este tem de ser introduzido como uma fórmula de Matriz.  A fórmula na célula F3 é =ÍNDICE(B2:B4;CORRESP(VERDADEIRO;A2:A4=F2;0);0) e é introduzida ao premir Ctrl+Shift+Enter
As funções ÍNDICE e CORRESP devem ser utilizadas com uma fórmula de matriz

Tem uma pergunta específica sobre funções?

Publique uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Tem sugestões sobre como podemos melhorar a próxima versão do Excel? Se tiver, consulte os tópicos em Excel User Voice.

Consulte Também

Corrigir um erro #VALOR!

Função ÍNDICE

Função CORRESP

Procurar valores com a função PROCV, ÍNDICE ou CORRESP

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Utilizar a verificação de erros para detetar erros nas fórmulas

Todas as funções do Excel (por ordem alfabética)

Todas as funções do Excel (por categoria)

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×