Como corrigir um erro #VALOR! na função CONTAR.SE/CONTAR.SE.S

Este tópico indica as causas mais comuns do erro #VALOR! nas funções CONTAR.SE e CONTAR.SE.S.

Problema: a fórmula refere-se a células num livro fechado

As funções CONTAR.SE/CONTAR.SE.S que se referem a uma célula ou a um intervalo num livro fechado resultarão num erro #VALOR!.

Nota: este é um problema conhecido em muitas outras funções do Excel como SOMA.SE, SOMA.SE.S, CONTAR.VAZIO, para citar algumas. Consulte As funções SOMA.SE, CONTAR.SE e CONTAR.VAZIO devolvem o erro #VALOR! para obter mais informações.

Solução: abra o livro ligado indicado na fórmula e prima F9 para atualizar a mesma.

Também pode contornar este problema com as funções SOMA e SE em conjunto numa fórmula de matriz. Consulte As funções SOMA.SE, CONTAR.SE e CONTAR.VAZIO devolvem o erro #VALOR! para obter mais informações.

Problema: a cadeia tem mais de 255 carateres

Solução: encurte a cadeia se for possível. Se não conseguir encurtar a mesma, utilize a função CONCATENAR ou o operador E comercial (&) para dividir o valor em múltiplas cadeias. Por exemplo:

  • =CONTAR.SE(B2:B12;"cadeia longa"&"outra cadeia longa")

Tem uma pergunta específica sobre funções?

Publique uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Tem sugestões sobre como podemos melhorar a próxima versão do Excel? Se tiver, consulte os tópicos em Excel User Voice.

Consulte Também

Corrigir um erro #VALOR!

Função CONTAR.SE

Função CONTAR.SE.S

Função SE – fórmulas aninhadas e evitar falhas

Ver um vídeo sobre as funções avançadas da função SE

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Utilizar a verificação de erros para detetar erros nas fórmulas

Todas as funções do Excel (por ordem alfabética)

Todas as funções do Excel (por categoria)

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×