Como corrigir um erro #REF!

Como corrigir um erro #REF!

Nota: Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

O #REF! mostra de erro quando uma fórmula refere-se a uma célula que não é válida. Isto acontece com mais frequência quando células que foram referenciadas por fórmulas obter eliminadas ou coladas sobre.

Exemplo: erro #REF! causado pela eliminação de uma coluna

O seguinte exemplo utiliza a fórmula =SOMA(B2;C2;D2) na coluna E.

Uma fórmula a utilizar referências explícitas a células como =SOMA(B2;C2;D2) pode causar um erro #REF! se uma coluna for eliminada.

Se fosse eliminar a coluna B, C ou D-seria causar uma #REF! Ocorreu um erro. Neste caso podemos irá eliminar coluna C (2007 vendas), e a fórmula é agora =SUM(B2,#REF!,C2). Quando utilizar referências explícitas a células, da seguinte forma (onde que fazem referência a cada célula individualmente, separados por um ponto e vírgula) e eliminar uma coluna ou linha referenciada, o Excel não consegue resolvê-lo, para que devolve o #REF! Ocorreu um erro. Este é o motivo principal porque é que a utilização de referências explícitas a células nas funções não é recomendada.

Exemplo do erro #REF! causado pela eliminação de uma coluna.

Solução

  • Se tiver eliminado acidentalmente linhas ou colunas, pode clicar imediatamente no botão Anular na Barra de Ferramentas de Acesso Rápido (ou premir Ctrl+Z) para restaurá-las.

  • Ajuste a fórmula para que utiliza uma referência de intervalo em vez de células individuais, como =SUM(B2:D2). Agora pode eliminar qualquer coluna no intervalo soma e o Excel irá ajustar automaticamente a fórmula. Pode também utilizar =SUM(B2:B5) para uma soma de linhas.

Exemplo: PROCV com referências de intervalo incorretas

No seguinte exemplo, =PROCV(A8;A2:D5;5;FALSO) devolve um erro #REF! pois está a procurar um valor para devolver da coluna 5, mas o intervalo de referência é A:D, que engloba apenas 4 colunas.

Exemplo de uma fórmula PROCV com um intervalo incorreto.  A fórmula é =PROCV(A8;A2:D5;5;FALSO).  Não existe uma quinta coluna no intervalo PROCV, pelo que 5 causa um erro #REF!.

Solução

Ajustar o intervalo de ser maior ou reduzir o valor de procura de coluna para fazer corresponder o intervalo de referência. =VLOOKUP(a8,a2:E5,5,FALSE) seria um intervalo de referência válida, como faria normalmente = VLOOKUP(A8,A2:D5,4,FALSE).

Exemplo: ÍNDICE com uma referência de linha ou coluna incorreta

Neste exemplo, a fórmula =ÍNDICE(B2:E5;5;5) devolve um erro #REF! porque o intervalo de ÍNDICE engloba 4 linhas e 4 colunas, mas a fórmula pede para devolver os conteúdos da quinta linha e da quinta coluna.

Exemplo de uma fórmula ÍNDICE com uma referência de intervalo inválida.  A fórmula é =ÍNDICE(B2:E5;5;5), mas o intervalo engloba apenas 4 linhas e 4 colunas.

Solução

Ajuste as referências de linha ou coluna para que estejam no interior do intervalo de pesquisa de índice remissivo. =Index(B2:E5,4,4) deve devolver um resultado válido.

Exemplo: fazer referência a um livro fechado com a função INDIRETO

No seguinte exemplo, uma função INDIRETO está a tentar fazer referência a um livro fechado, causando um erro #REF!.

Exemplo de um erro #REF! causado pela função INDIRETO a fazer referência a um livro fechado.

Solução

Abra o livro referenciado. Vai encontrar o mesmo erro se referência a um livro com uma fórmula de matriz dinâmicofechado.

Problemas OLE

Se utilizou uma ligação Object Linking and Embedding (OLE) que está a devolver um erro #REF!, inicie o programa ao qual a ligação está a ligar.

Nota: OLE é uma tecnologia que pode utilizar para partilhar informações entre programas.

Problemas DDE

Se tiver utilizado um tópico de Dynamic Data Exchange (DDE) que está a devolver uma #REF! erro, verificação primeira para se certificar de que está a referenciar o tópico correto. Se ainda estiver a receber um #REF! erro, verifique as Definições do Centro de fidedignidade para de conteúdo externo como destacada Bloquear ou desbloquear conteúdo externo nos documentos do Office.

Nota: Dynamic Data Exchange (DDE)é um protocolo estabelecido para intercâmbio de dados entre programas baseados no Windows da Microsoft.

Problemas Macro

Se uma macro introduz uma função da folha de cálculo que se refere a uma célula acima a função e a célula que contém a função está na linha 1, a função devolverá #REF! uma vez que não existem células acima da linha 1. Verificar a função para ver se um argumento que se refere a uma célula ou intervalo de células que não é válido. Isto pode requerer a editar a macro no Visual Basic Editor (VBE) para tirar esta situação para a conta.

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no UserVoice do Excel.

Consulte Também

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Utilizar a verificação de erros para detetar erros nas fórmulas

Funções do Excel (por ordem alfabética)

Funções do Excel (por categoria)

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×