Como corrigir um erro #DIV/0!

O Microsoft Excel mostra o erro #DIV/0! quando um número é dividido por zero (0). Ocorre quando introduz uma fórmula simples como =5/0 ou quando uma fórmula faz referência a uma célula com 0 ou em branco, como apresentado nesta imagem.

Exemplos de fórmulas que causam erros #DIV/0!.

Para corrigir o erro, efetue um dos seguintes procedimentos:

  • Certifique-se de que o divisor da função ou fórmula não é zero ou uma célula em branco.

  • Altere a referência de célula na fórmula para outra célula que não tenha um valor de zero (0) ou em branco.

  • Introduza #N/D na célula referenciada como divisor na fórmula, isto irá alterar o resultado da fórmula para #N/D para indicar que o valor do divisor não está disponível.

Muitas vezes, o erro #DIV/0! não pode ser evitado porque as fórmulas estão a aguardar a introdução de dados por parte do utilizador. Nesse caso, não quer que a mensagem de erro seja apresentada. Existem alguns métodos de processamento de erros que pode utilizar para suprimir o erro enquanto aguarda pela introdução de dados.

Avaliar o denominador para zero ou nenhum valor

A forma mais simples de suprimir o erro #DIV/0! é utilizar a função SE para avaliar a existência do denominador. Se for um zero ou nenhum valor, apresente um zero ou nenhum valor como o resultado da fórmula em vez do valor de erro #DIV/0!. Caso contrário, calcule a fórmula.

Por exemplo, se a fórmula que devolve o erro for =A2/A3, utilize =SE(A3;A2/A3;0) para devolver 0 ou =SE(A3;A2/A3;"") para devolver uma cadeia em branco. Também pode apresentar uma mensagem personalizada, por exemplo: =SE(A3;A2/A3;"Introdução Obrigatória"). Com a função QUOCIENTE do primeiro exemplo, utilizaria =SE(A3;QUOCIENTE(A2;A3);0). Esta função indica ao Excel SE(A3 existir, então devolver o resultado da fórmula, caso contrário ignorar).

Exemplos de resolução de erros #DIV/0!.

Utilizar SE.ERRO para suprimir o erro #DIV/0!

Também pode suprimir este erro ao aninhar a operação de divisão dentro da função SE.ERRO. Mais uma vez, com A2/A3, pode utilizar =SE.ERRO(A2/A3;0). Isto diz ao Excel para devolver 0 se a sua fórmula for avaliada como erro e, caso contrário, para devolver o resultado da fórmula.

Para versões do Excel anteriores ao Excel 2007, pode utilizar o método SE(É.ERRO()): =SE(É.ERRO(A2/A3);0;A2/A3) (Consulte Funções É).

Nota: ambos os métodos SE.ERRO e SE(É.ERRO()) são processadores de erros gerais, o que significa que irão suprimir todos os erros e não apenas #DIV/0!. Tem de se certificar de que a sua fórmula funciona corretamente antes de aplicar qualquer processador de erros. Caso contrário, poderá não se aperceber de que a sua fórmula não está a funcionar conforme previsto.

Sugestão:  Se a verificação de erros estiver ativada no Excel, pode clicar em Imagem de Botão junto à célula que mostra o erro. Clique em Mostrar Passos do Cálculo, se for apresentado, e escolha a solução adequada para os dados em questão.

Tem uma pergunta específica sobre funções?

Publique uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Tem sugestões sobre como podemos melhorar a próxima versão do Excel? Se tiver, consulte os tópicos em Excel User Voice.

Consulte Também

Função SE

Função SE.ERRO

Funções É

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Utilizar a verificação de erros para detetar erros nas fórmulas

Funções do Excel (por ordem alfabética)

Funções do Excel (por categoria)

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×