Como corrigir o erro #VALOR! na função SOMARPRODUTO

Nota: Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Este tópico abrange os cenários comuns do erro #VALOR! ao trabalhar com a função SOMARPRODUTO.

Problema: os argumentos da matriz não têm as mesmas dimensões

Todos os argumentos da matriz devem de ter as mesmas dimensões. Se não tiverem, irá obter o erro #VALOR!. Por exemplo, se a Matriz 1 se referir a um intervalo de 3 linhas e 2 colunas, a Matriz 2 também tem de corresponder a um intervalo semelhante.

A fórmula SOMARPRODUTO que causa um erro é =SOMARPRODUTO(D2:D13;E2:E10): E10 tem de ser alterada para E13 para corresponder ao primeiro intervalo.
  • =SOMARPRODUTO(D2:D13;E2:E10)

Irá ocorrer um erro, pois os intervalos referenciados não têm o mesmo número de linhas (13 no primeiro intervalo, mas apenas 10 no segundo).

Solução: altere a fórmula para

  • =SOMARPRODUTO(D2:D13;E2:E13).

Assim, ambos os intervalos terão os mesmos números de linhas iniciais e finais. Em seguida, experimente novamente a fórmula.

Resolver o erro #VALOR! nos dados para resolver o erro SOMARPRODUTO

Problema: uma ou mais células no intervalo contêm texto

Se uma ou mais células no intervalo referenciado tiverem texto ou estiverem formatadas como um tipo de dados de Texto, irá obter o erro #VALOR!. O texto poderá ser o resultado de um cálculo de outra fórmula ou talvez a célula não esteja formatada de forma correta.

A fórmula na célula E15 mostra um erro #VALOR! porque existe um erro #VALOR! na coluna E.

Solução: verifique se alguma célula contém texto ou se está formatada como texto e defina o tipo de dados correto.

Tem uma pergunta específica sobre funções?

Publique uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Tem sugestões sobre como podemos melhorar a próxima versão do Excel? Se tiver, consulte os tópicos no User Voice do Excel

Consulte Também 

Corrigir um erro #VALOR!

Função SOMARPRODUTO

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Detetar erros em fórmulas

Todas as funções do Excel (por ordem alfabética)

Todas as funções do Excel (por categoria)

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×