Como corrigir o erro #VALOR! na função CONCATENAR

Importante: No Excel 2016, Excel Mobile e Excel Online, a função CONCATENAR foi substituída pela função CONCAT. Apesar de a função CONCATENAR continuar disponível para efeitos de retrocompatibilidade, recomendamos que utilize a função CONCAT, uma vez que é mais eficiente.

Um dos cenários mais comuns em que pode encontrar o erro #VALOR! com a função CONCATENAR é quando tenta criar uma cadeia que inclui uma referência de célula com um erro, como #VALOR!.

No seguinte exemplo, queremos concatenar D2, E2 e F2, em que E2 tem um erro #VALOR!.

O erro #VALOR! na função CONCATENAR

O erro em E2 faz com que a função apresente o erro #VALOR!. Para que funcione com êxito, terá de substituir o erro por um valor diferente do erro. Pode criar uma fórmula que verifique se ocorre um erro na referência da célula e se ocorrer, apresentará a cadeia de texto onde aparece um 0 em vez do erro (ou pode substituir o seu próprio texto por 0, mas terá de colocar o texto entre aspas: "O Seu Texto").

Uma fórmula como esta poderá funcionar:

=SE(É.ERRO(E2);CONCATENAR(D2;" ";0;" ";F2))

As funções SE e É.ERRO utilizadas como uma solução para concatenar uma cadeia com o erro #VALOR!

Como funciona? A função SE utiliza a função SE.ERRO para determinar se existe um erro em E2 e, se existir, a função CONCATENAR combina os valores em D2, E2 e F2 (a função substitui o erro por 0) e apresenta a cadeia de texto resultante. Tenha em atenção que a fórmula também utiliza espaços (" ") para ajudar a separar os valores.

Corrigir o erro #VALOR! com a função CONCATENAR no Excel 2003 e versões anteriores

Se obter o erro #VALOR! no Office Excel 2003 ou em versões anteriores, terá de desmarcar a opção Avaliação Alternativa de Fórmulas (TFE) no Excel. Siga os passos indicados em Erro #VALOR! ao concatenar células para resolver o problema.

Tem uma pergunta específica sobre funções?

Publique uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Tem sugestões sobre como podemos melhorar a próxima versão do Excel? Se tiver, consulte os tópicos em Excel User Voice.

Consulte Também

Corrigir um erro #VALOR!

Função CONCATENAR

Função CONCAT

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Utilizar a verificação de erros para detetar erros nas fórmulas

Todas as funções do Excel (por ordem alfabética)

Todas as funções do Excel (por categoria)

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×