Como corrigir erros de fórmulas no Excel para Mac

Quer seja um erro #VALOR!, #NOME! ou um problema com a função PROCV, as seguintes informações podem ajudá-lo a corrigir o erro.

PROCV

Se estiver a obter erros ou resultados inesperados com a função PROCV, transfira a referência rápida de sugestões de resolução de problemas da função PROCV.

Erro #VALOR!

A origem deste problema normalmente está relacionada com uma combinação de valores numéricos e de valores de texto. Para obter mais informações, consulte o artigo Corrigir um erro #VALOR!.

Erro #NOME?

Certifique-se de que escreve os nomes corretamente, coloca qualquer texto entre aspas e nomes de folhas entre aspas simples ('). Para outras causas e soluções, consulte erro #NOME?.

Erro #NÚM!

Isto pode acontecer se escreveu carateres a mais numa fórmula. Por exemplo, não escreva 1 000 € numa fórmula. Em vez disso, introduza 1 000. Para outras causas e soluções, consulte Corrigir um erro #NÚM!.

Erro #N/D

Se uma fórmula não conseguir localizar um valor referenciado, devolve o erro #N/D. Para obter mais informações, consulte Corrigir um erro #N/D.

Erro #REF!

O Excel mostra este erro quando uma fórmula contém uma referência de célula inválida. Para obter mais informações, consulte Corrigir um erro #REF!.

Erro #DIV/0!

Isto ocorre quando um número é dividido por zero (0) ou quando uma fórmula se refere a uma célula que contém 0 ou está em branco. Para obter mais informações, consulte erro #DIV/0!.

Referenciar outras folhas e livros

Se estiver a referenciar o nome de outra folhas de cálculo, escreva ! a seguir ao nome e introduza uma célula ou intervalo. Se o nome da folha contiver espaços, coloque o nome entre aspas simples. Por exemplo: =SOMA('Relatório de Vendas'!A1:A8).

Ao referenciar outro livro externo:

  • Coloque o nome do livro entre parênteses retos [ ].

  • Escreva o caminho completo para o ficheiro.

  • Coloque o caminho entre aspas simples (no início do caminho e após o nome da folha de cálculo, antes do ponto de exclamação).

    Exemplo: =SOMA('/Utilizadores/oseunome/Ambientedetrabalho/[Q2 Operações.xlsx]Vendas'!A1:A8)

Outras soluções rápidas que podem ser úteis

  • Inicie cada fórmula com um sinal de igual (=). Exemplo: =SOMA(A1:A8)

  • Utilize o símbolo * para multiplicar números em vez de um X. Exemplo: =A1*A8

  • Corresponda todos os parênteses de abertura e de fecho. para que fiquem aos pares. Este exemplo tem dois pares: =SE(40>50;SOMA(G2:G5);0)

  • Introduza todos os argumentos necessários. O Criador de Fórmulas pode ajudá-lo com esta operação. Comece a escrever a fórmula com o nome de uma função e, em seguida, prima Controlo+A para ver o Criador de Fórmulas.

  • Utilize aspas em redor do texto em fórmulas. Exemplo: =SE(A2>B2,"Ultrapassa o Orçamento","OK")

  • Altere o tipo de dados de uma célula referenciada. Prima COMANDO +1 e selecione Número.

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×