Avaliar uma fórmula aninhada um passo de cada vez

Nota:  Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Por vezes, Noções sobre como uma aninhada fórmula calcula o resultado final é difícil porque existem vários cálculos intermédios e testes lógicos. No entanto, utilizando a caixa de diálogo Avaliar fórmula, pode ver as diferentes partes de uma fórmula aninhada avaliada pela ordem que a fórmula é calculada. Por exemplo, a fórmula =IF(AVERAGE(F2:F5) > 50,SUM(G2:G5),0) é mais fácil de compreender quando pode ver os seguintes resultados intermédios:

Passos demonstrados na caixa de diálogo

Descrição

=SE(MÉDIA(F2:F5)>50;SOMA(G2:G5);0)

A fórmula aninhada é apresentada inicialmente. A função MÉDIA e a função SOMA estão aninhadas na função SE.

=SE(40>50;SOMA(G2:G5);0)

O intervalo de células F2: F5 contém os valores 55, 35, 45 e 25 e, por isso, o resultado da função AVERAGE(F2:F5) é 40.

=SE(FalsoSOMA(G2:G5);0)

40 não for maior que 50, pelo que a expressão no primeiro argumento da função se (o argumento teste_lógico) é falsa.

0

A função se devolve o valor do terceiro argumento (o argumento valor_se_falso). A função soma não é avaliada uma vez que é o segundo argumento da função se (argumento valor_se_verdadeiro) e é devolvido apenas quando a expressão for verdadeira.

  1. Selecione a célula que pretende avaliar. Só é possível avaliar uma célula de cada vez.

  2. No separador Fórmulas, no grupo Auditoria de Fórmulas, clique em Avaliar Fórmula.

    Grupo Auditoria de Fórmulas no separador Fórmulas

  3. Clique em Avaliar para examinar o valor da referência sublinhada. O resultado da avaliação é apresentado em itálico.

    Se a parte sublinhada da fórmula for uma referência a outra fórmula, clique em Avançar para apresentar a outra fórmula na caixa Avaliação. Clique em Retroceder para voltar à célula e fórmula anteriores.

    Nota: O botão Avançar não está disponível para uma referência na segunda vez que a mesma é apresentada na fórmula ou se a fórmula se referir a uma célula noutro livro.

  4. Continue até que cada parte da fórmula tenha sido avaliada.

  5. Para ver a avaliação novamente, clique em Reiniciar.

    Para terminar a avaliação, clique em Fechar.

    Notas: 

    • Algumas partes das fórmulas que utilizam se e escolher entre funções não são avaliadas e # n/d é apresentada na caixa avaliação.

    • Se a referência estiver em branco, o valor zero (0) é apresentado na caixa Avaliação.

    • Fórmulas com referências circulares não poderão avaliar como esperado. Se referências circulares são assim o pretender, pode Ativar cálculo iterativo.

    • As seguintes funções são recalculadas cada vez que a folha de cálculo alterada e podem causar a ferramenta de Avaliar fórmula apresente resultados diferentes a partir do que é apresentado na célula: aleatório, deslocamento, célula, INDIRETO, agora, hoje, ALEATÓRIOENTRE, informações e soma.se (em alguns cenários).

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×