Adicionar uma ligação de dados a uma lista ou biblioteca de documentos do SharePoint

Nota:  Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Pode adicionar um ou mais ligações de dados secundária ao seu modelo de formulário que pode um dos dados da consulta a partir de uma lista ou biblioteca de documentos ou submeter dados a uma biblioteca de documentos num servidor a executar o Microsoft Windows SharePoint Services.

Neste artigo

Descrição geral

Antes de começar

Adicionar uma ligação de dados da consulta

Adicionar uma ligação de dados de submeter

Descrição Geral

Uma ligação de dados secundária é qualquer ligação de dados a uma origem de dados externos que adicionar a um modelo de formulário. Esta ligação de dados é a diferença entre a ligação de dados principal que é criada quando cria um modelo de formulário com base em definições numa biblioteca de ligações, serviço Web ou uma base de dados. Adicionar uma ligação de dados secundária apenas se não conseguir de consulta ou enviar dados através da ligação de dados principal.

Quando adiciona uma ligação de dados secundária ao seu modelo de formulário que dados de consultas, o Microsoft Office InfoPath cria uma secundário origem de dados com campos de dados e grupos que corresponde ao modo em que os dados são armazenados na lista ou biblioteca de documentos. Ícone conceptual para a secção Iniciar

Uma vez que a estrutura de dados na origem de dados secundária tem de corresponder a forma que os dados são armazenados na biblioteca de documentos ou lista, não é possível modificar campos existentes ou grupos na origem de dados secundária.

Uma ligação de dados que os dados de consultas a partir do SharePoint da biblioteca de documentos ou lista automaticamente devolve todos os itens nessa lista ou biblioteca de documentos. Se estiver a utilizar uma ligação de dados de consulta para preencher uma lista de caixa, caixa de lista pendente, ou controlo de caixa de combinação e o controlo contém demasiados itens ou que pretende apresentar apenas os itens que correspondam a critérios especificados, pode utilizar um filtro no controlo para limitar o número de produto MS. localizar ligações para mais informações sobre a filtragem dos dados apresentados num controlo na secção Consulte também.

Também pode configurar cada ligação de de dados de consulta para guardar os respectivos resultados de modo a que os utilizadores tenham acesso aos mesmos quando o formulário não está ligado a uma rede. Consoante a natureza dos dados, pode pretender apresentar os resultados da consulta apenas quando os utilizadores estão ligados a uma rede.

Nota de Segurança: Se estiver a utilizar uma ligação de dados secundária para obter dados sensíveis a maiúsculas e a partir de uma origem de dados externos, pretende desativar esta funcionalidade para ajudar a proteger os dados de utilização não autorizada caso o computador é roubado ou. Se desativar esta funcionalidade, os dados estará disponíveis apenas se o utilizador está ligado à rede.

Quando adicionar uma ligação de dados de consulta a um modelo de formulário, por predefinição, os formulários baseados nesse modelo de formulário utilizam a ligação de dados quando forem abertos por um utilizador. Também pode configurar um modelo de formulário para utilizar a ligação de dados de consulta de uma das seguintes formas:

  • Adicionar uma regra    Pode configurar uma regra para utilizar a ligação de dados de consulta sempre que ocorre a condição na regra.

  • Adicionar um botão    Pode adicionar um botão para o modelo de formulário que os utilizadores podem clicar para obter dados utilizando a ligação de dados da consulta.

  • Código personalizado de utilização    Se não é possível adicionar uma regra ou um botão, pode utilizar o código personalizado para obter dados utilizando a ligação de dados da consulta. Utilizando o código personalizado requer um programador criar o código personalizado.

Quando adiciona uma ligação de dados de submissão ao modelo do formulário, pode configurar o modelo de formulário para permitir que os utilizadores submetam os respectivos dados de formulário e pode configurar as opções de submissão para formulários que estão baseadas no modelo de formulário.

Início da página

Antes de começar

Antes de adicionar uma ligação de dados secundária ao modelo de formulário, necessita das seguintes informações do administrador do site:

  • A localização do site SharePoint e as permissões necessárias para aceder ao mesmo

  • A confirmação de que o site está configurado de modo a que os utilizadores possam obter dados da lista ou biblioteca de documentos

  • A confirmação de que pode armazenar os dados da lista ou biblioteca de documentos nos computadores dos utilizadores para utilização offline

Início da página

Adicionar uma ligação de dados de consulta

Para permitir que os utilizadores consultem dados de uma lista ou biblioteca de documentos num site que está localizado num servidor com o Microsoft Windows SharePoint Services, necessita de efectuar o seguinte no modelo de formulário:

  1. Adicionar uma ligação de dados secundária

  2. Configurar o modelo de formulário para utilizar a ligação de dados secundária.

Passo 1: Adicionar uma ligação de dados secundária

  1. No menu Ferramentas, clique em Ligações de Dados.

  2. Na caixa de diálogo Ligações de dados, clique em Adicionar.

  3. No Assistente de Ligação de Dados, clique em Crie uma nova ligação para, clique em Receber dados e, em seguida, clique em Seguinte.

  4. Na página seguinte do assistente, clique em Biblioteca ou lista do SharePoint e, em seguida, clique em Seguinte.

    Page in the Data Connection Wizard to specify a SharePoint site as the data source.

  5. Na página seguinte do assistente, escreva o URL do site do SharePoint com a lista ou biblioteca de documentos e, em seguida, clique em seguinte. Por exemplo, para utilizar uma lista de documentos num site do SharePoint com o URL http://www.adventureworks.com/EmployeeList, escreva http://www.adventureworks.com/EmployeeList.

  6. Na página seguinte do assistente, na lista Seleccione uma lista ou biblioteca, clique na lista ou biblioteca que pretende utilizar e, em seguida, clique em Seguinte.

  7. Na página seguinte do assistente, seleccione as caixas de verificação junto dos valores pretende receber. Se pretender publicar o modelo de formulário na biblioteca de documentos e que os formulários baseados nesse modelo de formulário obtenham metadados acerca do formulário, seleccione a caixa de verificação Incluir dados para o formulário activo apenas.

  8. Clique em Seguinte.

  9. Se pretender armazenar os resultados da consulta com o modelo de formulário, seleccione a caixa de verificação Armazenar uma cópia dos dados no modelo de formulário. Ao seleccionar esta caixa de verificação armazena os resultados da consulta no modelo de formulário. Como os dados são armazenados no modelo de formulário, os dados estarão disponíveis nos formulários preenchidos pelos utilizadores mesmo que os respectivos computadores não estejam ligados a uma rede.

    Nota de Segurança: Selecionar esta caixa de verificação armazena os resultados da consulta no modelo de formulário. Uma vez que os dados são armazenados no modelo de formulário, está disponível nos formulários de que os utilizadores preencherem, mesmo se os respetivos computadores não estiver ligados a uma rede. Se está a obter dados sensíveis a partir desta ligação de dados, poderá querer desativar esta funcionalidade para ajudar a proteger os dados, no caso do computador é roubado ou.

  10. Clique em Seguinte.

  11. Na página seguinte do assistente, na caixa introduzir um nome para esta ligação de dados, escreva um nome descritivo para esta ligação de dados secundária. Este é o nome apresentado na lista de origem de dados no painel de tarefas origem de dados. Se pretender que esta consulta para ser executada automaticamente sempre que o formulário está aberto por um utilizador, selecione a caixa de verificação obter dados automaticamente quando formulário está aberto.

Passo 2: Configurar o modelo de formulário para utilizar a ligação de dados secundária

Se pretender formulários baseados no modelo de formulário para utilizar esta ligação de dados depois do utilizador abre o formulário, pode adicionar uma regra para o modelo de formulário que utiliza esta ligação de dados numa determinada condição ou pode adicionar um botão ao modelo de formulário que os utilizadores podem clip Ma para utilizar esta ligação de dados.

Adicionar uma regra

Pode adicionar uma regra ao modelo de formulário para obter dados a partir da ligação de dados de consulta sempre que a condição para a regra for cumprida. O procedimento seguinte assume que criou uma ligação de dados de consulta para o modelo de formulário e que configurou um controlo no modelo de formulário para apresentar os dados dessa ligação de dados.

  1. Se o modelo de formulário tem múltiplas vistas, clique em nome da vista, no menu Ver para ir para a vista com o controlo onde pretende apresentar os dados de origem de dados secundária.

  2. Faça duplo clique no controlo pretendido para apresentar os resultados da consulta.

  3. Clique no separador Dados.

  4. Em Validação e Regras, clique em Regras.

  5. Na caixa de diálogo Regras, clique em Adicionar.

  6. Na caixa Nome, escreva um nome para a regra.

  7. Para especificar uma condição quando deve ser executada a regra, clique em Definir condição e, em seguida, introduza a condição. A regra será executada quando ocorre a condição. Se não definir uma condição, a regra será executada sempre que o utilizador altera o valor no controlo e, em seguida, move o cursor dele afastando-o de que o controlo.

  8. Clique em Adicionar Acção.

  9. Na lista Acção, clique em Consulta com uma ligação de dados.

  10. Na lista Ligação de dados, clique na ligação de dados de consulta que pretende utilizar e, em seguida, clique em OK para fechar cada caixa de diálogo aberta.

  11. Para testar as suas alterações, clique em Pré-visualizar na barra de ferramentas Padrão ou prima CTRL+SHIFT+B.

Adicionar um botão

Pode adicionar um controlo de botão ao modelo de formulário que os utilizadores possam clicar para utilizar essa ligação de dados de consulta. O procedimento seguinte assume que criou uma ligação de dados de consulta para o modelo de formulário.

  1. Se o modelo de formulário tem múltiplas vistas, clique em nome da vista, no menu Ver para ir para a vista com o controlo onde pretende apresentar os dados de origem de dados secundária.

  2. Se o painel de tarefas Controlos não estiver visível, clique em Mais Controlos no menu Inserir ou prima ALT+I, C

  3. Arraste um controlo de botão para o modelo de formulário.

  4. Faça duplo clique no controlo de botão que acabou de adicionar ao modelo de formulário.

  5. Clique no separador Geral.

  6. Na lista Acção, clique em Actualizar.

  7. Na caixa Rótulo, escreva o nome que pretende apresentar no botão no modelo de formulário.

  8. Clique em Definições.

  9. Na caixa de diálogo Actualizar, clique em Uma origem de dados secundária.

  10. Na lista Seleccione a origem de dados secundária, clique na origem de dados secundária que está associada à ligação de dados de consulta e, em seguida, clique em OK para fechar cada caixa de diálogo aberta.

  11. Para testar as suas alterações, clique em Pré-visualizar na barra de ferramentas Padrão ou prima CTRL+SHIFT+B.

Início da página

Adicionar uma ligação de dados de submissão

Para permitir que os utilizadores submetam formulários baseados no modelo de formulário a uma biblioteca de documentos, necessita de efectuar o seguinte procedimento:

  1. Adicione uma ligação de dados secundária que submete dados ao modelo de formulário.

  2. Configure o modelo de formulário para permitir que os utilizadores submetam os respectivos dados de formulário à biblioteca de documentos.

Passo 1: Adicionar uma ligação de dados secundária

  1. No menu Ferramentas, clique em Ligações de Dados.

  2. Na caixa de diálogo Ligações de dados, clique em Adicionar.

  3. No Assistente de Ligação de Dados, clique em Crie uma nova ligação para, clique em Submeter dados e, em seguida, clique em Seguinte.

  4. Em Como pretende submeter os dados, clique em Numa biblioteca de documentos num site do SharePoint e, em seguida, clique em Seguinte.

  5. No Assistente de Ligação de Dados, na caixa Biblioteca de documentos, escreva o URL da biblioteca de documentos do SharePoint.

  6. Na caixa Nome do ficheiro, escreva um nome que será utilizado para identificar o formulário na biblioteca de documentos.

    Sugestão: Também pode utilizar uma fórmula para garantir que cada nome de formulário é exclusivo.

    Como?

    1. Clique em Inserir fórmula Imagem de botão .

    2. Na caixa de diálogo Inserir Fórmula, execute um dos seguintes procedimentos:

      • Para utilizar um campo na fórmula, clique em Inserir Campo ou Grupo, clique no campo que pretende utilizar na caixa de diálogo Seleccionar um Campo ou Grupo e, em seguida, clique em OK.

      • Para utilizar uma função na fórmula, clique em Inserir Função, seleccione a função que pretende utilizar na caixa de diálogo Inserir Função e, em seguida, clique em OK.

        Sugestão: Se a função necessita de parâmetros, selecione a função na caixa de diálogo Inserir função, clique em OK e, em seguida, na caixa fórmula, na caixa de diálogo Inserir fórmula, faça duplo clique sobre a função que tenha adicionado e clique num campo ou grupo. Encontre ligações para mais informações sobre funções na secção Consulte também.

      • Para inserir um valor ou operador matemático na fórmula, introduza o valor ou o símbolo da operação matemática na caixa Fórmula.

    Operação

    Símbolo

    Adicionar

    +

    Subtrair

    -

    Multiplicar

    *

    Dividir

    /

    • Nota: Se a sua fórmula utiliza o operador de divisão (/), certifique-se de que existe um espaço antes e depois do operador de divisão. Se o operador de divisão não tem um espaço antes e depois, o InfoPath poderá interpretar "/" como um separador para obter os passos de localização XPath em vez de como um operador de divisão.

    • Para verificar se a fórmula tem a sintaxe correcta, na caixa de diálogo Inserir Fórmula, clique em Verificar Fórmula.

      Localize as hiperligações para obter mais informações acerca de fórmulas na secção Consulte Também.

  7. Para substituir quaisquer formulários existentes na biblioteca de documentos com o mesmo nome, seleccione a caixa de verificação Permitir substituir se existir ficheiro.

  8. Clique em Seguinte.

  9. Na página seguinte do assistente, na caixa introduzir um nome para esta ligação de dados, escreva um nome descritivo para este submeter a ligação de dados.

Depois de adicionar a ligação de dados de submissão secundária, é necessário configurar o modelo de formulário para permitir que os utilizadores submetam os respectivos dados de formulário utilizando esta ligação de dados de submissão.

Passo 2: Activar a submissão no modelo de formulário

Quando configura o modelo de formulário para permitir que os utilizadores submetam os respectivos dados de formulário, o InfoPath adiciona um botão Submeter à barra de ferramentas Padrão e um comando Submeter ao menu Ficheiro no formulário. Também pode personalizar as opções de submissão para o modelo de formulário das seguintes formas:

  • Altere o texto que aparece no botão Submeter.

  • Altere o atalho de teclado para o botão Submeter.

  • Crie mensagens personalizadas para apresentar aos utilizadores quando submetem os respectivos formulários.

  • Especifique se pretende deixar o formulário aberto, fechar o formulário ou abrir outro formulário em branco depois de o formulário ser submetido.

  • No menu Ferramentas, clique em Opções de submeter.

  • Na caixa de diálogo Opções de submeter, selecione a caixa de verificação Permitir que os utilizadores para submeter este formulário, clique em Enviar dados de formulário a um único destino e, em seguida, na lista, clique em biblioteca de documentos do SharePoint.

  • Na lista Seleccionar uma ligação de dados para submeter, clique no nome da ligação de dados de submissão à biblioteca do SharePoint.

    1. Para alterar o nome do botão para Submeter que aparece na barra de ferramentas padrão e o comando de Submeter que aparece no menu ficheiro, quando os utilizadores preencham o formulário, escreva o novo nome na caixa legenda na Submeter Opções caixa de diálogo.

      Sugestão: Se pretende atribuir um atalho de teclado para este botão e o comando, escreva um e comercial (&) antes do caráter que pretende utilizar como um atalho de teclado. Por exemplo, para atribuir ALT + B como o atalho de teclado para o botão Submeter e o comando, escreva & botão Submeter.

  • Se não pretender que as pessoas utilizarem um comando de Submeter ou no botão Submeter na barra de ferramentas padrão, quando estes preencham o formulário, desmarque a caixa de verificação Mostrar o item de menu submeter e o botão da barra de ferramentas de submeter.

    1. Por predefinição, depois dos utilizadores submeter um formulário InfoPath mantém o formulário aberto e apresenta uma mensagem para indicar se o formulário foi submetido com êxito. Para alterar este comportamento predefinido, clique em Avançadas e, em seguida, efetue um dos seguintes procedimentos:

      • Para fechar o formulário ou criar um novo formulário em branco depois do utilizador submete um formulário concluído, clique na opção que pretende na lista após submeter.

      • Para criar uma mensagem personalizada para indicar se o formulário foi submetido com êxito, selecione a caixa de verificação utilizam as mensagens de personalizado e, em seguida, escreva as suas mensagens nas caixas em caso de êxito e em caso de falha.

        Sugestão: Utilizar uma mensagem na caixa em caso de falha para informar os utilizadores o que fazer se não pode submeter o seu formulário. Por exemplo, pode sugerir que os utilizadores guardarem a sua forma e contactar alguém para obter mais instruções.

      • Se não pretender apresentar uma mensagem depois do utilizador submete um formulário, desmarque a caixa de verificação Mostrar mensagens com e sem êxito.

Início da página

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×