Adicionar uma ligação de dados a uma base de dados do Microsoft Access

Nota:  Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Se os utilizadores irão necessitar de dados a partir de uma base de dados Microsoft Office Access 2007 (formato. accdb) ou de uma base de dados do Access guardado numa versão anterior (. mdb format) para preencher um formulário baseado no seu modelo de formulário do Microsoft Office InfoPath, pode adicionar uma ligação de dados secundária para o formulário modelo de consulta uma base de dados do Access.

Pode adicionar uma ligação de dados secundária, mas essa ligação a dados só pode consultar uma base de dados do Access. Não pode adicionar uma ligação de dados secundária submete dados de formulário a uma base de dados do Access.

Se pretender que os utilizadores para submeter os seus dados de formulário para uma base de dados do Access, pode estruturar um modelo de formulário que é baseado na base de dados Access e, em seguida, ativar a ligação de dados de submeter na ligação de dados principal. Em alternativa, pode adicionar uma ligação de dados secundária para um serviço Web que funciona com a sua base de dados do Access.

Encontre ligações para mais informações sobre modelos de formulário que são baseados numa base de dados de acesso de estruturar e adicionar uma ligação de dados secundária a um serviço Web na secção Consulte também.

Neste artigo

Descrição geral

Considerações sobre compatibilidade

Antes de começar

Passo 1: Adicionar uma ligação de dados secundária

Passo 2: Configurar o modelo de formulário para utilizar a ligação de dados

Descrição Geral

Um secundário ligação de dados é uma ligação de dados que adicionar a um modelo de formulário. Uma ligação de dados secundária é a diferença entre a ligação de dados principal, criar quando estrutura um novo modelo de formulário que é baseado numa base de dados ou de um serviço Web. Ligação de dados principal de um modelo de formulário pode receber dados de origem de dados externa e também pode submeter dados de formulário a uma origem de dados externos. No entanto, um modelo de formulário pode ter apenas uma ligação de dados principal.

Pode adicionar quantas secundário ligações de dados para um modelo de formulário que pretender. Por exemplo, imaginemos que tem uma base de dados do Access que contém uma tabela que armazena dados de funcionários e outra tabela ou consulta que armazena dados de cliente. Pode adicionar uma ligação de dados secundária que obtém dados a partir da tabela Empregados e também pode adicionar outra ligação de dados secundária que obtém dados a partir da tabela de cliente na mesma base de dados do Access.

Apesar de poder adicionar uma ligação de dados secundária ao seu modelo de formulário que pode submeter dados de formulário a uma origem de dados externos, como um serviço Web ou a biblioteca do Windows SharePoint Services, só pode utilizar ligações de dados secundária para obter dados a partir do Access base de dados. Não pode adicionar uma ligação de dados secundária submete dados de formulário a uma base de dados do Access.

Quando adiciona uma ligação de dados de consulta numa base de dados, o InfoPath cria uma secundário origem de dados que contém os campos de dados e grupos que correspondem da forma que os dados são armazenados na base de dados. Uma vez que a estrutura de dados na origem de dados secundária tem de corresponder a forma que os dados são armazenados nas tabelas da base de dados, não é possível modificar os campos ou grupos na origem de dados secundária.

Pode configurar cada ligação de dados de consulta para guardar os seus resultados para que os utilizadores têm acesso aos dados quando o respetivo formulário não estiver ligado a uma rede. Dependendo da natureza dos dados, poderá pretender apresentar os resultados da consulta apenas quando os utilizadores estão ligados a uma rede.

Nota de Segurança: Se estiver a utilizar uma ligação de dados secundária para obter dados sensíveis a maiúsculas e a partir de uma origem de dados externos, pretende desativar esta funcionalidade para ajudar a proteger os dados de utilização não autorizada caso o computador é roubado ou. Se desativar esta funcionalidade, os dados estará disponíveis apenas se o utilizador está ligado à rede.

Quando adiciona uma ligação de dados de consulta para um modelo de formulário, por predefinição os formulários baseados neste modelo de formulário utilizam a ligação de dados quando são abertos por um utilizador. Também pode configurar o seu modelo de formulário para utilizar a ligação de dados de consulta de uma das seguintes formas:

  • Adicionar uma regra    Pode configurar uma regra para utilizar a ligação de dados de consulta sempre que ocorre a condição na regra.

  • Adicionar um botão    Pode adicionar um botão para o modelo de formulário que os utilizadores podem clicar para obter dados utilizando a ligação de dados da consulta.

  • Código personalizado de utilização    Se não é possível adicionar uma regra ou um botão, pode utilizar o código personalizado para obter dados utilizando a ligação de dados da consulta. Utilizando o código personalizado requer um programador criar o código personalizado.

Início da página

Considerações sobre compatibilidade

Não pode adicionar uma ligação de dados para uma base de dados do Access para um modelo de formulário compatível com o browser.

Início da página

Antes de começar

Antes de adicionar uma ligação de dados secundária para uma base de dados do Access ao seu modelo de formulário, tem as seguintes informações:

  • O nome e localização da base de dados.

    Nota: Se a base de dados do Access estiver armazenado numa localização de rede, certifique-se de que a sua base de dados está acessível aos seus utilizadores.

  • O nome da tabela ou consulta que irá fornecer dados a formulários baseados neste modelo de formulário. Irá utilizar esta tabela ou consulta como a principal tabela ou consulta quando configurar a ligação de dados da consulta.

  • Os nomes de outras tabelas ou consultas de dados adicionais à tabela principal ou consulta. Na maioria dos casos, as relações de tabela são já foram estabelecidas na base de dados. Se tiver de estabelecer manualmente as relações entre a tabela primária ou consulta e outra tabela ou consulta, terá os nomes de campo relacionado de tabelas ou consultas.

Início da página

Passo 1: Adicionar uma ligação de dados secundária

  1. No menu Ferramentas, clique em Ligações de dados.

  2. Na caixa de diálogo Ligações de dados, clique em Adicionar.

  3. No Assistente de ligação de dados, clique em criar uma nova ligação para, clique em dados de receção e, em seguida, clique em seguinte.

  4. Na página seguinte do assistente, clique em base de dados (Microsoft SQL Server ou apenas para o Microsoft Office Access) e, em seguida, clique em seguinte.

  5. Na página seguinte do assistente, clique em Selecionar base de dados.

  6. Na caixa de diálogo Selecionar origem de dados, navegue para a localização da base de dados.

    Nota: Se a base de dados estiver armazenado numa localização de rede, navegue para o caminho Convenção (UNC) universal naming da localização. Não navegue para a localização de rede através de uma unidade de rede mapeada. Se utilizar uma unidade de rede mapeadas, os utilizadores que criar formulários baseados neste modelo de formulário irão procurar a base de dados a partir de uma unidade de rede mapeada. Se o utilizador não tiver uma unidade de rede mapeadas, a forma não irá encontrar a base de dados.

  7. Clique no nome da base de dados e, em seguida, clique em Abrir.

  8. Na caixa de diálogo Selecionar tabela, clique na tabela primária ou consulta que pretende utilizar e, em seguida, clique em OK.

  9. Na página seguinte do assistente, selecione a caixa de verificação Mostrar colunas da tabela.

    Por predefinição, todos os campos da tabela ou consulta são adicionados à origem de dados principal do modelo de formulário.

  10. Desmarque as caixas de verificação para os campos que não pretende incluir na origem de dados secundária.

    Adicione mais tabelas ou consultas à ligação de dados.

    Como?

    1. Clique em Adicionar a tabela.

    2. Na caixa de diálogo Adicionar tabela ou consulta, clique no nome da tabela subordinada e, em seguida, clique em seguinte. Tenta InfoPath definir as relações através da correspondência de nomes de campos em ambas as tabelas. Se não pretende utilizar a relação sugerida, selecione a relação e, em seguida, clique em Remover relação. Para adicionar uma relação, clique em Adicionar relação. Na caixa de diálogo Adicionar relação, clique no nome de cada campo relacionado na coluna respetivos e, em seguida, clique em OK.

    3. Clique em Concluir.

    4. Para adicionar tabelas subordinadas adicionais, repita estes passos.

  11. Clique em Seguinte.

  12. Para disponibilizar os resultados da ligação de dados de consulta quando o formulário não estiver ligado a uma rede, selecione a caixa de verificação do arquivo de uma cópia dos dados no modelo de formulário.

    Nota de Segurança: Selecionar esta caixa de verificação armazena os dados no computador do utilizador quando o formulário utiliza esta ligação de dados. Se o formulário está a obter dados confidenciais esta ligação de dados, poderá pretender desativar esta funcionalidade para ajudar a proteger os dados, no caso do computador é roubado ou.

  13. Clique em Seguinte.

  14. Na página seguinte do assistente, escreva um nome descritivo para esta ligação de dados secundária e, em seguida, verifique se as informações na secção de Resumo estão corretas.

  15. Para configurar o formulário para receber dados automaticamente quando o formulário está aberto, selecione a caixa de verificação obter dados automaticamente quando formulário está aberto.

Início da página

Passo 2: Configurar o modelo de formulário para utilizar a ligação de dados

Se pretender que a formulários baseados neste modelo de formulário para utilizar esta ligação de dados, depois do utilizador abre o formulário, pode adicionar um regra ao modelo de formulário que utiliza esta ligação de dados numa determinada condição ou pode adicionar um botão ao modelo de formulário que os seus utilizadores, podem clicar para utilizar esta ligação de dados.

Adicionar uma regra

Pode adicionar uma regra para o modelo de formulário que serve para obter os dados da ligação de dados de consulta sempre que a condição para a regra é cumprida. Por exemplo, pode adicionar uma caixa de texto ao seu modelo de formulário que um utilizador pode preencher para obter dados específicos de origem de dados externa. Em seguida, pode adicionar uma regra que utiliza a ligação de dados sempre que um utilizador introduz dados na caixa de texto.

O seguinte procedimento assume que criou uma ligação de dados de consulta para o modelo de formulário e que configurou um controlo (que não seja um botão) no seu modelo de formulário para apresentar os dados dessa ligação de dados.

  1. Se o modelo de formulário tem múltiplas vistas, clique em nome da vista, no menu Ver para ir para a vista com o controlo onde pretende apresentar os dados de origem de dados secundária.

  2. Faça duplo clique no controlo ao qual pretende adicionar uma regra.

  3. Clique no separador Dados.

  4. Em regras de validação e, clique em regras.

  5. Na caixa de diálogo regras, clique em Adicionar.

  6. Na caixa nome, escreva um nome para a regra.

  7. Para especificar uma condição quando deve ser executada a regra, clique em Definir condição e, em seguida, introduza a condição. A regra será executada quando ocorre a condição. Se não definir uma condição, a regra será executada sempre que o utilizador altera o valor no controlo e, em seguida, move o cursor dele afastando-o de que o controlo.

  8. Clique em Adicionar ação.

  9. Na lista de ação, clique em consulta utilizando uma ligação de dados.

  10. Na lista de ligação de dados, clique na ligação de dados de consulta que pretende utilizar e, em seguida, clique em OK para fechar cada caixa de diálogo Abrir.

  11. Para testar as suas alterações, clique em Pré-visualizar na barra de ferramentas Padrão ou prima CTRL+SHIFT+B.

Adicionar um botão

Pode adicionar um controlo de botão ao seu modelo de formulário que os utilizadores podem clicar para obter dados a partir de ligação de dados de consulta.

  1. Se o modelo de formulário tem múltiplas vistas, clique em nome da vista, no menu Ver para ir para a vista com o controlo onde pretende apresentar os dados de origem de dados secundária.

  2. Se o painel de tarefas Controlos não estiver visível, clique em Mais Controlos no menu Inserir ou prima ALT+I, C

  3. Arraste um controlo de botão para o modelo de formulário.

  4. Faça duplo clique no controlo de botão que acabou de adicionar ao modelo de formulário.

  5. Clique no separador Geral.

  6. Na lista de ação, clique em Atualizar.

  7. Na caixa etiqueta, escreva o nome que pretende que apareçam no botão no seu modelo de formulário.

  8. Clique em Definições.

  9. Na caixa de diálogo Atualizar, efetue um dos seguintes procedimentos:

    • Para receber os dados mais recentes de todas as origens de dados externos com ligações de dados secundária para este modelo de formulário, clique em todas as origens de dados secundária.

    • Para configurar o botão para receber os dados mais recentes a partir de uma origem de dados externos com uma ligação de dados secundária ao seu modelo de formulário, clique numa ligação de dados secundária e, em seguida, clique numa origem de dados secundária na origem de dados de Escolher secundária lista.

  10. Clique em OK para fechar cada caixa de diálogo aberta.

  11. Para testar as suas alterações, clique em Pré-visualizar na barra de ferramentas Padrão ou prima CTRL+SHIFT+B.

Início da página

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×