Adicionar um botão para alternar entre vistas

Nota:  Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

No Microsoft Office InfoPath, pode criar vistas diferentes do mesmo modelo de formulário. Uma vista é uma forma alternativa para apresentar dados num modelo de formulário. Ao preencher formulários baseados no modelo de formulário, os utilizadores podem alternar entre vistas para escolher a quantidade de dados que são apresentados no formulário de. Por exemplo, num modelo de formulário de relatório de estado, poderá criar uma vista de resumo para além de uma vista detalhada. Os utilizadores, em seguida, podem escolher qual a vista que pretendem observe, dependendo de qual o tipo de informações que necessitam.

Vistas com frequência foram concebidas para trabalhar com regras. Regras permitem-lhe automatizar determinadas tarefas num modelo de formulário em resposta ao eventos ou ações iniciadas por pessoa que preenche o formulário. Por exemplo, este artigo descreve como pode inserir um botão no seu modelo de formulário e, em seguida, criar uma regra que alterna entre vistas quando esse botão é clicado.

Neste artigo

Passo 1: Inserir um botão de cada vista

Passo 2: Criar uma regra que alterna entre vistas

Passo 3: Teste a experiência do utilizador

Passo 1: Inserir um botão de cada vista

Nota: Para concluir o seguinte procedimento, tem de ter um modelo de formulário com duas vistas existentes. Encontre ligações para mais informações sobre como criar vistas na secção Consulte também.

  1. No menu Ver, clique em Gerir vistas.

  2. Em selecionar uma vista, clique na vista que pretende adicionar um botão para.

  3. No modelo de formulário, coloque o cursor onde pretende inserir o botão.

  4. No menu Inserir, clique em Mais controlos ou prima ALT + I, C.

  5. Em Inserir controlos, no painel de tarefas controlos, clique em botão.

  6. No modelo de formulário, faça duplo clique no botão que acabou de inserir.

  7. Clique no separador Geral.

  8. Na caixa etiqueta, escreva o texto que pretende que apareçam no botão e, em seguida, clique em OK.

  9. No menu Ver, clique em Gerir vistas.

  10. Em selecionar uma vista, clique no nome da vista de segundo.

  11. Siga os passos 3 a 8 para adicionar um botão para a segunda vista.

Início da página

Passo 2: Criar uma regra que alterna entre vistas

Depois de ter adicionado botões para cada vista do modelo de formulário, tem de criar regras de mudar de vistas quando os utilizadores clicam esses botões.

  1. No menu Ver, clique em Gerir vistas.

  2. Em selecionar uma vista, clique na vista que pretende trabalhar com.

  3. No modelo de formulário, faça duplo clique no botão que inseriu no procedimento anterior.

  4. Clique no separador Geral.

  5. Na lista de ação, clique em regras e código personalizado.

  6. Clique em regras.

  7. Na caixa de diálogo regras, clique em Adicionar.

  8. Na caixa nome, escreva um nome para a regra, como Mudar para a vista de 2. Verá este nome quando estiver a trabalhar com a vista no modo de estrutura. No entanto, o nome não ser visto por pessoas preenche o formulário.

  9. Clique em Adicionar ação.

  10. Na lista de ação, clique em Mudar vistas.

  11. Na lista vista, clique na vista que pretende mudar para e, em seguida, clique em OK.

  12. Clique em OK para fechar todas as caixas de diálogo Abrir.

  13. No painel de tarefas de vistas, em selecionar uma vista, clique na segunda vista.

  14. Siga os passos 3 a 12 para criar uma regra para o botão na segunda vista.

Início da página

Passo 3: Teste a experiência do utilizador

Depois de ter adicionado botões às suas vistas e criado as regras necessárias, é uma boa ideia para testar o seu modelo de formulário para se certificar de que funciona como esperado.

  1. Para testar as suas alterações, clique em Pré-visualizar na barra de ferramentas Padrão ou prima CTRL+SHIFT+B.

    Nota: A vista que estava a trabalhar na maior parte recentemente é a vista que serão apresentadas na janela de pré-visualização.

  2. Para testar se os botões para alternar entre vistas estão a funcionar corretamente, clique nos botões que criou no procedimento anterior.

Início da página

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×