Adicionar conexões entre formas

Adicionar conexões entre formas

Subscrição do Office 365, Office 2019, Office 2016, Office 2013, Office 2010

O Visio facilita a ligação de formas no seu desenho. Pode utilizar a Ligação Automática para ligar formas à medida que as adiciona e pode ligar formas existentes ao utilizar a ferramenta Conexão. Também pode alterar as formas apresentadas na minibarra de ferramentas e ativar ou desativar a Ligação Automática.

Ligar uma forma automaticamente

Ligar formas que já se encontrem na página

Ligar a uma forma noutra página

Utilizar temas para alterar o aspeto das conexões

Utilizar formas de conexão alternativas

Alterar as formas na minibarra de ferramentas Ligação Automática

Ativar ou desativar a Ligação Automática

Ligar uma forma automaticamente

Uma maneira de ligar formas é permitir que o Visio as ligue automaticamente quando adiciona formas a uma página. Esta funcionalidade é especialmente útil ao criar um fluxograma.

  1. Certifique-se de que a Ligação Automática está ativada. No separador Ver, no grupo Ajudas Visuais, verifique se a Ligação Automática está selecionada.

  2. Arraste uma forma do painel Formas para a página.

  3. Coloque o ponteiro sobre a forma até que as setas da Ligação Automática apareçam à volta da forma.

    Quando a Ligação Automática estiver ativa, paire com o cursor do rato sobre uma forma para apresentar setas de ligação.
  4. Coloque o ponteiro sobre a seta na direção em que pretende adicionar uma forma.

    Pairar com o cursor do rato sobre uma seta de Ligação Automática apresenta uma barra de ferramentas de formas a adicionar.

    É apresentada uma minibarra de ferramentas que contém as primeiras quatro Formas Rápidas que estão presentemente no stencil Formas Rápidas. Quando aponta para uma forma na barra de ferramentas, o Visio apresenta uma pré-visualização dessa forma na página.

  5. Clique na forma que pretende adicionar.

  6. Se quiser continuar, aponte para uma seta da Ligação Automática numa forma adicionada recentemente para adicionar outra forma que também será ligada automaticamente.

    Pairar com o cursor do rato sobre a forma adicionada recentemente apresenta setas da Ligação Automática para adicionar outra forma.

Início da Página

Ligar formas que já se encontrem na página

Sugestão: Os comandos no grupo Ferramentas no separador Base colocam o Visio num estado ou modo diferente, o que por vezes poderá ser confuso. Utilize o teclado para alternar, conforme necessário, entre a Ferramenta de Ponteiro  Selecionar Objetos (prima Ctrl+1) e a ferramenta Conexão  Imagem de botão (prima Ctrl+3). Independentemente da ferramenta que esteja a utilizar, como o Bloco de Texto ou o Ponto de Ligação, prima Esc várias vezes para voltar à Ferramenta de Ponteiro.

  1. No separador Base, no grupo Ferramentas, clique em Conexão Imagem de botão ou prima Ctrl+3.

  2. Clique numa forma e arraste uma conexão para outra forma.

  3. Quando terminar, clique em Ferramenta de Ponteiro Selecionar Objetos no separador Base no grupo Ferramentas ou prima Ctrl+1.

A ferramenta Conexão liga-se a formas com uma ligação por pontos em cada ponto final.

Em alternativa, o comando Ligar Formas pode ser adicionado ao friso e utilizado para ligar múltiplas formas pela ordem em que foram selecionadas.

Sugestão: os comandos úteis que ainda não estiverem visíveis no friso podem ser adicionados ao clicar em Ficheiro > Opções > Personalizar o Friso.

Início da Página

Ligar a uma forma noutra página

Apenas pode utilizar conexões entre formas na mesma página. Para ligar a uma forma noutra página, utilize a forma Referência Exterior à Página para criar uma hiperligação de uma página para a seguinte ou adicione uma Hiperligação e ação de Duplo clique a qualquer forma para navegar para uma página diferente no mesmo documento.

Utilizar uma Referência Exterior à Página

  1. Abra o stencil Formas de Fluxograma Base e, em seguida, arraste a forma de Referência exterior à página na página atual.

    Forma de referência exterior à página
  2. Na caixa de diálogo Referência exterior à página, selecione OK para adicionar a forma à página atual e a uma página criada recentemente.

  3. Na nova página, continue a criar o seu diagrama.

  4. Para alterar o aspeto da forma de Referência exterior à página, clique com o botão direito do rato na forma e, em seguida, selecione Saída, Entrada, Círculo ou Seta.

Para se deslocar entre páginas, faça duplo clique na forma de Referência exterior à página em qualquer uma das páginas. Para obter mais informações, consulte Caixa de diálogo Referência Exterior à Página.

Utilizar Hiperligação e Duplo Clique

  1. Clique com o botão direito do rato em qualquer forma ou prima Ctrl+K e, em seguida, selecione Hiperligação.

  2. Clique em Procurar junto ao campo Subendereço e, em seguida, clique na lista pendente junto a Página para selecionar a página pretendida.

    Caixa de diálogo Hiperligação

    Nota: o nome de uma forma na página de destino também pode ser especificado para uma hiperligação. Clique no separador Programador e, em seguida, selecione Nome da Forma, utilize o nome predefinido no campo Nome ou edite e, em seguida, clique em OK.

  3. Para definir a ação de duplo clique para uma forma, clique no separador Programador e, em seguida, selecione Comportamento.

  4. Clique no separador Duplo Clique, selecione a opção Ir para a página e, em seguida, clique na lista pendente para selecionar a página pretendida.

    Ação Fazer Duplo Clique no Visio

    Nota: só faça isto depois de ter editado os nomes das suas páginas porque as mesmas não serão atualizadas automaticamente aqui.

Início da Página

Utilizar temas para alterar o aspeto das conexões

Embora o aspeto predefinido das conexões possa consistir em simples linhas, algumas delas podem ter sido concebidas para funcionarem com temas que acrescentam adornos, como pontas de seta. Os temas incorporados podem ser aplicados a partir da galeria Temas no separador Estrutura. Para alterar um atributo de uma conexão, como o estilo, a cor, a espessura, etc., consulte Editar Formas de Conexão.

Notas: 

  • Para ver mais adornos, clique no separador Estrutura. No grupo Variantes, clique na seta pendente e, em seguida, selecione Conexões.

Utilizar formas de conexão alternativas

Todas as formas de conexão, como as que se encontram disponíveis em Mais Formas > Extras do Visio > Conexões podem ser utilizadas para ligar formas em vez de utilizar a forma predefinida Conexão dinâmica. Estas formas de conexão podem ser arrastadas e largadas numa página, selecionadas para as utilizar com as ferramentas Conexão e Ligar Formas ou podem simplesmente ser utilizadas para substituir conexões existentes.

  1. Abra o stencil que contém as formas de conexão alternativas.

  2. Selecione as conexões existentes que pretende substituir na página.

  3. No separador Base no grupo Editar, clique em Alterar Forma e, em seguida, selecione a forma de conexão pretendida.

Nota: a funcionalidade Alterar Forma foi introduzida no Visio 2013, mas as ferramentas Conexão e Ligar Formas foram introduzidas antes do Visio 2007.

Início da Página

Alterar as formas na minibarra de ferramentas Ligação Automática

As formas na minibarra de ferramentas pertencem ao stencil Formas Rápidas de um diagrama. A minibarra de ferramentas apresenta até quatro formas. Pode personalizar as formas apresentadas na minibarra de ferramentas. O procedimento seguinte utiliza o Diagrama Básico como exemplo.

  1. Por predefinição, as formas na minibarra de ferramentas são as primeiras quatro no stencil que vem imediatamente a seguir ao stencil Formas Rápidas. Por exemplo, estas são as primeiras quatro formas no stencil Formas Base.

    A minibarra de ferramentas a utilizar formas básicas predefinidas
  2. Para apresentar formas diferentes na minibarra de ferramentas para um determinado stencil, pode reordenar as formas ao arrastá-las para a parte superior do stencil. Por exemplo, pode arrastar as formas Estrela de 4 Pontas, Estrela de 5 Pontas, Estrela de 6 Pontas e Estrela de 7 Pontas para a parte superior do stencil Formas Base.

    A minibarra de ferramentas com novas formas básicas
  3. Também pode alterar a ordem dos stencils ao arrastá-los mais para cima ou para baixo no painel Formas. É apresentado um subconjunto destas formas no stencil Formas Rápidas e pela mesma ordem em que estão no painel Formas. Por exemplo, ao arrastar o stencil Formas Decorativas para imediatamente após o stencil Formas Rápidas no painel Formas, a sequência é alterada no stencil Formas Rápidas.

    A minibarra de ferramentas a utilizar um stencil diferente ao reordenar

    Nota: ao fechar e reabrir um diagrama, a ordem predefinida dos stencils no painel Formas é automaticamente restaurada e refletida nas Formas Rápidas.

  4. Para utilizar um stencil diferente como base para a minibarra de ferramentas, no stencil Formas Rápidas selecione uma forma no subconjunto destas formas para um stencil. Por exemplo, selecione Diagrama de Venn no stencil Formas de Expressões Matemáticas e de Gráfico.

    A minibarra de ferramentas a utilizar um novo stencil ao selecionar

Sugestão: para voltar à sequência de formas predefinida num stencil, clique com o botão direito do rato no nome do stencil no painel Formas e, em seguida, selecione Repor Stencil.

Nota: nem todos os stencils têm formas que podem ser utilizadas na minibarra de ferramentas. Por exemplo, as formas no stencil Formas de Setas não aparecem na minibarra de ferramentas.

Início da Página

Ativar ou desativar a Ligação Automática

Pode ativar e desativar a Ligação Automática para o desenho atual ou como predefinição para todos os desenhos do Visio.

Ativar ou desativar a Ligação Automática no diagrama ativo

  • No separador Ver, no grupo Ajudas Visuais, selecione ou limpe a Ligação Automática.

    Selecione ou desmarque a Ligação Automática no separador Ver para ativar ou desativar a Ligação Automática.

Se a caixa Ligação Automática não estiver disponível, verifique se a Ligação Automática foi desativada em todos os diagramas ao efetuar o seguinte procedimento.

Ativar ou desativar a Ligação Automática em todos os diagramas

  1. Clique no separador Ficheiro e, em seguida, clique em Opções.

  2. Em Opções do Visio, clique em Avançadas.

  3. Em Opções de edição, selecione Ativar Ligação Automática para ativar a Ligação Automática. Desmarque a caixa Ligação Automática para desativar a Ligação Automática.

    Selecione ou anule a seleção da opção Ativar Ligação Automática para ativar ou desativar a Ligação Automática para todos os diagramas e desenhos.
  4. Clique em OK.

Início da Página

Ligar formas com a Ligação Automática

Uma maneira de ligar formas é permitir que o Visio as ligue automaticamente quando adiciona formas a um desenho. Esta funcionalidade é especialmente útil ao criar um fluxograma.

Utilize o seguinte procedimento para adicionar uma forma ao seu desenho que o Visio liga automaticamente a uma forma existente.

Utilizar a Ligação Automática ao arrastar formas para a página

  1. Arraste uma forma de um stencil para a página de desenho e posicione-a junto a outra forma.

    Uma forma posicionada junto a outra forma

  2. Enquanto mantém premido o botão do rato, mova o ponteiro para cima de um dos triângulos azuis. O triângulo fica azul-escuro.

    Se colocar o ponteiro sobre um dos triângulos azuis, este torna-se azul-escuro.

  3. Solte o botão do rato. A forma está posicionada na página de desenho e é adicionada e colada uma conexão a ambas as formas.

    A forma está posicionada na página de desenho e é adicionada e colada uma conexão a ambas as formas.

Sugestão: Se não quiser arrastar formas, pode conseguir o mesmo resultado ao selecionar primeiro uma forma no stencil, colocar o cursor sobre uma forma no seu desenho e, em seguida, clicar num dos triângulos azuis que aparecem junto à forma.

Utilizar a Ligação Automática com formas que já se encontrem na página

  1. Coloque o ponteiro sobre a forma a partir da qual pretende efetuar a ligação.

    O ponteiro sobre a forma a partir da qual pretende efetuar a ligação

  2. Posicione o ponteiro sobre o triângulo azul mais próximo da forma à qual pretende ligar.

    O ponteiro posicionado sobre o triângulo azul mais próximo da forma à qual pretende ligar.

    O triângulo fica azul-escuro e é apresentada uma caixa vermelha em torno da forma à qual pretende ligar.

    Nota: Se não aparecer uma caixa vermelha em torno da forma à qual pretende ligar, a forma poderá estar demasiado longe. Mova a forma para mais perto e tente novamente.

  3. Clique no triângulo azul. É adicionada e colada uma conexão às duas formas.

    A forma está posicionada na página de desenho e é adicionada e colada uma conexão a ambas as formas.

Ativar ou desativar a funcionalidade Ligação Automática

Pode ativar ou desativar a funcionalidade Ligação Automática em todos os desenhos do Visio ou apenas no desenho atual. Para todos os desenhos:

  1. No menu Ferramentas, clique em Opções.

  2. Clique no separador Geral.

  3. Nas opções da janela Desenho, selecione a caixa de verificação Ativar Ligação Automática.

Apenas para o desenho atual:

  • Na barra de ferramentas Padrão, clique na ferramenta Ligação Automática.

    Nota: Se clicar na ferramenta Ligação Automática não ativar a Ligação Automática, certifique-se de que a caixa de verificação Ativar Ligação Automática está selecionada na caixa de diálogo Opções.

Ligar formas com a ferramenta Conexão

Uma das formas mais flexíveis de adicionar e colar uma conexão é desenhá-la com a ferramenta Conexão Imagem de botão na barra de ferramentas Padrão.

  1. Clique na ferramenta Conexão Imagem de botão na barra de ferramentas Padrão.

  2. Siga um dos seguintes procedimentos:

    • Para manter a conexão colada a um ponto específico numa forma, arraste a partir de um ponto de ligação Imagem do ponto de ligação - X azul na primeira forma para um ponto de ligação na segunda forma. Os pontos finais da conexão ficam a vermelho quando as formas estão ligadas. Isto chama-se uma ligação ponto-a-ponto. Com uma ligação ponto-a-ponto, a conexão permanece colada aos mesmos pontos de ligação se mover uma das formas.

    • Para permitir que a conexão se mova para o ponto de ligação mais próximo, posicione a ferramenta Conexão no centro da primeira forma até ser apresentada uma caixa vermelha em torno da forma. Mantenha premido o botão do rato e arraste para o centro da segunda forma. Assim que uma caixa vermelha for apresentada em torno da segunda forma, solte o botão do rato. Isto chama-se uma conexão forma-a-forma. Com uma conexão forma-a-forma, a conexão permanece colada a cada forma ao mover os pontos de ligação disponíveis mais próximos quando uma das formas é movida. Se não existirem pontos de ligação, a conexão move-se para os lados mais próximos.

      Nota: Também pode criar ligações entre formas em que um ponto final da conexão está ligado a um ponto de ligação e o outro ponto final da conexão está ligado à forma (e vice-versa).

  3. Clique na Ferramenta de Ponteiro Botão Ponteiro , na barra de ferramentas Padrão, para voltar à edição normal.

    Notas: 

    • Para adicionar uma conexão a partir de uma forma para várias formas, tem de adicionar várias conexões. Não existe uma forma de conexão de "ramificação".

    • Se estiver a tentar criar uma ligação ponto-a-ponto e estiver a ter dificuldades em colar uma conexão exatamente onde quer, experimente definições de ajuste e colagem diferentes.

    • No menu Ferramentas, clique em Ajustar e Colar e, em seguida, no separador Geral selecione as opções que pretende.

      Se colar à geometria da forma, a uma alça da forma ou a um vértice da forma, será adicionado automaticamente um ponto de ligação (se ainda não existir um).

Alternar entre a forma e os pontos de ligação

Pode colar conexões de um ponto numa forma para outro ponto numa forma diferente ou de uma forma inteira para outra forma inteira. Também pode criar ligações em que um ponto final da conexão está colado a um ponto numa forma e o outro ponto final da conexão está colado a uma forma inteira.

  1. Arraste o ponto final de uma conexão para longe da forma.

  2. Siga um dos seguintes procedimentos:

    • Para colar a extremidade de uma conexão num ponto de ligação numa forma, arraste a extremidade para um dos pontos de ligação da forma até ser apresentada uma caixa vermelha em torno do ponto de ligação.

    • Para colar o ponto final de uma conexão à forma inteira, arraste o ponto final até ao centro da forma até ser apresentada uma caixa vermelha em torno da forma inteira.

Consulte Também

Adicionar e editar texto de conexão

Criar uma conexão personalizada

Colar ou descolar conexões

Formação do Visio

All you need to know about Visio desktop connectors (Tudo o que precisa de saber acerca das conexões no Visio para ambiente de trabalho) – blogue da equipa do Visio

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×