Acerca da funcionalidade de livro partilhado

Nota: Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Importante: "Livros Partilhados" é uma funcionalidade mais antiga que lhe permite colaborar num livro com múltiplas pessoas. Esta funcionalidade tem muitas limitações e foi substituída pela cocriação. A cocriação está disponível em algumas versões do Excel, incluindo o Excel 2016 para subscritores do Office 365.

Experimentar o Office 365 ou a versão mais recente do Excel

Ativar a funcionalidade Livro Partilhado

  1. Certifique-se de que pretende utilizar este método antes de continuar. Livros partilhados têm limitações e uma em particular é a impossibilidade de editar utilizando o Excel Online. Por conseguinte, recomendamos vivamente a cocriação, qual é a substituição do livros partilhados.

  2. Crie um livro novo ou abra um livro existente. Em seguida, coloque-o numa localização da rede. Por exemplo, coloque-o numa localização como \\nome_do_servidor\nome_da_pasta. Não coloque o ficheiro no OneDrive ou SharePoint. Se preferir estas localizações para o ficheiro, cocrie o livro.

  3. Clique em Rever > Partilhar Livro.

    Tenha em atenção que nas versões mais recentes do Excel, o botão Partilhar Livro foi ocultado. Eis como o mostrar:

  4. Na caixa de diálogo Partilhar livro, selecione a caixa de verificação Permitir alterações por mais de um utilizador…

  5. No separador Avançado, selecione as opções que pretende utilizar para controlar e atualizar alterações e, em seguida, clique em OK.

  6. Caso se trate de um livro novo, escreva um nome na caixa Nome do ficheiro. Se este livro já existir, clique em OK para o guardar.

  7. Se o livro tiver ligações para outros livros ou documentos, verifique as ligações e atualize as ligações quebradas.

  8. Clique em Ficheiro > Guardar.

  9. Quando terminar, será apresentado - Partilhado na parte superior da janela do Excel, ao lado do nome do ficheiro.

Informações adicionais

Tenha em atenção que os Livros Partilhados são um método de partilha mais antigo. Portanto, muitos itens e ações não são suportados quando este método é utilizado. A tabela abaixo apresenta apenas uma lista parcial das funcionalidades não suportadas.

Itens não suportados:

Ações não suportadas:

Criar ou inserir tabelas

Inserir ou eliminar blocos de células

Adicionar ou alterar formatos condicionais

Eliminar folhas de cálculo

Adicionar ou alterar a validação de dados

Unir células ou dividir células unidas

Criar ou alterar gráficos ou relatórios de gráficos dinâmicos

Ordenar ou filtrar por formato

Inserir ou alterar imagens ou outros objetos

Utilizar ferramentas de desenho

Inserir ou alterar hiperligações

Atribuir, alterar ou remover palavras-passe

Criar, alterar ou visualizar cenários

Proteger ou desproteger folhas de cálculo ou o livro

Inserir subtotais automáticos

Agrupar ou destacar dados

Criar tabelas de dados

Escrever, registar, alterar, ver ou atribuir macros

Criar ou alterar relatórios de tabelas dinâmicas

Alterar ou eliminar fórmulas de matriz

Criar ou aplicar segmentações de dados

Adicionar, mudar o nome ou eliminar mapas XML

Criar ou modificar gráficos sparkline

Mapear células para elementos XML

Adicionar ou alterar folhas de caixa de diálogo do Microsoft Excel 4

Utilizar o painel de tarefas Origem XML, a barra de ferramentas XML ou os comandos XML no menu Dados

Utilizar um formulário de dados para adicionar novos dados

Adicionar comentários por tópicos

Editar ou eliminar comentários por tópicos

Antes de remover utilizadores, certifique-se de que os mesmos concluíram o trabalho no livro. Se remover utilizadores ativos, perder-se-á todo o trabalho não guardado realizado por estes.

  1. Clique em Rever > Partilhar Livro.

    Tenha em atenção que nas versões mais recentes do Excel, o botão Partilhar Livro foi ocultado. Eis como o mostrar:

  2. No separador Estado, na lista Quem tem este livro aberto, verifique os nomes dos utilizadores.

  3. Selecione o nome do utilizador que pretende remover e, em seguida, clique em Remover Utilizador. Tenha em atenção que, embora esta ação desligue o utilizador do livro, não o impede de editar novamente o livro.

  4. Para eliminar as definições de vista pessoal do utilizador removido, clique em Vista > Vistas Personalizadas e elimine todas as outras vistas de utilizador.

Antes de desativar esta funcionalidade, poderá fazer uma cópia do histórico de alterações. Primeiro, certifique-se de que todos os outros utilizadores concluíram o seu trabalho.

  1. Clique em Rever > Registar Alterações > Realçar Alterações.

    Tenha em atenção que nas versões mais recentes do Excel, o botão Registar Alterações foi ocultado. Eis como o mostrar:

  2. Na lista Quando, selecione Tudo.

  3. Desmarque as caixas de verificação Quem e Onde.

  4. Selecione a caixa de verificação Listar alterações numa nova folha de cálculo e, em seguida, clique em OK.

  5. Agora pode imprimir a folha de cálculo do Histórico ou copiar o histórico e colá-lo noutro livro.

  1. Clique em Rever > Partilhar Livro.

    Tenha em atenção que nas versões mais recentes do Excel, o botão Partilhar Livro foi ocultado. Eis como o mostrar:

  2. No separador Estado, certifique-se de que é o único utilizador na lista Quem tem este livro aberto.

  3. Desmarque a caixa de verificação Permitir alterações por mais de um utilizador… Se esta caixa de verificação não estiver disponível, primeiro tem de desproteger o livro. Faça o seguinte:

    1. Clique em OK para fechar a caixa de diálogo Partilhar Livro.

    2. No separador Rever, no grupo Alterações, clique em Desproteger Livro Partilhado.

    3. Caso lhe seja pedido, introduza a palavra-passe e, em seguida, clique em OK.

    4. No separador Rever, no grupo Alterações, clique em Partilhar Livro.

    5. Na caixa de diálogo Partilhar livro, desmarque a caixa de verificação Permitir alterações por mais de um utilizador…

    6. Quando for avisado acerca dos efeitos sobre os outros utilizadores, clique em Sim.

Ativar a funcionalidade Livro Partilhado

  1. Certifique-se de que pretende utilizar este método antes de continuar. Os Livros Partilhados têm limitações, por isso, recomendamos vivamente a cocriação, que substitui os Livros Partilhados.

  2. Criar um novo livro ou abra um livro existente. Em seguida, coloque-o numa localização de rede. Não coloque o ficheiro no OneDrive ou SharePoint. Se preferir essas localizações para o ficheiro, cocriar o livro em vez disso.

  3. Clique em Rever > Partilhar Livro.

  4. Na caixa de diálogo Partilhar livro, selecione a caixa de verificação Permitir alterações por mais de um utilizador…

  5. No separador Avançado, selecione as opções que pretende utilizar para controlar e atualizar alterações e, em seguida, clique em OK.

  6. Se este for um novo livro, escreva um nome na caixa Guardar como. Em alternativa, se este for um livro existente, clique em OK para guardar o livro.

  7. Se o livro tiver ligações para outros livros ou documentos, verifique as ligações e atualize as ligações quebradas.

  8. Clique em Ficheiro > Guardar.

  9. Quando terminar, será apresentado - Partilhado na parte superior da janela do Excel, ao lado do nome do ficheiro.

Informações adicionais

Tenha em atenção que os Livros Partilhados são um método de partilha mais antigo. Portanto, muitos itens e ações não são suportados quando este método é utilizado. A tabela abaixo apresenta apenas uma lista parcial das funcionalidades não suportadas.

Itens não suportados:

Ações não suportadas:

Criar ou inserir tabelas

Inserir ou eliminar blocos de células

Adicionar ou alterar formatos condicionais

Eliminar folhas de cálculo

Adicionar ou alterar a validação de dados

Unir células ou dividir células unidas

Criar ou alterar gráficos ou relatórios de gráficos dinâmicos

Ordenar ou filtrar por formato

Inserir ou alterar imagens ou outros objetos

Utilizar ferramentas de desenho

Inserir ou alterar hiperligações

Atribuir, alterar ou remover palavras-passe

Criar, alterar ou visualizar cenários

Proteger ou desproteger folhas de cálculo ou o livro

Inserir subtotais automáticos

Agrupar ou destacar dados

Criar tabelas de dados

Escrever, registar, alterar, ver ou atribuir macros

Criar ou alterar relatórios de tabelas dinâmicas

Alterar ou eliminar fórmulas de matriz

Criar ou aplicar segmentações de dados

Adicionar, mudar o nome ou eliminar mapas XML

Criar ou modificar gráficos sparkline

Mapear células para elementos XML

Adicionar ou alterar folhas de caixa de diálogo do Microsoft Excel 4

Utilizar o painel de tarefas Origem XML, a barra de ferramentas XML ou os comandos XML no menu Dados

Importar, atualizar e exportar dados XML

Utilizar um formulário de dados para adicionar novos dados

Antes de remover utilizadores, certifique-se de que os mesmos concluíram o trabalho no livro. Se remover utilizadores ativos, perder-se-á todo o trabalho não guardado realizado por estes.

  1. Clique em Rever > Partilhar Livro.

  2. No separador Estado, na lista Quem tem este livro aberto, verifique os nomes dos utilizadores.

  3. Selecione o nome do utilizador que pretende remover e, em seguida, clique em Remover Utilizador. Tenha em atenção que, embora esta ação desligue o utilizador do livro, não o impede de editar novamente o livro.

  4. Para eliminar as definições de vista pessoal do utilizador removido, clique em Vista > Vistas Personalizadas e elimine todas as outras vistas de utilizador.

Antes de desativar esta funcionalidade, poderá fazer uma cópia do histórico de alterações. Primeiro, certifique-se de que todos os outros utilizadores concluíram o seu trabalho.

  1. Clique em Rever > Registar Alterações > Realçar Alterações.

  2. Na lista Quando, selecione Tudo.

  3. Desmarque as caixas de verificação Quem e Onde.

  4. Selecione a caixa de verificação Listar alterações numa nova folha de cálculo e, em seguida, clique em OK.

  5. Agora pode imprimir a folha de cálculo do Histórico ou copiar o histórico e colá-lo noutro livro.

  1. Clique em Rever > Partilhar Livro.

  2. No separador Estado, certifique-se de que é o único utilizador na lista Quem tem este livro aberto.

  3. Desmarque a caixa de verificação Permitir alterações por mais de um utilizador… Se esta caixa de verificação não estiver disponível, primeiro tem de desproteger o livro. Faça o seguinte:

    1. Clique em OK para fechar a caixa de diálogo Partilhar Livro.

    2. No separador Rever, clique em Proteger livro.

    3. Caso lhe seja pedido, introduza a palavra-passe e, em seguida, clique em OK.

    4. No separador Rever, Partilhar livro.

    5. Na caixa de diálogo Partilhar livro, desmarque a caixa de verificação Permitir alterações por mais de um utilizador…

Antes de desativar esta funcionalidade, poderá fazer uma cópia do histórico de alterações. Primeiro, certifique-se de que todos os outros utilizadores concluíram o seu trabalho.

  1. Clique em Rever > Registar Alterações > Realçar Alterações.

  2. Na lista Quando, selecione Tudo.

  3. Desmarque as caixas de verificação Quem e Onde.

  4. Selecione a caixa de verificação Listar alterações numa nova folha de cálculo e, em seguida, clique em OK.

  5. Agora pode imprimir a folha de cálculo do Histórico ou copiar o histórico e colá-lo noutro livro.

  1. Clique em Rever > Partilhar Livro.

  2. No separador Estado, certifique-se de que é o único utilizador na lista Quem tem este livro aberto.

  3. Desmarque a caixa de verificação Permitir alterações por mais de um utilizador… Se esta caixa de verificação não estiver disponível, primeiro tem de desproteger o livro. Faça o seguinte:

    1. Clique em OK para fechar a caixa de diálogo Partilhar Livro.

    2. No separador Rever, clique em Proteger livro.

    3. Caso lhe seja pedido, introduza a palavra-passe e, em seguida, clique em OK.

    4. No separador Rever, Partilhar livro.

    5. Na caixa de diálogo Partilhar livro, desmarque a caixa de verificação Permitir alterações por mais de um utilizador…

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×