SOMA.SE (função SOMA.SE)

SOMA.SE (função SOMA.SE)

Nota: Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

A função SOMA.SE é utilizada para somar os valores num intervalo que correspondem aos critérios que o utilizador especifica. Por exemplo, suponhamos que, numa coluna que contém números, quer somar apenas os valores superiores a 5. Pode utilizar a seguinte fórmula: =SOMA.SE(B2:B25;">5")

O seu browser não suporta vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Este vídeo faz parte de um curso de formação denominado Adicionar números no Excel.

Sugestões: 

  • Se quiser, pode aplicar os critérios a um intervalo e somar os valores correspondentes noutro intervalo. Por exemplo, a fórmula =SOMA.SE(B2:B5; "João"; C2:C5) soma apenas os valores no intervalo C2:C5, em que as células correspondentes no intervalo B2:B5 são iguais a "João".

  • Para somar células com base em múltiplos critérios, consulte o artigo Função SOMA.SE.S.

Sintaxe

SOMA.SE(intervalo; critérios; [intervalo_soma])

A sintaxe da função SOMA.SE tem os seguintes argumentos:

  • intervalo   Obrigatório. O intervalo de células que pretende avaliar pelos critérios. As células em cada intervalo têm de ser números ou nomes, matrizes ou referências que contenham números. Os valores de texto e em branco são ignorados. O intervalo selecionado pode conter datas no formato padrão do Excel (exemplos abaixo).

  • critério   Obrigatório. Os critérios na forma de um número, expressão, uma referência de célula, texto ou uma função que define as células que serão adicionadas. Por exemplo, os critérios podem ser expressos como 32, ">32", B5, "32", "maçãs" ou hoje ().

    Importante: Qualquer critério de texto ou que inclua símbolos lógicos ou matemáticos tem de ser escrito entre aspas ("). Se os critérios forem numéricos, não é necessário utilizar aspas.

  • Intervalo_soma   Opcional. As células reais a adicionar, se pretender adicionar células que não sejam as especificadas no argumento intervalo . Se o argumento Intervalo_soma for omitido, o Excel adiciona as células especificadas no argumento intervalo (as mesmas células às quais os critérios são aplicados).

  • Pode utilizar os carateres universais - ponto de interrogação (?) e asterisco (*) - como o argumento critérios. Um ponto de interrogação corresponde a qualquer caráter individual e um asterisco corresponde a qualquer sequência de carateres. Se pretender localizar um ponto de interrogação ou asterisco, escreva um til (~) antes do caráter.

Comentários

  • A função SOMA.SE devolve resultados incorretos quando a utiliza para corresponder cadeias com mais de 255 carateres ou com a cadeia #VALOR!.

  • O argumento intervalo_soma não tem de ter o mesmo tamanho e forma que o argumento intervalo. As células reais adicionadas são determinadas utilizando a célula superior esquerda do argumento intervalo_soma como célula inicial e, em seguida, incluem as células que correspondem em tamanho e forma ao argumento intervalo. Por exemplo:

Se o intervalo for

E, intervalo_soma for

Então, as células reais são

A1:A5

B1:B5

B1:B5

A1:A5

B1:B3

B1:B5

A1:B4

C1:D4

C1:D4

A1:B4

C1:C2

C1:D4

No entanto, quando os argumentos intervalo e intervalo_soma na função SOMA.SE não contiverem o mesmo número de células, o recálculo poderá demorar mais tempo do que o esperado.

Exemplos

Exemplo 1

Copie os dados de exemplo na tabela seguinte e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem resultados, selecione-as, prima F2 e, em seguida, prima ENTER. Se pretender, pode ajustar as larguras das colunas para ver todos os dados.

Valor de Propriedade

Comissão

Dados

€ 100.000

€ 7.000

€ 250.000

€ 200.000

€ 14.000

€ 300.000

21.000 €

€ 400.000

€ 28.000

Fórmula

Descrição

Resultado

=SOMA.SE(A2:A5,">160000",B2:B5)

Soma das comissões dos valores de propriedade superiores a € 160.000.

€ 63.000

=SOMA.SE(A2:A5,">160000")

Soma dos valores de propriedade superiores a € 160.000

€ 900.000

=SOMA.SE(A2:A5,300000,B2:B5)

Soma das comissões de valores de propriedade iguais a € 300.000.

€ 21.000

=SOMA.SE(A2:A5,">" & C2,B2:B5)

Soma das comissões dos valores de propriedade maiores que o valor em C2.

€ 49.000

Exemplo 2

Copie os dados de exemplo que se encontram na seguinte tabela e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem resultados, selecione-as, prima F2 e, em seguida, prima ENTER. Caso seja necessário, pode ajustar as larguras das colunas para ver todos os dados.

Categoria

Alimentos

Vendas

Vegetais

Tomates

€ 2.300

Vegetais

Aipo

€ 5.500

Fruta

Laranjas

€ 800

Manteiga

€ 400

Vegetais

Cenouras

€ 4.200

Fruta

Maçãs

€ 1.200

Fórmula

Descrição

Resultado

=SOMA.SE(A2:A7,"Fruta",C2:C7)

Soma das vendas de todos os alimentos na categoria "Fruta".

€ 2.000

=SOMA.SE(A2:A7,"Vegetais",C2:C7)

Soma das vendas de todos os alimentos na categoria "Vegetais".

€ 12.000

=SOMA.SE(B2:B7,"*as",C2:C7)

Soma das vendas de todos os alimentos terminados em "as" (Laranjas, Cenouras).

€ 4.300

=SOMA.SE(A2:A7,"",C2:C7)

Soma das vendas de todos os alimentos sem uma categoria especificada.

€ 400

Início da Página

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no UserVoice do Excel.

Consulte também

A função SOMA.SE.S soma todos os argumentos que correspondem a múltiplos critérios

A função SOMARQUAD soma múltiplos valores após executar uma operação matemática em cada um deles

A função CONTAR.SE conta apenas os valores que correspondem a um único critério

A função CONTAR.SE.S conta apenas os valores que correspondem a múltiplos critérios

Função SE.S (Office 365, Excel 2016 e posterior)

Descrição geral de fórmulas no Excel

Como evitar fórmulas quebradas

Detetar erros em fórmulas

Funções de Matemática e Trigonometria

Funções do Excel (por ordem alfabética)

Funções do Excel (por Categoria)

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×