Publicar um livro num site do SharePoint no Excel para Windows

Pode publicar um livro numa biblioteca do Microsoft SharePoint para que as pessoas consigam ver e editar os dados do livro num browser sem a necessidade de ter o Excel instalado nos respetivos computadores. A publicação assemelha-se a guardar, mas com algumas opções incorporadas que lhe permitem controlar o que as pessoas podem ver quando abrem o livro num browser.

Se adotar a medida de guardar ou publicar um livro num site central do SharePoint na sua organização, estará a certificar-se de que não irão surgir cópias ligeiramente diferentes do mesmo livro ao enviá-lo por mensagem de correio eletrónico para toda a organização.

Se definir algumas opções de publicação, poderá realçar determinadas partes do livro, tais como gráficos ou excluir outras partes para não serem vistas em browsers. Por exemplo, pode mostrar um gráfico, mas não a área subjacente. Em alternativa, pode mostrar algumas folhas de cálculo às pessoas que precisam de as consultar enquanto oculta as restantes.

Este artigo mostra-lhe como pode publicar um livro a partir do Excel para Windows e não aborda a ligação de um livro ou de dados de um livro a uma peça Web Excel Web Access numa página do SharePoint.

Quando publicar um livro no site do SharePoint, este será guardado no SharePoint. Um utilizador com as permissões necessárias do SharePoint poderá ver e trabalhar em todo o livro no browser ou no programa de ambiente de trabalho Excel.

Se o Office na Web estiver implementado no SharePoint, ver e trabalhar com os dados no browser poderá ser muito semelhante a trabalhar no programa de ambiente de trabalho do Excel. Na realidade, ao contrário do programa de ambiente de trabalho do Excel, um livro pode ser editado por múltiplos utilizadores em simultâneo na grelha do browser. Ao visualizar um livro no browser, se o botão Editar no Excel Online estiver visível, saberá que o Office na Web está pronto para ser utilizado.

Editar no Excel Online no menu Editar Livro

Preparar o livro

Antes de publicar o livro, tem a oportunidade de selecionar as folhas de cálculo ou os itens que pretende que estejam visíveis no browser. Tenha em atenção que, embora possa limitar o que é visível neste modo, todo o conteúdo do livro ainda está guardado no servidor do SharePoint.

Se pretender incluir folhas de cálculo completas como um item para além de outros itens (por exemplo, gráficos ou tabelas dinâmicas), defina toda a folha de cálculo como um intervalo com nome. Selecione toda a folha de cálculo e, em seguida, defina um intervalo com nome. Este intervalo com nome irá então aparecer como item disponível na caixa de diálogo Opções de Publicação quando estiver pronto para publicar.

Para permitir aos utilizadores introduzir um valor numa célula para interagir com uma fórmula noutra célula, defina essa célula com um nome definido no Excel antes de a publicar no livro. Só então poderá adicionar o nome definido como parâmetro no separador Parâmetrosna caixa de diálogo Opções da Vista de Browser.

O exemplo seguinte apresenta a célula D2, que tem o nome definido como "Taxa". No browser, um utilizador introduz o valor de 5 625 na caixa Taxa do painel Parâmetros e, em seguida, clica em Aplicar. Esse valor aparece depois na célula D2 e a fórmula em A2 utiliza o valor na D2. O resultado da fórmula é recalculado e mostrado na A2: 1 151,31 €.

Introdução de um parâmetro no painel, que é utilizado na célula D2

Nota: Se criar segmentos de dados para uma tabela no Excel e atribuir um nome a um intervalo de células que contém a tabela e os segmentos de dados, não será possível utilizar os segmentos de dados para filtrar a tabela no browser se publicar o intervalo definido. Caso publique a tabela, a folha de cálculo completa ou o livro, os segmentos de dados irão funcionar no browser como esperado.

Publicar o livro

  1. Clique no separador Ficheiro, clique em Guardar Como e, em seguida, em SharePoint.

  2. Se vir a sua pasta do SharePoint em atual, recenteou anterior, clique na pasta que pretende.

    A caixa de diálogo Guardar Como é apresentada.


    Em alternativa, clique em Procurar, introduza o endereço do site do SharePoint e, em seguida, procure a pasta onde pretende publicar o livro.

    Clique numa pasta do SharePoint ou clique em Procurar
  3. Para selecionar folhas de cálculo ou itens individuais para publicar a partir do livro, clique em Opções da Vista de Browser.

    Na caixa de diálogo Guardar Como, clique em Opções da Vista de Browser

    Verá o separador Mostrar e o separador Parâmetros.

  4. Se apenas pretender publicar todo o livro, clique em Guardar. Em alternativa, efetue o seguinte procedimento:

    • Para mostrar todo o livro no browser, no separador Mostrar, selecione Livro Inteiro na caixa de listagem.

    • Para mostrar determinadas folhas de cálculo no browser, no separador Mostrar, selecione Folhas na caixa de listagem e, em seguida, desmarque as caixas de verificação das folhas que pretende mostrar no browser.

      Por predefinição, estão selecionadas todas as folhas. Para tornar rapidamente todas as folhas visualizáveis depois de desmarcar algumas das caixas de verificação, selecione a caixa de verificação Todas as Folhas.

    • Para mostrar apenas itens específicos no browser (como intervalos com nome, gráficos, tabelas ou tabelas dinâmicas), no separador Mostrar, selecione Itens no Livro na caixa de listagem e, em seguida, selecione as caixas de verificação dos itens que pretende mostrar.

    • No separador Parâmetros, adicione quaisquer nomes definidos que pretenda utilizar para especificar as células que estão editáveis quando os utilizadores visualizarem o livro no browser e, em seguida, clique em OK.

  5. Guarde o livro.

Notas: 

  • Se selecionar itens que têm o mesmo nome (tal como um gráfico e a respetiva tabela de dados subjacente), apenas um desses itens ficará disponível no browser. Para mostrar todos os itens, tem de se certificar de que cada item no livro tem um nome exclusivo.

  • Pode mudar o nome de tabelas no separador estrutura no grupo Propriedades , mudar o nome de tabelas dinâmicas no separador Opções no grupo tabela dinâmica e mudar o nome de gráficos ou gráficos dinâmicos no separador esquema no grupo Propriedades . Mude o nome de outros itens duplicados, como intervalos com nome no separador fórmulas no grupo nomes definidos .

Se o Office na Web estiver implementado no SharePoint, ver e trabalhar com os dados no browser poderá ser muito semelhante a trabalhar no programa de ambiente de trabalho do Excel. Na realidade, ao contrário do programa de ambiente de trabalho do Excel, um livro pode ser editado por múltiplos utilizadores em simultâneo na grelha do browser. Ao visualizar um livro no browser, se o botão Editar no Excel Online estiver visível, saberá que o Office na Web está pronto para ser utilizado.

Editar no Excel Online no menu Editar Livro

Para obter mais informações, consulte o artigo Diferenças entre utilizar um livro no Excel e nos Serviços do Excel.

Preparar o livro

Antes de publicar o livro, tem a oportunidade de selecionar as folhas de cálculo ou os itens que pretende que estejam visíveis no browser. Tenha em atenção que, embora possa limitar o que é visível neste modo, todo o conteúdo do livro ainda está guardado no servidor do SharePoint.

Se pretender incluir folhas de cálculo completas como um item para além de outros itens (por exemplo, gráficos ou tabelas dinâmicas), defina toda a folha de cálculo como um intervalo com nome. Selecione toda a folha de cálculo e, em seguida, defina um intervalo com nome. Este intervalo com nome irá então aparecer como item disponível na caixa de diálogo Opções de Publicação quando estiver pronto para publicar.

Para permitir aos utilizadores introduzir um valor numa célula para interagir com uma fórmula noutra célula, defina essa célula com um nome definido no Excel antes de a publicar no livro. Só então poderá adicionar o nome definido como parâmetro no separador Parâmetrosna caixa de diálogo Opções da Vista de Browser.

O exemplo seguinte apresenta a célula D2, que tem o nome definido como "Taxa". No browser, um utilizador introduz um valor, 5,625, na caixa do painel Parâmetros e clica em Aplicar. Esse valor aparece depois na célula D2 e a fórmula em A2 utiliza o valor na D2. O resultado da fórmula é recalculado e mostrado na A2: 1.151,31 €.

Consulte a Ajuda do Excel para obter informações sobre a definição de intervalos.

Introdução de um parâmetro no painel, que é utilizado na célula D2

Nota: Se criar segmentos de dados para uma tabela no Excel e atribuir um nome a um intervalo de células que contém a tabela e os segmentos de dados, não será possível utilizar os segmentos de dados para filtrar a tabela no browser se publicar o intervalo definido. Caso publique a tabela, a folha de cálculo completa ou o livro, os segmentos de dados irão funcionar no browser como esperado.

Publicar o livro

  1. Clique em Ficheiro > Guardar Como >SharePoint.

  2. Se vir a sua pasta do SharePointem pasta atual ou em pastas recentes, clique na pasta que pretende. Caso contrário, clique em procurar e introduza o endereço Web do site do SharePoint. Em seguida, navegue para a pasta onde pretende publicar o livro. A caixa de diálogo Guardar Como é apresentada.

  3. Para selecionar folhas de cálculo ou itens individuais para publicar a partir do livro, clique em Opções da Vista de Browser. Verá um separador Mostrar e um separador parâmetros . Se apenas pretender publicar todo o livro, clique em Guardar. Em alternativa, efetue o seguinte procedimento:

    • Para mostrar todo o livro no browser, no separador Mostrar, selecione Livro Inteiro na caixa de listagem.

    • Para mostrar determinadas folhas de cálculo no browser, no separador Mostrar, selecione Folhas na caixa de listagem e, em seguida, desmarque as caixas das folhas que pretende mostrar no browser.

      Por predefinição, estão selecionadas todas as folhas. Para tornar rapidamente todas as folhas visualizáveis depois de desmarcar algumas das caixas, selecione a caixa de verificação Todas as Folhas.

    • Para mostrar apenas os itens específicos no browser (como intervalos com nome, gráficos, tabelas ou Tabelas Dinâmicas), no separador Mostrar, selecione Itens no Livro na caixa de listagem e, em seguida, desmarque as caixas dos itens que pretende mostrar.

    • No separador Parâmetros, adicione os eventuais nomes definidos que pretenda utilizar para especificar as células editáveis aquando a visualização do livro no browser. Em seguida, clique em OK para fechar a caixa de diálogo.

  4. Guarde o livro.

Notas: 

  • Se selecionar itens que têm o mesmo nome (tal como um gráfico e a respetiva tabela de dados subjacente), apenas um desses itens ficará disponível no browser. Para mostrar todos os itens, tem de se certificar de que cada item no livro tem um nome exclusivo.

  • Se selecionar itens que têm o mesmo nome (tal como um gráfico e a respetiva tabela de dados subjacente), apenas um desses itens ficará disponível no browser. Para mostrar todos os itens, tem de se certificar de que cada item no livro tem um nome exclusivo.

  • Pode mudar o nome de tabelas no separador estrutura no grupo Propriedades , mudar o nome de tabelas dinâmicas no separador Opções no grupo tabela dinâmica e mudar o nome de gráficos ou gráficos dinâmicos no separador esquema no grupo Propriedades . Mude o nome de outros itens duplicados, como intervalos com nome no separador fórmulas no grupo nomes definidos .

  • Pode mudar o nome de tabelas no separador estrutura no grupo Propriedades , mudar o nome de tabelas dinâmicas no separador Opções no grupo tabela dinâmica e mudar o nome de gráficos ou gráficos dinâmicos no separador esquema no grupo Propriedades . Mude o nome de outros itens duplicados, como intervalos com nome no separador fórmulas no grupo nomes definidos .

Para obter mais informações sobre as peças Web do Excel Web Access, consulte o artigo apresentar um livro numa peça Web Excel Web Access.

Quando publica um livro num servidor do SharePoint, todo o conteúdo do livro é guardado no servidor e pode ser visualizado e utilizado quando abre o livro no programa de ambiente de trabalho do Excel. Se o Office Web Apps for implementado no SharePoint Server, ver e trabalhar com os seus dados no browser pode ser muito semelhante a trabalhar com os seus dados no programa de ambiente de trabalho do Excel. Na verdade, a edição simultânea de um livro é possível na grelha do browser quando o Office Web Apps é implementado. Quando vê um livro no browser, se o botão Editar no browser estiver visível, isto significa que o Office Web Apps está disponível.

Botão Editar no Browser

Para obter mais informações, consulte o artigo Diferenças entre utilizar um livro no Excel e nos Serviços do Excel.

Preparar o livro

Antes de publicar o livro, tem a oportunidade (na caixa de diálogo Opções de publicação ) para selecionar as folhas de cálculo ou os itens que pretende que sejam visíveis no browser quando a edição não está ativada ao clicar no botão Editar no browser . Lembre-se de que, embora possa selecionar o que é visível neste modo, todo o conteúdo do livro ainda é guardado no servidor do SharePoint.

Se pretender incluir folhas de cálculo completas como um item para além de outros itens (por exemplo, gráficos ou tabelas dinâmicas), defina toda a folha de cálculo como um intervalo com nome. Selecione toda a folha de cálculo e, em seguida, defina um intervalo com nome. Este intervalo com nome irá então aparecer como item disponível na caixa de diálogo Opções de Publicação quando estiver pronto para publicar.

Se quiser permitir que os utilizadores forneçam um parâmetro a uma fórmula ao visualizar uma folha de cálculo num browser, defina uma célula como um nome definido. Em seguida, pode adicionar esse nome definido como um parâmetro no separador parâmetros na caixa de diálogo Opções de publicação .

Por exemplo, no gráfico seguinte que mostra uma folha de cálculo no browser, a célula D2 tem a taxa de nome definida. No browser, um utilizador introduziu um valor, 5,625, na caixa do painel parâmetros e, em seguida, clico em aplicar. Esse valor aparece depois na célula D2 e a fórmula em A2 utiliza o valor na D2. O resultado da fórmula é recalculado e mostrado na A2: 1 151,31 €.

Utilizar um parâmetro no browser

Consulte a Ajuda do Excel para obter informações sobre a definição de intervalos.

Publicar o livro

  1. Clique no separador Ficheiro e, em seguida, clique em Guardar e Enviar.

  2. Clique em guardar no SharePoint.
    Nota:    se o comando guardar no SharePoint não estiver disponível, pode continuar a guardar o livro num site do SharePoint com o comando guardar como . A caixa de diálogo Opções de publicação não estará disponível. Também pode carregar diretamente o livro a partir de uma biblioteca do SharePoint. Os utilizadores podem ver e editar os conteúdos do livro no browser ao ir diretamente para o site onde o livro está guardado.

    O comando Guardar Como

  3. Se pretender selecionar folhas de cálculo ou itens individuais para publicar no livro, clique no botão Opções de publicação . Caso contrário, se pretender publicar o livro inteiro, pule diretamente para o passo 4.
    No separador Mostrar , faça o seguinte:

    • Para mostrar o livro completo no browser, selecione todo o livro na caixa de listagem.

    • Para mostrar apenas folhas de cálculo específicas no browser, selecione folhas na caixa de listagem e, em seguida, desmarque as caixas de verificação das folhas que não pretende tornar visíveis.
      Nota    por predefinição, todas as folhas estão selecionadas. Para tornar rapidamente todas as folhas visíveis depois de desmarcar algumas das caixas de verificação, pode selecionar a caixa de verificação todas as folhas .

    • Para mostrar apenas itens específicos no browser (como intervalos com nome, gráficos, tabelas ou tabelas dinâmicas), selecione itens no livro na caixa de listagem e, em seguida, selecione as caixas de verificação dos itens que pretende mostrar.
      Nota: se selecionar itens que tenham o mesmo nome (como um gráfico e a respectiva tabela de dados subjacente), apenas um destes itens estará disponível no browser. Para mostrar todos os itens, tem de certificar-se de que cada item no livro tem um nome exclusivo. Pode mudar o nome de tabelas no separador estrutura no grupo Propriedades , mudar o nome de tabelas dinâmicas no separador Opções no grupo tabela dinâmica e mudar o nome de gráficos ou gráficos dinâmicos no separador esquema no grupo Propriedades . Os itens duplicados, tais como intervalos com nome, podem ser renomeados no separador fórmulas no grupo nomes definidos .
      Seleccionar folhas de cálculo ou itens

    • No separador parâmetros , adicione os nomes definidos que pretende utilizar para especificar as células que são editáveis quando os utilizadores visualizam o livro no browser. Em seguida, clique em OK para fechar a caixa de diálogo.
      Definir parâmetros

  4. Selecione uma localização para publicar o seu livro.
    Podem já existir localizações de servidor guardadas em Localização atual, localizações recentesou localizações a partir das quais pode escolher. Se não existirem essas localizações ou pretender guardar numa nova localização, em localizações, faça duplo clique em procurar uma localização.

  5. Na caixa de diálogo guardar como , introduza o endereço Web do site do SharePoint e, em seguida, navegue para o site ou biblioteca onde pretende guardar o seu livro.

  6. Se ainda não tiver selecionado folhas de cálculo ou itens individuais ou definir parâmetros, clique no botão Opções de publicação .

  7. Na caixa nome de ficheiro , aceite o nome sugerido para o livro ou escreva um novo nome, se pretender.

  8. Para apresentar o conteúdo da pasta de trabalho numa janela do browser imediatamente após a operação de publicação ter sido concluída, certifique-se de que a caixa de verificação abrir com o Excel no browser está selecionada.

  9. Clique em Guardar.

Nota:  Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode indicar-nos se estas informações foram úteis? Eis o artigo em inglês para sua referência.​

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×