Preparar, publicar e actualizar o Web site do Publisher

Importante : Este artigo foi traduzido automaticamente, consulte a exclusão de responsabilidade. Veja este artigo em inglês aqui para ter uma referência.

Depois de planear e criar uma publicação para a Web no Microsoft Office Publisher 2007, pode publicá-lo para a Web, servidor de rede ou uma pasta partilhada no seu computador. Qualquer que seja o destino, o Publisher cria ficheiros HTML filtrados a partir de publicação para a Web. Pode abrir e leia estes ficheiros HTML em qualquer browser, como o Windows Internet Explorer.

Publicação para a Web com barra de navegação, texto e gráficos

Neste artigo

Este artigo abrange os procedimentos para criar e publicar a sua publicação para a Web como ficheiros HTML e para atualizar o seu Web site ao editar publicação para a Web e voltar a publicá-lo.

Preparar o seu Web site

Publicar o seu Web site

Actualizar o Web site

Preparar o seu Web site

O Web site é uma extensão de, seu negócio e a imagem corporativa da empresa. Antes de criar o seu Web site, planeá-lo. Para obter ajuda com fazê-lo, consulte o artigo Planear o Web site.

O que é a melhor ferramenta?

Quando planear o seu site e as informações que serão fornecem, considere qual ferramenta de criação se adequa às suas necessidades. Office Publisher 2007 é uma excelente ferramenta de criação de conteúdos para utilizar quando pretender criar rapidamente, publicar e gerir simples, estáticos Web sites que correspondem a sua marca de negócio e que necessitam de revisões de apenas texto e gráficos. Office Publisher 2007 não está a ferramenta apropriada nos casos seguintes:

  • Se o Web site necessita de interatividade ou conteúdo orientado pela base de dados, para que os visitantes podem responder de um Web site iniciar sessão (blogue) ou itens no carrinho de compras de compra

  • Se o seu Web site necessita de validação de dados, como crédito a verificar, por cartão de números

  • Se pretender alterar mais tarde o código HTML não processado num editor de HTML depois de criar o seu Web site no Office Publisher 2007, que combina código HTML, XML e VML para produzir Web sites

Para alojamento de Web básicas e criação de Web site online, o Microsoft Office Live pode ser a ferramenta de à direita por si. Para obter informações, aceda ao Web site do Microsoft Office Live .

Para interativos Web sites, o Microsoft Expression Web fornece ferramentas para produzir dados rich normas de Web sites baseados. Para obter informações, aceda ao site Microsoft Expression Web .

Criar o seu Web site

Pode criar uma nova publicação Web no Office Publisher 2007. Se pretender a trabalhar num Web site existente para a qual tenha sem publicação para a Web, pode copiar e colar conteúdo de páginas Web publicadas uma nova publicação Web, o qual recria o Web site como uma publicação para a Web, ou pode utilizar uma ferramenta de edição HTML.

  1. No menu Ficheiro, clique em Novo.

  2. Na lista de Tipos de publicação, clique em Web Sites.

  3. Execute um dos seguintes passos:

    • Para criar um Web site personalizado que é baseado nos objectivos do site, certifique-se de que o Assistente de Web de fácil utilização, no painel de tarefas Opções, está selecionada e, em seguida, clique no design pretendido.

    • Para criar um Web site de raiz, em Web Sites, clique em Tamanhos em branco e, em seguida, clique no tamanho que pretende.

  4. Clique em Criar.

  5. Se optar por utilizar o Assistente de Web fácil, selecione as opções que pretende na caixa de diálogo Construtor de Web sites fácil e, em seguida, clique em OK.

  6. Adicionar conteúdo à sua publicação e faça as alterações que pretende.

    Sugestão : Evite colocar objectos em páginas mestras na sua publicação da Web. Objetos que são colocados em páginas mestras Office Publisher 2007 não são apresentadas corretamente quando forem visualizados em alguns browsers.

Verificar a sua publicação da Web

Antes de publicar o seu Web site, consulte para se certificar de que o site irão funcionar como esperado e que tenham abordadas possíveis problemas que podem surgir.

Pode procurar os problemas utilizando o Verificador de Design e pré-visualizar o seu site.

Utilizar o Verificador de Design para localizar e corrigir problemas

O Verificador de Design é uma poderosa ferramenta para encontrar potenciais problemas. Muitas das suas verificações são para problemas de formatação básicos. No entanto, algumas verificações são especificamente para problemas que possam afetar publicações para a Web. Para executar o Verificador de Design, faça o seguinte:

  1. No menu Ferramentas, clique em Verificador de Design.

  2. No painel de tarefas Verificador de Design, selecione as caixas de verificação executar verificações gerais de design e executar verificações de web site.

    Nota : Certifique-se de que a caixa de verificação executar verificações de impressão comercial não está selecionada.

  3. No painel de tarefas Verificador de Design, em Seleccione um item para corrigir, clique na seta junto ao item que pretende corrigir e efectue um dos seguintes procedimentos:

    • Clique em correção automática para corrigir automaticamente o problema com o item.

      A correção automática variam consoante o problema. Na maioria dos casos, correcção automática não está disponível.

    • Clique em Ir para este Item para aceder à página onde está localizado o item do problema selecionado.

      Em seguida, pode corrigir o problema ao efetuar as alterações necessárias.

    • Clique em Explicar para abrir um tópico de Ajuda que explique mais detalhadamente o problema e ofereça sugestões sobre como o corrigir.

    • Clique em nunca execute este verificar novamente para desativar a verificação de.

      Clicar nesta opção afeta todas as instâncias do problema.

Pré-visualização do Web site

  • No menu Ficheiro, clique em Pré-visualizar a página Web.

O Web site irá pré-visualizar no browser predefinido. Verifique a pré-visualização para as seguintes opções:

  • O site abre e todas as páginas são acessíveis.

  • Todas as hiperligações funcionam como esperado.

  • Controlos de navegação funcionam como esperado.

  • Não faltam elementos.

  • Reproduzir sons fundo conforme esperado.

Encontrar uma serviço de alojamento na Web

Antes de poder publicar o seu Web site na Web, tem de subscrever um Web que aloja serviço fornecido por um fornecedor de serviços Internet (ISP). Este serviço irá fornecer-lhe acesso à Internet, o espaço de armazenamento no servidor Web e um Uniform Resource Locator (URL) para que as pessoas podem aceder ao Web site. Antes de publicar o seu Web site, contacte o seu ISP ou administrador de sistema para obter as informações que necessita e o URL do Web site ou o endereço do site FTP onde pode guardar ficheiros.

Várias ISPs estão provavelmente disponíveis na sua área. Certifique-se de que o ISP aos quais subscreve oferece o tipo de suporte que pretende. Se tiver pouca experiência na publicação na Web, poderá querer uma ISP que pode ajudá-lo através de quaisquer potenciais problemas.

Início da Página

Publicar o seu Web site

Depois de verificar e pré-visualizar a publicação de Web e subscrever um serviço de alojamento de Web, está pronto para publicar o seu Web site.

Pode publicar um Web site para uma servidor Web, servidor de rede, um servidor de protocolo de transferência de ficheiros (FTP) ou uma pasta no seu computador.

O site de publicação para uma localização no seu computador pode servir várias finalidades:

  • Pode utilizar os ficheiros publicados para testar o seu Web site antes de disponibilizar os ficheiros na Web.

  • Pode utilizar um utilitário FTP para publicar os ficheiros na Web ao carregá-los a partir da localização do ficheiro no seu computador.

  • Manter uma cópia local dos ficheiros HTML, bem como a publicação para a Web.

O seu ISP pode fornecer com as informações que irão ajudar a decidir o método de publicação que é a melhor por si.

Se publicar na Web ou para o seu computador, Office Publisher 2007 reúne todos os ficheiros relacionados que cria numa única pasta. Os ficheiros que Office Publisher 2007 cria incluem as páginas HTML que compõem o seu site, gráficos GIF e JPEG que utilizar no seu páginas e quaisquer ficheiros para sons incorporados.

Pode configurar o Office Publisher 2007 para organizar estes ficheiros na pasta onde publicar o seu Web site numa de duas formas. Por predefinição, o Office Publisher 2007 cria uma única página de base e uma subpasta que contém todos os ficheiros de suporte que são necessários para o seu Web site. Ou pode organizar a home page com todos os ficheiros de suporte para o Web site numa única pasta.

Como posso controlar onde Office Publisher 2007 organiza o Web site da ficheiros publica-lo?

No menu Ferramentas, clique em Opções, clique no separador Web e, em seguida, efetue um dos seguintes procedimentos:

  • Para separar a home page dos ficheiros de suporte, selecione a caixa de verificação organizar ficheiros de suporte numa pasta.

  • Para agrupar a home page e todos os ficheiros de suporte na mesma pasta, desmarque a caixa de verificação organizar ficheiros de suporte numa pasta.

Quando publicar uma publicação na Web, Office Publisher 2007 cria ficheiros HTML filtrados, propaguem mais rapidamente ficheiros HTML não filtrados para a Web. Uma vez que o HTML filtrado ficheiros que Office Publisher 2007 cria contêm sem etiquetas do Microsoft Office – específico, não é possível abrir os ficheiros HTML no Office Publisher 2007 e editá-los. Tem de efetuar alterações ao seu Web site de publicação para a Web e, em seguida, voltar a publicar o site para a Web.

Publicar um Web site para uma localização na Internet ou numa rede

Antes de seguir este procedimento, contacte o seu ISP ou administrador de sistema para obter as informações que necessita para publicar e o URL do Web site onde pode guardar ficheiros.

  1. No menu ficheiro, clique em Publicar na Web.

  2. Na caixa de diálogo Publicar na Web, na caixa nome de ficheiro, escreva o URL do servidor de rede ou Web onde pretende guardar o seu Web site. Por exemplo, escreva http://www.northwindtraders.com.

  3. Clique em Guardar.

  4. Se lhe for pedido, escreva o seu nome de utilizador e palavra-passe e, em seguida, clique em OK.

    Diretório do que está associado ao seu URL serão apresentados na caixa de diálogo Publicar na Web.

  5. Faça duplo clique na pasta onde pretende guardar o seu Web site.

  6. Na caixa nome de ficheiro, selecione o índice como o nome predefinido para a home page e, em seguida, clique em Guardar.

    Index é a seleção predefinida. Selecionar o índice como o nome da sua home page, é mais fácil para o access e impede os utilizadores de ver uma lista dos ficheiros que compõem o seu Web site.

  7. Quando lhe for pedido, clique em OK.

Publicar um Web site utilizando o FTP

Antes de seguir este procedimento, contacte o seu ISP ou administrador do sistema para obter as informações que necessita para publicar a um site de FTP. Também tem de criar um site FTP em Localizações FTP.

Como?

Antes de poder adicionar um local de FTP à lista de locais FTP, tem de ter acesso à Internet ou intranet.

No Windows Vista

  1. No menu ficheiro, clique em Publicar na Web.

  2. Na caixa de diálogo Publicar na Web, clique em Ferramentas e, em seguida, clique em Ligar unidade de rede.

  3. Na caixa de diálogo unidade de rede de mapa, faça o seguinte:

    • Na lista de unidade, clique numa letra de unidade. Pode escolher qualquer letra disponível.

    • Para se ligar sempre que iniciar sessão no seu computador, selecione a caixa de verificação restabelecer a ligação no início de sessão.

    • Clique em ligar a um Web site que pode utilizar para armazenar os seus documentos e imagens.

  4. No Assistente de localização de rede adicionar, clique em seguinte, clique em Escolher uma localização de rede personalizado e, em seguida, clique em seguinte.

  5. Na caixa de endereço Internet ou à rede, escreva o endereço do local de FTP (por exemplo, tipo ftp://ftp.microsoft.com) e, em seguida, clique em seguinte.

    Nota : Se não conseguir ligar para uma unidade de rede ou pasta, o computador pode ser desativado ou pode não ter as permissões corretas. Se não conseguir ligar, contacte o administrador de rede ou ISP.

  6. Se não pretender iniciar sessão de forma anónima, desmarque a caixa de verificação Iniciar sessão de forma anónima, escreva um nome de utilizador na caixa nome de utilizador e, em seguida, clique em seguinte.

  7. Escreva um nome para esta localização de rede e, em seguida, clique em seguinte.

  8. Clique em Concluir.

No Microsoft Windows XP

  1. No menu ficheiro, clique em Publicar na Web.

  2. Na lista Guardar em, clique na seta e, em seguida, clique em Localizações de FTP.

  3. Faça duplo clique em Adicionar/modificar FTP localizações.

  4. Na caixa nome do local de FTP, escreva o nome do local FTP. Por exemplo, escreva ftp.microsoft.com.

  5. Execute um dos seguintes passos:

    • Se pretender iniciar sessão para um local de FTP que permite que o início de sessão anónimo, em Iniciar sessão como, clique em acesso anónimo.

    • Se pretender iniciar sessão para um local de FTP que tem as permissões de utilizador, em Iniciar sessão como, clique em de utilizador e, em seguida, escreva a palavra-passe na caixa palavra-passe.

  6. Clique em Adicionar.

  7. Clique em OK.

  1. No menu ficheiro, clique em Publicar na Web.

  2. Na lista Guardar em, clique em Localizações de FTP.

  3. Na lista de sites de FTP, faça duplo clique sobre o site que pretende e, em seguida, faça duplo clique na pasta onde pretende publicar o seu Web site.

    Nota : Se o seu ISP requer que utilizar um programa específico para carregar o seu Web site ou se estiver a publicar o seu Web site numa intranet da empresa, poderá ter de guardar uma versão do seu Web site num formato de ficheiro específica HTML e siga um procedimento diferente para publicar o seu Web site. Peça ao seu ISP ou administrador de sistema para obter informações sobre como guardar e publicar o seu Web site.

Publicar um Web site para uma pasta no seu computador

No Windows Vista

  1. No menu ficheiro, clique em Publicar na Web.

  2. Na barra de endereço, clique na unidade ou a pasta onde pretende publicar o seu Web site, tal como a pasta de documentos.

    Se pretender adicionar o seu Web site para uma nova pasta, clique em Nova pasta na barra de ferramentas para criar uma nova pasta, escreva um nome para a nova pasta e, em seguida, prima ENTER.

  3. Na caixa nome de ficheiro, selecione o índice como o nome predefinido para a home page e, em seguida, clique em Guardar.

    Index é a seleção predefinida. Selecionar o índice como o nome da sua home page, é mais fácil para o access e impede os utilizadores de ver uma lista dos ficheiros que compõem o seu Web site.

No Windows XP

  1. No menu ficheiro, clique em Publicar na Web.

  2. Na lista Guardar em, clique na unidade ou a pasta onde pretende publicar o seu Web site, tal como a pasta Os meus documentos.

    Se pretender adicionar o seu Web site para uma nova pasta, botão direito do rato onde pretende adicionar uma nova pasta, selecione Novo, clique em pasta para criar uma nova pasta, escreva um nome para a nova pasta na caixa nome e, em seguida, clique em Abrir.

  3. Na caixa nome de ficheiro, selecione o índice como o nome predefinido para a home page e, em seguida, clique em Guardar.

    Index é a seleção predefinida. Selecionar o índice como o nome da sua home page, é mais fácil para o access e impede os utilizadores de ver uma lista dos ficheiros que compõem o seu Web site.

Início da Página

Actualizar o Web site

Depois de publicar o seu Web site, pode atualizar, conforme necessário para refletir as novas informações. No entanto, não consegue abrir os ficheiros HTML filtrados no Publisher. Tem de Abrir publicação para a Web original, efetue as alterações que pretende e, em seguida, voltar a publicar o site para a Web.

Nota : Não deve tente atualizar os ficheiros HTML filtrados utilizando um editor de texto, como o Microsoft Notepad ou Microsoft WordPad. Apesar de é possível fazer isto, HTML gerado pelo Publisher é muito complexo e provavelmente verificará que é difícil para editá-lo manualmente. Para obter melhores resultados, sempre atualizar o seu Web site do Publisher utilizando a publicação de Web e, em seguida, publicá-lo para a Web.

Publicar apenas o que mudou

No Office Publisher 2007, pode publicar actualizações para um Web site anteriormente publicado rapidamente ao utilizar utilizarão publicar na Web, que publica apenas essas páginas que atualizado. Se planear atualizar o seu Web site com frequência ou se o seu Web site está grandes e complexas, utilizarão publicar na Web, pode acelerar a tarefa de atualizar o seu Web site.

Se efetuar alterações ao seu site diretamente num servidor Web fora Office Publisher 2007, no entanto, ativar o registo utilizarão publicar na Web pode impedi-lo a publicação de atualizações posteriores ao seu Web site utilizando o comando Publicar na Web. Se pretender gerir os seus ficheiros de Web site diretamente no servidor Web (tais como através de um programa em separado FTP ), deve desativar utilizarão publicar na Web.

Nota : Publicar incremento Web está ativada por predefinição no Publisher.

Ativar utilizarão publicar na Web ou desativar

  1. No menu Ferramentas, clique em Opções e, em seguida, clique no separador Web.

  2. Em Guardar, efetue um dos seguintes procedimentos:

    • Para desativar utilizarão publicar na Web, desmarque a caixa de verificação Ativar utilizarão publicar na Web.

    • Para ativar utilizarão publicar na Web, selecione a caixa de verificação Ativar utilizarão publicar na Web.

Publicar as alterações ao seu Web site

Atualizações de publicação a um Web site é ligeiramente diferente a partir de um Web site de publicação pela primeira vez. Depois de a publicar um Web site para uma localização na Web ou uma rede, aparece um atalho para o servidor Web ou servidor de rede nos meus locais na rede.

No Windows Vista

  1. No menu ficheiro, clique em Publicar na Web.

  2. Na caixa de diálogo Publicar na Web, no painel de navegação, clique em computador.

  3. Na lista de ficheiros, faça duplo clique no atalho para a pasta no servidor Web ou servidor de rede onde publicou o seu Web site.

  4. Faça duplo clique na pasta onde pretende guardar o ficheiro.

  5. Na caixa nome de ficheiro, escreva o nome do ficheiro que está a atualizar e, em seguida, clique em Guardar.

No Windows XP

  1. No menu ficheiro, clique em Publicar na Web.

  2. Na caixa de diálogo Publicar na Web, clique nos Meus locais de rede.

  3. Faça duplo clique no atalho para a pasta no servidor Web ou servidor de rede onde publicou o seu Web site.

  4. Faça duplo clique na pasta onde pretende guardar o ficheiro.

  5. Na caixa nome de ficheiro, escreva o nome do ficheiro que está a atualizar e, em seguida, clique em Guardar.

Início da Página

Nota : Exclusão de Responsabilidade da Tradução Automática: Este artigo foi traduzido por um sistema informático sem intervenção humana. A Microsoft fornece estas traduções automáticas para ajudar utilizadores que não falam inglês a desfrutarem de conteúdos acerca dos produtos, serviços e tecnologias da Microsoft. Uma vez que o artigo foi traduzido de forma automática, é possível que contenha erros de vocabulário, sintaxe ou gramática.

As informações foram úteis?

Ótimo! Tem mais feedback?

Como podemos melhorá-lo?

Obrigado pelos seus comentários!

×