Mostrar as notas dos alunos online

Importante : Este artigo foi traduzido automaticamente, consulte a exclusão de responsabilidade. Veja este artigo em inglês aqui para ter uma referência.

Pode mostrar as notas de cada aluno online e manter um registo das notas armazenando-as numa lista em O Meu Site. Apesar de poder ver e alterar todas as notas na lista, o aluno só pode ver as respectivas notas na página de Peças Web. A página de Peças Web mostra apenas as notas, porque esta página utiliza as informações de início de sessão do aluno e a Peça Web Filtro do Utilizador Actual para mostrar apenas informações relacionadas com esse aluno.

Quando trabalha com a lista, pode utilizar a vista de folha de dados para que possa ver as notas de todos os alunos. A vista de folha de dados permite adicionar rapidamente novas notas ou alterar uma já existente na lista.

A vista de folha de dados Introduzir Notas permite actualizar as notas.
O por um instrutor utiliza a vista de folha de dados para adicionar novos ou alterar as notas do aluno existentes rapidamente.

Quando o aluno inicia sessão na rede da escola e visita esta página de Peças Web, vê apenas as respectivas notas.

Vista do aluno da lista de notas com as notas de um aluno.
Os estudantes vê apenas os respetivos as notas do aluno na página de peças Web.

A página de Peças Web mostra apenas as notas do aluno, porque a Peça Web Filtro do Utilizador Actual mostra informações relacionadas apenas com o nome de utilizador da pessoa que está a visualizar a página. A lista nesta página está configurada para que o aluno tenha apenas permissões de visualização relativamente às suas notas — o aluno não pode alterar as respectivas notas nesta página.

Para criar esta funcionalidade, efectuará o seguinte:

  1. Criar um novo ou utilizar uma folha de cálculo do Excel existente — criará uma folha de cálculo no livro do Excel que irá conter informações e as notas do aluno. Se já tiver uma folha de cálculo existente com as informações de estudantes, pode ir para o passo seguinte. Se o seu classificações por letras são armazenadas numa lista que já se encontra no Meu Site, pode ignorar o próximo passo e ir para o terceiro passo, criar uma vista de folha de dados.

  2. Criar a lista — irá importar as informações na folha de cálculo para o site como uma nova lista. Depois de criar a nova lista, pode arquivar ou eliminar o livro uma vez que já não necessita que o livro. Irá funcionar nesta lista para adicionar novos ou alterar as notas do aluno existentes.

  3. Criar uma vista de folha de dados — irá criar uma vista da lista para que possa facilmente adicionar novo ou actualizar notas existentes.

  4. Criar uma vista do aluno — irá criar uma vista limitada para estudantes, porque a sua lista pode conter informações adicionais que não pretende mostrar na página de peças Web.

  5. Criar uma página de peças Web — irá criar página de peças Web onde um aluno pode ver as suas notas do aluno. Esta página irá mostrar apenas as notas do aluno quem está a ver esta página.

  6. Adicionar as peças Web — irá adicionar a peça Web lista e uma peça Web de filtro de utilizador actual para a página de peça Web que criou no passo anterior.

  7. Configurar a peça Web — irá configurar a peça Web de lista para utilizar a vista do aluno.

  8. Ligar as peças Web — irá ligar as peças Web em conjunto para mostrar apenas as notas do aluno quem está a ver esta página.

Passo 1: Criar uma nova folha de cálculo do Excel ou utilizar uma já existente

A folha de cálculo deverá conter as seguintes colunas:

  • Nome de utilizador — nome utilizado pelo aluno para iniciar sessão na rede da escola. A Peça Web Filtro do Utilizador Actual utiliza estas informações para mostrar apenas as notas desse aluno.

  • Uma coluna para cada trabalho de casa e nota de teste — trabalhos e notas de testes de cada aluno.

A folha de cálculo pode assemelhar-se à folha de cálculo seguinte:

A folha de cálculo com as informações e as notas do aluno utilizadas neste artigo.
Folha de cálculo com as informações e as notas do aluno. Folha de cálculo tem colunas adicionais para o aluno do primeiro e último nome.

Depois de criar a folha de cálculo, guarde-a numa localização disponível para o site, como a unidade local.

Passo 2: Criar a lista

  1. Clique em Ver Todo o Conteúdo dos Sites e, em seguida, em Criar na página Todo o Conteúdo do Site.

    Sugestão : Na maioria dos casos, pode utilizar o menu Ações do Site Imagem de botão para concluir este passo.

  1. Em Listas Personalizadas na página Criar, clique em Importar Folha de Cálculo.

  2. Na caixa nome, na página Novo, escreva English4-2008. O nome aparece na barra de título e o URL da nova lista.

  3. Na caixa Descrição, escreva as notas do aluno para a classe de inglês 4-2008. A descrição é apresentada sob o título na nova lista.

  4. Clique em Procurar. Na página de propriedades Escolher ficheiro, navegue até à localização da folha de cálculo, clique na folha de cálculo e, em seguida, clique em Abrir.

  5. Na página Novo, clique em Importar.

  6. Na lista Tipo de Intervalo na página de propriedades Importar para a lista do Windows SharePoint Services, clique em Intervalo de Células.

    caixa de diálogo importar com o intervalo de células seleccionado na lista intervalo de células.

  7. Clique dentro da caixa Seleccionar Intervalo e, no Excel, seleccione as células com as informações que pretende importar para esta lista.

  8. Clique em Importar.

Nota : Depois de criar a nova lista com as informações na folha de cálculo, é possível arquivar ou eliminar o livro à medida que introduzir ou actualizar as notas directamente nesta lista. A folha de cálculo não está ligada à lista.

Passo 3: Criar uma vista de folha de dados

Esta é a vista que o professor irá utilizar para adicionar novas notas e actualizar as já existentes.

  1. No de menu vista menu ver , clique em Criar vista.

  2. Em Escolha um formato de vista na página Criar Vista: Inglês4-2008, clique em Vista de Folha de Dados.

  3. Na caixa Nome da vista, escreva Introduza classificações por letras. Este nome aparece no menu Ver a lista nova.

  4. Clique em OK.

Passo 4: Criar uma vista de aluno

Esta é a vista que os alunos utilizarão para ver as respectivas notas pessoais.

  1. No de menu vista menu ver , clique em Criar vista.

  2. Em Escolha um formato de vista na página Criar Vista: Inglês4-2008, clique em Vista Padrão.

  3. Na caixa Nome da vista, escreva as notas do aluno. Este nome aparece na lista Vista seleccionada no painel de ferramentas da peça Web English4-2008.

  4. Em Ver Audiência na secção Audiência, clique em Criar uma Vista Pública.

  5. Na secção Colunas, desmarque todas as caixas de verificação das colunas que pretende ocultar dos alunos. Mantenha a coluna Nome de utilizador seleccionada, porque a Peça Web Filtro do Utilizador Actual utiliza esta coluna para mostrar apenas as notas de um aluno.

  6. Clique no número adequado na lista Posição da Esquerda para dispor as colunas.

  7. Clique em OK.

Passo 5: Criar uma página de Peças Web

Esta é a página de Peças Web onde os alunos podem ver as respectivas notas.

  1. Clique em Ver Todo o Conteúdo dos Sites e, em seguida, em Criar na página Todo o Conteúdo do Site.

    Sugestão : Na maioria dos casos, pode utilizar o menu Ações do Site Imagem de botão para concluir este passo.

  1. Em Páginas Web, na página Criar, clique em Página de Peças Web.

  2. Na caixa Nome da vista, escreva os estudantes. O nome aparece na barra de título e o URL da nova página.

  3. Em Escolha um Modelo de Esquema na secção Esquema, clique em Página Inteira, Vertical.

  4. Na lista Biblioteca de Documentos na secção Guardar Localização, clique em Documentos Partilhados.

  5. Clique em Criar.

Anote o URL desta página. Irá dar este URL aos alunos quando esta página estiver concluída.

Passo 6: Adicionar as Peças Web

  1. Na página de Peças Web, clique em Adicionar Peça Web.

  2. Na secção Lista e Bibliotecas na página Adicionar Peças Web -- Diálogo de Página Web, seleccione a caixa de verificação Inglês4-2008.

  3. Na secção Filtros, seleccione a caixa de verificação Filtro do Utilizador Actual.

  4. Clique em Adicionar.

Passo 7: Configurar as Peças Web

  1. Na peça Web do English4 2008, clique de botão Editar Menu Peça Web e, em seguida, clique em Modificar peça Web partilhada.

    O painel de ferramentas é aberto para que possa configurar as propriedades para mostrar a vista correcta e impedir os alunos de alterarem as notas. Esta é uma vista só de leitura que mostra apenas as informações do utilizador que o SharePoint determina que está a visualizar a página.

    painel de ferramentas da peça web onde pode configurar as propriedades da peça web.

  2. Nas lista Vista Seleccionada, clique em Notas.

    Painel de ferramentas da Peça Web com a opção Todos os Itens seleccionada na lista Vista Seleccionada.

  3. Na caixa de mensagem sobre os resultados de mudar a vista, clique em OK.

  4. Na lista Tipo de Barra de Ferramentas, clique em Sem Barra de Ferramentas. Este item na lista oculta a barra de ferramentas na Peça Web Inglês4-2008 para impedir que um aluno altere as respectivas notas.

    Painel de ferramentas da Peça Web com a opção Sem Barra de Ferramentas seleccionada na lista Tipo de Barra de Ferramentas.

  5. Clique em OK.

  6. Na peça Web de filtro da utilizador atual, clique de botão Editar Menu Peça Web e, em seguida, clique em Modificar peça Web partilhada.

    O painel de ferramentas é aberto para que possa configurar as propriedades para mostrar informações relacionadas apenas com o nome de utilizador da pessoa que está a visualizar a página.

    Painel de ferramentas da Peça Web Filtro do Utilizador Actual.

  7. Em Seleccionar valor a fornecer, clique em Nome de utilizador actual.

    clique na opção do nome de utilizador actual no painel de ferramentas da peça web filtro do utilizador actual.

  8. No painel de ferramentas, clique em OK.

Passo 8: Ligar as Peças Web

  1. Sobre a peça Web de filtro da utilizador atual, clique de botão Editar Menu Peça Web , aponte para ligações, aponte para Enviar valores de filtro para e, em seguida, clique em English4-2008.

  2. Na lista Nome do Campo do Consumidor, clique em Nome de utilizador e, em seguida, clique em Concluir.

  3. Clique em Sair do Modo de Edição.

Quando o aluno iniciar sessão na rede da escola e aceder à página do aluno, a Peça Web Filtro do Utilizador Actual mostra apenas as notas desse utilizador. Desactivou a barra de ferramentas da lista nesta página para impedir que os alunos alterem as respectivas notas.

Para adicionar novos ou actualizar notas existentes, visite a lista. No de menu vista menu ver , clique em Introduzir classificações por letras para alterar para a vista de folha de dados para que possa rapidamente adicionar novo ou actualizar notas existentes.

Início da página

Nota : Exclusão de Responsabilidade da Tradução Automática: Este artigo foi traduzido por um sistema informático sem intervenção humana. A Microsoft fornece estas traduções automáticas para ajudar utilizadores que não falam inglês a desfrutarem de conteúdos acerca dos produtos, serviços e tecnologias da Microsoft. Uma vez que o artigo foi traduzido de forma automática, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Aumente os seus conhecimentos
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×