Importar dados do Excel, SQL Server, sites SharePoint e outras origens externas

Importante : Este artigo foi traduzido automaticamente, consulte a exclusão de responsabilidade. Veja este artigo em inglês aqui para ter uma referência.

Pode importar e apresentar dados diretamente no seu formas, utilizando Microsoft Office Visio Professional 2007 rapidamente. O primeiro passo é ligar à origem de dados e importar dados para o seu desenho. O segundo passo é ligar os dados importados a formas.

Para informação como efectuar a adição de dados para as suas formas sem importar os dados, consulte Adicionar dados a dados.

Neste artigo

Passo 1: Importe os seus dados

Passo 2: Ligação de linhas de dados às formas no desenho

Passo 1: Importe os seus dados

Neste primeiro passo tem de utilizar o Assistente de Selecção de Dados para importar os dados para a janela Dados Externos.

Os dados que aparece na janela Dados externos são um instantâneo dos seus dados de origem no momento da importação. Pode atualizar os dados no seu desenho para corresponder às alterações nos seus dados de origem. No entanto, não é possível atualizar a sua origem de dados ao alterar os dados no seu desenho. Consulte o artigo Atualizar dados importados.

  1. No menu Dados, clique em Ligar Dados às Formas.

  2. Na primeira página do Assistente do Selector de Dados, escolha qual dos seguintes tipos de origens de dados pretende utilizar:

    • Livro do Microsoft Office Excel

    • Base de dados do Microsoft Office Access

    • Lista do Microsoft Windows SharePoint Services

    • Base de dados do Microsoft SQL Server

    • Outra origem de dados OLEDB ou ODBC

    • Ligação previamente criada

  3. Conclua os restantes passos do assistente.

    Nota : Se escolher uma outra opção que não um livro do Excel, base de dados do Access ou lista do SharePoint na primeira página do assistente, é possível que seja temporariamente redireccionado para o Assistente de Ligação de Dados enquanto segue os passos do Assistente do Selector de Dados.

    Encontra-se disponível ajuda específica para a maior parte das páginas do assistente. Para aceder à Ajuda, prima F1 ou clique no botão Ajuda.

Depois de premir Concluir na última página do Assistente de Ligação de Dados, a janela Dados Externos aparece com os dados importados apresentados numa grelha.

Início da Página

Passo 2: Ligação de linhas de dados às formas no desenho

Existem três formas de ligar linhas de dados às formas no desenho: é possível ligar uma linha de cada vez a formas existentes, é possível ligar as linhas às formas automaticamente ou pode criar formas a partir dos dados.

Ligar uma linha de cada vez às formas existentes

Esta é a melhor abordagem para os desenhos existentes com relativamente poucas formas.

  • Arraste uma linha da janela Dados Externos para uma forma no desenho.

    Os dados aparecem na forma e é apresentado um ícone de ligação à esquerda da linha na janela Dados Externos.

    Arrastar linha para forma

    Notas : 

    • É possível ligar uma única linha a múltiplas formas, mas não é possível ligar múltiplas linhas a uma única forma.

    • Para alterar ou melhorar a aspecto das formas e dados, consulte Melhore os dados com gráficos de dados.

    • Para apresentar a janela Dados Externos no menu Ver clique em Janela Dados Externos.

Ligar automaticamente linhas a formas existentes

Esta abordagem é melhor para os desenhos existentes com um grande número de formas. Isto só funciona se as formas tiverem dados já no-los de que pode fazer corresponder aos dados na origem de dados.

  1. No menu Dados, clique em Ligar Automaticamente.

  2. Siga os passos no Assistente de Ligação Automática.

    Os seus dados serão apresentados na sua formas. Para alterar ou melhorar o aspecto das formas e dos dados, consulte o artigo enriquecer os dados com gráficos de dados.

Obter ajuda específica está disponível para a maioria das páginas do assistente. Para aceder à ajuda, prima a tecla F1 ou clique no ícone de ajuda.

Criar formas a partir dos dados

Esta abordagem é mais adequada se os desenhos não contêm formas e não é necessário utilizar formas específicas.

  1. Clique na forma na janela Formas.

  2. Arraste uma linha ou conjunto de linhas da janela Dados Externos para um espaço vazio no desenho.

    Uma instância da forma que clicar aparece em cada linha que arraste para o desenho.

Início da Página

Nota : Exclusão de Responsabilidade da Tradução Automática: Este artigo foi traduzido por um sistema informático sem intervenção humana. A Microsoft fornece estas traduções automáticas para ajudar utilizadores que não falam inglês a desfrutarem de conteúdos acerca dos produtos, serviços e tecnologias da Microsoft. Uma vez que o artigo foi traduzido de forma automática, é possível que contenha erros de vocabulário, sintaxe ou gramática.

As informações foram úteis?

Ótimo! Tem mais feedback?

Como podemos melhorá-lo?

Obrigado pelos seus comentários!

×