Função CONTAR.SE

Este artigo descreve a sintaxe da fórmula e a utilização da funçãoCONTAR.SE no Microsoft Office Excel.

Descrição

A função CONTAR.SE conta o número de células de um intervalo que correspondem a um critério especificado. Por exemplo, pode contar todas as células iniciadas por uma determinada letra ou todas as células que contêm um número maior ou menor que um número especificado. Por exemplo, suponha que tem uma folha de cálculo que contém uma lista de tarefas na coluna A e o nome próprio da pessoa atribuída a cada tarefa na coluna B. Poderá utilizar a função CONTAR.SE para contar o número de vezes que o nome de uma pessoa aparece na coluna B e, deste modo, determinar quantas tarefas estão atribuídas a essa pessoa. Por exemplo:

=CONTAR.SE(B2:B25;"Leonor")

Nota   Para contar células com base em vários critérios, consulte Função CONTAR.SE.S.

Sintaxe

CONTAR.SE(intervalo; critérios)

A sintaxe da função CONTAR.SE tem os seguintes argumento:

  • intervalo    Necessário. Uma ou mais células que pretende contar, incluindo números ou nomes, matrizes ou referências que contenham números. Os valores de texto e em branco são ignorados.

  • critérios    Necessário. Um critério na forma de um número, expressão, referência da célula ou texto) que define quais as células que serão contadas. Por exemplo, critérios podem ser expressos como 32, "32", ">;32", "maçãs" ou B4.

    Nota   

    • Pode utilizar os caracteres universais — o ponto de interrogação (?) e o asterisco (*) — nos critérios. Um ponto de interrogação corresponde a qualquer carácter individual e um asterisco corresponde a qualquer sequência de caracteres. Se pretender localizar mesmo um ponto de interrogação ou asterisco, escreva um til (~) antes do carácter.

    • Os critérios não são sensíveis a maiúsculas e minúsculas; por exemplo, a cadeia "maçãs" e a cadeia "MAÇÃS" corresponderão às mesmas células.

Exemplo 1: Fórmulas CONTAR.SE comuns

É mais fácil compreender o exemplo se o copiar para uma folha de cálculo em branco.

Como copiar um exemplo?

  1. Selecione o exemplo neste artigo. Se estiver a copiar o exemplo do Excel Online, copie e cole uma célula de cada vez.
    Important: Não selecione os cabeçalhos de linha ou coluna.

    Selecionar um exemplo na Ajuda

    Selecionar um exemplo na Ajuda

  2. Prima CTRL+C.

  3. Crie um livro ou folha de cálculo em branco.

  4. Na folha de cálculo, selecione a célula A1 e prima CTRL+V. Se estiver a trabalhar no Excel Online, repita o passo de copiar e colar para cada célula no exemplo.
    Important: Para que o exemplo funcione corretamente, terá de colá-lo na célula A1 da folha de cálculo.

  5. Para alternar entre visualizar os resultados e visualizar as fórmulas que devolvem os resultados, prima CTRL+` (acento grave), ou no separador Fórmulas, no grupo Auditoria de fórmulas, clique no botão Mostrar Fórmulas.

Depois de copiar o exemplo para uma folha de cálculo em branco, pode adaptá-lo de modo a que este se adeque às suas necessidades.

1

2

3

4

5

6


7


8


9



10


11




12

A

B

C

Dados

Dados

maçãs

32

laranjas

54

pêssegos

75

maçãs

86

Fórmula

Descrição

Resultado

=CONTAR.SE(A2:A5;"maçãs")

Número de células com maçãs nas células A2 a A5.

2

=CONTAR.SE(A2:A5;A4)

Número de células com pêssegos nas células A2 a A5.

1

=CONTAR.SE(A2:A5;A3)+CONTAR.SE(A2:A5;A2)

Número de células com laranjas e maçãs nas células A2 a A5.

3

=CONTAR.SE(B2:B5;">55")

Número de células com um valor superior a 55 nas células B2 a B5.

2

=CONTAR.SE(B2:B5;"<>"&B4)

Número de células com um valor diferente de 75 nas células B2 a B5.

3

=CONTAR.SE(B2:B5;">=32")-CONTAR.SE(B2:B5;">85")

Número de células com um valor maior que ou igual a 32 e menor que ou igual a 85 nas células B2 a B5.

3

Exemplo 2: Fórmulas CONTAR.SE utilizando caracteres universais e tratamento de valores em branco

É mais fácil compreender o exemplo se o copiar para uma folha de cálculo em branco.

Como copiar um exemplo?

  1. Selecione o exemplo neste artigo. Se estiver a copiar o exemplo do Excel Online, copie e cole uma célula de cada vez.
    Important: Não selecione os cabeçalhos de linha ou coluna.

    Selecionar um exemplo na Ajuda

    Selecionar um exemplo na Ajuda

  2. Prima CTRL+C.

  3. Crie um livro ou folha de cálculo em branco.

  4. Na folha de cálculo, selecione a célula A1 e prima CTRL+V. Se estiver a trabalhar no Excel Online, repita o passo de copiar e colar para cada célula no exemplo.
    Important: Para que o exemplo funcione corretamente, terá de colá-lo na célula A1 da folha de cálculo.

  5. Para alternar entre visualizar os resultados e visualizar as fórmulas que devolvem os resultados, prima CTRL+` (acento grave), ou no separador Fórmulas, no grupo Auditoria de fórmulas, clique no botão Mostrar Fórmulas.

Depois de copiar o exemplo para uma folha de cálculo em branco, pode adaptá-lo de modo a que este se adeque às suas necessidades.

1

2

3

4

5

6

7

8




9






10




11



12





13





14

A

B

C

Dados

Dados

maçãs

Sim

laranjas

Não

pêssegos

Não

maçãs

sim

Fórmula

Descrição

Resultado

=CONTAR.SE(A2:A7;"*es")

Número de células que terminam com as letras "ãs" nas células A2 a A7.

2

=CONTAR.SE(A2:A7;"???ãs")

Número de células que terminam com as letras "ãs" e com 5 letras exactamente nas células A2 a A7.

2

=CONTAR.SE(A2:A7;"*")

Número de células que contêm qualquer texto nas células A2 a A7.

4

=CONTAR.SE(A2:A7;"<>"&"*")

Número de células que não contêm texto nas células A2 a A7.

2

=CONTAR.SE(B2:B7;"Não") / LINS(B2:B7)

O número médio de votos "Não" (incluindo células em branco) nas células B2 a B7.

0,333333333

=CONTAR.SE(B2:B7;"Sim") / (LINS(B2:B7) -CONTAR.SE(B2:B7; "<>"&"*"))

O número médio de votos "Sim" (excluindo células em branco) nas células B2 a B7.

0,5

Nota    Para visualizar o número como uma percentagem, seleccione a célula e, em seguida, no separador Folha, no grupo Número, clique em Estilo de Percentagem Imagem do botão.

Aplica-se a: Excel 2007



As informações foram úteis?

Sim Não

Como podemos melhorá-lo?

255 carateres restantes

Para proteger a sua privacidade, não inclua informações de contacto nos seus comentários. Reveja o nosso política de privacidade.

Obrigado pelos seus comentários!

Recursos de suporte

Alterar idioma