Contar o número de ocorrências de um valor

Digamos que deseja saber quantas vezes um texto ou valor numérico particular ocorre. Por exemplo:

  • se um intervalo contiver os valores numéricos 5, 6, 7 e 6, o número 6 ocorrerá duas vezes.

  • Se uma coluna contiver "Bruno", "Daniel", "Daniel" e "Daniel", "Daniel" ocorrerá três vezes.

Existem diversas formas de contar com que frequência um valor ocorre.

O que pretende efectuar?

Contar com que frequência ocorre um único valor utilizando uma função

Detalhes da função

Contar com que frequência ocorrem múltiplos valores numéricos utilizando funções

Detalhes da função

Contar com que frequência ocorrem múltiplos valores numéricos ou cadeias de texto utilizando funções

Detalhes da função

Contar com que frequência ocorrem múltiplos valores utilizando um relatório de tabela dinâmica

Contar com que frequência ocorre um único valor utilizando uma função

Utilize a função CONTAR.SE para executar esta tarefa.

Exemplo

Será mais fácil compreender o exemplo se o copiar para uma folha de cálculo em branco.

Como copiar um exemplo

  1. Crie um livro ou folha de cálculo em branco.

  2. Seleccione o exemplo no tópico de Ajuda.

    Nota   Não seleccione os cabeçalhos de linha ou coluna.

    Selecionar um exemplo na Ajuda

    Seleccionar um exemplo na Ajuda

  3. Prima CTRL+C.

  4. Na folha de cálculo, seleccione a célula A1 e prima CTRL+V.

  5. Para alternar entre a visualização dos resultados e das fórmulas que devolvem os resultados, prima CTRL+` (acento grave) ou, no separador Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.

1

2

3

4

5

6

7

A

B

Vendedor

Factura

Bruno

15.000

Bruno

9.000

Sandra

8.000

Sandra

20.000

Bruno

5.000

Daniel

22.500

Fórmula

Descrição (Resultado)

=CONTAR.SE(A2:A7;"Bruno")

Número de entradas de Bruno (3)

=CONTAR.SE(A2:A7,A4)

Número de entradas de Sandra (2)

=CONTAR.SE(B2:B7,"< 20000")

Número de valores de factura inferiores a 20.000 (4)

=CONTAR.SE(B2:B7,">="&B5)

Número de valores de factura maiores ou iguais a 20.000 (2)

Detalhes da função

CONTAR.SE

Início da Página

Contar com que frequência ocorrem múltiplos valores numéricos utilizando funções

Digamos que precisa de determinar quantos vendedores venderam um item particular numa determinada região, ou que deseja saber quantas vendas acima de determinado valor foram efectuadas por determinado vendedor. Poderá utilizar as funções SE e CONTAR.

Exemplo

Será mais fácil compreender o exemplo se o copiar para uma folha de cálculo em branco.

Como copiar um exemplo

  1. Crie um livro ou folha de cálculo em branco.

  2. Seleccione o exemplo no tópico de Ajuda.

    Nota   Não seleccione os cabeçalhos de linha ou coluna.

    Selecionar um exemplo na Ajuda

    Seleccionar um exemplo na Ajuda

  3. Prima CTRL+C.

  4. Na folha de cálculo, seleccione a célula A1 e prima CTRL+V.

  5. Para alternar entre a visualização dos resultados e das fórmulas que devolvem os resultados, prima CTRL+` (acento grave) ou, no separador Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.

1

2

3

4

5

6

7

8

9

10

11

A

B

C

D

Região

Vendedor

Tipo

Vendas

Sul

Bruno

Bebidas

3571

Oeste

David

Lacticínios

3338

Este

Sandra

Bebidas

5122

Norte

Sandra

Lacticínios

6239

Sul

Daniel

Produtos agrícolas

8677

Sul

David

Carne

450

Sul

David

Carne

7673

Este

Sandra

Produtos agrícolas

664

Norte

David

Produtos agrícolas

1500

Sul

Daniel

Carne

6596

Fórmula

Descrição (resultado)

=CONTAR(SE((A2:A11="Sul")*(C2:C11="Carne"),D2:D11))

Número de vendedores que venderam carne na região Sul (3)

=CONTAR(SE((B2:B11="Sandra")*(D2:D11>=1000),D2:D11))

Número de vendas superiores a 1000 efectuadas por Sandra (2)

Nota   

  • As fórmulas do exemplo devem ser introduzidas como fórmula de matriz. Depois de copiar o exemplo para uma folha de cálculo em branco, seleccione a célula da fórmula. Prima F2 e, em seguida, prima CTRL+SHIFT+ENTER. Se a fórmula não for introduzida como uma fórmula de matriz, é devolvido o erro #VALOR!.

  • Para que estas fórmulas funcionem, o segundo argumento da função SE terá de ser um número.

Detalhes da função

CONTAR

SE

Início da Página

Contar com que frequência ocorrem múltiplos valores numéricos ou cadeias de texto utilizando funções

Utilize as funções SE e SOMA para executar esta tarefa:

  • Atribua o valor de 1 a cada condição verdadeira utilizando a função SE.

  • Determine o total, utilizando a função SOMA.

Exemplo

Será mais fácil compreender o exemplo se o copiar para uma folha de cálculo em branco.

Como copiar um exemplo

  1. Crie um livro ou folha de cálculo em branco.

  2. Seleccione o exemplo no tópico de Ajuda.

    Nota   Não seleccione os cabeçalhos de linha ou coluna.

    Selecionar um exemplo na Ajuda

    Seleccionar um exemplo na Ajuda

  3. Prima CTRL+C.

  4. Na folha de cálculo, seleccione a célula A1 e prima CTRL+V.

  5. Para alternar entre a visualização dos resultados e das fórmulas que devolvem os resultados, prima CTRL+` (acento grave) ou, no separador Fórmulas, no grupo Auditoria de Fórmulas, clique no botão Mostrar Fórmulas.

1

2

3

4

5

6

7

A

B

Vendedor

Factura

Bruno

15.000

Bruno

9.000

Sandra

8.000

Sandra

20.000

Bruno

5.000

Daniel

22.500

Fórmula

Descrição (Resultado)

=SOMA(SE((A2:A7="Bruno")+(A2:A7="Daniel"),1,0))

Número de facturas de Bruno ou Daniel (4)

=SOMA(SE((B2:B7<9000)+(B2:B7>19000),1,0))

Número de facturas com valores menores que 9.000 ou maiores que 19.000 (4)

=SOMA(SE(A2:A7="Bruno",SE(B2:B7<9000,1,0)))

Número de facturas de Bruno com um valor inferior a 9.000. (1)

Nota   As fórmulas do exemplo devem ser introduzidas como fórmula de matriz. Seleccione cada célula que contenha uma fórmula, prima F2 e, em seguida, prima CTRL+SHIFT+ENTER.

Detalhes da função

SE

SOMA

Início da Página

Contar com que frequência ocorrem múltiplos valores utilizando um relatório de tabela dinâmica

Pode utilizar um relatório de tabela dinâmica para mostrar os totais e para contar as ocorrências de valores únicos.

  1. Seleccione a coluna que contém os dados. Certifique-se de que a coluna tem um cabeçalho de coluna.

  2. No separador Inserir, no grupo Tabelas, clique em Tabela Dinâmica.

  3. É mostrada a caixa de diálogo Criar Tabela Dinâmica.

  4. Clique em Seleccionar uma tabela ou intervalo.

  5. Coloque o relatório de tabela dinâmica numa nova folha de cálculo começando na célula A1, clicando em Nova Folha de Cálculo.

  6. Clique em OK.

    É adicionado um relatório de Tabela Dinâmica vazio à localização que especificou com a lista de campos da Tabela Dinâmica mostrada.

  7. Na secção de campos no início da lista de campos da Tabela Dinâmica, clique e mantenha premido o nome do campo e, em seguida, arraste o campo para a caixa Rótulos de Linha na secção de esquema no final da lista de campos da Tabela Dinâmica.

  8. Na secção de campos no início da lista de campos da Tabela Dinâmica, clique e mantenha premido o mesmo nome de campo e, em seguida, volte a arrastar o campo para a caixa Valores na secção de esquema no final da Lista de Campos da Tabela Dinâmica.

Nota   Se os dados contiverem números, o relatório de Tabela Dinâmica totaliza as entradas em vez de as contar. Para mudar da função sumário de Soma para a função de resumo Contar, seleccione uma célula dessa coluna e, em seguida, no separador Opções no grupo Campo Activo, clique em Definições do Campo, clique no separador Resumir utilizando, clique em Contagem e, em seguida, clique em OK.

Início da Página

Aplica-se a: Excel 2007



As informações foram úteis?

Sim Não

Como podemos melhorá-lo?

255 carateres restantes

Para proteger a sua privacidade, não inclua informações de contacto nos seus comentários. Reveja o nosso política de privacidade.

Obrigado pelos seus comentários!

Recursos de suporte

Alterar idioma