CONTAR.SE (função CONTAR.SE)

Utilize a função CONTAR.SE, uma das funções estatísticas, para contar o número de células que correspondem a um critério. Por exemplo, para contar o número de vezes que uma determinada cidade é apresentada numa lista de clientes.

Sintaxe

CONTAR.SE(intervalo; critérios)

Por exemplo:

  • =CONTAR.SE(A2:A5,"maçãs")

  • =CONTAR.SE(A2:A5,A4)

Nome do argumento

Descrição

intervalo    (obrigatório)

O grupo de células que pretende contar. O intervalo pode conter números, matrizes ou referências que contêm números. Os valores em branco e de texto são ignorados.

Saiba como selecionar intervalos numa folha de cálculo.

critérios    (obrigatório)

Um número, expressão, referência de célula ou cadeia de texto que determina que células vão ser contadas.

Por exemplo, pode utilizar um número (32), uma comparação (">32"), uma célula (B4) ou uma palavra ("maçãs").

A função CONTAR.SE utiliza um único critério. Utilize a função CONTAR.SE.S caso pretenda utilizar vários critérios.

Exemplos

Para utilizar estes exemplos no Excel, copie os dados na tabela abaixo e cole-os na célula A1 de uma nova folha de cálculo.

Dados

Dados

maçãs

32

laranjas

54

pêssegos

75

maçãs

86

Fórmula

Descrição

=CONTAR.SE(A2:A5,"maçãs")

Conta o número de células com maçãs nas células A2 a A5. O resultado é 2.

=CONTAR.SE(A2:A5,A4)

Conta o número de células com pêssegos (utilizando o critério em A4) nas células A2 a A5. O resultado é 1.

=CONTAR.SE(A2:A5,A3)+CONTAR.SE(A2:A5,A2)

Conta o número de células com laranjas (utilizando o critério em A3) e maçãs (utilizando o critério em A2) nas células A2 a A5. O resultado é 3.

=CONTAR.SE(B2:B5,">55")

Conta o número de células com um valor superior a 55 nas células B2 a B5. O resultado é 2.

=CONTAR.SE(B2:B5,"<>"&B4)

Conta o número de células com um valor diferente de 75 nas células B2 a B5. O E comercial (&) intercala o operador de comparação "<>" (diferente de) e o valor em B4 para ler =CONTAR.SE(B2:B5,"<>75"). O resultado é 3.

=CONTAR.SE(B2:B5,">=32")-CONTAR.SE(B2:B5,">85")

Conta o número de células com um valor maior ou igual a 32 e menor ou igual a 85 nas células B2 a B5. O resultado é 3.

=CONTAR.SE(A2:A5,"*")

Conta o número de células que contêm qualquer texto nas células A2 a A5. O asterisco * é o caráter universal utilizado para corresponder a qualquer caráter. O resultado é 4.

=CONTA.SE(A2:A5,"?????es")

Conta o número de células com precisamente 7 carateres que terminam com as letras "es" nas células A2 a A5. O caráter universal ? é utilizado para corresponder a carateres individuais. O resultado é 2.

Problemas Comuns

Problema

O que correu mal

Foi devolvido um valor errado para as cadeias longas.

A função CONTAR.SE devolve resultados incorretos quando a utiliza para corresponder a cadeias com mais de 255 carateres.

Para corresponder cadeias com mais de 255 carateres, utilize a função CONCATENAR ou o operador concatenar &. Por exemplo, =CONTAR.SE(A2:A5,"cadeia longa"&"outra cadeia longa").

Não foi devolvido nenhum valor.

Certifique-se de que introduz o argumento critérios entre aspas.

Práticas recomendadas

Faça o seguinte

Por que motivo

Tenha em atenção que a função CONTAR.SE ignora as letras maiúsculas e minúsculas nas cadeias de texto.

Os critérios não são sensíveis a maiúsculas/minúsculas. Por outras palavras, a cadeia "maçãs" e a cadeia "MAÇÃS" vão corresponder às mesmas células.

Utilize carateres universais.

Os carateres universais - o ponto de interrogação (?) e o asterisco (*) - podem ser utilizados nos critérios. Um ponto de interrogação corresponde a qualquer caráter individual e um asterisco corresponde a qualquer sequência de carateres. Se pretender localizar um verdadeiro ponto de interrogação ou asterisco, escreva um til (~) à frente do caráter.

Por exemplo, =CONTAR.SE(A2:A5,"maçã?") contará todas as instâncias de "maçã" em que a última letra pode variar.

Certifique-se de que os seus dados não contêm carateres inválidos.

Ao contar os valores de texto, certifique-se de que os dados não contêm espaços à esquerda, espaços à direita, carateres não imprimíveis ou que não utilizam de forma inconsistente as aspas retas (' ou ") e curvas (‘ ou “). Nestes casos, a função CONTAR.SE pode devolver um valor inesperado.

Pode ser necessário remover os espaços à direita numa célula, a seguir aos valores da tabela, para obter resultados precisos. Tente utilizar a função LIMPARB ou a função COMPACTAR.

Relacionado

Aplica-se a:



As informações foram úteis?

Sim Não

Como podemos melhorá-lo?

255 carateres restantes

Para proteger a sua privacidade, não inclua informações de contacto nos seus comentários. Reveja o nosso política de privacidade.

Obrigado pelos seus comentários!

Recursos de suporte

Alterar idioma