Avaliar uma fórmula aninhada um passo de cada vez

Por vezes, é difícil compreender como uma fórmula aninhada calcula o resultado final porque existem vários cálculos intermédios e testes lógicos. No entanto, ao utilizar a caixa de diálogo Avaliar Fórmula, pode ver as diferentes partes de uma fórmula aninhada avaliadas de acordo com a ordem do cálculo da fórmula. Por exemplo, a fórmula = se (a média (F2: F5) >50, soma (G2: G5); 0) é mais fácil de compreender quando pode ver os seguintes resultados intermediários:

Passos demonstrados na caixa de diálogo

Descrição

=SE(MÉDIA(F2:F5)>50;SOMA(G2:G5);0)

A fórmula aninhada é apresentada inicialmente. A função MÉDIA e a função SOMA estão aninhadas na função SE.

=SE(40>50;SOMA(G2:G5);0)

O intervalo de células F2:F5 contém os valores 55, 35, 45 e 25, pelo que o resultado da função MÉDIA(F2:F5) é 40.

=SE(FalsoSOMA(G2:G5);0)

40 não é superior a 50, pelo que a expressão no primeiro argumento da função se (o argumento teste_lógico) é falso.

0

A função SE devolve o valor do terceiro argumento ( o argumento valor_se_falso). A função soma não é avaliada porque é o segundo argumento da função se (argumento valor_se_verdadeiro) e é devolvido apenas quando a expressão é verdadeiro.

  1. Selecione a célula que pretende avaliar. Só é possível avaliar uma célula de cada vez.

  2. No separador Fórmulas, no grupo Auditoria de Fórmulas, clique em Avaliar Fórmula.

    Grupo Auditoria de Fórmulas no separador Fórmulas

  3. Clique em Avaliar para examinar o valor da referência sublinhada. O resultado da avaliação é apresentado em itálico.

    Se a parte sublinhada da fórmula for uma referência a outra fórmula, clique em Avançar para apresentar a outra fórmula na caixa Avaliação. Clique em Retroceder para voltar à célula e fórmula anteriores.

    Nota: O botão Avançar não está disponível para uma referência na segunda vez que a mesma é apresentada na fórmula ou se a fórmula se referir a uma célula noutro livro.

  4. Continue até que cada parte da fórmula tenha sido avaliada.

  5. Para ver a avaliação novamente, clique em Reiniciar.

    Para terminar a avaliação, clique em Fechar.

    Notas: 

    • Algumas partes das fórmulas que utilizam as funções se e selecionar não são avaliadas e #N/A é apresentado na caixa avaliação .

    • Se a referência estiver em branco, o valor zero (0) é apresentado na caixa Avaliação.

    • As fórmulas com referências circulares podem não ser avaliadas conforme esperado. Se forem pretendidas referências circulares, pode ativar o cálculo iterativo.

    • As seguintes funções são recalculadas sempre que a folha de cálculo for alterada e podem fazer com que a ferramenta avaliar fórmula contenha resultados diferentes do que é apresentado na célula: Rand, offset, CÉL, indireto, agora, hoje, RANDBETWEEN, info e soma. cenários).

Nota:  Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode indicar-nos se estas informações foram úteis? Eis o artigo em inglês para sua referência.​

Consulte Também

Como evitar fórmulas quebradas

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×