Adicionar uma ligação de dados para um serviço Web

Nota:  Queremos fornecer-lhe os conteúdos de ajuda mais recentes o mais rapidamente possível e no seu idioma. Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode informar-nos se as informações foram úteis no final desta página? Eis o artigo em inglês para referência.

Pode adicionar uma ou mais ligações de dados secundária ao seu modelo de formulário que possa de consulta ou submeter dados para um serviço Web.

Neste artigo

Descrição geral

Considerações sobre compatibilidade

Antes de começar

Adicionar uma ligação de dados da consulta

Adicionar uma ligação de dados de submeter

Descrição Geral

Uma ligação de dados secundária é qualquer ligação de dados a uma origem de dados externos que adicionar a um modelo de formulário. Esta ligação de dados é a diferença entre a ligação de dados principal que é criada quando cria um modelo de formulário com base em definições numa biblioteca de ligações, serviço Web ou uma base de dados. Adicionar uma ligação de dados secundária apenas se não conseguir de consulta ou enviar dados através da ligação de dados principal.

Quando adiciona uma ligação de dados secundária ao seu modelo de formulário que dados de consultas, o Microsoft Office InfoPath cria uma secundário origem de dados com campos de dados e grupos que corresponde à Esquema XML do serviço Web. Uma vez que a estrutura de dados na origem de dados secundária tem de corresponder o esquema XML, é possível modificar campos ou grupos na origem de dados secundária existentes. Quando adiciona uma ligação de dados de submeter ao seu modelo de formulário, pode configura o modelo de formulário para permitir aos utilizadores submeter os seus dados de formulário e configurar as opções de submissão para os formulários baseados no modelo de formulário.

Início da página

Considerações sobre compatibilidade

Não é possível configurar a ligação de dados de submeter num modelo de formulário compatível com o browser para permitir que os utilizadores para submeter alterar informações juntamente com os respetivos dados de formulário para um serviço Web que aceita um Microsoft ADO.NET DataSet. Altere as informações é composta pelas modificações que um utilizador faz aos dados armazenados numa base de dados. A base de dados utiliza um serviço Web para ligar os utilizadores à base de dados. ADO.NET pode utilizar as informações da alteração para determinar como atualizar os dados na base de dados. Peça ao seu administrador de serviços Web se o serviço Web necessita de informações da alteração para atualizar uma base de dados. Em caso afirmativo, deverá estruturar um modelo de formulário cujos formulários podem ser preenchidos apenas utilizando o InfoPath.

Início da página

Antes de começar

Antes de adicionar uma ligação de dados secundária ao seu modelo de formulário, tem as seguintes informações a partir do administrador do serviço Web:

  • A localização do serviço Web.

  • Verificação de que o serviço Web utiliza a codificação de estilo de documento/literal. O InfoPath pode consumir apenas documento/literal estilo serviços Web.

  • O nome da operação de serviço Web que irão enviar dados para ou receber dados de formulários baseados neste modelo de formulário.

Início da página

Adicionar uma ligação de dados da consulta

Para permitir que os utilizadores para consultar os dados de um serviço Web utilizando o modelo de formulário, terá de fazer o seguinte no modelo de formulário:

  1. Adicione uma ligação de dados secundária.

  2. Configure o modelo de formulário para utilizar a ligação de dados secundária.

Passo 1: Adicionar uma ligação de dados secundária

  1. No menu Ferramentas, clique em Ligações de dados.

  2. Na caixa de diálogo Ligações de dados, clique em Adicionar.

  3. No Assistente de ligação de dados, clique em criar uma nova ligação para, clique em dados de receção e, em seguida, clique em seguinte.

  4. Em a partir da qual pretende receber os seus dados, clique em serviço Web e, em seguida, clique em seguinte.

  5. Na página seguinte do assistente, escreva a localização do serviço Web e, em seguida, clique em seguinte.

    Nota: Se pretender procurar um serviço Web utilizando um servidor Universal descrição deteção e avaliação de Integration (UDDI), clique em Procurar no UDDI, introduza o URL do servidor UDDI que pretende procurar, especifique se pretende procurar por fornecedor ou por um serviço que está fornecido, introduza uma palavra-chave de pesquisa e, em seguida, clique em Procurar. Serviços Web que correspondem a sua palavra-chave de pesquisa serão apresentados na lista de resultados de pesquisa. Selecione o serviço Web que pretende utilizar e, em seguida, clique em OK.

  6. Na lista Selecione uma operação na página seguinte do assistente, clique na operação de serviço Web que devolve dados ao formulário e, em seguida, clique em seguinte.

  7. Se o Assistente de ligação de dados encontrar um elemento desconhecido o esquema do serviço Web, a página seguinte do assistente pode pedir-lhe especificar valores de exemplo para cada parâmetro para determinar os campos ou grupos para adicionar à origem de dados principal.

    Como?

    1. Selecione um parâmetro na tabela parâmetros e, em seguida, clique em Definir valor de exemplo.

    2. Na caixa valor do exemplo, escreva um valor que o utilizador poderá utilizar para este campo e, em seguida, clique em OK.

    3. Repita estes passos para cada parâmetro na tabela parâmetros e, em seguida, clique em seguinte.

    Detalhes técnicos

    Quando configurar uma ligação de dados para um serviço Web no Assistente de ligação de dados, o Microsoft Office InfoPath liga-se ao serviço Web e pede o ficheiro de serviço descrição linguagem WSDL (Web). O ficheiro WSDL contém o esquema utilizado pelo serviço Web. O serviço Web responde ao pedido enviando este ficheiro para o InfoPath. Para adicionar os campos adequados e os grupos à origem de dados secundária no modelo de formulário, o InfoPath utiliza as informações neste ficheiro. Se o InfoPath encontrar um tipo de elemento desconhecida no ficheiro WSDL, o InfoPath utiliza dados de exemplo para determinar a definição do tipo de elemento desconhecido e, em seguida, adiciona os campos adequados e os grupos à origem de dados secundária.

  8. Se pretender que os resultados da consulta para estar disponível quando o formulário não estiver ligado a uma rede, selecione a caixa de verificação do arquivo de uma cópia dos dados no modelo de formulário.

    Nota de Segurança: Selecionar esta caixa de verificação armazena os resultados da consulta no modelo de formulário. Uma vez que os dados são armazenados no modelo de formulário, está disponível nos formulários de que os utilizadores preencherem, mesmo se os respetivos computadores não estiver ligados a uma rede. Se está a obter dados sensíveis a partir desta ligação de dados, poderá querer desativar esta funcionalidade para ajudar a proteger os dados, no caso do computador é roubado ou.

  9. Clique em Seguinte.

  10. Na página seguinte do assistente, escreva um nome descritivo para a ligação de dados da consulta.

  11. Para ativar a formulários baseados neste modelo de formulário para receber dados automaticamente quando são abertos, selecione a caixa de verificação obter dados automaticamente quando formulário está aberto.

  12. Verifique se as informações na secção de Resumo estão corretas e, em seguida, clique em Concluir.

  13. Clique em Fechar.

Passo 2: Configurar o modelo de formulário para utilizar a ligação de dados secundária

Quando adiciona uma ligação de dados de consulta para um modelo de formulário, por predefinição os formulários baseados neste modelo de formulário utilizam a ligação de dados quando são abertos por um utilizador. Também pode configurar o seu modelo de formulário para utilizar a ligação de dados de consulta de uma das seguintes formas:

  • Adicionar uma regra    Pode configurar uma regra para utilizar a ligação de dados de consulta sempre que ocorre a condição na regra.

  • Adicionar um botão    Pode adicionar um botão para o modelo de formulário que os utilizadores podem clicar para obter dados utilizando a ligação de dados da consulta.

  • Código personalizado de utilização    Se não é possível adicionar uma regra ou um botão, pode utilizar o código personalizado para obter dados utilizando a ligação de dados da consulta. Utilizando o código personalizado requer um programador criar o código personalizado.

Adicionar uma regra

Pode adicionar uma regra para o modelo de formulário para obter dados a partir da ligação de dados da consulta, sempre que a condição para a regra é cumprida. O seguinte procedimento assume que criou uma ligação de dados de consulta para o modelo de formulário e que configurou um controlo no seu modelo de formulário para apresentar os dados dessa ligação de dados.

  1. Se o modelo de formulário tem múltiplas vistas, clique em nome da vista, no menu Ver para ir para a vista com o controlo onde pretende apresentar os dados de origem de dados secundária.

  2. Faça duplo clique no controlo ao qual pretende adicionar uma regra.

  3. Clique no separador Dados.

  4. Em regras de validação e, clique em regras.

  5. Na caixa de diálogo regras, clique em Adicionar.

  6. Na caixa nome, escreva um nome para a regra.

  7. Para especificar uma condição quando deve ser executada a regra, clique em Definir condição e, em seguida, introduza a condição. A regra será executada quando ocorre a condição. Se não definir uma condição, a regra será executada sempre que o utilizador altera o valor no controlo e, em seguida, move o cursor dele afastando-o de que o controlo.

  8. Clique em Adicionar ação.

  9. Na lista de ação, clique em consulta utilizando uma ligação de dados.

  10. Na lista de ligação de dados, clique na ligação de dados de consulta que pretende utilizar e, em seguida, clique em OK para fechar cada caixa de diálogo Abrir.

  11. Para testar as suas alterações, clique em Pré-visualizar na barra de ferramentas Padrão ou prima CTRL+SHIFT+B.

Adicionar um botão

Pode adicionar um controlo de botão ao seu modelo de formulário que os utilizadores podem clicar para obter dados a partir de ligação de dados de consulta. O seguinte procedimento assume que criou uma ligação de dados de consulta para o modelo de formulário.

  1. Se o modelo de formulário tem múltiplas vistas, clique em nome da vista, no menu Ver para ir para a vista com o controlo onde pretende apresentar os dados de origem de dados secundária.

  2. Se o painel de tarefas Controlos não estiver visível, clique em Mais Controlos no menu Inserir ou prima ALT+I, C

  3. Arraste um controlo de botão para o modelo de formulário.

  4. Faça duplo clique no botão que acabou de adicionar ao seu modelo de formulário.

  5. Clique no separador Geral.

  6. Na lista de ação, clique em Atualizar.

  7. Na caixa etiqueta, escreva o nome que pretende que apareçam no botão no seu modelo de formulário.

  8. Clique em Definições.

  9. Na caixa de diálogo Atualizar, clique numa origem de dados secundária.

  10. Na lista Escolher a origem de dados secundária, clique em origem de dados secundária que está associada a ligação de dados de consulta e, em seguida, clique em OK para fechar cada caixa de diálogo Abrir.

  11. Para testar as suas alterações, clique em Pré-visualizar na barra de ferramentas Padrão ou prima CTRL+SHIFT+B.

Início da página

Adicionar uma ligação de dados de submeter

Para permitir que os utilizadores podem submeter formulários baseados no modelo de formulário a um serviço Web, primeiro adiciona uma ligação de dados secundária ao seu modelo de formulário que submete dados e, em seguida, configurar o modelo de formulário para permitir que os utilizadores submeter os seus dados de formulário.

Passo 1: Adicionar uma ligação de dados secundária

  1. No menu Ferramentas, clique em Ligações de dados.

  2. Na caixa de diálogo Ligações de dados, clique em Adicionar.

  3. No Assistente de ligação de dados, clique em criar uma nova ligação, clique em Submeter dados e, em seguida, clique em seguinte.

  4. Em como pretende submeter os seus dados, clique num serviço Web e, em seguida, clique em seguinte.

  5. Na página seguinte do assistente, escreva a localização do serviço Web onde os utilizadores irão submeter os seus dados e, em seguida, clique em seguinte.

    Nota: Se pretender procurar um serviço Web utilizando um servidor Universal descrição deteção e avaliação de Integration (UDDI), clique em Procurar no UDDI, introduza o URL do servidor UDDI que pretende procurar, especifique se pretende procurar por fornecedor ou por um serviço que está fornecido, introduza uma palavra-chave de pesquisa e, em seguida, clique em Procurar. Serviços Web que correspondem a sua palavra-chave de pesquisa serão apresentados na lista de resultados de pesquisa. Selecione o serviço Web que pretende utilizar e, em seguida, clique em OK.

  6. Na lista Selecione uma operação, clique na operação do serviço Web que irá receber os dados de formulário e, em seguida, clique em seguinte.

  7. Na página seguinte do assistente, para selecionar quais os dados no formulário da submeter para cada parâmetro no serviço Web, efetue um dos seguintes procedimentos:

    Submeter os dados num campo ou grupo

    1. Na lista de parâmetros, clique no parâmetro do serviço Web que irão receber os dados a partir do formulário.

    2. Em Opções de parâmetro, clique em campo ou grupo.

    3. Clique em Modificar Imagem de botão .

    4. Na caixa de diálogo selecionar um campo ou grupo, clique no campo ou grupo cujos dados pretende submeter e, em seguida, clique em OK.

    5. Na caixa incluir, clique em texto e elementos subordinados só para apresentar apenas os dados neste campo e os elementos subordinados do campo ou grupo, ou clique em subárvore XML, incluindo o elemento seleccionado para submeter o nome do campo, os dados no campo, e os elementos subordinados no campo ou grupo selecionado.

    Submeter todos os dados no formulário

    1. Na lista de parâmetros, clique no parâmetro do serviço Web que irão receber os dados a partir do formulário.

    2. Em Opções de parâmetro, clique em formulário completo (documento XML, incluindo as instruções de processamento).

    Submeter os dados como uma cadeia

    1. Na lista de parâmetros, clique no parâmetro do serviço Web que irão receber os dados a partir do formulário.

    2. Em Opções de parâmetro, clique em formulário completo (documento XML, incluindo as instruções de processamento).

    3. Selecione a caixa de verificação Submeter dados como uma cadeia.

      Nota: Normalmente, selecionar esta caixa de verificação para submeter dados assinados digitalmente. Na maioria dos casos, desmarque esta caixa de verificação.

    Nota técnica sobre os objectos ADO.NET conjunto de dados

    Se o serviço Web requer um objeto de ADO.NET conjunto de dados, selecione um nó do conjunto de dados quando configurar esta ligação de dados. Se utilizar qualquer outro tipo de nó de uma ligação de dados para um serviço Web que necessita de um objeto de ADO.NET conjunto de dados, a ação de submeter irá falhar.

  8. Clique em Seguinte.

  9. Na página seguinte do assistente, escreva um nome para a ligação de dados de submeter.

  10. Verifique se as informações na secção de Resumo estão corretas e, em seguida, clique em Concluir.

  11. Clique em Fechar.

Depois de adicionar secundária submeter a ligação de dados, tem de configurar o seu modelo de formulário para permitir que os utilizadores podem submeter os respetivos dados de formulário utilizando este submeter a ligação de dados.

Passo 2: Ativar submeter no modelo de formulário

Quando configurar o modelo de formulário para permitir aos utilizadores submeter os seus dados de formulário, o InfoPath adiciona um botão Submeter a barra de ferramentas padrão e um comando de Submeter ao menu ficheiro no formulário. Também pode personalizar as opções de submissão para o modelo de formulário das seguintes formas:

  • Altere o texto que aparece no botão para Submeter e o comando Submeter.

  • Altere o atalho de teclado para o botão Submeter e o comando Submeter.

  • Crie mensagens personalizadas para apresentar aos seus utilizadores quando estes submeterem os seus formulários.

  • Especifique se pretende deixar o formulário aberto, feche o formulário ou abrir outro formulário em branco depois de submeter o formulário.

  • No menu Ferramentas, clique em Opções de submeter.

  • Na caixa de diálogo Opções de submeter, selecione a caixa de verificação Permitir que os utilizadores para submeter este formulário, clique em Enviar dados de formulário a um único destino e, em seguida, na lista, clique em Serviço Web.

  • Na lista Escolher uma ligação de dados para submeter, clique no nome da ligação de dados submeter para o serviço Web que criou nos passos anteriores.

    1. Para alterar o nome do botão para Submeter que aparece na barra de ferramentas padrão e o comando de Submeter que aparece no menu ficheiro, quando os utilizadores preencham o formulário, escreva o novo nome na caixa legenda na Submeter Opções caixa de diálogo.

      Sugestão: Se pretende atribuir um atalho de teclado para este botão e o comando, escreva um e comercial (&) antes do caráter que pretende utilizar como um atalho de teclado. Por exemplo, para atribuir ALT + B como o atalho de teclado para o botão Submeter e o comando, escreva & botão Submeter.

  • Se não pretender que as pessoas utilizarem um comando de Submeter ou no botão Submeter na barra de ferramentas padrão, quando estes preencham o formulário, desmarque a caixa de verificação Mostrar o item de menu submeter e o botão da barra de ferramentas de submeter.

    1. Por predefinição, depois dos utilizadores submeter um formulário InfoPath mantém o formulário aberto e apresenta uma mensagem para indicar se o formulário foi submetido com êxito. Para alterar este comportamento predefinido, clique em Avançadas e, em seguida, efetue um dos seguintes procedimentos:

      • Para fechar o formulário ou criar um novo formulário em branco depois do utilizador submete um formulário concluído, clique na opção que pretende na lista após submeter.

      • Para criar uma mensagem personalizada para indicar se o formulário foi submetido com êxito, selecione a caixa de verificação utilizam as mensagens de personalizado e, em seguida, escreva as suas mensagens nas caixas em caso de êxito e em caso de falha.

        Sugestão: Utilizar uma mensagem na caixa em caso de falha para informar os utilizadores o que fazer se não pode submeter o seu formulário. Por exemplo, pode sugerir que os utilizadores guardarem a sua forma e contactar alguém para obter mais instruções.

      • Se não pretender apresentar uma mensagem depois do utilizador submete um formulário, desmarque a caixa de verificação Mostrar mensagens com e sem êxito.

Início da página

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×