ÍNDICE (Função ÍNDICE)

A função ÍNDICE devolve um valor ou a referência a um valor de uma tabela ou intervalo.

O seu browser não suporta vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Existem duas formas de utilizar a função ÍNDICE:

  • Se quiser devolver o valor de uma determinada célula ou matriz de células, consulte Forma de matriz.

  • Se quiser devolver uma referência para determinadas células, consulte Forma de referência.

Forma de matriz

Descrição

Devolve o valor de um elemento numa tabela ou matriz, selecionado pelos índices de número de linha e coluna.

Utilize a forma de matriz quando o primeiro argumento de ÍNDICE for uma constante de matriz.

Sintaxe

ÍNDICE(matriz, núm_linha, [núm_coluna])

A forma de matriz da função índice tem os seguintes argumentos:

  • matricial    Obrigatório. É um intervalo de células ou uma constante de matriz.

    • Se a matriz contiver apenas uma linha ou coluna, o argumento núm_linha ou núm_coluna correspondente é opcional.

    • Se matriz tiver mais de uma linha e mais do que uma coluna e apenas núm_linha ou núm_coluna forem utilizados, índice devolve uma matriz de uma linha ou coluna inteira na matriz.

  • núm_linha    Obrigatório. Seleciona a linha na matriz a partir da qual é devolvido um valor. Se núm_linha for omitido, núm_coluna é obrigatório.

  • núm_coluna    Opcional. Seleciona a coluna na matriz a partir da qual é devolvido um valor. Se núm_coluna for omitido, núm_linha é obrigatório.

Observações

  • Se os argumentos núm_linha e núm_coluna forem utilizados, índice devolve o valor na célula na intersecção de núm_linha e núm_coluna.

  • núm_linha e núm_coluna têm de apontar para uma célula na matriz; caso contrário, índice devolve um #REF! .

  • Se definir núm_linha ou núm_coluna como 0 (zero), índice devolve a matriz de valores para a coluna ou linha inteira, respectivamente. Para utilizar os valores devolvidos como uma matriz, introduza a função índice como uma fórmula de matriz.

    Nota: Se tiver uma versão atual do Office 365, pode introduzir a fórmula na parte superior esquerda da célula do intervalo de resultados e, em seguida, premir Enter para confirmar a fórmula como uma fórmula de matriz dinâmica. Caso contrário, a fórmula tem de ser introduzida como uma fórmula de matriz herdada ao selecionar primeiro o intervalo de resultados, introduzir a fórmula no canto superior esquerdo do intervalo de resultados e, em seguida, premir Ctrl + Shift + Enter para o confirmar. O Excel insere parênteses retos no início e no fim da fórmula. Para obter mais informações sobre fórmulas de matriz, consulte Diretrizes e exemplos de fórmulas de matriz.

Exemplos

Exemplo 1

Estes exemplos utilizam a função ÍNDICE para encontrar o valor na célula de interceção entre uma linha e uma coluna.

Copie os dados de exemplo da tabela seguinte e cole-os na célula A1 de uma folha de cálculo nova do Excel. Para que as fórmulas mostrem os resultados, selecione-as, prima F2 e, em seguida, prima Enter.

Dados

Dados

Maçãs

Limões

Bananas

Peras

Fórmula

Descrição

Resultado

=ÍNDICE(A2:B3,2,2)

Valor do cruzamento da segunda linha e da segunda coluna no intervalo A2:B3.

Peras

=ÍNDICE(A2:B3,2,1)

Valor do cruzamento da segunda linha e da primeira coluna no intervalo A2:B3

Bananas

Exemplo 2

Este exemplo utiliza a função ÍNDICE numa fórmula de matriz para encontrar os valores em duas células especificadas numa matriz 2x2.  

Nota: Se tiver uma versão atual do Office 365, pode introduzir a fórmula na parte superior esquerda da célula do intervalo de resultados e, em seguida, premir Enter para confirmar a fórmula como uma fórmula de matriz dinâmica. Caso contrário, a fórmula tem de ser introduzida como uma fórmula de matriz herdada ao selecionar duas células em branco, introduzir a fórmula no canto superior esquerdo do intervalo de resultados e, em seguida, premir Ctrl + Shift + Enter para a confirmar. O Excel insere parênteses retos no início e no fim da fórmula. Para obter mais informações sobre fórmulas de matriz, consulte Diretrizes e exemplos de fórmulas de matriz.

Fórmula

Descrição

Resultado

=ÍNDICE({1,2;3,4},0,2)

Valor encontrado na primeira linha, segunda coluna da matriz. A matriz contém 1 e 2 na primeira linha e 3 e 4 na segunda linha.

2

Valor encontrado na segunda linha, segunda coluna na matriz (mesma matriz que em cima).

4

Início da Página


Formulário de referência

Descrição

Devolve a referência da célula na interseção de uma determinada linha e coluna. Se a referência for composta por seleções não adjacentes, pode selecionar a seleção a procurar.

Sintaxe

núm_linha(referência;núm_linha;[núm_coluna];[núm_área])

A forma de referência da função índice tem os seguintes argumentos:

  • refere    Obrigatório. É uma referência a um ou mais intervalos de células.

    • Se estiver a introduzir um intervalo não adjacente para a referência, coloque a referência entre parênteses.

    • Se cada área na referência contiver apenas uma linha ou coluna, o argumento núm_linha ou núm_coluna, respectivamente, é opcional. Por exemplo, para uma referência a uma única linha, utilize ÍNDICE(referência;núm_coluna).

  • núm_linha    Obrigatório. É o número da linha na referência a partir da qual é devolvida uma referência.

  • núm_coluna    Opcional. É o número da coluna na referência a partir da qual é devolvida uma referência.

  • Núm_área    Opcional. Seleciona um intervalo em referência a partir do qual irá devolver a intersecção de núm_linha e núm_coluna. A primeira área selecionada ou introduzida é numerada como 1, o segundo é 2 e assim sucessivamente. Se Núm_área for omitido, índice utiliza a área 1.  As áreas aqui indicadas devem estar todas em uma folha.  Se especificar áreas que não estejam na mesma folha que a outra, isto causará uma #VALUE! .  Se precisar de utilizar intervalos localizados em folhas diferentes uns dos outros, recomendamos que utilize a forma de matriz da função índice e utilize outra função para calcular o intervalo que compõe a matriz.  Por exemplo, pode utilizar a função escolher para calcular o intervalo que será utilizado.

Por exemplo, se a referência descrever as células (a1: B4; D1: E4; G1: H4), Núm_área 1 é o intervalo a1: B4, Núm_área 2 é o intervalo D1: E4 e Núm_área 3 é o intervalo G1: H4.

Observações

  • Após a referência e Núm_área selecionar um intervalo específico, núm_linha e núm_coluna selecione uma célula específica: núm_linha 1 é a primeira linha do intervalo, núm_coluna 1 é a primeira coluna, entre outros. A referência retornada por índice é a intersecção de núm_linha e núm_coluna.

  • Se definir núm_linha ou núm_coluna como 0 (zero), índice devolve a referência para a coluna ou linha inteira, respectivamente.

  • núm_linha, núm_coluna e Núm_área têm de apontar para uma célula na referência; caso contrário, índice devolve um #REF! . Se núm_linha e núm_coluna forem omitidos, índice devolve a área na referência especificada por Núm_área.

  • O resultado da função ÍNDICE é uma referência e é interpretado como tal por outras fórmulas. Dependendo da fórmula, o valor devolvido de ÍNDICE pode ser utilizado como uma referência ou como um valor. Por exemplo, a fórmula CÉL ("largura";ÍNDICE(A1:B2;1;2)) é equivalente a CÉL ("largura";B1). A função CÉL utiliza o valor devolvido de ÍNDICE como uma referência de célula. Por outro lado, uma fórmula como 2*ÍNDICE(A1:B2;1;2) converte o valor devolvido por ÍNDICE no número da célula B1.

Exemplos

Copie os dados de exemplo que se encontram na seguinte tabela e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem resultados, selecione-as, prima F2 e, em seguida, prima ENTER.

Fruta

Preço

Contagem

Maçãs

0,69 €

40

Bananas

0,34 €

38

Limões

0,55 €

15

Laranjas

0,25 €

17

Peras

0,59 €

40

Amêndoas

2,80 €

10

Acajus

3,55 €

16

Amendoins

1,25 €

20

Nozes

1,75 €

12

Fórmula

Descrição

Resultado

=ÍNDICE(A2:C6;2;3)

A interseção da segunda linha e da terceira coluna no intervalo A2:C6, que é o conteúdo da célula C3.

38

=ÍNDICE((A1:C6;A8:C11);2;2;2)

A interseção da segunda linha e da segunda coluna na segunda área de A8:C11, que é o conteúdo da célula B9.

1,25

=SOMA(ÍNDICE(A1:C11;0;3;1))

A soma da terceira coluna na primeira área do intervalo A1:C11, que é a soma de C1:C11.

216

=SOMA(B2:ÍNDICE(A2:C6;5;2))

A soma do intervalo com início em B2 e fim na interseção da quinta linha e da segunda coluna do intervalo A2:A6, que é a soma de B2:B6.

2,42

Início da Página

Consulte Também

Função PROCV

Função CORRESP

INDIRECTO (função INDIRECTO)

Diretrizes e exemplos de fórmulas de matriz

Funções de pesquisa e referência (referência)

Nota:  Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode indicar-nos se estas informações foram úteis? Eis o artigo em inglês para sua referência.​

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×