VALORDOCAMPO (Função VALORDOCAMPO)

Você pode usar a função VALORDOCAMPO para recuperar dados de campo de tipos de dados vinculados, como os tipos de dados Ações ou Geografia. Há métodos mais fáceis para gravar fórmulas que fazem referência a tipos de dados. Portanto, a função VALORDOCAMPO deve ser usada principalmente para criar cálculos condicionais com base em tipos de dados vinculados.

Observação: 27 de novembro de 2018. Os tipos de dados foram lançados para todos os assinantes do Windows Office 365, exceto em algumas localidade geopolíticas (em breve). Se você for um assinante do Office 365, verifique se possui a versão mais recente do Office.

Detalhes técnicos

Sintaxe

=VALORDOCAMPO(valor, nome_do_campo)

A sintaxe da função VALORDOCAMPO tem os seguintes argumentos:

Argumento

Descrição

valor

A função retorna todos os campos correspondentes do tipo de dados vinculado especificado no argumento de valor.

field_name

O nome ou os nomes dos campos que você deseja extrair do tipo de dados vinculado.

Descrição

Exemplos

No exemplo básico a seguir, a fórmula =VALORDOCAMPO(A2;"Preço") extrai o campo Preço do tipo de dados de ações para JM Smucker Co.

Recuperar um preço de ação de empresa com =VALORDOCAMPO(A2;"Preço")

A seguir há um exemplo mais comum da função VALORDOCAMPO. Aqui, usamos a função SEERRO para verificar se há erros. Se não há um nome de empresa na célula A2, a fórmula VALORDOCAMPO retorna um erro e, nesse caso, não queremos exibir nada (""). Porém, se há um nome de empresa, queremos recuperar o Preço de tipo de dados em A2 com =SEERRO(VALORDOCAMPO($A2;B$1);"").

Recuperar um preço de ação de empresa e ignorar erros com =SEERRO(VALORDOCAMPO($A2;B$1);"")

Observe que a função VALORDOCAMPO permite fazer referência a células da planilha para o argumento nome_do_campo. Portanto, a fórmula acima faz referência à célula B1 para Preço, em vez de ser preciso digitar "Preço" na fórmula. 

Comentários

Se você tentar recuperar dados de um campo de tipo de dados não existente, a função VALORDOCAMPO retornará o erro #CAMPO!. Por exemplo, você pode ter inserido "Preços" quando o campo de tipo de dados real é denominado "Preço". Verifique a fórmula para garantir que você está usando um nome de campo válido. Se quiser exibir uma lista de nomes de campos de um registro, selecione a célula do registro e pressione Alt+Shift+F10.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no User Voice do Excel.

Confira também

Tipos de dados Ações e Geografia

Como escrever fórmulas que façam referência a tipos de dados

Erro #CAMPO!

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×