Usar valores de um banco de dados do SQL Server para preencher uma caixa de listagem, caixa de listagem suspensa ou caixa de combinação

Observação:  Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. As informações foram úteis? Dê sua opinião no final desta página. Aqui está o artigo em inglês para facilitar a referência.

Você pode preencher uma caixa de listagem, caixa de listagem suspensa ou caixa de combinação com dados de uma conexão de dados de consulta para um banco de dados do Microsoft SQL Server.

Neste artigo

Visão geral

Antes de começar

Etapa 1: Adicionar uma conexão de dados de consulta

Etapa 2: Configurar o controle

Visão geral

Uma caixa de listagem, caixa de listagem suspensa ou caixa de combinação exibe itens que um usuário pode selecionar ao preencher um formulário que é baseado no modelo de formulário. Você pode configurar esses tipos de controles para mostrar os dados de uma conexão de dados secundária para um banco de dados do Microsoft SQL Server. Uma conexão de dados secundária é qualquer conexão de dados a uma fonte de dados externos que você adicionar a um modelo de formulário para que os usuários que preencherem formulários baseados neste modelo de formulário podem obter dados de ou enviar dados para uma fonte de dados externos, como um serviço da Web.

Quando você adiciona uma conexão de dados secundária que dados de consultas para seu modelo de formulário, o Microsoft Office InfoPath criam um secundário fonte de dados com grupos e campos de dados que corresponde à maneira como os dados será armazenado no banco de dados. A conexão de dados de consulta obtém dados do serviço da Web e armazena dados na fonte de dados secundária do formulário. Por padrão, os dados na fonte de dados secundária estão disponíveis somente enquanto os usuários estão conectados a uma rede. Você pode configurar a conexão de dados secundária para salvar os resultados da consulta nos computadores dos seus usuários para que eles tenham acesso aos dados quando o formulário não estiver conectado a uma rede.

Observação de segurança: Se você estiver usando uma conexão de dados secundária para recuperar dados confidenciais de uma fonte de dados externos, talvez você queira desabilitar esse recurso para ajudar a proteger os dados de uso não autorizado, caso o computador seja perdido ou roubado. Se você desabilitar esse recurso, os dados estará disponíveis somente se o usuário estiver conectado à rede.

Como a estrutura de dados na fonte de dados secundária deve corresponder a maneira que os dados são armazenados no banco de dados, você não pode modificar campos ou grupos na fonte de dados secundária existentes. Encontre links para obter mais informações sobre fontes de dados e conexões de dados na seção Consulte também.

Início da página

Antes de começar

Antes de poder usar valores de um banco de dados do SQL Server para preencher um controle no seu modelo de formulário, você precisa das seguintes informações do administrador do banco de dados:

  • O nome do servidor com o banco de dados que você usará com este modelo de formulário.

  • O nome do banco de dados que você usará com este modelo de formulário.

  • A autenticação necessária pelo banco de dados. O banco de dados pode usar a autenticação do Microsoft Windows ou autenticação do SQL Server para determinar como os usuários podem acessar o banco de dados.

  • O nome da tabela que contém os dados que você deseja enviar para o formulário. Esta é a tabela primária. Se você planeja usar mais de uma tabela no banco de dados, é necessário que os nomes dos outros, tabelas filho. Você também precisa os nomes dos campos nas tabelas filho que tiverem relações aos campos na tabela primária.

  • Se você pode armazenar em segurança os resultados da consulta nos computadores dos seus usuários para uso offline.

Início da página

Etapa 1: Adicionar uma conexão de dados de consulta

Se você não tiver uma conexão de dados de consulta existente que você pode usar no seu modelo de formulário, siga estas etapas para adicionar uma conexão de dados secundária para seu modelo de formulário que dados de consultas. Se seu modelo de formulário já tem uma conexão de dados secundária que você pode usar, você pode pular esta seção e vá para etapa 2: configurar o controle.

  1. No menu Ferramentas, clique em Conexões de dados.

  2. Na caixa de diálogo Conexões de dados, clique em Adicionar.

  3. No Assistente de Conexão de dados, clique em criar uma nova conexão para, clique em receber dados e clique em Avançar.

  4. Na próxima página do assistente, clique em banco de dados (Microsoft SQL Server ou Microsoft Office Access apenas) e clique em Avançar.

  5. Na próxima página do assistente, clique em Selecionar banco de dados.

  6. Na caixa de diálogo Selecionar fonte de dados, clique em Nova fonte.

  7. Na próxima página do assistente, na lista que tipo de fonte de dados que você deseja conectar-se a, clique em Microsoft SQL Server e, em seguida, clique em Avançar.

  8. Na caixa nome do servidor, digite o nome do servidor que contém o banco de dados do SQL Server.

  9. Em credenciais de logon, siga um destes procedimentos:

    • Se o banco de dados determina quem tem acesso com base em credenciais usadas em uma rede do Microsoft Windows, clique em Usar autenticação do Windows.

    • Se o banco de dados determina quem tem acesso com base em um nome de usuário especificado e a senha que você obtém do administrador do banco de dados, clique em usar o seguinte nome de usuário e senha e, em seguida, digite seu nome de usuário e senha em Nome de usuário e Senha caixas.

  10. Clique em Avançar.

  11. Na lista Selecione o banco de dados que contém os dados desejados, clique no nome do banco de dados que você deseja usar, clique em conectar a uma tabela específica, clique no nome da tabela primária e clique em Avançar.

  12. Na próxima página do assistente, na caixa Nome do arquivo, digite um nome para o arquivo que armazena as informações de conexão de dados e clique em Concluir para salvar essas configurações.

    Se você planeja usar outras tabelas na conexão de dados da consulta, você pode adicionar outras tabelas nesta página do assistente.

    Adicionar outras tabelas

    1. Clique em Adicionar a tabela.

    2. Na caixa de diálogo Adicionar tabela ou consulta, clique no nome da tabela filho e clique em Avançar. InfoPath tenta definir as relações combinando nomes de campos em ambas as tabelas. Se você não quiser usar a relação sugerida, selecione a relação e clique em Remover relação. Para adicionar uma relação, clique em Adicionar relação. Na caixa de diálogo Adicionar relação, clique no nome de cada campo relacionado na coluna respectiva e clique em Okey.

    3. Clique em Concluir.

    4. Para adicionar tabelas filho adicionais, repita essas etapas.

  13. Clique em Avançar.

  14. Para armazenar os resultados da consulta com o modelo de formulário, marque a caixa de seleção armazenar uma cópia dos dados no modelo de formulário. Marcar esta caixa de seleção armazena os resultados da consulta no modelo de formulário. Becuase que os dados são armazenados no modelo de formulário. os dados estão disponíveis nos formulários que os usuários preencherem, mesmo se seus computadores não estiver conectados a uma rede.

    Observação de segurança: Marcar esta caixa de seleção armazena os resultados da consulta no modelo de formulário. Como os dados são armazenados no modelo de formulário, ele está disponível nos formulários que os usuários preencherem, mesmo se seus computadores não estiver conectados a uma rede. Se você estiver recebendo dados confidenciais desta conexão de dados, talvez você queira desabilitar esse recurso para ajudar a proteger os dados, caso o computador seja perdido ou roubado.

  15. Clique em Avançar.

  16. Na próxima página do assistente, digite um nome descritivo para esta conexão de dados secundária. Se desejar que o formulário para receber dados automaticamente quando o formulário é aberto, marque a caixa de seleção recuperar dados automaticamente quando o formulário é aberto.

Início da página

Etapa 2: Configurar o controle

  1. Se o modelo de formulário tiver vários modos de exibição, clique em nome de exibição no menu Exibir para ir para o modo de exibição com o controle onde você deseja exibir os dados da fonte de dados secundária.

  2. Clique duas vezes na caixa de listagem, caixa de listagem suspensa ou controle de caixa de combinação que você deseja preencher.

  3. Clique na guia Dados.

  4. Em entradas da caixa de listagem, clique em Consultar valores de uma fonte de dados externos.

  5. Na lista Fonte de dados, clique na fonte de dados que você deseja usar.

  6. Clique em Selecionar XPath Imagem do botão ao lado da caixa de entradas.

  7. Na caixa de diálogo Selecionar campo ou grupo, especifique quais dados serão exibidos para o usuário e quais dados serão enviados à fonte de dados externa, seguindo um destes procedimentos.

    Especificar que os dados que o usuário verá os mesmos dados que o usuário será enviado

    • Clique em um campo e, em seguida, clique em Okey.

    Especificar que os dados que o usuário verá diferentes dos dados que o usuário enviará

    Observação: Neste cenário, os dados que o usuário verá são de um dos campos no grupo, e os dados que o usuário enviará estiverem em outro campo no mesmo grupo.

    1. Clique em um grupo e clique em Okey.

    2. Na caixa de diálogo Propriedades de controle, clique em Selecionar XPath Imagem do botão ao lado da caixa valor.

    3. Na caixa de diálogo Selecionar campo ou grupo, clique em um campo que contém os dados que o usuário enviar à fonte de dados externa e clique em Okey.

    4. Na caixa de diálogo Propriedades de controle, clique em Selecionar XPath Imagem do botão ao lado da caixa de nome para exibição.

    5. Na caixa de diálogo Selecionar campo ou grupo, clique em um campo que contém os dados que aparecerão no controle e clique em Okey.

  8. Se o campo na caixa nome para exibição tem valores com nomes de exibição semelhantes e desejar exibir somente os nomes exclusivos, marque a caixa de seleção Mostrar apenas entradas com nomes para exibição exclusivos.

Início da página

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×