TEXTO (Função TEXTO)

Observação: Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. As informações foram úteis? Dê sua opinião no final desta página. Aqui está o artigo em inglês para facilitar a referência.

A função TEXTO permite que você altere a maneira de exibir um número aplicando formatação a ele com códigos de formatação. Isso é útil quando você deseja exibir números em um formato mais legível ou deseja combinar números com texto ou símbolos.

Observação: A função TEXTO converterá números em texto, o que pode dificultar a referência em cálculos posteriores. É melhor manter o valor original de uma célula e usar a função TEXTO em outra célula. Assim, se você precisar criar outras fórmulas, referencie sempre o valor original e não o resultado da função TEXTO.

Sintaxe

TEXTO(valor;formato_texto)

A sintaxe da função TEXTO tem os seguintes argumentos:

Nome do argumento

Descrição

valor

Um valor numérico que você deseja ver convertido em texto.

formato_texto

Uma cadeia de texto que define a formatação a ser aplicada ao valor fornecido.

Visão geral

Em sua forma mais simples, a função TEXTO diz:

  • =TEXTO(valor que você deseja formatar; "Código de formatação que deseja aplicar")

Aqui estão alguns exemplos comuns que você pode copiar diretamente no Excel para testar por conta própria. Observe os códigos de formatação entre aspas.

Fórmula

Descrição

=TEXTO(1234,567;"$#;##0,00")

Moeda com separador de milhares e duas casas decimais, como R$ 1.234,57. Observe que o Excel arredonda o valor para duas casas decimais.

=TEXTO(HOJE();"DD/MM/AA")

Data de hoje no formato DD/MM/AA, como 14/03/12

=TEXTO(HOJE();"DDDD")

Dia da semana hoje, como segunda-feira

=TEXTO(AGORA();"HH:MM")

Hora atual, como 13:29

=TEXTO(0,285;"0,0%")

Porcentagem, como 28,5%

= TEXT(4.34,"# ?/?")

Fração, como 4 1/3

=ARRUMAR(TEXTO(0,34;"#? /?" ))

Fração, como 1/3. Observe que a função ARRUMAR é usada para remover os espaços à esquerda em um valor decimal.

=TEXTO(12200000;"0,00E+00")

Notação científica, como 1,22E+07

=TEXTO(2112345678;"[<=9999999]####-####;(##)")

Números especiais (número de telefone), como (21) 1234-5678

=TEXTO(1234;"0000000")

Adiciona zeros (0), como 0001234

=TEXTO(123456;"##0° 00' 00''")

Personalizado – Latitude/Longitude

Observação: Embora você possa usar a função texto para alterar a formatação, não é a única maneira. Você pode alterar o formato sem uma fórmula pressionando CTRL + 1 (ou Imagem do ícone do botão Command no MAC +1 no Mac), e selecione o formato desejado de Formatar células > caixa de diálogo de número.

Baixar nossos exemplos

Você pode baixar uma pasta de trabalho de exemplo com todos os exemplos de função de texto que você encontrará neste artigo, além de algumas extras. Você pode acompanhar ou criar sua própria função texto códigos de formato.

Exemplos de função de baixar o texto do Excel

Outros códigos de formatação disponíveis

Você pode usar o diálogo Formatar Células para localizar os outros códigos de formatação disponíveis:

  1. Pressione Ctrl+1 ( Imagem do ícone do botão Command no MAC +1 no Mac) para exibir o diálogo Formatar Células.

  2. Selecione o formato desejado na guia Número .

  3. Selecione a opção Personalizado,

  4. O código de formatação desejado agora aparece na caixa Tipo. Nesse caso, selecione tudo na caixa Tipo, exceto o ponto e vírgula (;) e o símbolo @. No exemplo abaixo, selecionamos e copiamos apenas dd/mm/aa.

  5. Pressione Ctrl+C para copiar o código de formatação e pressione Cancelar para descartar o diálogo Formatar Células.

  6. Agora, basta apenas pressionar Ctrl+V para colar o código de formatação em sua fórmula TEXTO, como: =TEXTO(B2;"dd/mm/aa"). Não deixe de colar o código de formatação entre aspas ("código de formatação"). Caso contrário, o Excel vai gerar uma mensagem de erro.

Exemplo de como usar a caixa de diálogo Formatar > Células > Número > Personalizado para que o Excel crie cadeias de caracteres de formato para você.

Códigos de formatação por categoria

Estes são alguns exemplos de como você pode aplicar diferentes formatos de número aos valores usando o diálogo Formatar Células e usando a opção Personalizado para copiar os códigos de formatação na função TEXTO.

Por que o Excel exclui meu zero à esquerda?

Excel é treinamento para procurar números sendo inseridos nas células, não os números que a aparência do texto, como números de peças ou do SKU. Para manter os zeros à esquerda, formate o intervalo de entrada como texto antes de colar ou insira valores. Selecione a coluna ou intervalo, onde você deverá estar colocando os valores, use CTRL + 1 para exibir o Formatar > células diálogo e na guia de número, selecione texto. Agora o Excel manterá o líder da 0.

Se você já inseriu dados e o Excel removeu os zeros à esquerda, poderá usar a função TEXTO para adicioná-los novamente. Você pode fazer referência à célula superior com os valores e usar =TEXTO(valor;"00000"), em que o número de zeros na fórmula representa o número total de caracteres desejado. Em seguida, copie e cole no restante do intervalo.

Exemplos do uso de TEXTO para formatar zeros à esquerda. =TEXTO(A2;"00000")

Se por algum motivo você precisa reverter os valores de texto em números, multiplique por 1, como =D4*1, ou use o operador unário duplo (--), como =--D4.

O Excel fará a separação de milhar se o formato contiver um ponto delimitado por teclas de cerquilha (#) ou por zeros. Por exemplo, se a cadeia de caracteres de formatação for "#.###", o Excel exibirá o número 12200000 como 12.200.000.

O ponto que segue um espaço reservado para dígito escala o número por 1.000. Por exemplo, se a cadeia de caracteres de formatação é "#.###,0.", o Excel exibirá o número 12200000 como 12.200,0.

Exemplos da função TEXTO usando o separador Milhares

Observações: 

  • O separador de milhares depende das configurações regionais. No Brasil é um ponto, mas em outras localidades é uma vírgula (,).

  • O separador de milhares está disponível para os formatos número, moeda e contábil.

A seguir estão exemplos de formatos número (somente separador de milhares e decimais), moeda e contábil padrão. O formato moeda permite a você inserir o símbolo de moeda à sua escolha e o alinha ao lado de seu valor; já o formato contábil alinha o símbolo de moeda à esquerda da célula e o valor à direita. Observe a diferença entre os códigos de formatação moeda e contábil abaixo, em que contábil usa um asterisco (*) para criar separação entre o símbolo e o valor.

Exemplos da função TEXTO com os formatos Número, Moeda e Contábil

Para encontrar o código de formatação de um símbolo de moeda, primeiro pressioneCtrl+1 (ou Imagem do ícone do botão Command no MAC +1 no Mac), selecione o formato desejado e escolha um símbolo na lista suspensa Símbolo:

Seleção de Símbolo de Moeda no diálogo Formatar Células

Clique em Personalizado à esquerda da seção Categoria e copie o código de formatação, inclusive o símbolo da moeda.

Função TEXTO – Moeda personalizada com símbolo

Observação: A função TEXTO não dá suporte à formatação de cor e, portanto, se você copiar um código de formatação de número do diálogo Formatar Células que inclua uma cor, como este: R$#.## 0,00_); [Vermelho](R$#,##0,00), a função TEXTO aceitará o código do formato, mas não exibirá a cor.

Você pode alterar a forma de exibição de uma data usando uma combinação de "M" para mês, "D" para dias e "Y" para anos.

Códigos de formato Mês, Dia e Ano

Os códigos de formatação na função TEXTO não diferenciam maiúsculas e minúsculas e, portanto, você pode usar "D" ou "d", "M" ou "m", "A" ou "a".

Mynda Treacy, MVP em Excel

Recomendação da Mynda...

Se você compartilhar arquivos do Excel e relatórios com usuários de diferentes países, em seguida, talvez você queira dar a elas um relatório em seu idioma. MVP do Excel, Mynda Treacy tem uma ótima solução neste artigo Excel as datas exibidas em diferentes idiomas . Ele também inclui uma pasta de trabalho de exemplo que você pode baixar.

Você pode alterar a forma de exibição da hora usando uma combinação de "H" para horas, "M" para minutos ou "S" para segundos e "AM/PM" para um relógio de 12 horas.

Formatos de hora para horas, minutos e segundos

Se você excluir "AM/PM" ou "A/P", a hora será exibida com base no relógio de 24 horas.

Os códigos de formatação na função TEXTO não diferenciam maiúsculas e minúsculas e, portanto, você pode usar "H" ou "h", "M" ou "m", "S" ou "s".

Você pode alterar o modo de exibição de valores decimais com formatos de porcentagem (%).

Códigos de formato para Porcentagem

Você pode alterar o modo de exibição de valores decimais com formatos de fração (?/?).

Códigos de formato para Frações

Notação científica é uma maneira de exibir números em decimal entre 1 e 10 elevado à décima potência. Ela é usada com frequência para encurtar a exibição de números grandes.

Códigos de formato para Científico

O Excel oferece 4 formatos especiais:

  • CEP – "00000"

  • CEP + 4 - "00000-0000"

  • Número de telefone – "[<=9999999]####-####;(##)">

  • CPF – "000.000.000-00"

Formatos especiais para a função TEXTO

Os formatos especiais serão diferentes dependendo da localidade, mas se não existirem formatos especiais na sua região ou se ele não atenderem às suas necessidades, crie seu próprio usando o diálogo Formatar Células > Personalizado.

Cenário comum

A função texto raramente é usada sozinha e geralmente é usada em conjunto com algo diferente. Digamos que você deseja combinar o texto e um valor de número, como "relatório impresso: 03/14/12", ou "receita semanal: $66,348.72". Você pode digitar que para o Excel manualmente, mas que derrotas a finalidade de ter o Excel fazer isso por você. Infelizmente, quando você combina texto e números formatados, como datas, horas, moeda, etc., o Excel não sabe como deseja exibi-los, para que ele descarta a formatação de número. Isso é onde a função texto é muito útil, porque ele permite que você forçar o Excel para formatar os valores da maneira desejada usando um código de formato, como "DD/MM/AA" para o formato de data.

No exemplo a seguir, você verá o que acontece se você tentar ingressar no texto e um número sem usar a função texto . Nesse caso, estamos usando o e comercial (&) para concatenar uma cadeia de texto, um espaço ("") e um valor com = A2 & "" & B2.

Exemplo de união de texto sem a função TEXTO

Como você pode ver, o Excel removeu a formatação da data na célula B2. No próximo exemplo, você verá como a função TEXTO permite aplicar o formato desejado.

Exemplo de união de texto com a função TEXTO

Nossa fórmula atualizada é:

  • Célula C2: =A2&" "&TEXTO(B2;"dd/mm/aa") – formato de data

Perguntas frequentes

Infelizmente, você não pode fazer que, com a função de texto , você precisa usar o Visual Basic para código Applications (VBA). O link a seguir tem um método: como converter um valor numérico em palavras em inglês no Excel

Sim, você pode usar as funções MAIÚSCULA, MINÚSCULA e PRI.MAIÚSCULA. Por exemplo, =MAIÚSCULA("olá") retornaria "OLÁ".

Sim, mas leva algumas etapas. Primeiro, selecione as células onde você deseja que isso acontecer e usar Ctrl + 1 para exibir o Formatar > células caixa de diálogo, em seguida, Alinhamento > controle de texto > marcar a opção Quebrar texto automaticamente. Em seguida, ajuste sua função texto concluída para incluir a função ASCII CARACT (10) onde deseja que a quebra de linha. Você pode precisar ajustar a largura da coluna dependendo de como o resultado final se alinha.

Exemplo do uso de texto com CARACT(10) para inserir uma quebra de linha. ="Hoje é: "&CARACT(10))&TEXTO(HOJE();"DD/MM/AA")

Nesse caso, usamos: ="Hoje é: "&CARACT(10)&TEXTO(HOJE();"dd/mm/aa")

Isso se chama notação científica, e o Excel converterá automaticamente números com mais de 12 dígitos se uma ou mais células estiverem formatadas como Gerale com mais de 15 dígitos se uma ou mais células estiverem formatadas como um Número. Se você precisar inserir cadeias de caracteres numéricos longas, mas não quiser convertê-las, formate as células em questão como Texto antes de inserir ou colar os valores no Excel.

Mynda Treacy, MVP em Excel

Recomendação da Mynda...

Se você compartilhar arquivos do Excel e relatórios com usuários de diferentes países, em seguida, talvez você queira dar a elas um relatório em seu idioma. MVP do Excel, Mynda Treacy tem uma ótima solução neste artigo Excel as datas exibidas em diferentes idiomas . Ele também inclui uma pasta de trabalho de exemplo que você pode baixar.

Confira também

Criar ou excluir um formato de número personalizado

Converter números armazenados como texto em números

Todas as funções do Excel (por categoria)

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×