SEERRO (Função SEERRO)

Você pode usar a função SEERRO para interceptar e manipular erros em uma fórmula. SEERRO retornará um valor especificado se uma fórmula for avaliada como um erro; caso contrário, retorna o resultado da fórmula.

Sintaxe

SEERRO(valor, valor_se_erro)

A sintaxe da função SEERRO tem os seguintes argumentos:

  • valor    Obrigatório. O argumento verificado quanto ao erro.

  • value_if_error    Obrigatório. O valor a ser retornado se a fórmula for avaliada como um erro. Os seguintes tipos de erros são avaliados: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME? ou #NULL!.

Comentários

  • Se valor ou value_if_error for uma célula vazia, SEERRO a tratará como um valor de cadeia de caracteres vazio ("").

  • Se valor for uma fórmula de matriz, SEERRO retornará uma matriz de resultados para cada célula no intervalo especificado em valor. Consulte o segundo exemplo a seguir.

Exemplos

Copie os dados de exemplo da tabela a seguir e cole-os na célula A1 de uma nova planilha do Excel. Para que as fórmulas mostrem resultados, selecione-as, pressione F2 e pressione Enter.

Cota

Unidades Vendidas

210

35

55

0

23

Fórmula

Descrição

Resultado

=SEERRO(A2/B2, "Erro no cálculo")

Verifica se há erros na fórmula no primeiro argumento (divide 210 por 35), não localiza nenhum erro e, em seguida, retorna os resultados da fórmula.

6

=SEERRO(A3/B3, "Erro no cálculo")

Verifica se há erros na fórmula no primeiro argumento (divide 55 por 0), localiza um erro de divisão por 0 e, em seguida, retorna valor_se_erro

Erro no cálculo

=SEERRO(A4/B4, "Erro no cálculo")

Verifica se há erros na fórmula no primeiro argumento (divide "" por 23), não localiza nenhum erro e, em seguida, retorna os resultados da fórmula.

0

Exemplo 2

Cota

Unidades Vendidas

Proporção

210

35

6

55

0

Erro no cálculo

23

0

Fórmula

Descrição

Resultado

=C2

Verifica se há erros na fórmula no primeiro argumento, no primeiro elemento da matriz (A2/B2 ou divide 210 por 35), não localiza nenhum erro e, em seguida, retorna o resultado da fórmula

6

=C3

Verifica se há erros na fórmula no primeiro argumento, no segundo elemento da matriz (A3/B3 ou divide 55 por 0), localiza um erro de divisão por 0 e, em seguida, retorna valor_se_erro

Erro no cálculo

=C4

Verifica se há erros na fórmula no primeiro argumento, no terceiro elemento da matriz (A4/B4 ou divide "" por 23), não localiza nenhum erro e, em seguida, retorna o resultado da fórmula

0

Observação: se você tiver uma versão atual do Office 365, poderá inserir a fórmula na parte superior esquerda do intervalo de saída e, em seguida, pressionar Enter para confirmar a fórmula como uma fórmula de matriz dinâmica. Caso contrário, a fórmula deve ser inserida como uma fórmula de matriz herdada primeiro selecionando o intervalo de saída, inserindo a fórmula na célula superior esquerda do intervalo de saída e, em seguida, pressione CTRL + SHIFT + ENTER para confirmá-la. O Excel insere chaves no início e no final da fórmula para você. Para obter mais informações sobre fórmulas de matriz, confira Diretrizes e exemplos de fórmulas de matriz.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no User Voice do Excel.

Observação:  Esta página foi traduzida automaticamente e pode apresentar erros gramaticais ou imprecisões. Nosso objetivo é que este conteúdo seja útil para você. Você pode nos dizer se as informações foram úteis? Use o artigo em inglês como referência.​

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×