Publicar uma pasta de trabalho em um site do SharePoint no Excel para Windows

Você pode publicar uma pasta de trabalho em uma biblioteca do Microsoft SharePoint para que as pessoas possam exibi-la ou editá-la em um navegador da Web sem precisar instalar o Excel em seus computadores. Essencialmente, publicar é igual a salvar, mas com algumas opções internas que permitem controlar o que as pessoas podem ver quando abrem a pasta de trabalho em um navegador.

A adoção em toda a organização da prática de salvar ou publicar uma pasta de trabalho em um site central do SharePoint pode ajudar você a assegurar que versões ligeiramente diferentes da mesma pasta de trabalho não comecem a surgir por toda a organização quando ela for distribuída em um email.

Ao definir algumas opções de publicação, você pode enfatizar partes específicas da sua pasta de trabalho, como gráficos, ou excluir outras partes da exibição no navegador. Por exemplo, você pode mostrar um gráfico, mas não seus dados subjacentes. Ou pode mostrar apenas determinadas planilhas às pessoas que precisam vê-las e ocultar as demais planilhas.

Este artigo mostra como publicar uma pasta de trabalho do Excel para Windows e não abrange a conexão de dados de uma pasta de trabalho ou pasta de trabalho a uma Web Part do Excel Web Access em uma página do SharePoint.

Quando você publica uma pasta de trabalho em um site do SharePoint, a pasta de trabalho inteira é salva no SharePoint. Um usuário com as permissões necessárias do SharePoint pode exibir a pasta de trabalho inteira e trabalhar com ela no navegador ou no programa de desktop Excel.

Se o Office para a Web for implantado no SharePoint, exibir e trabalhar com seus dados no navegador poderá ser muito semelhante a trabalhar com seus dados no programa de área de trabalho do Excel. De fato, diferentemente do programa de área de trabalho do Excel, vários usuários podem editar simultaneamente uma pasta de trabalho na grade do navegador. Quando você exibe uma pasta de trabalho no navegador, se o botão Editar no Excel Online estiver visível, você saberá que o Office para a Web está pronto para ser usado.

Editar no Excel Online no menu Editar Pasta de Trabalho

Preparar a pasta de trabalho

Antes de publicar a pasta de trabalho, você pode optar por selecionar apenas as planilhas ou os itens que quer que fiquem visíveis no navegador. Lembre-se apenas de que, embora você possa limitar o que pode ser visualizado nesse modo, todo o conteúdo da pasta de trabalho ainda é salvo no servidor do SharePoint.

Se você quiser incluir planilhas inteiras como um item além de outros itens, como gráficos ou tabelas dinâmicas, defina a planilha inteira como um intervalo nomeado. Selecione toda a planilha e, em seguida, defina um intervalo nomeado. Esse intervalo nomeado será exibido como um item disponível na caixa de diálogo Opções de publicação quando você estiver pronto para publicar.

Para permitir que os usuários insiram um valor em uma célula para trabalhar com uma fórmula em outra célula, configure essa célula como um nome definido no Excel antes de publicar a pasta de trabalho. Você pode então adicionar esse nome definido como um parâmetro na guia Parâmetros da caixa de diálogo Opções de Exibição no Navegador.

Por exemplo, a seguir está uma célula D2, que tem o nome definido "Taxa". No navegador, um usuário insere o valor 5,625 na caixa Taxa no painel Parâmetros e clica em Aplicar. Esse valor então aparece na célula D2 e a fórmula em A2 usa o valor em D2. O resultado da fórmula é recalculado e mostrado em A2: US$ 1.151,31.

A inserção de um parâmetro no painel usado na célula D2

Observação: Se você criar segmentações de dados para uma tabela do Excel e definir um nome para o intervalo de células contendo a tabela e as segmentações de dados, você não poderá usar as segmentações de dados para filtrar a tabela no navegador se publicar o intervalo definido. Se você publicar a tabela ou a planilha inteira ou sua pasta de trabalho, as segmentações de dados funcionarão conforme o esperado no navegador.

Publicar a pasta de trabalho

  1. Clique na guia Arquivo, clique em Salvar como e clique em SharePoint.

  2. Se você vir a sua pasta do SharePoint em Atual, Recente ou Mais antigos, clique na pasta desejada.

    A caixa de diálogo Salvar como é exibida.


    Caso contrário, clique em Procurar, insira o endereço Web do site do SharePoint e navegue até a pasta na qual você deseja publicar a pasta de trabalho.

    Clique em uma pasta do SharePoint ou clique em Procurar
  3. Para selecionar planilhas ou itens individuais da pasta de trabalho, clique em Opções de Exibição do Navegador.

    Na caixa de diálogo Salvar como, clique em Opções de Exibição do Navegador

    Você verá a guia Mostrar e a guia Parâmetros.

  4. Se quiser apenas publicar a pasta de trabalho inteira, clique em Salvar. Caso contrário, siga um destes procedimentos:

    • Para mostrar a pasta de trabalho inteira no navegador, na guia Mostrar, selecione Pasta de Trabalho Inteira na caixa de listagem.

    • Para mostrar apenas planilhas específicas no navegador, na guia Mostrar, selecione Planilhas na caixa de listagem e depois desmarque as caixas de seleção das planilhas que você não quer ocultar no navegador.

      Por padrão, todas as planilhas estão selecionadas. Para tornar todas as planilhas rapidamente visíveis após desmarcar algumas caixas de seleção, marque a caixa de seleção Todas as Planilhas.

    • Para mostrar apenas itens específicos no navegador (como intervalos nomeados, gráficos, tabelas ou Tabelas Dinâmicas), na guia Mostrar, selecione Itens na Pasta de Trabalho na caixa de listagem e depois marque as caixas de seleção dos itens que você deseja mostrar.

    • Na guia Parâmetros, adicione todos os nomes definidos que você deseja usar para especificar células que são editáveis quando os usuários exibem a pasta de trabalho no navegador e clique em OK.

  5. Salve a pasta de trabalho.

Observações: 

  • Se você selecionar itens que tenham o mesmo nome (como um gráfico e sua tabela de dados subjacente), somente um desses itens estará disponível no navegador. Para mostrar todos os itens, verifique se cada item na pasta de trabalho tem um nome exclusivo.

  • Você pode renomear tabelas na guia Design do grupo Propriedades, renomear Tabelas Dinâmicas na guia Opções do grupo Tabela Dinâmica e renomear gráficos ou Gráficos Dinâmicos na guia Layout do grupo Propriedades. Renomeie outros itens duplicados, como intervalos nomeados, na guia Fórmulas do grupo Nomes Definidos.

Se o Office para a Web for implantado no SharePoint, exibir e trabalhar com seus dados no navegador poderá ser muito semelhante a trabalhar com seus dados no programa de área de trabalho do Excel. De fato, diferentemente do programa de área de trabalho do Excel, vários usuários podem editar simultaneamente uma pasta de trabalho na grade do navegador. Quando você exibe uma pasta de trabalho no navegador, se o botão Editar no Excel Online estiver visível, você saberá que o Office para a Web está pronto para ser usado.

Editar no Excel Online no menu Editar Pasta de Trabalho

Para obter mais informações, consulte o artigo diferenças entre usar uma pasta de trabalho no Excel e nos serviços do Excel.

Preparar a pasta de trabalho

Antes de publicar a pasta de trabalho, você pode optar por selecionar apenas as planilhas ou os itens que quer que fiquem visíveis no navegador. Lembre-se apenas de que, embora você possa limitar o que pode ser visualizado nesse modo, todo o conteúdo da pasta de trabalho ainda é salvo no servidor do SharePoint.

Se você quiser incluir planilhas inteiras como um item além de outros itens, como gráficos ou tabelas dinâmicas, defina a planilha inteira como um intervalo nomeado. Selecione toda a planilha e, em seguida, defina um intervalo nomeado. Esse intervalo nomeado será exibido como um item disponível na caixa de diálogo Opções de publicação quando você estiver pronto para publicar.

Para permitir que os usuários insiram um valor em uma célula para trabalhar com uma fórmula em outra célula, configure essa célula como um nome definido no Excel antes de publicar a pasta de trabalho. Você pode então adicionar esse nome definido como um parâmetro na guia Parâmetros da caixa de diálogo Opções de Exibição no Navegador.

Por exemplo, a seguir está uma célula D2, que tem o nome definido "Taxa". No navegador, um usuário insere um valor, 5,625, na caixa do painel de parâmetros e clica em aplicar. Esse valor então aparece na célula D2 e a fórmula em A2 usa o valor em D2. O resultado da fórmula é recalculado e mostrado em A2: US$ 1.151,31.

Consulte a ajuda do Excel para obter informações sobre como definir intervalos.

A inserção de um parâmetro no painel usado na célula D2

Observação: Se você criar segmentações de dados para uma tabela do Excel e definir um nome para o intervalo de células contendo a tabela e as segmentações de dados, você não poderá usar as segmentações de dados para filtrar a tabela no navegador se publicar o intervalo definido. Se você publicar a tabela ou a planilha inteira ou sua pasta de trabalho, as segmentações de dados funcionarão conforme o esperado no navegador.

Publicar a pasta de trabalho

  1. Clique em arquivo > salvar como >SharePoint.

  2. Se você vir a pasta do SharePointna pasta atual ou em pastas recentes, clique na pasta desejada. Caso contrário, clique em procurar e insira o endereço Web do site do SharePoint. Em seguida, navegue até a pasta na qual você deseja publicar a pasta de trabalho. A caixa de diálogo Salvar como é exibida.

  3. Para selecionar planilhas ou itens individuais da pasta de trabalho, clique em Opções de Exibição do Navegador. Você verá uma guia Mostrar e uma guia parâmetros . Se quiser apenas publicar a pasta de trabalho inteira, clique em Salvar. Caso contrário, siga um destes procedimentos:

    • Para mostrar a pasta de trabalho inteira no navegador, na guia Mostrar, selecione Pasta de Trabalho Inteira na caixa de listagem.

    • Para mostrar somente planilhas específicas no navegador, na guia Mostrar , selecione planilhas na caixa de listagem e desmarque as caixas das planilhas que você não deseja ocultar no navegador.

      Por padrão, todas as planilhas estão selecionadas. Para fazer com que todas as planilhas sejam exibidas rapidamente novamente após desmarcar algumas das caixas, marque a caixa de seleção todas as planilhas .

    • Para mostrar apenas itens específicos no navegador (como intervalos nomeados, gráficos, tabelas ou tabelas dinâmicas), na guia Mostrar , selecione itens na pasta de trabalho na caixa de listagem e marque as caixas dos itens que você deseja mostrar.

    • Na guia parâmetros , adicione os nomes definidos que você deseja usar para especificar as células que são editáveis quando os usuários visualizam a pasta de trabalho no navegador. Em seguida, clique em OK para fechar a caixa de diálogo.

  4. Salve a pasta de trabalho.

Observações: 

  • Se você selecionar itens que tenham o mesmo nome (como um gráfico e sua tabela de dados subjacente), somente um desses itens estará disponível no navegador. Para mostrar todos os itens, verifique se cada item na pasta de trabalho tem um nome exclusivo.

  • Se você selecionar itens que tenham o mesmo nome (como um gráfico e sua tabela de dados subjacente), somente um desses itens estará disponível no navegador. Para mostrar todos os itens, verifique se cada item na pasta de trabalho tem um nome exclusivo.

  • Você pode renomear tabelas na guia Design do grupo Propriedades, renomear Tabelas Dinâmicas na guia Opções do grupo Tabela Dinâmica e renomear gráficos ou Gráficos Dinâmicos na guia Layout do grupo Propriedades. Renomeie outros itens duplicados, como intervalos nomeados, na guia Fórmulas do grupo Nomes Definidos.

  • Você pode renomear tabelas na guia Design do grupo Propriedades, renomear Tabelas Dinâmicas na guia Opções do grupo Tabela Dinâmica e renomear gráficos ou Gráficos Dinâmicos na guia Layout do grupo Propriedades. Renomeie outros itens duplicados, como intervalos nomeados, na guia Fórmulas do grupo Nomes Definidos.

Para obter mais informações sobre Web Parts do Excel Web Access, confira o artigo exibir uma pasta de trabalho em uma Web Part do Excel Web Access.

Quando você publica uma pasta de trabalho em um servidor do SharePoint, todo o conteúdo da pasta de trabalho é salvo no servidor e poderá ser visualizado e trabalhado se você abrir a pasta de trabalho no programa de área de trabalho do Excel. Se o Office Web Apps for implantado no servidor do SharePoint, exibir e trabalhar com seus dados no navegador da Web pode ser muito parecido com trabalhar com seus dados no programa da área de trabalho do Excel. Na verdade, a edição simultânea de uma pasta de trabalho é possível na grade do navegador quando o Office Web Apps é implantado. Quando você exibe uma pasta de trabalho no navegador, se o botão Editar no navegador estiver visível, isso significa que os Office Web Apps estão disponíveis.

Botão Editar no Navegador

Para obter mais informações, consulte o artigo diferenças entre usar uma pasta de trabalho no Excel e nos serviços do Excel.

Preparar a pasta de trabalho

Antes de publicar a pasta de trabalho, você tem a oportunidade (na caixa de diálogo Opções de publicação ) para selecionar as planilhas ou os itens que você deseja que fiquem visíveis no navegador quando a edição não tiver sido habilitada clicando no botão Editar no navegador . Lembre-se de que, embora você possa selecionar o que é visível nesse modo, todo o conteúdo da pasta de trabalho ainda é salvo no servidor do SharePoint.

Se você quiser incluir planilhas inteiras como um item além de outros itens, como gráficos ou tabelas dinâmicas, defina a planilha inteira como um intervalo nomeado. Selecione toda a planilha e, em seguida, defina um intervalo nomeado. Esse intervalo nomeado será exibido como um item disponível na caixa de diálogo Opções de publicação quando você estiver pronto para publicar.

Se você quiser permitir que os usuários forneçam um parâmetro a uma fórmula ao exibir uma planilha em um navegador, defina uma célula como um nome definido. Em seguida, você pode adicionar esse nome definido como um parâmetro na guia parâmetros na caixa de diálogo Opções de publicação .

Por exemplo, no gráfico a seguir que mostra uma planilha no navegador, a célula D2 tem a taxa de nomes definida. No navegador, um usuário inseriu um valor, 5,625, na caixa do painel parâmetros e clica em aplicar. Esse valor então aparece na célula D2 e a fórmula em A2 usa o valor em D2. O resultado da fórmula é recalculado e mostrado em A2: US$ 1.151,31.

Usando um parâmetro no navegador

Consulte a ajuda do Excel para obter informações sobre como definir intervalos.

Publicar a pasta de trabalho

  1. Clique na guia Arquivo e depois em Salvar e Enviar.

  2. Clique em salvar no SharePoint.
    Observação    se o comando salvar no SharePoint não estiver disponível, você ainda poderá salvar a pasta de trabalho em um site do SharePoint usando o comando salvar como . A caixa de diálogo Opções de publicação não estará disponível. Você também pode carregar diretamente a pasta de trabalho de uma biblioteca do SharePoint. Os usuários podem exibir e editar o conteúdo da pasta de trabalho no navegador indo diretamente para o site em que a pasta de trabalho é salva.

    O comando Salvar como

  3. Se você quiser selecionar planilhas individuais ou itens a serem publicados na pasta de trabalho, clique no botão Opções de publicação . Caso contrário, se você quiser publicar a pasta de trabalho inteira, pule diretamente para a etapa 4.
    Na guia Mostrar , faça o seguinte:

    • Para mostrar a pasta de trabalho inteira no navegador, selecione toda a pasta de trabalho na caixa de listagem.

    • Para mostrar somente planilhas específicas no navegador, selecione planilhas na caixa de listagem e desmarque as caixas de seleção das planilhas que você não deseja que fiquem visíveis.
      Observação    por padrão, todas as planilhas são selecionadas. Para fazer com que todas as planilhas sejam exibidas rapidamente novamente depois de desmarcar algumas das caixas de seleção, você pode marcar a caixa de seleção todas as planilhas .

    • Para mostrar apenas itens específicos no navegador (como intervalos nomeados, gráficos, tabelas ou tabelas dinâmicas), selecione os itens na pasta de trabalho na caixa de listagem e marque as caixas de seleção dos itens que você deseja mostrar.
      Observação se você selecionar itens que tenham o mesmo nome (como um gráfico e sua tabela de dados subjacente), apenas um desses itens estará disponível no navegador. Para mostrar todos os itens, você deve verificar se cada item na pasta de trabalho tem um nome exclusivo. Você pode renomear tabelas na guia Design do grupo Propriedades, renomear Tabelas Dinâmicas na guia Opções do grupo Tabela Dinâmica e renomear gráficos ou Gráficos Dinâmicos na guia Layout do grupo Propriedades. Itens duplicados, como intervalos nomeados, podem ser renomeados na guia fórmulas do grupo nomes definidos .
      Selecionando planilhas ou itens

    • Na guia parâmetros , adicione os nomes definidos que você deseja usar para especificar células que sejam editáveis quando os usuários exibirem a pasta de trabalho no navegador. Em seguida, clique em OK para fechar a caixa de diálogo.
      Definindo parâmetros

  4. Escolha um local no qual deseja publicar a pasta de trabalho.
    Pode ser que já haja locais do servidor salvos em local atual, locais recentesou locais dos quais você pode escolher. Se não houver esses locais ou se você quiser salvar em um novo local, em locais, clique duas vezes em procurar um local.

  5. Na caixa de diálogo salvar como , insira o endereço Web do site do SharePoint e navegue até o site ou a biblioteca em que você deseja salvar sua pasta de trabalho.

  6. Se você ainda não tiver selecionado planilhas ou itens individuais ou definir parâmetros, clique no botão Opções de publicação .

  7. Na caixa nome do arquivo , aceite o nome sugerido para a pasta de trabalho ou digite um novo nome, se desejar.

  8. Para exibir o conteúdo da pasta de trabalho em uma janela do navegador imediatamente após a conclusão da operação de publicação, certifique-se de que a caixa de seleção abrir com o Excel no navegador esteja marcada.

  9. Clique em Salvar.

Observação:  Esta página foi traduzida automaticamente e pode apresentar erros gramaticais ou imprecisões. Nosso objetivo é que este conteúdo seja útil para você. Você pode nos dizer se as informações foram úteis? Use o artigo em inglês como referência.​

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×