Obter dados do Analysis Services

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

O Analysis Services fornece dados dimensionais adequados para a exploração de dados em Tabelas dinâmicas e relatórios do Power View. Você pode obter dados do Analysis Services de:

  • Cubos OLAP em um servidor do Analysis Services multidimensional.

  • Modelos de tabela em um servidor tabular do Analysis Services.

  • Se a pasta de trabalho contém um modelo de dados do Excel no SharePoint 2010 ou posterior, as pastas de trabalho.

Você pode analisar os dados a partir de uma fonte de dados externa do Analysis Services usando uma conexão online. À medida que você transforma linhas em colunas, corta e filtra um relatório, o Excel consulta o Analysis Services em busca dos dados que você pediu. A análise dos dados dessa maneira exige uma conexão online com a fonte de dados.

Outra abordagem é trabalhar offline. Você pode trabalhar offline importando dados em sua pasta de trabalho de modo que as visualizações de dados e de relatório sejam independentes e totalmente portáteis em um único arquivo. Se você importar dados, é necessário saber que ao fazer isso está introduzindo novas exigências, incluindo o suplemento do Power Pivot, algum conhecimento de MDX e espaço em disco suficiente para armazenar pastas de trabalho maiores. Este artigo explica como importar dados de diferentes fontes de dados do Analysis Services.

Pastas de trabalho do Excel que você salvar no SharePoint ou no Office 365 estão sujeitos a um tamanho máximo de arquivo. Usando o Assistente de importação de tabela no suplemento do Power Pivot, você pode importar seletivamente tabelas, colunas e linhas para reduzir o tamanho de arquivo geral. Se sua pasta de trabalho é grande demais para exibir em Excel Online, você pode abri-lo no Excel, em vez disso.

O Office 365 proíbe a atualização de dados em fontes de dados externas, incluindo soluções do Analysis Services executadas em servidores de rede. Se suas necessidades incluem dados atualizáveis, escolha o SharePoint ou use um compartilhamento de arquivo de rede.

Neste artigo

Pré-requisitos

Conectar a um cubo, modelo de tabela ou modelo de dados do Power Pivot

Importar dados de um cubo

Importar dados de um modelo de tabela

Importar dados de um modelo de dados de pasta de trabalho no SharePoint

Atualizar os dados de um banco de dados externo do Analysis Services

Pré-requisitos

Cubos do Analysis Services devem ser a versão do SQL Server 2005 ou posterior.

Bancos de dados de modelo tabular do Analysis Services estão somente no SQL Server 2012 ou posterior.

Você precisa saber como se conectar a um banco de dados do Analysis Services. Verifique com o administrador de banco de dados do Analysis Services para determinar os nomes do servidor e do banco de dados e quais credenciais usar.

Para importar dados em um modelo de dados, você deve ter o suplemento Power Pivot que acompanha o Office Professional Plus. Você também precisa saber como escrever uma consulta MDX que recupera os dados que você deseja usar. As alternativas para escrever a consulta MDX incluem o uso de um construtor de consultas para escolher quais medidas, atributos de dimensão e hierarquias você deseja analisar.

Para se conectar a uma Tabela dinâmica ou Gráfico dinâmico de forma interativa por meio do Excel, nenhum conhecimento sobre MDX é necessário. O Excel se conecta a um cubo OLAP inteiro ou modelo de tabela.

Os tamanhos de arquivo serão maiores do que você pode estar acostumado. A título de comparação, uma pasta de trabalho que usa uma conexão de dados pode facilmente cair abaixo dos 100 KB, enquanto a mesma pasta de trabalho com dados importados pode ter dez vezes o tamanho. Se o espaço em disco for um problema, você precisará liberar espaço para arquivos maiores.

pastas de trabalho de Power Pivot que você usa como fontes de dados podem ser publicadas com o SharePoint 2010 ou posterior. O site do SharePoint deve estar executando em um computador diferente do que você está usando para criar um relatório. Você deve ter permissões de exibição no site do SharePoint ao relatório nas pastas de trabalho no SharePoint.

Conectar a um cubo, modelo de tabela ou modelo de dados do Power Pivot

A maneira mais fácil de analisar os dados em um cubo ou modelo do Analysis Services é configurar uma conexão com um banco de dados externo. A Tabela dinâmica ou relatório terá uma conexão ativa com a fonte de dados. Cada vez que você arrastar um campo para uma área de Valores, Linhas, Colunas ou Filtro de uma lista de Campos, o Excel criará uma consulta e a enviará ao Analysis Services.

Ter uma conexão ativa com os dados que você está analisando tem suas vantagens. Você pode executar uma análise livre. Adicione qualquer campo a uma Tabela dinâmica ou relatório e o Analysis Services devolverá os dados que você solicitou. Uma lista de Campos conectada ao Analysis Services inclui todos os objetos em um cubo ou modelo, assim você não precisa escrever MDX para obter os dados que deseja.

As desvantagens incluem a dependência de uma conexão com o servidor. Se o servidor cair, ou se você quiser trabalhar offline, a manipulação de dados será completamente interrompida.

Início da Página

Importar dados de um cubo

Quaisquer dados contidos em um banco de dados do SQL Server Analysis Services podem ser copiados para um modelo de dados no Excel. É possível extrair total ou parcialmente uma dimensão, ou obter fatias e agregações do cubo, como soma das vendas, mês a mês, durante o ano atual.

O procedimento a seguir demonstra como usar o suplemento e MDX a fim de obter um subconjunto de dados de um cubo tradicional em uma instância do Analysis Services. O MDX sempre é usado ao criar uma consulta usando o suplemento Power Pivot.

Este procedimento usa o banco de dados de exemplo Adventure Works DW Multidimensional 2012 para explicar como importar um subconjunto de um cubo. Se você tiver acesso a um servidor do Analysis Services que tem o banco de dados de exemplo Adventure Works DW Multidimensional 2012, siga estas etapas para aprender a importar dados do Analysis Services.

  1. Na janela do Power Pivot, clique em Obter Dados Externos > Do Banco de Dados > Do Analysis Services ou Power Pivot.

  2. Em Conectar-se ao Microsoft SQL Server Analysis Services, em Nome do Servidor ou do Arquivo, digite o nome do computador que executa o Analysis Services.

  3. Clique na seta para baixo à direita da lista Nome do banco de dados e selecione um banco de dados do Analysis Services na lista. Por exemplo, se você tiver acesso ao banco de dados de exemplo Adventure Works DW Multidimensional 2012, selecionará Adventure Works DW Multidimensional 2012.

  4. Clique em Testar Conexão para verificar se o servidor do Analysis Services está disponível.

  5. Clique em Próximo.

  6. Na página Especificar uma Consulta MDX, clique em Design para abrir um construtor de consultas MDX.

    Nesta etapa, você arrasta para a área de design de consulta grande todas as medidas, atributos de dimensão, hierarquias e membros calculados que deseja importar.

    Escolha pelo menos uma medida e uma ou mais dimensões.

    Se você tiver uma instrução MDX existente que queira usar, cole a instrução na caixa de texto e clique em Validar para ter a certeza de que a instrução funcionará. Para obter mais informações sobre como usar o designer, consulte Designer de consulta MDX do Analysis Services (Power Pivot).

    Neste procedimento, usando o cubo de exemplo Adventure Works, faça o seguinte:

    1. No painel Metadados, expanda Medidas e, em seguida, expanda Resumo das Vendas.

    2. Arraste Valor Médio das Vendas para o painel de design grande.

    3. No painel Metadados, expanda a dimensão Produto.

    4. Arraste Categorias do Produto para a esquerda de Valor Médio das Vendas na área de design grande.

    5. No painel Metadados, expanda a dimensão Data e, em seguida, expanda Calendário.

    6. Arraste Date.Calendar Year para a esquerda de Categoria na área de design grande.

    7. Se desejar, adicione um filtro para importar um subconjunto dos dados. No painel localizado na parte superior direita do designer, em Dimensão, arraste Data para o campo de dimensão. Em Hierarquia, selecione Date.Calendar Year; em Operador, selecione Diferente de; para Expressão do Filtro, clique na seta para baixo e selecione CY 2009 e CY 2010.

      Esse procedimento criará um filtro no cubo para que você exclua os valores de 2009.

  7. Clique em OK e revise a consulta MDX criada pelo designer de consulta.

  8. Digite um nome amigável para o conjunto de dados. Esse nome será usado como o nome da tabela no modelo de dados. Se você não atribuir um novo nome, por padrão, os resultados da consulta serão salvos em uma nova tabela chamada Query.

  9. Clique em Concluir.

  10. Quando o carregamento dos dados terminar, clique em Fechar.

Todos os dados importados de um banco de dados de cubo são simplificados. Em seu modelo, os dados aparecem como uma única tabela contendo todas as colunas especificadas em sua consulta. Se você definiu uma consulta que recupera medidas ao longo de várias dimensões, os dados serão importados com cada dimensão em uma coluna separada.

Depois que você importar os dados no modelo de dados, convém verificar o tipo de dados de colunas que contêm dados numéricos ou financeiros. Se o Power Pivot encontrar valores vazios em uma coluna, ele alterará o tipo de dados para Texto. Você pode verificar e alterar o tipo de dados selecionando cada coluna e exibindo Tipo de Dados no grupo Formatação na faixa de opções. É possível usar a opção Tipo de Dados para corrigir o tipo de dados se seus dados numéricos ou financeiros forem atribuídos ao tipo errado.

Para usar os dados em uma Tabela dinâmica, alterne de volta para o Excel:

  1. Clique em Inserir > Tabela > Tabela Dinâmica.

  2. Clique em Usar fontes de dados externas e clique em Escolher Conexões.

  3. Clique em Tabelas.

  4. Em Modelo de Dados desta Pasta de Trabalho, selecione a tabela que você acabou de importar.

Início da Página

Importar dados de um modelo de tabela

O procedimento a seguir descreve a importação de dados, usando a amostra de banco de dados tabular como exemplo. Você pode usar a amostra, Modelo de Tabela Adventure Works do SQL 2012, em execução em um servidor tabular do Analysis Services, para acompanhar.

  1. Certifique-se de que banco de dados tabular contenha pelo menos uma medida. A importação falhará se faltar medidas para o banco de dados. Se você estiver usando a solução da amostra, ela inclui medidas.

  2. Na janela do Power Pivot, clique em Obter Dados Externos > Do Banco de Dados > Do Analysis Services ou Power Pivot.

  3. Em Conectar-se ao Microsoft SQL Server Analysis Services, em Nome do Servidor ou do Arquivo, digite o nome do computador que executa o Analysis Services.

  4. Clique na seta para baixo à direita da lista Nome do banco de dados e selecione um banco de dados do Analysis Services na lista. Por exemplo, se você tem acesso ao banco de dados de exemplo Modelo Tabular de Vendas pela Internet AW, deve selecionar Modelo Tabular da Adventure Works do SQL 2012

  5. Clique em Testar Conexão para verificar se o servidor do Analysis Services está disponível.

  6. Clique em Próximo.

  7. Na página Especificar uma Consulta MDX, clique em Design para abrir um construtor de consultas MDX.

    Nesta etapa, você arrasta para a área de design de consulta grande todas as medidas, colunas e hierarquias que você deseja importar.

    Se você tiver uma instrução MDX existente que queira usar, cole a instrução na caixa de texto e clique em Validar para ter a certeza de que a instrução funcionará. Para obter mais informações sobre como usar o designer, consulte Designer de Consultas MDX do Analysis Services (Power Pivot).

    Neste procedimento, usando a amostra de modelo como exemplo, faça o seguinte:

    1. No painel Metadados, expanda Medidas e, em seguida, expanda Vendas pela Internet.

    2. Arraste Total de Vendas pela Internet para o painel de design grande.

    3. Expanda a tabela Produto.

    4. Role até o final da lista e arraste Categoria para a esquerda de Total de Vendas pela Internet na área de design grande. Esta é uma hierarquia, então ela retornará todos os campos na hierarquia.

    5. Expanda a tabela Data.

    6. Arraste Ano Civil para a esquerda de Categoria na área de design grande.

    7. Expanda Território de Vendas.

    8. Arraste Região de Território de Vendas para a área Filtro na parte superior do designer. Na expressão Filtro, selecione Austrália.

      Consulta MDX para amostra de banco de dados tabular

  8. Clique em OK e revise a consulta MDX criada pelo designer de consulta.

  9. Digite um nome amigável para o conjunto de dados. Esse nome será usado como o nome da tabela no modelo de dados. Se você não atribuir um novo nome, por padrão, os resultados da consulta serão salvos em uma nova tabela chamada Query.

  10. Clique em Concluir.

  11. Quando o carregamento dos dados terminar, clique em Fechar.

Depois que você importar os dados no modelo de dados, convém verificar o tipo de dados de colunas que contêm dados numéricos ou financeiros. Se o Power Pivot encontrar valores vazios em uma coluna, ele alterará o tipo de dados para Texto. Você pode verificar e alterar o tipo de dados selecionando cada coluna e exibindo Tipo de Dados no grupo Formatação na faixa de opções. É possível usar a opção Tipo de Dados para corrigir o tipo de dados se seus dados numéricos ou financeiros forem atribuídos ao tipo errado.

Para usar os dados em uma Tabela dinâmica, alterne de volta para o Excel:

  1. Clique em Inserir > Tabela > Tabela Dinâmica.

  2. Clique em Usar fontes de dados externas e clique em Escolher Conexões.

  3. Clique em Tabelas.

  4. Em Modelo de Dados desta Pasta de Trabalho, selecione a tabela que você acabou de importar.

Início da Página

Importar dados de um modelo de dados de pasta de trabalho no SharePoint

SharePoint talvez seja necessário software adicional para carregar os dados. Se você estiver usando o SharePoint 2010, você deve ter Power Pivot para SharePoint 2010. Em contraste, o SharePoint 2013 ou superior inclui o recurso interno para carregar e consultar um modelo de dados. Se você estiver usando o SharePoint, pergunte ao administrador do SharePoint se os serviços do Excel é habilitado e configurado para cargas de trabalho de BI.

  1. Na janela do Power Pivot, clique em Obter Dados Externos > Do Banco de Dados > Do Analysis Services ou Power Pivot.

  2. Em Conecte-se ao Microsoft SQL Server Analysis Services, em Nome de conexão amigável, digite um nome descritivo para a conexão de dados. O uso de nomes descritivos na conexão pode ajudar você a se lembrar de como a conexão é utilizada.

  3. Em Nome do Servidor ou do Arquivo, digite o endereço de URL do arquivo .xlsx publicado. Por exemplo, http://Contoso-srv/Shared Documents/ContosoSales.xlsx.

    Observação : Não é possível usar uma pasta de trabalho local do Excel como uma fonte de dados; a pasta de trabalho do deve ser publicada em um site do SharePoint.

  4. Clique em Testar Conexão para verificar se a pasta de trabalho no SharePoint está disponível.

  5. Clique em Próximo.

  6. Clique em Design.

  7. Compile a consulta arrastando medidas, atributos de dimensão ou hierarquias para a área de design grande. Se desejar, use o painel de filtro no canto superior direito para selecionar um subconjunto dos dados a serem importados.

  8. Clique em OK.

  9. Clique em Validar.

  10. Clique em Concluir.

Os dados do Power Pivot são copiados para o modelo de dados e armazenados em um formato compactado. Depois que os dados forem importados, a conexão à pasta de trabalho será fechada. Para consultar novamente os dados originais, você pode atualizar a pasta de trabalho no Excel.

Início da Página

Atualizar os dados de um banco de dados externo do Analysis Services

No Excel, clique em Dados > Conexões > Atualizar Tudo para reconectar-se a um banco de dados do Analysis Services e atualizar os dados na pasta de trabalho.

A atualização atualizará células individuais e adicionará linhas introduzidas no banco de dados externo desde a última importação. Somente as linhas e colunas existentes serão atualizadas; para adicionar uma nova coluna ao modelo, você precisará importá-la seguindo as etapas fornecidas anteriormente neste artigo.

A atualização executa novamente a consulta usada para importar os dados. Se a fonte de dados não estiver mais no mesmo local ou se as tabelas ou colunas tiverem sido removidas ou renomeadas, a atualização falhará, mas você ainda terá os dados importados anteriormente. Para exibir a consulta usada durante a atualização de dados, clique em Power Pivot > Gerenciar para abrir a janela Power Pivot. Clique em Design > Propriedades da Tabela para exibir a consulta.

O Analysis Services usa sua conta de usuário do Windows para ler os dados de seus bancos de dados. Antes de você poder importar dados, um administrador de banco de dados tinha que conceder permissões de leitura para sua conta de usuário do Windows no banco de dados. Estas mesmas permissões também são usados para atualizar dados. Se outras pessoas que também quiserem atualizar os dados, elas também precisarão de permissões de leitura no banco de dados.

Lembre-se de que maneira de compartilhar sua pasta de trabalho determinará se a atualização de dados pode ocorrer. No Office 365, é possível atualizar dados em uma pasta de trabalho que seja salvo no Office 365. No SharePoint Server 2013 ou versões posteriores, você pode programar a atualização de dados autônoma no servidor, mas isso requer que Power Pivot para SharePoint está instalado e configurado em seu ambiente do SharePoint. Verifique com o administrador do SharePoint para descobrir se a atualização de dados agendada está disponível.

Início da Página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×