Não consigo salvar meu banco de dados replicado no formato Access 2007

Importante:  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Sintomas

No Microsoft Office Access 2007, replicado bancos de dados criados em versões anteriores do Access (. Formato MDB) não pode ser salvos no novo. Formato de arquivo ACCDB. A opção aparece esmaecida (não disponível) quando você tenta usar o comando Salvar como banco de dados (clique do Botão Microsoft Office Imagem do botão Office e, em seguida, clique na seta ao lado de Salvar como ).

Causa

O formato de arquivo .ACCDB não oferece suporte à replicação.

Solução

Use o banco de dados replicado no formato de arquivo .MDB

Você pode continuar usando o banco de dados replicado no formato de arquivo .MDB. Ainda há suporte para o recurso de replicação para o formato de arquivo .MDB.

Recrie manualmente o banco de dados no formato de arquivo Office Access 2007

Se você decidir que o novo formato de arquivo oferece benefícios que superam os benefícios obtidos pela replicação, poderá criar um novo banco de dados, no formato Office Access 2007, e recriar manualmente o banco de dados replicado.

Observação: Este método funcionará em qualquer banco de dados replicado, mas a menos que você esteja trabalhando com uma réplica completa que tenha sido sincronizada com todas as outras réplicas no conjunto de réplicas, todos os dados e projetos que ainda não estejam na sua réplica não estarão no novo banco de dados.

Antes de começar a recriar seu banco de dados, certifique-se de que todos os objetos ocultos e do sistema, na réplica, estejam visíveis. Isso garante que você possa acessar os campos específicos da réplica ao recriá-la.

  1. Abra a réplica que deseja converter. Você deve abrir a réplica usando a mesma versão do Access, usada originalmente para criar a réplica, para exibir os campos ocultos e do sistema.

  2. No menu Ferramentas, clique em Opções. A caixa de diálogo Opções será aberta.

  3. Na guia Exibir, na seção Mostrar, selecione Objetos ocultos e Objetos do sistema. Clique em OK para aplicar as novas configurações e fechar a caixa de diálogo Opções.

Recriar manualmente o banco de dados

  1. Crie um banco de dados vazio e abra-o.

    Observação: O Access cria uma nova tabela vazia nomeada Tabela1. Você deve excluir esta tabela — é possível fazer isso fechando-a imediatamente antes de fazer alterações nela. Clique com o botão direito do mouse em sua guia de objetos e clique em Fechar, no menu de atalho.

  2. Na guia Dados externos, no grupo Importar, clique em acesso.

    A caixa de diálogo Obter Dados Externos - Banco de Dados do Access aparece.

  3. Clique em Procurar para localizar o banco de dados replicado.

  4. Clique no banco de dados replicado que contém os objetos de banco de dados que você deseja recriar no novo banco de dados e clique em Abrir.

  5. Na caixa de diálogo Obter Dados Externos - Banco de Dados do Access, clique em Importar tabelas, consultas, formulários, relatórios, macros e módulos no banco de dados atual e, em seguida, clique em OK.

  6. Clique nos objetos do banco de dados que você deseja importar para o novo banco de dados. Se você quiser importar todos os objetos, clique em Selecionar Tudo em cada guia.

    Importante    Não selecione tabelas neste ponto. Você recriará as tabelas em uma etapa posterior.

  7. Quando terminar de selecionar objetos, clique em OK para importá-los.

    Na última página do assistente, você tem a opção de salvar as etapas de importação para uso futuro. Para isso, marque a caixa de seleção Salvar etapas de importação, insira as informações apropriadas e clique em Salvar Importação.

  8. Abra o banco de dados replicado no Office Access 2007. Para cada tabela no banco de dados replicado, crie uma consulta Criar Tabela, que pegue todos os dados na tabela antiga, e crie uma tabela no novo banco de dados com os mesmos dados.

    Observação: Se o s_GUID é uma chave primária (e chaves estrangeiras em outras tabelas se referir a ela), você deve incluir o campo s_GUID na nova tabela. Se o campo s_GUID não é usado como uma chave primária, não há nenhum motivo para preservá-lo na nova tabela. Não copie os campos s_Lineage e s_Generation para a nova tabela.

    Por padrão, os campos s_GUID, s_Lineage e s_Generation são ocultos. Para exibir esses campos, use o procedimento a seguir:

    1. No banco de dados replicado, certifique-se de que todas as tabelas estejam fechadas.

    2. Clique com o botão direito do mouse na parte superior do Painel de Navegação e clique em Opções de Navegação. A caixa de diálogo Opções de Navegação é aberta.

    3. Na seção Exibir Opções, selecione Mostrar Objetos do Sistema e clique em OK.

      Como?

      1. Crie uma consulta, selecionando as tabelas que contêm os registros que você deseja colocar na nova tabela.

        Como?

        1. Na guia Criar, no grupo Outros, clique em Design da Consulta.

        2. Na caixa de diálogo Mostrar Tabela, clique na guia que lista as tabelas com os dados que você deseja trabalhar.

        3. Clique duas vezes no nome de cada objeto que você deseja adicionar à consulta e, em seguida, clique em Fechar.

        4. Adicione campos à linha Campo na grade de design.

        5. Para exibir os resultados da consulta, clique no menu Exibir e, em seguida, clique em Modo Folha de Dados.

      2. Em modo Design da consulta, na guia Design, no grupo Tipo de Consulta, clique em Criar Tabela. A caixa de diálogo Criar Tabela aparecerá.

      3. Na caixa Nome da Tabela, digite o nome da tabela que você deseja criar ou substituir.

      4. Clique em Outro Banco de Dados e depois digite o caminho do banco de dados onde você deseja colocar a nova tabela ou clique em Procurar para localizar o banco de dados.

      5. Clique em OK.

      6. Na guia Design, no grupo resultados, clique em Executar. Isso tornará a nova tabela.

        Observação: A nova tabela criada não herda as propriedades de campo ou a configuração da chave primária da tabela original.

  9. Para cada tabela, no novo banco de dados, crie o mesmo índice e a chave primária, usados na tabela da réplica.

    Como?

    1. Abra uma tabela no modo Design.

    2. Na parte superior da janela, clique no campo para o qual você deseja criar um índice.

    3. Na parte inferior da janela, clique na caixa da propriedade Indexado e, em seguida, clique em Sim (Duplicação autorizada) ou Sim (Duplicação não autorizada).

    4. Selecione o campo ou os campos que contenham a chave primária.

    5. Na guia Design, no grupo Ferramentas, clique em Chave primária.

  10. Para cada tabela no novo banco de dados, crie as relações existentes para a tabela da réplica.

    Como?

    Quando você cria uma relação entre tabelas, os campos relacionados não precisam ter os mesmos nomes. No entanto, os campos relacionados devem ter o mesmo tipo de dados, a menos que o campo de chave primária for um campo Numeração automática. Você pode associar um campo Numeração automática com um campo número somente se a propriedade TamanhoDoCampo de ambos os campos correspondentes é a mesma. Por exemplo, você pode associar um campo Numeração automática e um campo número se a propriedade TamanhoDoCampo de ambos os campos for Inteiro longo. Mesmo quando os campos coincidentes são campos número, ele devem ter a mesma configuração de propriedade TamanhoDoCampo.

    Definir um um-para-muitos ou um relacionamento individual

    1. Feche qualquer tabela que esteja aberta. Você não pode criar ou modificar relações entre tabelas abertas.

    2. Na guia Ferramentas de Banco de dados, no grupo Mostrar/Ocultar, clique em Relações.

    3. Se você ainda não tiver definido relações em seu banco de dados, a caixa de diálogo Mostrar Tabela será automaticamente exibida.

      Se você precisar adicionar as tabelas que deseja relacionar e a caixa de diálogo Mostrar Tabela não estiver exibida, abra-a: na guia Design, clique no grupo Mostrar/Ocultar, clique no botão Mostrar Tabela.

    4. Clique duas vezes nos nomes das tabelas que você deseja relacionar e feche a caixa de diálogo Mostrar Tabela. Para criar uma relação dentro da mesma tabela, adicione a tabela duas vezes.

    5. Arraste o campo que você deseja relacionar de uma tabela para o campo relacionado na outra tabela.

      Para arrastar vários campos, pressione a tecla CTRL, clique em cada campo e, em seguida, arraste-os.

      Na maior parte dos casos, você arrasta o campo de chave primária (o qual é exibido em texto com negrito), de uma tabela para um campo semelhante (normalmente com o mesmo nome) denominado chave estrangeira, na outra tabela.

    6. A caixa de diálogo Editar Relações é exibida. Verifique os nomes dos campos exibidos nas duas colunas para certificar-se de que eles estejam corretos. Você pode alterá-los, se necessário.

      Defina as opções de relação, se necessário.

    7. Clique no botão Criar para criar a relação.

    8. Repita as etapas de 4 a 7 para cada par de tabelas a ser relacionado.

      Quando você fechar a janela Relações, o Microsoft Access perguntará se você deseja salvar o layout. Salvando o layout ou não, as relações que você criou serão salvas no banco de dados.

    Definir uma relação muitos-para-muitos

    1. Crie as duas tabelas que terão uma relação muitos para muitos.

    2. Crie uma terceira tabela, chamada tabela de junção, e adicione a ela novos campos com as mesmas definições que os campos de chave primária de cada uma das outras duas tabelas. Na tabela de junção, os campos de chave primária funcionam como chaves externas. Você pode adicionar outros campos à tabela de junção, exatamente como você pode fazer em qualquer outra tabela.

    3. Na tabela de junção, defina a chave primária para incluir os campos de chave primária das duas outras tabelas. Por exemplo, em uma tabela de junção Detalhes do Pedido, a chave primária seria composta dos campos NúmeroDoPedido e CódigoDoProduto.

      Como?

      1. Abra a tabela no modo Design.

      2. Selecione o campo ou os campos que deseja definir como a chave primária.

        Para selecionar um campo, clique no seletor de linha do campo desejado.

        Para selecionar vários campos, mantenha pressionada a tecla CTRL e, em seguida, clique no seletor de linha de cada campo.

      3. Na guia Design, no grupo Ferramentas, clique em Chave primária.

        Observação: Se você deseja que a ordem dos campos em uma chave primária de campos múltiplos seja diferente da ordem desses campos na tabela, clique no botão Índices, no grupo Mostrar/Ocultar para exibir a janela Índices e, em seguida, ordene novamente os nomes dos campos para o índice denominado ChavePrimária.

    4. Defina uma relação um-para-muitos entre cada uma das duas tabelas primárias e a tabela de junção.

  11. Salve o seu novo banco de dados.

Observação: Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×