Mover um modelo de formulário publicado para uma nova biblioteca do SharePoint

Observação:  Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. As informações foram úteis? Dê sua opinião no final desta página. Aqui está o artigo em inglês para facilitar a referência.

Neste artigo

Visão geral

Antes de começar

Obter uma cópia de trabalho de seu modelo de formulário

Etapa 1: Publicar o modelo de formulário para a nova biblioteca de documentos

Etapa 2: Copiar e vincular novamente os formulários existentes

Visão geral

Depois de publicar um modelo de formulário em uma biblioteca de documentos para seus usuários preencher, você talvez precise mover esse modelo de formulário para outra biblioteca de documentos. Por exemplo, você pode ter mover seu modelo de formulário para um servidor com mais capacidade, para que mais usuários podem preencher formulários ao mesmo tempo. Alguns usuários podem já tiverem preenchido formulários que são baseados no seu modelo de formulário que foi armazenado na biblioteca de documentos original. Quando você move o seu modelo de formulário para uma nova biblioteca de documentos, deseja mover esses formulários existentes, também. Você também quer certificar-se de que esses formulários existentes funcionam nova biblioteca de documentos antes de arquivar ou excluir a antiga biblioteca de documentos.

Dica: Antes de mover os modelos de formulário publicado para uma nova biblioteca de documentos, crie um plano que inclui informando aos usuários que seus formulários foram movidos para uma nova biblioteca de documentos. Deseja que seus usuários usem a nova biblioteca de documentos para armazenar novos formulários ou modificar formulários existentes. O plano também deve incluir um processo de arquivamento ou a exclusão de biblioteca de documentos original.

Para mover um modelo de formulário e seus formulários existentes para uma nova biblioteca de documentos, primeiro você precisa publicar a cópia de trabalho de seu modelo de formulário para a nova biblioteca de documentos. A cópia de trabalho é a versão que está armazenada no seu computador ou em um programa de controle de versão, como Microsoft Visual SourceSafe.

Dica: Se você não tiver uma cópia de trabalho do modelo de formulário, você pode salvar uma cópia do modelo de formulário da biblioteca de documentos original no seu computador para usar como uma cópia de trabalho.

Depois que você publica a cópia de trabalho para a nova biblioteca de documentos, você precisa copiar todos os formulários da biblioteca de documentos antiga para a nova biblioteca de documentos e, em seguida, vincular novamente os formulários na nova biblioteca de documentos para o modelo de formulário publicado recentemente.

Se você precisar fazer alterações como resultado de mover o modelo de formulário, faça essas alterações antes de publicar o modelo de formulário. Por exemplo, o local das fontes de dados externos que são usadas pelos formulários que são baseados neste modelo de formulário também pode mudar como resultado de mover o modelo de formulário. Nesse caso, você precisa alterar a conexão de dados no modelo de formulário para o novo local das fontes de dados externos antes de publicar o modelo de formulário. Encontre links para obter mais informações sobre como alterar as conexões de dados na seção Consulte também.

Observação: Publicação de um modelo de formulário não é a mesma que salvar um modelo de formulário. Quando você publica um modelo de formulário, o Assistente de publicação adiciona o local de publicação e instruções de processamento para o modelo de formulário para que os usuários podem abrir formulários que são baseados neste modelo de formulário. Quando você salva um modelo de formulário, você está salvando uma cópia do modelo de formulário, assim como faz quando você salva um arquivo no seu computador. Você sempre deve usar o Assistente de publicação quando você quiser disponibilizar seu modelo de formulário para seus usuários preencher.

Início da página

Antes de começar

Antes de mover o modelo de formulário e formulários existentes que são baseados no modelo de formulário para uma nova biblioteca de documentos, você precisará do seguinte:

  • A cópia de trabalho do modelo de formulário    Esta é uma cópia do modelo de formulário que você modifique e depois republicar nova biblioteca de documentos. A cópia de trabalho pode ser armazenada em seu computador ou em um programa de controle de versão, como Visual SourceSafe.

  • Locais de quaisquer novas fontes de dados externas    Se os formulários que são baseados no modelo de formulário usam fontes de dados externas que foram alterados, você precisará os novos locais as fontes de dados externas. Verifique com seu administrador que você e seus usuários têm as permissões apropriadas para usar as fontes de dados externas. Se o modelo de formulário usa configurações em um arquivo de conexão de dados para se conectar à fonte de dados externa, verifique se que o arquivo de conexão de dados foi atualizado com o novo local da fonte de dados externa.

  • Os direitos apropriados no servidor executando o Windows SharePoint Services 3.0    Você terá os direitos apropriados no servidor para publicar um modelo de formulário e copiar quaisquer formulários existentes da biblioteca de documentos antiga para a nova biblioteca de documentos. Verifique com o administrador do servidor para garantir que você tenha esses direitos.

Início da página

Obter uma cópia de trabalho de seu modelo de formulário

Se você deseja modificar um modelo de formulário que foi publicado em uma biblioteca de documentos ou em um local de rede compartilhada e você não tem uma cópia de trabalho de seu modelo de formulário, você pode salvar uma cópia de trabalho do modelo de formulário do local de publicação no seu computador.

Dica: Considere usar um programa de controle de versão, como Microsoft Visual SourceSafe, para gerenciar as cópias de trabalho dos seus modelos de formulário.

Salvar uma cópia do modelo de formulário de uma biblioteca de documentos no seu computador

  1. Em um navegador da Web, abra a biblioteca de documentos onde o modelo de formulário foi publicado.

  2. No menu configurações, clique em configurações e, em seguida, clique em Configurações da biblioteca de formulário.

  3. Em Configurações Gerais, clique em Configurações avançadas.

  4. Na seção Modelo de documento, clique em Editar modelo.

    O modelo de formulário será aberto no Microsoft Office InfoPath.

  5. Na caixa de diálogo Microsoft Office InfoPath, clique em Sim.

  6. No menu Arquivo, clique em Salvar como.

  7. Na caixa de diálogo Microsoft Office InfoPath, clique em Okey.

  8. Na caixa de diálogo Salvar como, navegue até o local onde deseja salvar uma cópia do modelo de formulário e clique em Salvar.

Salvar uma cópia do modelo de formulário da pasta de rede compartilhada com seu computador

  1. No menu arquivo, clique em Design de um modelo de formulário.

  2. Em Abrir um modelo de formulário, clique No meu computador.

  3. Navegue até a pasta de rede compartilhada do modelo de formulário publicado, clique no modelo de formulário e clique em Abrir.

  4. No menu Arquivo, clique em Salvar como.

  5. Na caixa de diálogo Microsoft Office InfoPath, clique em Okey.

  6. Na caixa de diálogo Salvar como, selecione um local diferente de original publicar o local onde você deseja salvar uma cópia de trabalho do modelo de formulário e clique em Salvar.

Início da página

Etapa 1: Publicar o modelo de formulário para a nova biblioteca de documentos

  1. Abra a cópia de trabalho do modelo de formulário no modo de design.

  2. No menu arquivo, clique em Publicar.

  3. No Assistente de publicação, clique em um servidor do SharePoint com ou sem InfoPath Forms Services e clique em Avançar.

  4. Na caixa Digite o local do site do SharePoint ou o InfoPath Forms Services, digite o local do site do SharePoint que contém a nova biblioteca de documentos que você deseja mover seu modelo de formulário e clique em Avançar.

  5. Na próxima página do assistente, clique em Biblioteca de documentos e clique em Avançar.

  6. Clique em criar uma nova biblioteca de documentos e clique em Avançar.

  7. Na próxima página do assistente, digite um nome e uma descrição para a nova biblioteca de documentos e clique em Avançar.

  8. Escolha os campos no modelo de formulário que você deseja exibir como colunas na exibição padrão da biblioteca de documentos.

    Como?

    1. Clique em Adicionar.

    2. Selecione o campo que você deseja adicionar como uma coluna na biblioteca de documentos e, em seguida, siga um destes procedimentos:

      • Digite um nome para a coluna na caixa nome da coluna.

      • Selecione a coluna de site na lista de grupo de colunas de Site, selecione um nome na lista nome da coluna e clique em Okey.

        Observação: Se você selecionou um campo de repetição para exibir dados na biblioteca de documentos, você pode definir como deseja exibir o campo na biblioteca de documentos, clicando em um valor na lista de função. Você pode escolher se deseja exibir o primeiro valor no campo, o último valor no campo ou uma contagem de todas as ocorrências do campo, ou por mesclar todos os valores juntos.

    3. Clique em OK.

    Encontre links para obter mais informações sobre como exibir dados em colunas em uma biblioteca de documentos na seção Consulte também.

  9. Clique em Avançar.

  10. Na próxima página do assistente, verifique se as informações mostradas estão corretas e clique em Publicar.

  11. Para abrir a biblioteca de documentos e testar o processo para preencher um formulário que é baseado neste modelo de formulário, marque a caixa de seleção Abrir esta biblioteca de documentos e, em seguida, clique em Fechar.

    A biblioteca de documentos será aberto em um navegador. Quando você clicar em novo na barra de ferramentas lista, um formulário baseado neste modelo de formulário será aberto no Microsoft Office InfoPath.

Depois de publicar o modelo de formulário para uma nova biblioteca de documentos, você pode copiar os formulários existentes que se baseiam a versão antiga do modelo de formulário da biblioteca de documentos antiga para a nova biblioteca de documentos. Após copiar os formulários existentes, você pode vincular novamente os formulários existentes para a nova versão do modelo de formulário. Se você não vincular os formulários existentes, os usuários não poderá abrir esses formulários existentes.

Início da página

Etapa 2: Copiar e vincular novamente os formulários existentes

Este procedimento pressupõe que ambas as bibliotecas de documentos estão em um servidor que está executando o Windows SharePoint Services 3.0.

  1. Abra a biblioteca de documentos antigos em um navegador da Web.

  2. No menu Exibir, clique em Modo de exibição do Explorer.

  3. Pressione e mantenha pressionada a tecla CTRL, selecione cada formulário que você deseja mover e clique em um dos formulários.

  4. Na caixa de diálogo Internet Explorer, clique em Sim e clique em Copiar no menu de atalho.

  5. Abra a nova biblioteca de documentos.

  6. Em Selecione um modo de exibição, clique em Modo de exibição do Explorer.

  7. Clique com botão direito na área em branco na janela da pasta.

  8. Na caixa de diálogo Internet Explorer, clique em Sim e clique em Colar no menu de atalho.

  9. No menu Exibir, clique em Vincular documentos.

  10. Na coluna vincular novamente, marque a caixa de seleção para cada formulário que você deseja vincular o novo modelo de formulário.

  11. Na barra de ferramentas de lista, clique em Vincular novamente documentos selecionados.

Após vincular novamente os formulários existentes para o novo modelo de formulário, os usuários podem alterar os formulários existentes que você copiou para a nova biblioteca de documentos ou preencha novos formulários que são baseados no modelo de formulário publicado recentemente.

Início da página

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×