Importar bancos de dados do Access 2.0 e do Access 95 para versões atuais

Importar bancos de dados do Access 2.0 e do Access 95 para versões atuais

Se você usar um banco de dados existente no formato do Access 2.0 (.mdb) ou no formato do Access 95 (.mdb), em alguns casos, será possível importar tabelas, consultas e macros desse banco de dados para uma versão mais atual do Access que usa o formato de arquivo .accdb.

Para importar formulários e relatórios que contêm código VBA (e também módulos), primeiro converta seu banco de dados do Access 2.0 ou Access 95 para o formato de arquivo do Access 2002-2003 ou Access 2000, usando o Microsoft Office Access 2003, Access 2002 ou Access 2000. Em seguida, você pode usar uma versão mais atual, como o Access 2007, para convertê-lo no formato de arquivo .accdb, que pode ser aberto pelo Access 2010, Access 2013 ou Access 2016

As seções a seguir neste artigo explicam como realizar essas tarefas.

Você está usando o Access 2010, o Access 2013 ou o Access 2016?

O Access 2007 foi a última versão que oferecia suporte a abrir, importar, vincular ou exportar para o Access 2.0 e o Access 95. Você precisará do Access 2007 para poder exportar, importar ou vincular dados de bancos de dados do Access 95 e de arquivos do Access 1.0 e 2.0 (Red 2 ou Jet 2). Neste caso, você precisará usar o Access 2007 como uma etapa intermediária para converter totalmente um banco de dados do Access 2.0 em uma dessas versões.

O que você deseja fazer?

Abrir um banco de dados do Access 2.0 no Access 2007

Importar dados de um banco de dados do Access 2.0 para o Access 2007

Importar dados de um banco de dados do Access 95 para o Access 2007

Converter um banco de dados do Access 2.0 ou Access 95 usando o Access 2003, Access 2002 ou Access 2000

Abrir um banco de dados do Access 2.0 no Access 2007

Quando você abre um banco de dados do Access 2.0 no Access 2007, o Access exibe vários prompts que, quando seguidos, terminam com a mensagem Este banco de dados foi salvo no formato de arquivo do Microsoft Access 2.0.

Este banco de dados foi salvo no formato de arquivo do Microsoft Access 2.0.

Você pode importar tabelas, consultas e macros de um banco de dados do Access 2.0 para um banco de dados do Access 2007 (.accdb). Para importar formulários, relatórios ou módulos em um banco de dados do Access 2007, primeiro converta o banco de dados usando uma versão anterior do Access. Em seguida, abra o banco de dados convertido no Access 2007 e converta o banco de dados em um banco de dados de formato do arquivo do Access 2007, .accdb. Confira mais informações na seção Converter um banco de dados do Access 2.0 ou Access 95 usando o Access 2003, Access 2002 ou Access 2000.

Importar dados de um banco de dados do Access 2.0 para o Access 2007

Quando você importa objetos de outro banco de dados, cópias dos objetos importados são criadas no banco de dados de destino. A fonte não é alterada. Para importar dados de um banco de dados do Access 2.0 para o Access 2007, você primeiro abre o banco de dados para o qual deseja importar os dados. Você então usa comandos na guia Dados Externos para prosseguir com o processo de importação, que inclui chamar o Assistente de Importação.

  1. No Access 2007, clique no Botão do Microsoft Office e clique em Abrir.

  2. Na caixa de diálogo Abrir, selecione e abra o banco de dados para o qual deseja importar as tabelas, consultas ou macros.

  3. Na guia Dados Externos, no grupo Importar, clique em Access.

  4. Na caixa de texto Nome do arquivo do Assistente Obter Dados Externos, digite o nome do banco de dados de origem ou clique em Procurar para exibir a caixa de diálogo Abrir Arquivo e escolha ou digite o nome do banco de dados de origem.

  5. Clique em Importar tabelas, consultas, formulários, relatórios, macros e módulos no banco de dados atual e, em seguida, clique em OK.

  6. Na caixa de diálogo Importar Objetos, clique em cada guia e selecione os objetos desejados. Lembre-se de que você apenas pode importar tabelas, consultas e macros de um banco de dados do Access 2.0 para o Access 2007.

    Caixa de diálogo Importar Objetos

    Para cancelar um objeto selecionado, clique no objeto novamente.

  7. Clique em Opções para especificar configurações adicionais.

    A tabela a seguir descreve como cada opção afeta os resultados da operação.

    Elemento

    Descrição

    Caixa de seleção Relações

    Importa as relações entre as tabelas selecionadas.

    Caixa de seleção Menus e Barras de Ferramentas

    Importa quaisquer barras de ferramentas e menus personalizados que existam no banco de dados de origem. Os menus e as barras de ferramentas são exibidos em uma guia chamada Suplementos.

    Caixa de seleção Especificações de importação/exportação

    Importa quaisquer especificações de importação ou exportação que existam no banco de dados de origem.

    Caixa de seleção Grupos do painel de navegação

    Importa quaisquer grupos personalizados do Painel de Navegação que existam no banco de dados de origem.

    Botão Definição e dados

    Importa a estrutura e os dados de todas as tabelas selecionadas.

    Botão Somente Definição

    Importa apenas os campos nas tabelas selecionadas. Os registros de origem não serão importados.

    Botão Como Consultas

    Importa as consultas selecionadas como consultas. Neste caso, lembre-se de importar todas as tabelas subjacentes juntamente com as consultas.

    Botão Como Tabelas

    Importa as consultas como tabelas. Neste caso, você não precisa importar as tabelas subjacentes.

  8. Clique em OK para concluir a operação.

    O Access copia os dados e exibe mensagens de erro se ele encontra problemas. Se a operação conseguir importar os dados, a página final do assistente permitirá que você salve os detalhes da operação como uma especificação de importação para uso futuro.

Importar dados de um banco de dados do Access 95 para o Access 2007

Para importar dados de um banco de dados do Access 95 para o Access 2007, você primeiro abre o banco de dados do Access 2007 para o qual deseja importar os dados. Você então usa os comandos na guia Dados Externos, o que envolve chamar o Assistente de Importação.

Você pode importar tabelas, consultas e macros de um banco de dados do formato do Access 95 (.mdb) para um banco de dados do Access 2007 (.accdb). Você também pode importar formulários e relatórios que não usam o código do VBA. Para importar formulários e relatórios que contêm código VBA (e também módulos), primeiro converta seu banco de dados do Access 95 para o formato de arquivo do Access 2002-2003 ou do Access 2000 usando o Microsoft Office Access 2003, Access 2002 ou 2000 e use o Access 2007 para converter esse arquivo para o formato de arquivo .accdb do Access 2007.

  1. No Access 2007, clique no Botão do Microsoft Office e clique em Abrir.

  2. Na caixa de diálogo Abrir, selecione e abra o banco de dados para o qual deseja importar as tabelas, consultas ou macros.

  3. Na guia Dados Externos, no grupo Importar, clique em Access.

  4. Na caixa Nome do arquivo do Assistente Obter Dados Externos, digite o nome do banco de dados de origem ou clique em Procurar para exibir a caixa de diálogo Abrir Arquivo e escolha ou digite o nome do banco de dados de origem.

  5. Clique em Importar tabelas, consultas, formulários, relatórios, macros e módulos no banco de dados atual e clique em OK.

  6. Na caixa de diálogo Importar objetos, clique em cada guia e selecione os objetos que deseja importar.

    Para cancelar a seleção de um objeto, clique nele novamente.

  7. Clique em Opções para especificar configurações adicionais. Essas configurações adicionais serão exibidas em grupos abaixo da lista de objetos.

  8. Clique em OK para concluir a operação.

    O Access copia os dados e exibe mensagens de erro se ele encontra problemas. Se a operação conseguir importar os dados, a página final do assistente permitirá que você salve os detalhes da operação como uma especificação de importação para uso futuro.

Converter um banco de dados do Access 2.0 ou Access 95 usando o Access 2003, Access 2002 ou Access 2000

Você pode converter um banco de dados do Access 2.0 para o formato de arquivo do Access 2000 ou do Access 2002-2003 usando uma das versões do Access listadas na seguinte tabela, desde que você tenha comprado e instalado essa versão do Access no seu computador. Dependendo da sua versão do Access, o conversor do Access 2.0 já deve estar instalado.

Versão

Conversor do Access 2.0

Microsoft Office Access 2003

Essa versão requer o download e a instalação do Conversor do Access 2.0 para o Access 2003. No entanto, essa ferramenta não está mais disponível no Centro de Download da Microsoft porque o Access 2003 está fora do suporte estendido.

Microsoft Access 2002

Incluído no produto.

Microsoft Access 2000

Incluído no produto.

Você deve converter o arquivo do Access 2.0 ou do Access 95 para o formato de arquivo .mdb do Access 2000 ou Access 2002-2003. Em seguida, você pode usar o Access 2007 para converter o arquivo resultante no formato de arquivo do Access 2007, .accdb. Em seguida, você pode usar o banco de dados no Access 2007 ou abri-lo no Access 2010, Access 2013 ou Access 2016. Dependendo da versão mais antiga do Access, faça o seguinte:

  1. Inicie o Access 2003, Access 2002 ou Access 2000.

  2. No menu Arquivo, clique em Abrir e clique no nome de arquivo do banco de dados do Access 95 que você deseja converter.

  3. No menu Ferramentas, clique em Utilitários de Banco de Dados, clique em Converter Banco de Dados e clique em Para o Formato de Arquivo do Access 2000.

  4. Na caixa de diálogo Converter Banco de Dados Em, insira um nome de arquivo para o novo arquivo e clique em Salvar.

    Você poderá ver uma mensagem informativa avisando que não será possível usar o banco de dados convertido em versões anteriores do Access. Se essa mensagem aparecer, clique em OK.

    O arquivo é salvo no formato de arquivo Access 2000.

  5. Iniciar o Access 2007.

  6. Clique no Botão do Microsoft Office e clique em Abrir.

  7. Na caixa de diálogo Abrir, selecione e abra o banco de dados convertido.

  8. Clique no Botão do Microsoft Office e em Converter.

  9. Na caixa de diálogo Salvar Como, insira um nome de arquivo para o arquivo Access 2007 ou aceite o nome de arquivo fornecido e clique em Salvar.

    O arquivo é salvo no formato de arquivo .accdb do Access 2007.

Início da página

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×