Implantar um aplicativo do Access

O Access fornece uma plataforma de recursos avançados para desenvolver aplicativos de banco de dados. Um aplicativo de banco de dados é um programa de computador que oferece uma forma de armazenar e gerenciar dados e uma interface de usuário que segue a lógica de tarefas de negócios (lógica de aplicativo).

Para implantar aplicativos do Access que posam ser executados sem uma instalação do Access no computador do usuário, você pode distribuí-los juntamente com a Access Runtime, que está disponível gratuitamente do Centro de Download da Microsoft.com.

Este artigo descreve o planejamento básico, os recursos do Access Runtime e como baixar o Runtime. Este artigo também fornece uma visão geral da implantação de aplicativos de banco de dados usando o Access.

O que você deseja fazer?

Plano de implantação

Entender o Access Runtime

Baixar o Access Runtime

Implantar um aplicativo do Access

Plano de implantação

Antes de começar, você deve se fazer as seguintes perguntas sobre a forma como o aplicativo será implantado.

Os dados e a lógica devem ser separados?

Você pode criar um aplicativo do Access que combina o gerenciamento de dados e a lógica de aplicativo em um arquivo. Essa é a estrutura padrão de aplicativo no Access. A combinação da lógica de aplicativo e do gerenciamento de dados em um arquivo oferece o mais simples método de implantação, mas esse método funciona melhor se apenas uma pessoa usar o aplicativo por vez, e isso envolve alguns riscos. Por exemplo, um usuário pode causar a perda de dados ao excluir ou danificar o arquivo do aplicativo acidentalmente.

Na maioria dos casos, você deve separar o gerenciamento de dados e a lógica de aplicativo. Isso ajuda a melhorar:

  • Segurança    Usar um servidor para o armazenamento de dados pode ajudar a proteger os dados.

  • Desempenho    Usar um banco de dados dividido ou um servidor de banco de dados pode ajudar a reduzir o tráfego de rede.

  • Personalização    Novas ações macro do Painel de Navegação podem ajudar você a controlar quem vê quê. Você pode distribuir diferentes arquivos de lógica aplicativo a diferentes usuários.

Maneiras de separar dados e lógica

Uma forma de separar os dados e a lógica é usando o comando Acessar Banco de Dados (na guia Ferramentas de Banco de Dados, no grupo Mover Dados). O comando Acessar Banco de Dados divide seu aplicativo de banco de dados em dois arquivos do Access: um para os dados e o outro para a lógica. Quando você usa o comando Acessar Banco de Dados, o Access cria um arquivo com "_be" (que significa "back-end") anexo ao nome do arquivo — por exemplo, se o nome original do arquivo de banco de dados for "Database1.accdb", o Access cria um novo arquivo de banco de dados chamado "Database1_be.accdb".

Outra maneira de separar o gerenciamento de dados e a lógica de aplicativo é usando um programa de servidor de banco de dados (como o Microsoft SQL Server) para o gerenciamento de dados e o Access para a lógica de aplicativo.

Para decidir se um único arquivo do Access é suficiente para o gerenciamento de dados e a lógica de aplicativo, considere o seguinte:

  • Segurança e integridade de dados    Os usuários do Access devem ter permissões de leitura/gravação do arquivo que contém a lógica de aplicativo. Se você combinar dados e lógica em um arquivo, os dados são expostos aos mesmos riscos que a lógica de aplicativo.

    Um aplicativo do Access que separa a lógica e os arquivos de dados pode ajudar a proteger a integridade e segurança de dados com o aproveitamento dos recursos de segurança NTFS. Como os usuários precisam de acesso explícito de leitura/gravação somente ao arquivo do aplicativo lógica, o arquivo de dados pode ser mais seguro.

    Seu aplicativo pode precisar de mais opções de segurança, como a capacidade de controlar quais usuários têm acesso a dados específicos. Nesse caso, você deve usar um produto de servidor como o SQL Server ou um sistema operacional de servidor de Windows que tenha o Windows SharePoint Services para armazenar e gerenciar seus dados de aplicativo, além de usar o Access para fornecer a lógica de aplicativo.

  • Escalabilidade    Um arquivo Access pode ter um tamanho máximo de 2 GB (gigabytes). Embora 2 GB seja uma boa quantidade de dados de texto, pode ser insuficiente para alguns aplicativos, especialmente os aplicativos que armazenam anexos em registros do banco de dados. Se você separar os dados e a lógica, seu aplicativo pode acomodar mais dados. Se você acredita que os usuários armazenarão um grande volume de dados, pode cogitar usar mais de um Access arquivo de dados.

    Você também deve analisar as especificações de programa do Access para obter outras informações sobre escalabilidade. Para saber mais sobre as especificações do Access, confira o artigo Especificações do Access.

  • Capacidade da rede    Caso vários usuários precisem usar o aplicativo ao mesmo tempo em uma rede, a probabilidade de que os dados sejam corrompidos aumenta caso os dados e a lógica estejam combinados em um único arquivo. Além disso, se você combinar os dados e a lógica de um arquivo do Access, não será possível otimizar o tráfego de rede gerado pelo Access. Caso vários usuários usem o aplicativo simultaneamente em uma rede, você deve separar os dados e a lógica usando dois ou mais arquivos do Access ou usando um servidor de banco de dados para os dados e o Access para a lógica de aplicativo.

Qual será a aparência do ambiente de rede?

Caso seus usuários estejam todos na mesma rede local ou o aplicativo não seja usado em uma rede, um arquivo único de aplicativo pode apresentar boa execução na maioria das situações.

O desempenho da rede será melhor se você separar os dados e a lógica. Caso seus usuários não estejam na mesma rede local, use um servidor para armazenar e gerenciar seus dados e use o Access para a lógica de aplicativo.

Os usuários terão o Access?

Caso todos os seus usuários tenham o Access instalado no computador, eles podem abrir e usar o aplicativo como fariam com qualquer arquivo de banco de dados do Access.

Caso alguns ou todos os usuários não tenham o Access instalado no computador, você precisará implantar o software Access Runtime para esses usuários quando você implantar seu aplicativo.

Início da Página

Entender o Access Runtime

O Access Runtime é um programa redistribuível que permite que as pessoas que não têm o Access instalado no computador usem aplicativos de banco de dados do Access. Ao abrir um banco de dados do Access usando o Access Runtime, o banco de dados é aberto no modo de tempo de execução.

O que é o modo de tempo de execução?

O modo de tempo de execução é um modo operacional do Access em que alguns recursos do Access não estão disponíveis por padrão. Contudo, alguns desses recursos indisponíveis podem estar disponíveis no modo de tempo de execução.

Quais recursos não estão disponíveis no modo de tempo de execução?

Os recursos do Access a seguir não estão disponíveis no modo de tempo de execução:

  • Painel de Navegação    O Painel de Navegação não está disponível no modo de tempo de execução. Isso ajuda a impedir o acesso de usuários a objetos arbitrários no seu aplicativo de banco de dados. Somente os objetos que você exibir aos usuários — por exemplo, fornecendo um formulário do menu de controle — podem ser abertos ao usar o modo de tempo de execução. Você não pode tornar o Painel de Navegação disponível no modo de tempo de execução.

  • A Faixa de Opções    Por padrão, a Faixa de Opções não está disponível no modo de tempo de execução. Isso ajuda a impedir que os usuários criem ou modifiquem os objetos do banco de dados e realizem outras ações potencialmente perigosas, por exemplo, se conectar a novas fontes de dados ou exportar dados de maneiras não planejadas por você. Você pode criar uma Faixa de Opções personalizada e associá-la a um formulário ou relatório. Não é possível exibir as guias da Faixa de Opções padrão no modo de tempo de execução.

  • Modos de exibição de Design e de Layout    Os modos de exibição de Design e de Layout não estão disponíveis para nenhum objeto de banco de dados no modo de tempo de execução. Isso ajuda a impedir que os usuários modifiquem o design dos objetos no seu aplicativo de banco de dados. Não é possível habilitar os modos de exibição de Design ou de Layout no modo de tempo de execução.

  • Ajuda    Por padrão, a Ajuda integrada não está disponível no modo de tempo de execução. Como é você que controla qual funcionalidade fica disponível em seu aplicativo do modo de tempo de execução, alguns tópicos padrão da Ajuda integrada do Access podem ser irrelevantes para as pessoas que usam seu aplicativo, podendo acabar confundindo ou frustrando os usuários. Você poderia criar seu próprio arquivo de Ajuda personalizado para complementar seu aplicativo do modo de tempo de execução.

Posso abrir um banco de dados do Access no modo de tempo de execução sem usar o software Access Runtime?

Você pode executar qualquer banco de dados do Access no modo de tempo de execução em um computador que tenha a versão completa do Access instalada. Para executar um banco de dados do Access no modo de tempo de execução, siga um destes procedimentos:

  • Altere a extensão do nome de arquivo do banco de dados de .accdb para .accdr.

  • Crie um atalho para o banco de dados e inclua nele a opção de linha de comando /Runtime.

O modo de tempo de execução torna meu banco de dados mais seguro?

Embora o modo de tempo de execução limite a disponibilidade de recursos de design e navegação, você não deve usá-lo como a principal forma de proteger um aplicativo de banco de dados. Em um computador que tenha a versão completa do Access instalada, talvez seja possível que um usuário abra um aplicativo de banco de dados de tempo de execução como um aplicativo de banco de dados comum (ou seja, com todos os recursos disponíveis) e, em seguida, altere o design ou realize outras ações indesejadas.

Mesmo que você implante seu aplicativo de banco de dados apenas em computadores que não têm a versão completa do Access instalada, o usuário ainda pode transferir o aplicativo para um computador que tem a versão completa de um Access instalada para depois abrir o aplicativo de banco de dados de tempo de execução como um aplicativo de banco de dados comum.

Observação: Caso queira distribuir um aplicativo do Access de modo que os usuários não possam modificar o design de formulários, relatórios ou módulos VBA (Visual Basic for Applications) da Microsoft, cogite usar um arquivo binário compilado (.accde). Para obter mais informações sobre como usar um arquivo binário compilado, confira a seção Decidir qual formato de arquivo usar posteriormente neste artigo.

Topo da Página

Baixar o Access Runtime

Para baixar o Access Runtime no Centro de Download da Microsoft, clique no link apropriado para sua versão:

Não é preciso comprar para baixar, usar ou redistribuir o Access Runtime, e não há limites da quantidade de usuários aos quais você pode distribuir o Runtime.

Início da Página

Implantar um aplicativo do Access

Para implantar um aplicativo do Access, no mínimo é preciso executar as seguintes tarefas:

  1. Criar o aplicativo    Seu aplicativo deve fornecer aos usuários uma forma de abrir e usar objetos de banco de dados. Caso o aplicativo não forneça uma forma, os usuários precisarão ter o Access instalado no computador para usar o aplicativo. Além disso, não será possível prever como os usuários navegarão no seu aplicativo, tornando mais difícil fornecer uma documentação completa do aplicativo. E caso os usuários abram o aplicativo usando o software Access Runtime, os recursos internos de navegação do Access estarão indisponíveis.

    Uma possível abordagem é criar um formulário que tenha botões de comando para abrir objetos de banco de dados ou realizar outras ações e depois especificar esse formulário como sendo o padrão a ser aberto quando o aplicativo for iniciado.

    Observação: Para obter ajuda sobre como criar um formulário, confira o tópico Criar um formulário usando a ferramenta Formulário.

    Como especificar o formulário padrão a ser aberto?

    1. Clique em Arquivo > Opções. Observe que, se estiver usando o Access 2007, você deverá clicar no Botão do Microsoft Office e, em seguida, em Opções do Access.

    2. No painel esquerdo da caixa de diálogo Opções do Access, clique em Banco de Dados Atual.

    3. No painel direito, em Opções do Aplicativo, selecione o formulário padrão que deseja usando a caixa de combinação do Formulário de Exibição.

    Também é possível criar uma Faixa de Opções personalizada e associá-la a um formulário que é aberto ao iniciar o aplicativo. Para obter mais informações sobre como criar uma Faixa de Opções personalizada, confira o artigo Criar uma faixa de opções personalizada no Access.

  2. Instalar o aplicativo    Há várias opções e considerações ao instalar um aplicativo. Talvez você queira implantar um formato de arquivo específico para controlar melhor como os usuários usarão o aplicativo. Como alternativa, você pode compactar o aplicativo para facilitar a instalação ou implantar componentes diferentes de dados e lógica.

    Confira as seções a seguir para obter mais informações sobre essas opções e considerações.

Decidir qual formato de arquivo usar

Há quatro formatos de arquivo do Access disponíveis ao implantar um aplicativo:

  • .accdb    Esse é o formato de arquivo padrão para o Access. Ao implantar um aplicativo nesse formato, os usuários têm a maioria das opções para personalizar e navegar pelo aplicativo como quiserem. Caso queira garantir que os usuários não alterem o design do seu aplicativo, use o formato de arquivo .accde. Além disso, um usuário não consegue determinar facilmente se um arquivo .accdb foi alterado depois de ter sido compactado — para tornar isso óbvio, use o formato de arquivo .accdc.

  • .accdc    Esse formato também é conhecido como um arquivo de implantação do Access. Um arquivo implantação do Access consiste em um arquivo de aplicativo e uma assinatura digital associada a ele. Esse formato de arquivo garante aos usuários que ninguém alterou o arquivo de aplicativo depois da compactação. Você pode aplicar esse formato em um formato padrão de arquivo do Access (.accdb) ou a um arquivo binário compilado do Access (.accde).

    Você só pode colocar um arquivo de aplicativo em um arquivo de implantação do Access. Se o aplicativo tiver arquivos separados de dados e lógica, você pode compactá-los separadamente.

  • .accde    Esse formato também é conhecido como um arquivo binário compilado. No Access, um arquivo binário compilado é um arquivo de aplicativo de banco de dados que foi salvo com todo o código VBA compilado. Nenhum código-fonte VBA permanece em um arquivo binário compilado do Access.

    Você pode usar o Access Runtime para abrir um arquivo binário compilado do Access. No entanto, por padrão, o Runtime não reconhece a extensão de nome de arquivo .accde. Para abrir um arquivo binário compilado usando o Access Runtime, crie um atalho que aponte para o Runtime e inclua o caminho do arquivo binário compilado que você deseja que o atalho abra.

    Importante: Se os usuários abrirem um arquivo binário compilado usando uma versão do Access anterior à versão da compilação, eles não conseguirão abrir o arquivo binário compilado. Para resolver esse problema, você deve compila o arquivo binário na mesma versão do Access dos seus usuários.

    Como salvar um arquivo do Access como um arquivo binário compilado?

    1. No Access, abra o banco de dados (arquivo .accdb) que você deseja salvar como um arquivo binário compilado (.accde).

    2. Clique na guia Arquivo e em Salvar como.

    3. Em Tipos de Arquivo de Banco de Dados, clique em Criar ACCDE e depois em Salvar como.

    4. Na caixa de diálogo Salvar como, navegue até a pasta onde você deseja salvar o arquivo, digite um nome para o arquivo na caixa Nome do Arquivo e clique em Salvar.

    Observação: Caso esteja usando o Access 2007, na guia Ferramentas de Banco de Dados, no grupo Ferramentas de Banco de Dados, clique em Criar ACCDE.

  • .accdr    Esse formato permite habilitar um aplicativo que é aberto no modo de tempo de execução. Implantar um aplicativo de tempo de execução pode ajudar a controlar a forma que ele é usado, embora não seja uma forma de proteger um aplicativo. Para obter mais informações sobre o modo de tempo de execução, confira a seção Entender Access Runtime.

Compactar e assinar um banco de dados do Access

O Access torna mais fácil e rápido assinar e distribuir um banco de dados em comparação a versões anteriores. Ao criar um arquivo do tipo .accdb ou .accde, você pode compactá-lo, aplicar uma assinatura digital a ele e distribuir o pacote assinado para outros usuários. O recurso Compactar e Assinar coloca o banco de dados em um arquivo de implantação do Access (.accdc), depois coloca o pacote codificado por assinatura em um local do computador do usuário determinado por você. Os usuários poderão extrair o banco de dados do pacote e trabalhar diretamente nele (fora do arquivo de pacote).

Observação: O recurso descrito nesta seção compacta um arquivo do Access e aplica uma assinatura digital nele, o que ajuda a indicar aos usuários que o arquivo é confiável.

Lembre-se destes fatos ao criar e assinar um pacote:

  • Compactar um banco de dados e assinar o pacote são formas de transmitir confiança. Quando você ou seus usuários receberem o pacote, a assinatura confirmará que o banco de dados não foi adulterado. Se você confiar no autor, pode habilitar o conteúdo.

  • O novo recurso Compactar e assinar aplica-se apenas a bancos de dados salvos no formato de arquivo .accdb. O Access fornece ferramentas de versões anteriores do Microsoft Office que podem ser usadas para assinar e distribuir bancos de dados que foram criados em um formato de arquivo .mdb mais antigo. É possível usar as ferramentas de versões anteriores do Office para assinar e implantar arquivos criados nos formatos de arquivo .accdb mais recentes.

  • Você pode adicionar apenas um arquivo de banco de dados a um pacote.

  • Ao compactar e assinar um banco de dados, todos os objetos no arquivo de banco de dados são codificados por assinatura, não apenas as macros ou os módulos de código. O processo de compactação e assinatura também compacta o arquivo para ajudar a reduzir o tempo de download.

  • É possível extrair bancos de dados dos arquivos de pacote localizados no servidores do SharePoint.

As seções a seguir explicam como criar um arquivo de pacote assinado e como usar o banco de dados de um arquivo de pacote assinado.

Observação: Para concluir essas etapas, você deve ter pelo menos um certificado de segurança disponível. Caso não tenha um certificado instalado no computador, é possível criar um usando a ferramenta SelfCert. Para obter mais informações sobre como criar um certificado de segurança particular, confira o artigo Demonstrar confiança adicionando uma assinatura digital.

Criar um pacote assinado

  1. Abra o banco de dados que deseja empacotar e assinar.

  2. Clique na guia Arquivo e em Salvar como.

  3. Em Tipos de Arquivo de Banco de Dados, clique em Compactar e Assinar e depois em Salvar como.

    Observação: Se você estiver usando o Access 2007, clique no Botão do Microsoft Office, depois em Publicar e, por fim, clique em Compactar e assinar.

  4. Na caixa de diálogo Selecionar Certificado, selecione um certificado digital e clique em OK.

    A caixa de diálogo Criar Pacote Assinado do Microsoft Office Access será exibida.

  5. Na lista Salvar em, selecione um local para o pacote assinado do banco de dados.

  6. Digite um nome para o pacote assinado na caixa Nome do arquivo e clique em Criar.

    O Access vai criar o arquivo .accdc e coloca-lo no local que você escolher.

Extrair e usar um pacote assinado

  1. Clique em Arquivo > Abrir.

    Observação: Se você estiver usando o Access 2007, clique no Botão do Microsoft Office e depois em Abrir.

  2. Na caixa de diálogo Abrir, selecione Pacotes Assinados do Microsoft Office Access (*.accdc) como o tipo de arquivo.

  3. Na lista Pesquisar, localize a pasta que contém o arquivo .accdc, selecione-o e clique em Abrir.

  4. Siga um desses procedimentos:

    • Se optar por confiar no certificado digital de segurança que foi aplicado no pacote de implantação, a caixa de diálogo Extrair Banco de Dados para será exibida. Vá para a Etapa 5.

    • Se você ainda não optou por confiar no certificado digital, uma mensagem de aviso será exibida.

      1. Mensagem de aviso

      2. Se você confiar no banco de dados, clique em Abrir. Se você confiar em qualquer certificado desse provedor, clique em Confiar em todo o conteúdo do editor. A caixa de diálogo Extrair Banco de Dados para será exibida.

  5. Opcionalmente, na lista Salvar em, selecione um local para o banco de dados extraído e digite um nome diferente para ele, na caixa Nome do arquivo.

Se não tiver certeza sobre a confiabilidade de um certificado, o artigo Como saber se uma assinatura digital é confiável fornecerá informações gerais sobre como verificar as datas e outros itens em um certificado para garantir sua validade.

Início da página

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×