Gravar uma macro

Observação: Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. As informações foram úteis? Dê sua opinião no final desta página. Aqui está o artigo em inglês para facilitar a referência.

Se você executa uma tarefa repetidamente no Microsoft Office Project, é possível automatizá-la com uma macro. Uma macro é uma série de comandos e funções que são armazenados em um módulo e pode ser executada sempre que você precisar realizar a tarefa.

  1. Na guia Exibir, clique em Macros e, em seguida, clique em Gravar Macro.

    (No Project 2007, no menu Ferramentas, aponte para Macro e clique em Gravar Nova Macro.)

  2. Na caixa Nome da macro, digite um nome para a macro.

    O primeiro caractere do nome da macro deve ser uma letra. Outros caracteres podem ser letras, números ou caracteres de sublinhado. Os espaços em branco não são permitidos em um nome de macro, mas o sublinhado funciona bem como um separador de palavras.

  3. Para executar a macro pressionando uma tecla de atalho, insira uma letra ou combinação de teclas na caixa Tecla de atalho.

    Você pode utilizar a tecla CTRL+letra (para letras minúsculas) ou as teclas CTRL+SHIFT+letra (para letras maiúsculas), em que a letra é qualquer tecla de letra do teclado, mas não um número nem um caractere especial. Você não pode utilizar uma combinação de teclas que já esteja sendo usada no Microsoft Office Project.

  4. Na lista Armazenar macro em, clique no local onde deseja armazenar a macro:

    • Para tornar a macro disponível sempre que utilizar o Project, clique em Arquivo Global.

    • Para tornar a macro disponível somente para o projeto atual, clique em Este Projeto.

  5. Para incluir uma descrição da macro, digite a descrição na caixa Descrição.

  6. Se você selecionar células enquanto estiver gravando uma macro, a macro selecionará a mesma coluna (campo) toda vez que for executada, independentemente de qual célula seja primeiramente selecionada, pois ela grava referências absolutas para colunas. Se você desejar que uma macro selecione colunas, independentemente da posição da célula ativa, quando for executada, clique em Relativa em Referências de coluna.

    Do contrário, a macro selecionará as linhas independentemente da posição da célula ativa quando você executá-la, pois ela grava referências relativas para linhas. Se desejar que uma macro sempre selecione a mesma linha, independentemente de qual célula seja primeiramente selecionada, clique em Absoluta (identificação) em Referências de linha.

    Observação: O Project continuará utilizando essas configurações ao gravar macros até que você as altere ou feche o Project.

  7. Clique em OK e execute as ações que deseja gravar.

  8. Quando você concluir todas as ações que você deseja gravar, na guia Exibir, clique em Macros e, em seguida, clique em Parar gravação.

    (No Project 2007, no menu Ferramentas, aponte para Macro e clique em Parar gravação.)

Observação de segurança: Como as macros podem conter vírus, tenha cuidado ao executá-los. Tome as seguintes precauções: execute software antivírus atualizado no seu computador; Defina o nível de segurança de macro como alto; Desmarque a opção confiar em todos os suplementos e modelos; Use assinaturas digitais; Manter uma lista de fornecedores confiáveis.

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×