Gravar macros no Visio

Observação:  Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. As informações foram úteis? Dê sua opinião no final desta página. Aqui está o artigo em inglês para facilitar a referência.

Crie uma macro para automatizar processos executadas repetidamente ou etapas. Os comandos de gravação de uma macro estão na guia desenvolvedor.

Observação: Macros podem disparar alertas de segurança, pois eles podem ser criados e usados para fins mal-intencionados. Para obter mais informações sobre os riscos de macros e o que fazer com um alerta de segurança, consulte Habilitar ou desabilitar macros em arquivos do Office.

  1. Na guia Desenvolvedor, clique em Gravar Macro. Se você não vê a guia Desenvolvedor, consulte “Mostrar a guia Desenvolvedor” abaixo.

    Botão Idioma da Faixa de Opções do Publisher

  2. Na caixa Nome da macro, digite um nome para a macro.

  3. Na caixa Tecla de atalho, digite uma tecla de atalho que possa ser usada com a tecla CTRL para executar a macro.

  4. Na caixa Armazenar macro em, selecione o documento no qual você deseja armazenar a macro.

  5. Na caixa Descrição, digite uma descrição para a macro.

  6. Clique em OK para começar a gravar a macro.

  7. Execute as ações que você deseja incluir na macro. Na guia Desenvolvedor, use Pausar Gravação, se necessário.

    Quando você grava uma macro, pode usar o mouse para clicar em comandos e opções, e trabalhar com formas e objetos em desenhos.

  8. Para parar de gravar sua macro, clique em Interromper Gravação na guia Desenvolvedor.

Você também pode pausar ou continuar a gravação da macro usando a barra de ferramentas Gravação.

Para ver o código resultante, no menu Ferramentas, aponte para Macros, clique em Macros, clique no nome da macro e depois clique em Editar.

Mostrar a guia Desenvolvedor

  1. Clique na guia Arquivo e clique em Opções.

  2. Clique em Personalizar a Faixa de Opções.

  3. Em Personalizar a Faixa de Opções e em Guias Principais, marque a caixa de seleção Desenvolvedor.

    A guia Desenvolvedor aparece no final da faixa da opções, no lado oposto à guia Arquivo.

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×